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Notice

The material contained in thisdocument is provided “asis’, and is subject to being changed, without notice,
in future editions.

Further, to the maximum extent permitted by applicable law, Agilent disclaims all warranties, either
expressed or implied with regard to this manual and to any of the Agilent products to which it pertains,
including but not limited to the implied warranties of merchantability and fitness for a particular purpose.
Adgilent shall not be liable for errors or for incidental or consequential damages in connection with the
furnishing, use, or performance of this document or any of the Agilent products to which it pertains. Should
Agilent have awritten contract with the User and should any of the contract terms conflict with these terms,
the contract terms shall control.

Questions or Comments about our Documentation?

We welcome any questions or comments you may have about our documentation. Please send us an E-mail
at sources_manuals@am.exch.agilent.com.
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1 E4428C Analog Signal Generator Overview

This chapter provides a general overview of the Agilent ESG Analog Signal Generator and includes the
following major sections:

o “Standard Analog Signal Generator Features’ on page 2
e “Options’ on page 3

e “Maodes of Operation” on page 4

e “Front Panel Overview” on page 5

* “Front Panel Display” on page 11

e “Rear Panel Overview” on page 15
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Standard Analog Signal Generator Features

—

Standard Analog Signal Generator Features

* CW output from 250 kHz to 3 or 6 GHz; the high-end frequency is dependent on the frequency option
purchased with your signal generator

» list and step sweep of frequency and amplitude, with multiple trigger sources

» user flatness correction

» automatic leveling control (ALC) on and off modes; power calibration in ALC-off mode is available,
even without power search

» 10 MHz reference oscillator with external output

e GPIB, RS-232, and 10Base-T LAN interfaces

» closed-loop AM

* dc-synthesized FM to 10 MHz rates; maximum deviation depends on the carrier frequency
» phase modulation

* pulse modulation

» afunction generator that includes the following features:

— 50Q low frequency output, 0to 3V,

— selectable waveforms: sine, square, ramp, triangle, noise, swept-sine, dual-sine, and pulse
— variable frequency modulation rates

— variabletriggering in list and step sweep modes: auto, external, single, or remote

» apulse generator that includes the following features:

— external pulse

— internal square wave

— internal pulse sources: internal square, internal pulse, external 1 dc-coupled, and external 2
dc-coupled

— adjustable pulse width

— adjustable pulse period

— adjustable pulse rate

e externa modulation inputs for AM, FM, and ®M

e simultaneous modulation configurations
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Options

Options

ESG signal generators have hardware, firmware, software, and documentation options. The data sheet
shipped with your signal generator provides an overview of available options. For details, refer to the
Agilent Technol ogies website.

1. Open: http://mmw.agilent.comv/find/esg.
2. Select the E4428C Analog Signal Generator link.
3. Click View price list.
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Modes of Operation

Modes of Operation

Depending on the installed options, the ESG signal generator provides up to three basic modes of operation:
continuous wave (CW), swept signal, and anal og modul ation.

Continuous Wave

In this mode, the signal generator produces a continuous wave signal. The signal generator is set to asingle
frequency and power level.

Swept Signal

In this mode, the signal generator sweeps over arange of frequencies and/or power levels. Both list and step
sweep functionality is available. Option 007 adds analog ramp sweep functionality.

Analog Modulation

In this mode, the signal generator modulates a CW signal with an analog signal. The analog modulation
types available depend on the installed options.

Option UNT provides AM, FM, and ®M modulations. Some of these modulations can be used together.
Options UNU and UNW provide standard and narrow pulse modul ation capability, respectively.
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Front Panel Overview

Front Panel Overview

Figure 1-1 shows the signal generator front panel. This interface enables you to define, monitor, and manage
input and output characteristics.

Figure 1-1 Front Panel Feature Overview
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\ —
O
-
i
== @
:l:l \®
P’?‘ D D ﬂ El

/IR é@\.\%\\@

1. Display

The LCD screen provides information on the current function. Information can include status indicators,
frequency and amplitude settings, and error messages. Labels for the softkeys are located on the right-hand
side of the display. For further description of the front panel display, refer to “ Front Panel Display” on page
11.

2. Softkeys
Softkeys activate the function indicated by the displayed label to the left of each key.
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3. Frequency Key

Pressing this hardkey makes frequency the active function. You can change the RF output frequency or use
the menus to configure frequency attributes such as frequency multiplier, offset, and reference.

4. Amplitude Key

Pressing this hardkey activates the amplitude function. You can change the RF output amplitude or use the
menus to configure amplitude attributes such as power search, user flatness, and ALC BW.

5. Knob

Rotating the knob increases or decreases a numeric value or changes a highlighted digit or character. You
can also use the knob to step through lists or select items in arow. The knob uses the Incr Set value in
conjunction with the knab ratio (set with the Step/Knob Ratio softkey) to determine how much each turn of
the knob changes the active function value. For example, if the Incr Set value for the active functionis 10 dB
and the knob ratio is 50 to 1, then each turn of the knob changes the active function by 0.2 dB (1/50th of
10 dB). By modifying either value or both, you change the amount for each turn of the knob. For more
information on softkeys, refer to the E4428C/38C ESG Sgnal Generators Key and Data Field Reference.

7. Save Key

This hardkey accesses amenu of softkeys enabling you to save datato the signal generator’sinstrument state
memory register. The instrument state register is a section of memory divided into 10 sequences numbered 0
through 9. Each sequence contains 100 registers numbered 00 through 99.

The Save hardkey provides a quick aternative to reconfiguring the signal generator viathe front panel or
with SCPI commands when switching between different configurations. The Recall hardkey recalls a saved
instrument state.

Refer to “ Saving an Instrument State” on page 69 for more information on the save operation.
7. Menu Keys

These hardkeys access softkey menus enabling configuration of list and step sweeps, utility functions, the
LF output, and various analog modulation types. For detailed information on these keys, refer to the
E4428C/38C ESG Sgnal Generators Key and Data Field Reference.

8. Recall Key

This hardkey restores any instrument state that you previously saved in ainstrument state memory register.
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9. EXT 1 INPUT Connector

This BNC input connector acceptsa+1 'V, signa for AM, FM, ®M and Pulse. For al these modulations,
+1V,, produces the indicated deviation or depth. With pulse modulation, +1 V isonand 0V is off. When
ac-coupled inputs are selected for AM, FM, or ®M and the peak input voltage differs from 1V, by more
than 3%, the HI/LO annunciators light on the display. The damage levelsare 5 Vg and 10 V,.

On signal generators with Option 1EM, thisinput is relocated to afemale BNC connector on the rear panel.

10. EXT 2 INPUT Connector

This BNC input connector acceptsa+1 'V, signa for AM, FM, ®M, and pulse modulation. With AM, FM,
or ®M, £1V, produces the indicated deviation or depth. With pulse modulation, +1 V isonand 0 V is off.

When ac-coupled inputs are selected for AM, FM, or ®M and the peak input voltage differs from 1V, by
more than 3%, the HI/LO annunciators light on the display. The damage levelsare 5 Vg and 10 V.

If you configure your signal generator with Option 1EM, thisinput is rel ocated to afemale BNC connector
on the rear panel.

11. Help Key

Press this key to display a short description of any hardkey or softkey. There are two help modes available:
single and continuous. Single mode is the factory preset condition. To toggle between single and continuous
mode, press Utility > Instrument Info/Help Mode > Help Mode Single Cont.

» Insingle mode, help text is provided for the next key you press without activating the key’s function.
Any key pressed afterward exits the help mode and activates the key’s function.

» Incontinuous mode, help text is provided for each subsequent key press until you either press the Help
key again, or change to single mode. In continuous mode, pressing the Help key also activates the key's
function (except for the Preset key).

12. Trigger Key

This hardkey initiates an immediate trigger event for afunction such as alist or step sweep. The trigger
mode must be set to Trigger Key prior to initiating atrigger event with this hardkey.

13. LF OUTPUT Connector

This BNC connector is the output for modulation signals generated by the low frequency (LF) source
function generator. This output is capable of driving 3 V, (nominal) into a 50Q load.

On signal generators with Option 1EM, this output is relocated to a rear-panel female BNC connector.
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14. RF OUTPUT Connector

Thisfemale Type-N connector isthe output for RF signals. The source impedance is 50Q. For Options 501,
502, 503, and 504 the damage levels are 50 Vdc, 50 W at < 2 GHz, and 25 W at > 2 GHz maximum. For
Options 501, 502, 503, and 504 the reverse power protection circuit will trip, however, at nominally 1 W.

CAUTION E4428C and E4438C signal generators with Option 506 are not equipped with reverse
power protection circuits.

On signal generators with Option 1EM, this output is relocated to arear-panel female Type-N connector.

15. Mod On/Off Key

Pressing this hardkey enables or disables all active modulation formats (AM, FM, ®M, or Pulse) that are
applied to the output carrier signal.

This hardkey does not set up or activate an AM, FM, ®M, or Pulse format; each individual modulation
format must still be set up and activated (for example, AM > AM On) or nothing will be applied to the output
carrier signal when the Mod On/0ff hardkey is enabled.

The MCD QY GFF annunciator, which is always present on the display, indicates whether active modulation
formats have been enabled or disabled with the Mod On/0ff hardkey.

16. RF On/0ff Key

This hardkey toggles the operating state of the RF signal present at the RF OUTPUT connector. The
RF On/ O f annunciator is aways visible in the display to indicate whether the RF is turned on or off.

17. Numeric Keypad

The numeric keypad consists of the 0 through 9 hardkeys, a decimal point hardkey, and a backspace hardkey
( ). The backspace hardkey enables you to backspace or specify a negative value. When specifying a
negative numeric value, the negative sign must be entered prior to entering the numeric value.

18. Incr Set Key

This hardkey enables you to set the increment value of the current active function. When this hardkey is
pressed, the increment val ue of the current active function appears as the active entry for the display. Use the
numeric keypad, arrow hardkeys, or the knob to adjust the increment value. Changing the Incr Set hardkey’s
value also affects how much each turn of the knob changes an active function’s value according to the
knob's current ratio setting. For more information on softkeys, refer to the E4428C/38C ESG Signal
Generators Key and Data Field Reference.
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19. Arrow Keys

The up and down arrow hardkeys are used to increase or decrease a numeric value, step through displayed
lists, or select itemsin arow of adisplayed list. Individual digits or characters may be highlighted using the
left and right arrow hardkeys. Once an individual digit or character is highlighted, its value can be changed
using the up and down arrow hardkeys.

20. Hold Key

This hardkey blanks the softkey label area, the active function area, and the text areas of the display.
Softkeys, arrow hardkeys, the knob, the numeric keypad, and the Incr Set hardkey have no effect once this
hardkey is pressed. Press any other hardkey to end the hold mode.

21. Return Key

This hardkey enables you to retrace your key presses. When in a menu with more than one level (More 1 of
3, More 2 of 3, etc.), the Return key will always return you to the first level of the menu.

22. Display Contrast Increase Key

This hardkey, when pressed or held, causes the display background to darken.

23. Display Contrast Decrease Key

This hardkey, when pressed or held, causes the display background to lighten.

24. Local Key

This hardkey is used to deactivate remote operation and return the signal generator to front panel control.

25. Preset Key

This hardkey is used to set the signal generator to a known state (factory or user-defined).

26. Standby LED

Thisyellow LED indicates when the signal generator power switch is set to the standby condition.

27. Line Power LED

This green LED indicates when the signal generator power switch is set to the on position.
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28. Power Switch

This switch activates full power to the signal generator when set to the on position, and deactivates all signal
generator functions when in standby mode. In standby mode, the signal generator remains connected to the
line power, and power is supplied to someinternal circuits.
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Front Panel Display

Figure 1-2 showsthefront panel display. The LCD screen displays datafiel ds, annotations, key pressresults,
softkey labels, error messages, and annunciators that represent various active functions.

Figure 1-2 Front Panel Display
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The current frequency setting is shown in this portion of the display. In this same area, the ESG displaysthe
indicators for frequency offset (OFFS) and multiplier (MULT) functions. In addition, REF appears when you
enable the frequency reference mode and CHANNEL is turned on when you turn on a frequency channel
(Freq Channels Off On softkey).

1. Frequency Area
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2. Annunciators

The display annunciators show the status of some of the signal generator functions, and indicate error
conditions. An annunciator position may be used by more than one function. This does not create a problem,
because only one function that shares an annunciator position can be active at agiven time.

oM This annunciator appears when phase modulation isturned on. If frequency modulation
isturned on, the FMannunciator will replace ®M

ALC OFF This annunciator appears when the ALC circuit is disabled. A second annunciator,
UNLEVEL, will appear in the same position if the ALC is enabled and is unable to
maintain the output level.

AM This annunciator appears when amplitude modulation is turned on.

ARMED This annunciator appears when a sweep has been initiated and the signal generator is
waiting for the sweep trigger event.

ATTEN HOLD This annunciator appears when the attenuator hold function is turned on. When this
function is on, the attenuator is held at its current setting.

ERR This annunciator appears when an error message is placed in the error queue. This
annunciator will not turn off until you have viewed all of the error messages or cleared
the error queue. You can access error messages by pressing Utility > Error Info.

EXT1 LOH Thisannunciator isdisplayed aseither EXT1 LOor EXT1 H . Thisannunciator appears
when the ac-coupled signal to the EXT 1 INPUT islessthan 0.97 V| or greater than

1.03V,,

EXT2 LOH Thisannunciator isdisplayed as either EXT2 LOor EXT2 H . Thisannunciator appears
when the ac-coupled signal to the EXT 2 INPUT islessthan 0.97 V|, or greater than

103V,
EXT REF This annunciator appears when an external frequency referenceis applied.
FM This annunciator appears when frequency modulation is turned on. If phase modulation

isturned on, the ®Mannunciator will replace FM

L This annunciator appears when the signal generator isin listener mode and is receiving
information or commands over the GPIB, RS-232, or VXI-11/Sockets (LAN) interface.
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This annunciator indicates if the RF carrier is modulated (MOD ON whilethereisan
active modulation format), or if the modulation is off (MOD OFF). Either condition of
this annunciator is always visiblein the display.

The MCD QN annunciator may be showing even when there are no active modulation
formats. This merely indicates that the carrier signal will be modulated when a
modulation format is enabled.

This annunciator appears when the temperature of the internal oven reference oscillator
has dropped below an acceptable level. When this annunciator is on, frequency
accuracy is degraded. This condition should occur for several minutes after the signal
generator is first connected to line power. The annunciator istimed, and automatically
turns off after a specified period.

This annunciator appears when pulse modulation is turned on.

This annunciator appears when the signal generator is remotely controlled over the
GPIB, RS-232, or VX1-11/Sockets (LAN) interface.

This annunciator indicates when the RF signal is present (RF ON) at the RF OUTPUT,
or if the RF signal is not present (RF OFF) at the RF OUTPUT. Either condition of this
annunciator is aways visible in the display.

This annunciator appears when the signal generator has generated a service reguest
(SRQ) over the GPIB, RS-232, or V X1-11/Sockets (LAN) interface.

This annunciator appears when the signal generator is sweeping in list or step mode.

Thisannunciator appears when the signal generator isin talker mode and is transmitting
information over the GPIB, RS-232, or VX1-11/Sockets (LAN) interface.

This annunciator appears when the signal generator is unable to maintain the correct
output level. The UNLEVEL annunciator is not necessarily an indication of instrument
failure. Unleveled conditions can occur during normal operation. A second annunciator,
ALC COFF, will appear in the same position when the ALC circuit is disabled.

This annunciator appears when any of the phase |ocked |oops are unable to maintain
phase lock. You can determine which loop is unlocked by examining the error

Messages.

Chapter 1

13



E4428C Analog Signal Generator Overview
Front Panel Display

3. Amplitude Area

The current output power level setting is shown in this portion of the display. When active, the following
functions also display indicators in the amplitude area:

e Amplitude offset (OFFS)

e Amplitude reference mode (REF)
* Alternate Amplitude (A = 0.00dB)
»  User flatness (UF)

4. Softkey Label Area

The labelsin this area define the function of the softkeys located immediately to the right of the label. The
softkey label will change depending upon the function selected. For detailed softkey descriptions, refer to
the E4428C/38C ESG Sgnal Generators Key and Data Field Reference.

5. Error Message Area

Abbreviated error messages are reported in this space. When multiple error messages occur, only the most
recent message remains displayed. Reported error messages with details can be viewed by pressing
Utility > Error Info.

6. Text Area

Thisareaof the display is used to show status information about the signal generator such as the modulation
status, sweep lists, and file catalogs. This area also enables you to perform functions such as managing
information, entering information, and displaying or deleting files.

7. Active Function Area

The current active function is shown in thisarea. For example, if frequency isthe active function, the current
frequency setting will be displayed here. If the current active function has an increment val ue associated
with it, that value is also displayed.
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E4428C Analog Signal Generator Overview

Rear Panel Feature Overview

(

Figure 1-4 shows a portion of the rear panel for signal generators with Option 1EM, which moves front

panel connectors to the rear panel. For Option 1EM connectors not described in this section, see

The signal generator rear panel (Figure 1-3) provides input, output, and remote interface connections.
“Front Panel Overview” on page 5.

Rear Panel Overview

Figure 1-3
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Rear Panel Overview

1. AC Power Receptacle

The power cord receptacle accepts a three-pronged cabl e that is shipped with the signal generator. The line

voltage is connected here.

2. GPIB Connector

The GPIB connector allows communications with compatible devices such as external controllers. Itis
functionally equivalent to the LAN and RS 232 connectors.

3. RS 232 Connector

This female DB-9 connector is an RS-232 serial port that can be used for controlling the signal generator
remotely. It is functionally equivalent to the GPIB and LAN connectors. The following table shows the
description of the pinouts. Figure 1-5 shows the pin configuration.

Table 1-1 RS 232 Connector
Pin Number Signal Description Signal Name

1 No Connection

2 Receive Data RECV

3 Transmit Data XMIT

4 +5V

5 Ground, 0V

6 No Connection

7 Request to Send RTS

8 Clear to Send CTS

9 No Connection
Figure 1-5

5 40 3¢ 24 1o View looking into
O¢ 8¢ 7e be rear panel connector
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4, LAN Connector

LAN based communication is supported by the signal generator viathe LAN (local area network) connector.
The LAN connector enables the signal generator to be remotely programmed by a L AN-connected
computer. The distance between a computer and the signal generator islimited to 100 meters (10Base-T) on
asingle cable. For more information about the LAN, refer to the E4428C/38C ESG Signal Generators
Programming Guide.

5. TRIG OUT Connector

This female BNC connector outputs a TTL signal that is asserted high at the start of a dwell sequence, or at
the start of waiting for the point trigger in manual sweep mode. It is asserted low when the dwell is over,
when the point trigger is received, or once per sweep during an LF sweep. The logic polarity can be
reversed.

6. TRIG IN Connector

This female BNC connector accepts a CMOS signal for triggering operations, such as point-to-point in
manual sweep mode or an LF sweep in external sweep mode. Triggering can occur on either the positive or
negative edge. The damage levels are > +5.5 volts and < —0.5volts.

7. 10 MHz IN Connector

Thisfemale BNC connector accepts a—3.5 to +20 dBm signal from an external timebase reference that is
within £10 ppm (standard timebase) or £1 ppm (high stability timebase). The nominal input impedance is
50Q. The signal generator detects when avalid reference signal is present at this connector and
automatically switches from internal to external reference operation. The signal generator will only
automatically switch from internal to external reference operation when the instrument isin its factory
default mode where the Ref Oscillator Source Auto Off On softkey is set to on.

8. SWEEP OUT Connector

This female BNC connector provides avoltage range of 0 to +10 V. When the signal generator is sweeping,
the SWEEP OUT signal ranges from O V at the beginning of the sweep to +10 V at the end of the sweep
regardless of the sweep width. In CW mode this connector has no output. The output impedance is less than
1Q and can drive 2 kQ.

9. 10 MHz OUT Connector

This female BNC connector provides a nominal signal level of +3.9 dBm +2 dB, and an output impedance
of 50Q. The accuracy is determined by the timebase used.

Chapter 1 17



E4428C Analog Signal Generator Overview
Rear Panel Overview

18 Chapter 1



2 E4438C Vector Signal Generator Overview

This chapter provides ageneral overview of the Agilent E4438C ESG Vector Signal Generator and includes
the following major sections:

e “Standard Vector Signal Generator Features’ on page 20
e “Options’ on page 21

e “Maodes of Operation” on page 22

e “Front Panel Overview” on page 24

» “Front Panel Display” on page 31

e “Rear Panel Overview” on page 35
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Standard Vector Signal Generator Features

CW output from 250 kHz to 1, 2, 3, 4 or 6 GHz; the high-end frequency is dependent on the frequency

option purchased with your signal generator
list and step sweep of frequency and amplitude, with multiple trigger sources

user flatness correction

automatic leveling control (ALC) on and off modes; power calibration in ALC-off modeis available,

even without power search

10 MHz reference oscillator with external output

GPIB, RS-232, and 10Base-T LAN interfaces

closed-loop AM

dc-synthesized FM to 10 MHz rates;, maximum deviation depends on the carrier frequency
phase modulation

pulse modulation

afunction generator that includes the following features:

— 50Q low frequency output, 0to 3V,

— selectable waveforms: sine, square, ramp, triangle, noise, swept-sine, dual-sine, and pulse
— variable frequency modulation rates

— variabletriggering in list and step sweep modes: auto, external, single, or remote

apulse generator that includes the following features:

— external pulse

— internal square wave

— internal pulse sources: internal square, internal pulse, external 1 dc-coupled, and external 2
dc-coupled

— adjustable pulse width

— adjustable pulse period

— adjustable pulse rate

external modulation inputs for AM, FM, ®M, and 1/Q modulation

simultaneous modulation configurations

20
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Options

ESG signal generators have hardware, firmware, software, and documentation options. The data sheet
shipped with your signal generator provides an overview of available options. For details, refer to the
Agilent Technol ogies website.

1. Open: http://mmw.agilent.comv/find/esg.
2. Select the E4438C Vector Signal Generator link.

3. Click View price list.

Understanding Baseband Generator Options

Your E4438C can have one of four baseband generator options, depending upon when you first purchased
the instrument and whether or not the baseband generator has been upgraded to a newer version. The options
consist of the following:

Option 001 internal baseband generator with 8 megasample memory (no longer available)
Option 002 internal baseband generator with 32 megasample memory (no longer available)
Option 601 internal baseband generator with 8 megasample memory and digital bus capability
Option 602 internal baseband generator with 64 megasample memory and digital bus capability

These four baseband generators are similar in some respects, and very different in others. They aresimilar in
that all four versions support the same signal generation formats, such as W-CDMA, cdma2000, WLAN,
and many others. All four versions offer both arbitrary waveform capability and real-time baseband
generation capability.

The first obvious difference between these four baseband generators is that they offer different playback
memory sizes. Thisis primarily important to users providing their own arbitrary waveform files, since these
may be very large in size. Of the signal creation personalities offered by Agilent, currently only Signal
Studio for WLAN and Signal Studio for Pulse Building are capable of creating waveforms that can exceed
the 8 megasample memory of the Option 001/601 models.

The second important difference between these baseband generators is that only Option 601 and 602 offer
digital bus capability. This proprietary digital busis used for communication with the Agilent Baseband
Studio suite of products. Baseband Studio products provide a range of baseband signal processing functions,
including baseband digital outputs, fading, and hard drive waveform streaming. These functions are not
compatible with Options 001 or 002. An upgrade kit is available, however, if you want to add Option 601 or
602 to your existing E4438C ESG.
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Modes of Operation

Depending on the model and installed options, the ESG signal generator provides up to four basic modes of
operation: continuous wave (CW), swept signal, analog modulation, and digital modulation.

Continuous Wave

In this mode, the signal generator produces a continuous wave signal. The signal generator is set to asingle
frequency and power level. Both the E4438C and E4428C can produce a CW signal.

Swept Signal

In this mode, the signal generator sweeps over arange of frequencies and/or power levels. Both the E4438C
and E4428C provide list and step sweep functionality. Option 007 adds analog ramp sweep functionality.

Analog Modulation

In this mode, the signal generator modulates a CW signal with an analog signal. The analog modulation
types available depend on the installed options.

Option UNT provides AM, FM, and ®M modulations. Some of these modulations can be used together.
Options UNU and UNW provide standard and narrow pulse modul ation capability, respectively.

Digital Modulation

In this mode, the signal generator modulates a CW signal with either areal-time 1/Q signal or arbitrary 1/Q
waveform. 1/Q modulation is only available on the E4438C. An internal baseband generator
(Option 001/601 002/602) adds the following digital modulation formats:

» Custom Arb Waveform Generator mode can produce a single-modulated carrier or multiple-modul ated
carriers. Each modul ated carrier waveform must be calculated and generated before it can be output; this
signal generation occurs on theinternal baseband generator. Once awaveform has been created, it can be
stored and recalled, which enables repeatabl e playback of test signals. To learn more, refer to “ Using the
Arbitrary Waveform Generator” on page 354.

e Custom Real TimeI/Q Baseband mode produces a single carrier, but it can be modulated with rea -time
datathat allows real-time control over all of the parameters that affect the signal. The single-carrier
signal that is produced can be modified by applying various data patterns, filters, symbol rates,
modulation types, and burst shapes. To learn more, refer to “Using the Real Time 1/Q Baseband
Generator” on page 360.
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Multitone mode produces up to 64 continuous wave signals (or tones). Like the Two Tone mode, the
frequency spacing between the signals and the amplitudes are adjustable. To learn more, refer to
“Multitone Waveform Generator” on page 347.

« Dual ARB modeis used to control the playback sequence of waveform segments that have been written

into the ARB memory located on the internal baseband generator. These waveforms can be generated by
the internal baseband generator using the Custom Arb Waveform Generator mode, or downloaded
through a remote interface into the ARB memory. To learn more, refer to “Using the Dual ARB
Waveform Player” on page 104.
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Front Panel Overview

Figure 2-1 showsthe signal generator front panel. Thisinterface enables you to define, monitor, and manage

input and output characteristics.

Figure 2-1 Front Panel Feature Overview
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The LCD screen provides information on the current function. Information can include status indicators,
frequency and amplitude settings, and error messages. Labels for the softkeys are located on the right-hand

side of the display. For further description of the front panel display, refer to “ Front Panel Display” on page
3L

pk70ic

1. Display

2. Softkeys
Softkeys activate the function indicated by the displayed label to the left of each key.

3. Frequency Key

Pressing this hardkey makes frequency the active function. You can change the RF output frequency or use
the menus to configure frequency attributes such as frequency multiplier, offset, and reference.
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4. Amplitude Key

Pressing this hardkey activates the amplitude function.

When active, the following functions also display indicators in the amplitude area:

*Amplitude offset (OFFS)
*Amplitude reference mode (REF)
Alternate Amplitude (A = 0.00dB)
*User flatness (UF)

5. Knob

Rotating the knob increases or decreases a numeric value or changes a highlighted digit or character. You
can also use the knob to step through lists or select itemsin arow. The knob usesthe Incr Set valuein
conjunction with the knab ratio (set with the Step/Knob Ratio softkey) to determine how much each turn of
the knob changes the active function value. For example, if the Incr Set value for the active functionis 10 dB
and the knob ratio is 50 to 1, then each turn of the knob changes the active function by 0.2 dB (1/50th of
10 dB). By modifying either value or both, you change the amount for each turn of the knob. For more
information on softkeys, refer to the E4428C/38C ESG Sgnal Generators Key and Data Field Reference.

6. Menu Keys

These hardkeys access softkey menus enabling configuration of list and step sweeps, utility functions, the
LF output, and various analog and digital modulation types. For detailed information on these keys, refer to
the E4428C/38C ESG Sgnal Generators Key and Data Field Reference.

7. Save Key

This hardkey accesses a menu of softkeys enabling you to save instrument settings to the signal generator’s
instrument state memory register. The instrument state register is a section of memory divided into 10
seguences numbered 0 through 9. Each sequence contains 100 registers numbered 00 through 99.

The Save hardkey provides a quick aternative to reconfiguring the signal generator viathe front panel. The
Recall hardkey recalls a saved instrument state.

Refer to “ Saving an Instrument State” on page 69 for more information on the save operation.

8. Recall Key

This hardkey restores any instrument state that you previously saved in ainstrument state memory
register.When you load the waveform file from NVWFM into waveform memory (WFM 1), and then use the
Recall softkey to recall the signal generator settings associated with thefile.
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9. EXT 1 INPUT Connector

This BNC input connector accepts a+1 'V, signa for AM, FM, and ®M. For all these modulations, 1V,

produces the indicated deviation or depth. With pulse modulation, +1 V ison and 0V is off. When
ac-coupled inputs are selected for AM, FM, or ®M and the peak input voltage differs from 1V, by more

than 3%, the HI/LO annunciators light on the display. The damage levelsare 5 Vg and 10 V..

This connector can also serve as burst envelope input providing linear control as follows:
0V =100% amplitude, —1.00 V = 0% amplitude.

On signal generators with Option 1EM, thisinput isrelocated to an SMB connector on the rear panel.

10. EXT 2 INPUT Connector

This BNC input connector acceptsa+1 V, signal for AM, FM, ®M, and pulse modulation. With AM, FM,
or ®M, +1V, produces the indicated deviation or depth. With pulse modulation, +1V isonand 0 V is off.

When ac-coupled inputs are selected for AM, FM, or ®M and the peak input voltage differs from 1V, by
more than 3%, the HI/LO annunciators light on the display. The damage levelsare 5V s and 10 V,.

If you configure your signal generator with Option 1EM, thisinput is relocated to an SM B connector on the
rear panel.

11. Help Key

Press this key to display a short description of any hardkey or softkey. There are two help modes available;
single and continuous. Single mode is the factory preset condition. To toggle between single and continuous
mode, press Utility > Instrument Info/Help Mode > Help Mode Single Cont.

» Insingle mode, help text is provided for the next key you press without activating the key’s function.
Any key pressed afterward exits the help mode and activates the key’s function.

» In continuous mode, help text is provided for each subsequent key press until you either press the Help
key again, or change to single mode. In continuous mode, pressing the Help key also activates the key’s
function (except for the Preset key).

12. Trigger Key

This hardkey initiates an immediate trigger event for afunction such as alist or step sweep. The trigger
mode must be set to Trigger Key prior to initiating atrigger event with this hardkey.

26 Chapter 2



E4438C Vector Signal Generator Overview
Front Panel Overview

13. LF OUTPUT Connector

This BNC connector is the output for modulation signals generated by the low frequency (LF) source
function generator. This output is capable of driving 3V, (nominal) into a 50Q load.

On signal generators with Option 1EM, this output relocated to a rear-panel SMB connector.

14. RF OUTPUT Connector

Thisfemale Type-N connector isthe output for RF signals. The source impedance is 50Q. For Options 501,
502, 503, and 504 the damage levels are 50 Vdc, 50 W at < 2 GHz, and 25 W at > 2 GHz maximum. For
Options 501, 502, 503, and 504 the reverse power protection circuit will trip, however, at nominally 1 W.

CAUTION E4428C and E4438C signal generators with Option 506 are not equipped with reverse
power protection circuits.

On signal generators with Option 1EM, this output relocated to a rear-panel female Type-N connector.

15. Mod On/Off Key

Pressing this hardkey enables or disables all active modulation formats (AM, FM, ®M, Pulse, or 1/Q) that
are applied to the output carrier signal.

This hardkey does not set up or activate an AM, FM, ®M, Pulse, or I/Q format; each individual modulation
format must still be set up and activated (for example, AM > AM On) or nothing will be applied to the output
carrier signal when the Mod On/0ff hardkey is enabled.

The MCD QY GFF annunciator, which is always present on the display, indicates whether active modulation
formats have been enabled or disabled with the Mod On/0ff hardkey.

16. RF On/0ff Key

This hardkey toggles the operating state of the RF signal present at the RF OUTPUT connector. The
RF On/ O f annunciator is aways visible in the display to indicate whether the RF is turned on or off.

17. Numeric Keypad

The numeric keypad consists of the 0 through 9 hardkeys, a decimal point hardkey, and a backspace hardkey
( ). The backspace hardkey enables you to backspace or specify a negative value. When specifying a
negative numeric value, the negative sign must be entered prior to entering the numeric value.
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18. Incr Set Key

This hardkey enables you to set the increment value of the current active function. When this hardkey is
pressed, the increment val ue of the current active function appears as the active entry for the display. Use the
numeric keypad, arrow hardkeys, or the knob to adjust the increment value. Changing the Incr Set hardkey’s
value also affects how much each turn of the knob changes an active function’s value according to the
knob's current ratio setting. For more information on softkeys, refer to the E4428C/38C ESG Signal
Generators Key and Data Field Reference.

19. Arrow Keys

The up and down arrow hardkeys are used to increase or decrease a numeric value, step through displayed
lists, or select itemsin arow of adisplayed list. Individual digits or characters may be highlighted using the
left and right arrow hardkeys. Once an individual digit or character is highlighted, its value can be changed
using the up and down arrow hardkeys.

20. Hold Key

This hardkey blanks the softkey label area, the active function area, and the text areas of the display.
Softkeys, arrow hardkeys, the knob, the numeric keypad, and the Incr Set hardkey have no effect once this
hardkey is pressed. Press any other hardkey to end the hold mode.

21. Return Key

This hardkey enables you to retrace your key presses. When in a menu with more than one level (More 1 of
3, More 2 of 3, etc.), the Return key will always return you to the first level of the menu.

22. Display Contrast Increase Key

This hardkey, when pressed or held, causes the display background to darken.

23. Display Contrast Decrease Key
This hardkey, when pressed or held, causes the display background to lighten.

24. Local Key

This hardkey is used to deactivate remote operation and return the signal generator to front panel control.

25. Preset Key

This hardkey is used to set the signal generator to a known state (factory or user-defined).
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26. Standby LED

Thisyellow LED indicates when the signal generator power switch is set to the standby condition.

27. Line Power LED

This green LED indicates when the signal generator power switch is set to the on position.

28. Power Switch

This switch activates full power to the signal generator when set to the on position, and deactivates all signal
generator functions when in standby mode. In standby mode, the signal generator remains connected to the
line power, and power is supplied to someinternal circuits.

29. SYMBOL SYNC Connector (Option 001/601 or 002/602)

Thisfemale BNC input connector accepts an externally supplied symbol sync signal for use with digital
modul ation applications. The expected input isa CMOS bit clock signal. It may be used in two modes.
When used as a symbol sync in conjunction with a data clock, the signal must be high during the first data
bit of the symbol. The signal must be valid during the falling edge of the data clock signal and may be a
single pulse or continuous. When the SYMBOL SYNC itself is used as the (symbol) clock, the CMOS
faling edgeis used to clock the DATA signal.

The maximum clock rate is 50 MHz. The damage levels are > +5.5 volts and < —0.5volts.

On signal generators with Option 1EM, thisinput isrelocated to arear panel SMB connector.

When using the real-time W-CDMA uplink personality, this connector should not be used to connect the
external baseband generator data clock. The BASEBAND GEN REF IN connector should be used instead.

30. DATA CLOCK Connector (Option 001/601 or 002/602)

The female BNC input connector accepts a CMOS externally supplied CMOS compatible signal data-clock
input used with digital modulation applications. The expected input isa CMOS bit clock signal where the
rising edge is aligned with the beginning data bit. The falling edge is used to clock the DATA and SY MBOL
SYNC signals.

The maximum clock rate is 50 MHz. The damage levels are > +5.5 volts and < —0.5 volts.

On signal generators with Option 1EM, thisinput isrelocated to arear panel SMB connector.
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31. DATA Connector (Option 001/601 or 002/602)

The female BNC input connector accepts a CMOS externally supplied CMOS compatible signal data input
used with digital modulation applications. The expected input isa CMOS signal whereaCMOS highis
equivalent to adatal and aCMOS low is equivalent to adata 0.

The maximum input data rate is 50 Mb/s.The data must be valid on the DATA CLOCK falling edges. The
damage levels are > +5.5 voltsand < — 0.5 valts.

On signal generators with Option 1EM, thisinput isrelocated to arear panel SMB connector.

32. Q Connector

Thisfemale BNC input connector accepts an externally supplied, analog, quadrature-phase component of
I/Q modulation. The signal level is Piq = 0.5 Vs for acalibrated output level. The input impedanceis

50Q. The damage level is 1 Vs and 10 volts pesk.
To activate asignal applied to this connector, press Mux > 1/Q Source 1 or 1/Q Source 2 and then select either

Ext 50 Ohm or Ext 600 Ohm. On signal generators with Option 1EM, thisinput is relocated as an SMB to the
rear panel.

33. | Connector

This female BNC input connector accepts an externally supplied, analog, in-phase component of 1/Q
modulation. Thesignal level is | Q= 0.5 Vs for acalibrated output level. The input impedance is 50Q.

The damage level is 1 Vs and 10 volts peak.
To activate a signal applied to this connector, press Mux > 1/Q Source 1 or 1/Q Source 2 and then select either

Ext 50 Ohm or Ext 600 Ohm. On signal generators with Option 1EM, thisinput is relocated as an SMB to the
rear panel.

30 Chapter 2



E4438C Vector Signal Generator Overview
Front Panel Display

Front Panel Display

Figure 2-2 showsthe front panel display. The LCD screen displays datafiel ds, annotations, key pressresults,
softkey labels, error messages, and annunciators that represent various active functions.

Figure 2-2 Front Panel Display
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1. Frequency Area

The current frequency setting is shown in this portion of the display. In this same area, the ESG displaysthe
indicators for frequency offset (OFFS) and multiplier (MULT) functions. In addition, REF appears when you
enable the frequency reference mode and CHANNEL is turned on when you turn on a frequency channel
(Freq Channels Off On softkey).
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2. Annunciators

The display annunciators show the status of some of the signal generator functions, and indicate error
conditions. An annunciator position may be used by more than one function. This does not create a problem,
because only one function that shares an annunciator position can be active at agiven time.

oM This annunciator appears when phase modulation isturned on. If frequency modulation
isturned on, the FMannunciator will replace ®M

ALC OFF This annunciator appears when the ALC circuit is disabled. A second annunciator,
UNLEVEL, will appear in the same position if the ALC is enabled and is unable to
maintain the output level.

AM This annunciator appears when amplitude modulation is turned on.

ARMED This annunciator appears when a sweep has been initiated and the signal generator is
waiting for the sweep trigger event.

ATTEN HOLD This annunciator appears when the attenuator hold function is turned on. When this
function is on, the attenuator is held at its current setting.

BERT This annunciator appears when the Option UN7 bit error rate test (BERT) functions are
turned on.

ENVLP This annunciator appearsif the burst envelope modulation is turned on.

ERR This annunciator appears when an error message is placed in the error queue. This

annunciator will not turn off until you have viewed all of the error messages or cleared
the error queue. You can access error messages by pressing Utility > Error Info.

EXT1 LOH Thisannunciator isdisplayed aseither EXT1 LOor EXT1 H . Thisannunciator appears
when the ac-coupled signal to the EXT 1 INPUT islessthan 0.97 V| or greater than

1.03V,,

EXT2 LOH Thisannunciator isdisplayed as either EXT2 LOor EXT2 H . Thisannunciator appears
when the ac-coupled signal to the EXT 2 INPUT islessthan 0.97 V|, or greater than

103V,
EXT REF This annunciator appears when an external frequency referenceis applied.
FM This annunciator appears when frequency modulation is turned on. If phase modulation

isturned on, the ®Mannunciator will replace FM

L This annunciator appears when the signal generator isin listener mode and is receiving
information or commands over the GPIB, RS-232, or VX1-11/Sockets (LAN) interface.
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MOD ON/ OFF This annunciator indicates if the RF carrier is modulated (MOD ON whilethereisan
active modulation format), or if the modulation is off (MOD OFF). Either condition of
this annunciator is always visiblein the display.

The MCD QN annunciator may be showing even when there are no active modulation
formats. This merely indicates that the carrier signal will be modulated when a
modulation format is enabled.

OVEN COLD This annunciator appears when the temperature of the internal oven reference oscillator
has dropped below an acceptable level. When this annunciator is on, frequency
accuracy is degraded. This condition should occur for several minutes after the signal
generator is first connected to line power. The annunciator istimed, and automatically
turns off after a specified period.

PULSE This annunciator appears when pulse modulation is turned on.

R This annunciator appears when the signal generator is remotely controlled over the
GPIB, RS-232, or VX1-11/Sockets (LAN) interface.

RF OV OFF This annunciator indicates when the RF signal is present (RF ON) at the RF OUTPUT,
or if the RF signal is not present (RF OFF) at the RF OUTPUT. Either condition of this
annunciator is aways visible in the display.

S This annunciator appears when the signal generator has generated a service reguest
(SRQ) over the GPIB, RS-232, or V X1-11/Sockets (LAN) interface.

SWEEP This annunciator appears when the signal generator is sweeping in list or step mode.

T Thisannunciator appears when the signal generator isin talker mode and is transmitting

information over the GPIB, RS-232, or VX1-11/Sockets (LAN) interface.

UNLEVEL This annunciator appears when the signal generator is unable to maintain the correct
output level. The UNLEVEL annunciator is not necessarily an indication of instrument
failure. Unleveled conditions can occur during normal operation. A second annunciator,
ALC COFF, will appear in the same position when the ALC circuit is disabled.

UNLOCK This annunciator appears when any of the phase |ocked |oops are unable to maintain
phase lock. You can determine which loop is unlocked by examining the error

messages.
3. Digital Modulation Annunciators

All digital modulation annunciators appear in this location. These annunciators appear only when the
modulation is active, and only one digital modulation can be active at any given time.
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4. Amplitude Area

The current output power level setting is shown in this portion of the display. When active, the following
functions also display indicators in the amplitude area:

e Amplitude offset (OFFS)

e Amplitude reference mode (REF)
* Alternate Amplitude (A = 0.00dB)
»  User flatness (UF)

5. Softkey Label Area

The labelsin this area define the function of the softkeys located immediately to the right of the label. The
softkey label will change depending upon the function selected. For detailed softkey descriptions, refer to
the E4428C/38C ESG Sgnal Generators Key and Data Field Reference.

6. Error Message Area

Abbreviated error messages are reported in this space. When multiple error messages occur, only the most
recent message remains displayed. Reported error messages with details can be viewed by pressing Utility >
Error Info.

7. Text Area

Thisareaof the display is used to show status information about the signal generator such as the modulation
status, sweep lists, and file catalogs. This area also enables you to perform functions such as managing
information, entering information, and displaying or deleting files.

8. Active Function Area

The current active function is shown in thisarea. For example, if frequency isthe active function, the current
frequency setting will be displayed here. If the current active function has an increment val ue associated
with it, that value is also displayed.
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Rear Panel Feature Overview

AN 1177

Figure 2-4 shows a portion of the rear panel for signal generators with Option 1EM, which moves front

panel connectors to the rear panel. For Option 1EM connectors not described in this section, see

The signal generator rear panel (Figure 2-3) provides input, output, and remote interface connections.
“Front Panel Overview” on page 24.

Rear Panel Overview

Figure 2-3
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1. 321.4 IN Connector (Option 300)

Use thisfemale SMB connector to input a downconverted 321.4 MHz GSM/EDGE signal for base
transceiver station (BTS) loopback measurements. (Option 300 also requires Options UN7, 001/6010r
002/602, and 402).

2. BER GATE IN Connector (Option UN7)

Use this connector to input the clock gate signal for the bit-error-rate measurements. The clock signal to the
BER CLK IN connector isvalid only when the signal to this connector is a high or low, depending on your
softkey selection or SCPI command. The damage levelsare > +5.5 volts and < —0.5valts. This connector accepts
a high impedance TTL-compatible signal or a 75Q input. It can be enabled or disabled by a softkey or a
SCPI command.

3. BER CLK IN Connector (Option UN7)

Use this connector to input the clock signal for the bit-error-rate measurements. The rising (positive) or
faling (negative) edge of the signal (selected either by softkey or SCPI command) causes data on the BER
DATA IN connector to be sampled. The damage levelsare > +5.5 volts and < —0.5volts. This connector accepts
a high impedance TTL-compatible signal or a 75Q input.

4. BER DATA IN Connector (Option UN7)

Use this connector to input the data streams for the bit-error-rate measurements. The rising (positive) or
faling (negative) edge of the BER CLK IN signal (selected by the softkey or the SCPI command) is used to
trigger the reading of the data. The damage levelsare > +5.5 volts and < —0.5valts. This connector accepts ahigh
impedance TTL-compatible signal or a 75Q input.

5. I-bar OUT Connector (Option 001/601 or 002/602)

Thisfemale BNC connector is used in conjunction with the | OUT connector to provide abal anced baseband
stimulus. Balanced signals are signals present in two separate conductors that are symmetrical relative to
ground, and are opposite in polarity (180 degrees out of phase). The nominal output impedance of this
connector is 50Q, DC-coupled. The damage levelsare > +2 V and < -2 V. The DC origin offset is typically
< 10 mV. The output signal levelsinto a50Q load are as follows:

« 0.5V, typical, corresponds to one unit length of the I/Q vector.
« 0.69Vy (2.84dB), typical, maximum crest factor for peaks for /4 DQPSK with alpha = 0.5.

0.71Vy (3.08 dB), typical, maximum crest factor for peaks for 7v4 DQPSK with alpha = 0.35.

Typically 1V, maximum (Option 001/601or 002/602 only).
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If you configure your signal generator with Option 1EM, thisoutput is relocated and changed from aBNC to
an SMB connector.

6. | OUT Connector (Option 001/601 or 002/602)

Thisfemale BNC connector outputs the analog, in-phase component of 1/Q modulation from the internal
baseband generator. The nominal output impedance of this connector is 50Q, DC-coupled. The damage
levelsare> +3.5V and < —3.5 V. The DC origin offset istypically < 10 mV. The output signal levelsinto a
50Q load are as follows:

« 0.5V, typical, corresponds to one unit length of the I/Q vector.

¢ 0.69Vy (284 dB), typical, maximum crest factor for peaks for 74 DQPSK with alpha=0.5.
« 0.71Vy (3.08 dB), typical, maximum crest factor for peaks for /4 DQPSK with alpha=0.35.
+ Typicaly 1V, , maximum.

If you configure your signal generator with Option 1EM, this output is relocated from a BNC to an SMB
connector.

7. COH CARRIER Output Connector

The coherent carrier connector outputs RF that is modulated with FM or ®M. The output power isnominally
—2 dBm %5 dB. The output frequency range is from 249.99900001 MHz to the maximum specified
frequency of your signal generator or 4 GHz for Option 506 instruments. If the RF output frequency is
below this range, the coherent carrier output signal will have the following frequency: Frequency of
coherent carrier = (1E9 — Frequency of RF output) in Hz. The damage levels are 20 Vdc and 13 dBm reverse
RF power.

8. Q OUT Connector (Option 001/601 or 002/602)

Thisfemale BNC connector outputs the analog, quadrature-phase component of 1/Q modulation from the
internal baseband generator. The nominal output impedance of this connector is 50Q, DC-coupled. The
damage levelsare > +3.5V and < —3.5 V. The DC origin offset is typically < 10 mV. The output signal
levelsinto a50Q load are asfollows:

« 0.5V, typical, corresponds to one unit length of the I/Q vector.

« 0.69Vy (284 dB), typical, maximum crest factor for peaks for 4 DQPSK with alpha=0.5.
« 0.71Vyy (3.08 dB), typical, maximum crest factor for peaks for /4 DQPSK with alpha=0.35.
+ Typicaly 1V, , maximum.

If you configure your signal generator with Option 1EM, this output is relocated from a BNC to an SMB
connector.
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9. Q-bar OUT Connector (Option 001/601 or 002/602)

This female BNC connector is used in conjunction with the Q OUT connector to provide a balanced
baseband stimulus. Balanced signals are signal's present in two separate conductors that are symmetrical
relative to ground, and are opposite in polarity (180 degrees out of phase). The nominal output impedance of
this connector is 50Q, DC-coupled. The damage levelsare > +2 V and < -2 V. The DC origin offset is
typically < 10 mV. The output signal levelsinto a50Q load are as follows:

« 0.5V, typical, corresponds to one unit length of the I/Q vector.

¢ 0.69Vy (284 dB), typical, maximum crest factor for peaks for 7v4 DQPSK with alpha=0.5.
« 0.71V (3.08 dB), typical, maximum crest factor for peaks for /4 DQPSK with alpha=0.35.
« Typicaly 1V, , maximum.

If you configure your signal generator with Option 1EM, this output is relocated from a BNC to an SMB
connector.

10. EVENT 1 Connector (Option 001/601 or 002/602)

This female BNC connector outputs a pulse that can be used to trigger the start of a data pattern, frame, or
timedlot. It is adjustable to within plus or minus one timeslot with one bit of resolution. With Option 401
installed, an even second output is generated. A marker isoutput every two secondsindicating the beginning
of each short code sequence for use in synchronizing CDMA analysis instruments.

There is amarker on/off condition associated with each waveform point. The marker 1 level is+3.3V
CMOS high when positive polarity is selected; —3.3 V CMOS low when negative polarity is selected. The
output on the EVENT 1 connector occurs whenever Marker 1 isturned on in the waveform. (Markers are
automatically turned on whenever you set them in a waveform segment. When you combine waveform
segments that contain Marker 1 into a sequence, the markers are automatically turned off until you toggle
them onin either the Edit Selected Waveform Sequence menu or in the Build New Waveform Sequence
menu.)

The damage levelsfor the Event 1 connector are > +8 V and < -4 V. On signal generators with Option 1EM,
this output is changed from a BNC to an SMB connector. With Option 401 you can select from several
different output signals for this connector.

11. EVENT 2 Connector (Option 001/601 or 002/602)

This female BNC connector outputs a data enable signal for gating external equipment. The output is
applicable when the external datais clocked into internally generated timeslots. Datais enabled when the
signal islow. With Option 401 installed, a marker is output on the EVENT 2 connector every

26.67 milliseconds, corresponding to the start of each short code.

There isamarker on/off condition associated with each waveform point. The marker 2 level is+3.3V
CMOS high when positive polarity is selected; —3.3 V CMOS low when negative polarity is selected. The
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output on the EVENT 1 connector occurs whenever Marker 1 isturned on in the waveform.The output on
the EVENT 2 connector occurs whenever Marker 2 isturned on in the waveform. (Markers are
automatically turned on whenever you set them in awaveform segment. When you combine waveform
segments that contain Marker 2 into a sequence, the markers are automatically turned off until you toggle
them onin either the Edit Selected Waveform Sequence menu or in the Build New Waveform Sequence
menu.)

The damage levelsare > +8 V and < —4 V. On signal generators with Option 1EM, this output is changed
from aBNC to an SMB connector. With Option 401 this connector is used for system reset output.

12. PATT TRIG IN Connector (Option 001/601 or 002/602)

Thisfemale BNC input connector can accept either a CMOS low to CMOS high, or CMOS high to CMOS
low edge trigger. The minimum trigger input pulse width, high or low, is 100 ns. The damage levels are

> +5.5 volts and < —0.5 valts. If you configure your signal generator with Option 1EM, thisinput is
changed from a BNC to an SMB connector.

Theinput tothe PATT TRIG IN connector is used to trigger the internal digital modulation pattern generator
to start asingle pattern output or to stop and re-synchronize a pattern that is being continuously output. The
trigger edge is latched and then sampled by the falling edge of the internal data bit clock to synchronize the
trigger with the data bit clock timing. The minimum delay from the trigger edge to the first bit of the frame
is1.5to0 2.5 hit clock periods.

This connector is the source for the external trigger for all of the ARB waveform generator triggers. With
Option 401, this connector is used for even second synchronization input.

13. AUX I/0 Connector

This female 37-pin connector is active only on instruments with an internal baseband generator (Option
001/6010r 002/602); on signal generators without one of these options, this connector is non-functional.
This connector provides access to the inputs and outputs described in the following table and shown in
Figure 2-5.

Connector Pin Description

ALT PWRIN Pin-16 of the Aux I/O connector is used with an internal baseband generator. This pin
accepts a CMOS signal for synchronization of external data and alternate power signal
timing. Damage levels are > +5.5 volts and < —0.5volts.

DATA CLK OUT Pin-6 of the Aux /O connector is used with an internal baseband generator. This pin
relays aCMOS hit clock signal for synchronizing serial data. Damage levels are >
+5.5 voltsand < -0.5volts.
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Connector Pin

Description (Continued)

DATA OUT

Pin-7 of the Aux I/O connector is used with an internal baseband generator. This pin
outputs data (CMOS) from theinternal data generator or the externally supplied signal at
datainput. Damage levels are > +5.5 volts and < —0.5volts.

EVENT 3

Pin-19 of the Aux I/O connector is used with an internal baseband generator. In arbitrary
waveform mode, this pin outputs atiming signal generated by Marker 3.

The marker 3 output level is +3.3 V CMOS regardless of marker polarity settings. The
reverse damage levels for this connector pin are > +5.5 volts and < —0.5volts.

EVENT 4

Pin-18 of the Aux I/O connector is used with an internal baseband generator. In arbitrary
waveform mode, this pin outputs atiming signal generated by Marker 4.

The marker 4 output level is +3.3 V CMOS regardless of marker polarity settings. The
reverse damage levels for this connector pin are > +5.5 volts and < —0.5volts.

PATT TRIGIN 2

Pin-17 of the Aux 1/O connector accepts asignal that triggers an internal pattern or frame
generator to start single pattern output. Minimum pulse width is 100 ns. Damage levels
are>+55and<-05V.

SYM SYNCOUT

Pin-5 of the Aux /O connector is used with an internal baseband generator. This pin
outputs the CMOS symbol clock for symbol synchronization, one data clock period
wide. Damage levels are > +5.5 volts and < —0.5volts.

BERMEASTRIG/BER
NO DATA

Pin-22 isused for bit error rate testing (Option UN7). Damage levels are > +5.5 volts
and < —0.5valts.

BER ERR OUT Pin-21 isused for bit error rate testing (Option UN7). Damage levels are > +5.5 volts
and < -0.5voalts

BER TEST OUT Pin-20 is used for bit error rate testing (Option UN7). Damage levels are > +5.5 volts
and < -0.5voalts

BER SYNC LOSS Pin-4 is used for bit error rate testing (Option UN7). Damage levels are > +5.5 volts and
<-0.5volts.

BER MEAS END Pin-1isused for bit error rate testing (Option UN7). Damage levels are > +5.5 volts and
<-0.5volts.
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Rear Panel Overview

* Future Capability

Thisisaproprietary bus used for Agilent Baseband Studio products, which require Option 601 or 602. This
connector is not operational for general purpose customer use. Signals are present only when a Baseband
Studio option isinstalled (for details, refer to www.agilent.com/find/basebandstudio).

15. AC Power Receptacle

The power cord receptacle accepts a three-pronged cable that is shipped with the signal generator. The line
voltage is connected here.
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16. GPIB Connector

The GPIB connector allows communications with compatible devices such as external controllers. Itis
functionally equivalent to the LAN and RS 232 connectors.

17. RS 232 Connector

This female DB-9 connector is an RS-232 serial port that can be used for controlling the signal generator
remotely. It is functionally equivalent to the GPIB and LAN connectors. The following table shows the
description of the pinouts. Figure 2-6 shows the pin configuration.

Table 2-1 RS 232 Connector
Pin Number Signal Description Signal Name

1 No Connection
2 Receive Data RECV
3 Transmit Data XMIT
4 +5V
5 Ground, 0V
6 No Connection
7 Request to Send RTS
8 Clear to Send CTS
9 No Connection

Figure 2-6

5 40 30 24 1o View looking into
Oe¢ 8¢ 7o 6e rear panel connector

18. LAN Connector

LAN based communication is supported by the signal generator viathe LAN (local area network) connector.
The LAN connector enables the signal generator to be remotely programmed by a L AN-connected
computer. The distance between a computer and the signal generator islimited to 100 meters (10Base-T) on
asingle cable. For more information about the LAN, refer to the E4428C/38C ESG Signal Generators
Programming Guide.
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19. TRIG OUT Connector

This female BNC connector outputs a TTL signal that is asserted high at the start of a dwell sequence, or at
the start of waiting for the point trigger in manual sweep mode. It is asserted low when the dwell is over,
when the point trigger is received, or once per sweep during an LF sweep. The logic polarity can be
reversed.

20. BURST GATE IN Connector (Option 001/601 or 002/602)

The female BNC connector accepts a CMOS signal for gating burst power in digital modulation
applications. The burst gating is used when you are externally supplying data and clock information. The
input signal must be synchronized with the external datainput that will be output during the burst. The burst
power envelope and modulated data are internally delayed and re-synchronized. The input signal must be
CMOS high for normal burst RF power or CW RF output power and CMOS low for RF off. The leading
edges must be synchronous with the DATA CLOCK rising edges. The damage levels are > +5.5 volts and
<-0.5volts.

If you configure your signal generator with Option 1EM, this output is changed from a BNC to an SMB
connector. With Option 401, this connector is used for system reset trigger input.

21. TRIG IN Connector

This female BNC connector accepts a CMOS signal for triggering operations, such as point-to-point in
manual sweep mode or an LF sweep in external sweep mode. Triggering can occur on either the positive or
negative edge. The damage levels are > +5.5 voltsand < -0.5volts.

22.10 MHz IN Connector

This female BNC connector accepts a—3.5 to +20 dBm signal from an external timebase reference that is
within £10 ppm (standard timebase) or £1 ppm (high stability timebase). The nominal input impedance is
50Q. The signal generator detects when avalid reference signal is present at this connector and
automatically switches from internal to external reference operation. The signal generator will only
automatically switch from internal to external reference operation when the instrument isin its factory
default mode where the Ref Oscillator Source Auto Off On softkey is set to on.

23. SWEEP OUT Connector

This female BNC connector provides avoltage range of 0 to +10 V. When the signal generator is sweeping,
the SWEEP OUT signal ranges from O V at the beginning of the sweep to +10 V at the end of the sweep
regardless of the sweep width. In CW mode this connector has no output. The output impedanceis less than
1Q and can drive 2 kQ.
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24. 10 MHz OUT Connector

This female BNC connector provides anominal signal level of +3.9 dBm +2 dB, and an output impedance
of 50Q. The accuracy is determined by the timebase used.

25. BASEBAND GEN REF IN Connector (Option 001/601 or 002/602)

The BASEBAND GEN REF IN connector accepts a0 to +20 dBm sine wave or TTL sguare wave signal
from an external timebase reference. This digital modulation reference clock is used by the internal
baseband generator for both component and receiver test applications (only the internal baseband generator
can be locked to this external reference; the RF frequency remains locked to the 10 MHz reference). The
nominal input impedanceis 50Q at 13 MHz, AC-coupled.

This connector acceptsa TTL or > —10 dBm sine wave external reference at rates from 250 kHz through
100 MHz. Theinternal clock for the arbitrary waveform generator is locked to this signal when external
reference is selected in the ARB setup. The minimum pulse width must be > 10 ns. The damage levels are
>+8V and<-8V.

This female BNC connector is provided only on signal generators with Options 001/601 and 002/602. On
signal generators with Option 1EM, this output is changed from a BNC to an SMB connector.

When using the real-time W-CDMA uplink personality, this connector is used to connect the external
baseband generator data clock.
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Using Table Editors

The signal generator table editors enable you to simplify configuration tasks, such as creating alist sweep.
This section familiarizes you with basic table editor functionality using the List Mode Values table editor as

an example.

Press Preset > Sweep/List > Configure List Sweep.

The signal generator displays the List Mode Values table editor, as shown below.

Figure 3-1

Active Function Area

\

Cursor

F‘ ECQUENCY AMPLITY :
Edit Item
4.000 000 000 00 &z | -136.00 den
HHD Insert Row
Delete Rou
List Mode Values
Frequency Pouer Duell
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525 HHz
5h5 IHz Insert Item
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; E;g iz Delete Item
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L 10 j==r Hare
/ (1 of 23

/

Table Editor Name

Active Function Area

Cursor

Table Editor Softkeys
Table Items

/

Table Items Table Editor Softkeys

displays the active table item whileits value is edited.

an inverse video identifier used to highlight specific table itemsfor
selection and editing.

select table items, preset table values, and modify table structures.

values arranged in humbered rows and titled columns (The columns
are also known as data fields. For example, the column below the
Frequency titleis known as the Frequency datafield).
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Table Editor Softkeys

The following table editor softkeys are used to load, navigate, modify, and store table item values. Press
More (1 of 2) to access Load/Store and its associated softkeys.

Edit Item

Insert Row
Delete Row

Goto Row

Insert Item
Delete Item

Page Up and
Page Down

Load/Store

displays the selected item in the active function area of the display where theitem’s
value can be modified.

inserts an identical row of table items above the currently selected row.
deletes the currently selected row.

opens amenu of softkeys (Enter, Goto Top Row, Goto Middle Row, Goto Bottom Row, Page Up,
and Page Down) used to quickly navigate through the table items.

inserts an identical item in a new row below the currently selected item.

deletes the item from the bottom row of the currently selected column.

displays table items that occupy rows outside the limits of the ten-row table display
area.

opens amenu of softkeys (Load From Selected File, Store To File, Delete File, Goto Row, Page
Up, and Page Down) used to load table items from afile in the memory catalog, or to
store the current table items as afile in the memory catalog. The signal generator
accepts a file name with amaximum length of 23 characters (alphanumeric and special
characters).

Modifying Table Items in the Data Fields

To modify existing table items:

1. Usethearrow keys or the knob to move the table cursor over the desired item. In Figure 3-1 on page 46,
thefirst item in the Frequency datafield has been selected.

2. PressEdit Item.

The selected item is displayed in the active function area of the display.

3. Usetheknob, arrow keys, or the numeric keypad to modify the value.

4. PressEnter.

The modified item is now displayed in the table.
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Configuring the RF Output

This section will show you how to create continuous wave and swept RF outputs.

Configuring a Continuous Wave RF Output
Using these procedures, you will learn how to set the following parameters:

* RF output frequency
» frequency reference and frequency offset
* RF output amplitude

» amplitude reference and amplitude offset

Setting the RF Output Frequency

1. PressPreset.

This returns the signal generator to the factory-defined state.

NOTE You can change the preset condition of the signal generator to a user-defined state. For these
examples, however, use the factory-defined preset state (the Preset Normal User softkey in
the Utility menu must be set to Normal).

2. Observe the FREQUENCY area of the display (in the upper left-hand corner).
The value displayed is the maximum specified frequency of the signal generator.
3. PressRF On/0ff.

The RF On/0ff hardkey must be pressed before the RF signal is available at the RF OUTPUT connector.
The display annunciator changes from RF OFF to R ON. The maximum specified frequency is now
being output at the RF OUTPUT connector (at the signal generator’s minimum power level).

4. PressFrequency > 700 > MHz.

The 700 MHz RF frequency is now displayed in the FREQUENCY area of the display and also in the
active entry area.

5. PressFrequency > Incr Set > 1 > MHz.

This changes the frequency increment valueto 1 MHz.
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Press the up arrow key.

Each press of the up arrow key increases the frequency by the increment value last set with the Incr Set
hardkey. The increment valueis displayed in the active entry area.

The down arrow decreases the frequency by the increment value set in the previous step. Practice
stepping the frequency up and down in 1 MHz increments.

You can also adjust the RF output frequency using the knob. Aslong as frequency isthe active function
(the frequency is displayed in the active entry ared), the knob will increase and decrease the RF output
frequency.

Use the knob to adjust the frequency back to 700 MHz.

Setting the Frequency Reference and Frequency Offset

The following procedure sets the RF output frequency as a reference frequency to which all other frequency
parameters are relative. The frequency initially shown on the display will be 0. 00 Hz (the frequency output
by the hardware minus the reference frequency). Although the display changes, the frequency output does
not change. Any subsequent frequency changes are shown as incremental or decremental to 0 Hz.

1
2.
3.

Press Preset.
Press Frequency > 700 > MHz.
Press Freq Ref Set.

This activates the frequency reference mode and sets the current output frequency (700 MHz) asthe
reference value. The FREQUENCY area displays 0. 00 Hz, which is the frequency output by the
hardware (700 MHz) minus the reference value (700 MHZz). The REF indicator is activated and the
Freq Ref Off On softkey has toggled to On.

Press RF On/Off.

The display annunciator has changed from RF OFF to R ON. The RF frequency at the RF OUTPUT
connector is 700 MHz.

Press Frequency > Incr Set > 1 > MHz.
This changes the frequency increment valueto 1 MHz.
Press the up arrow key.

This increments the output frequency by 1 MHz. The FREQUENCY area display changes to show
1.000 000 00 MHz, which is the frequency output by the hardware (700 MHz + 1 MHZz) minus the
reference frequency (700 MHz). The frequency at the RF OUTPUT changesto 701 MHz.
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Press Freq Offset > 1 > MHz.

Thisentersa 1 MHz offset. The FREQUENCY areadisplays2. 000 000 00 MHz, whichisthe
frequency output by the hardware (701 MHZz) minus the reference frequency (700 MHz) plus the offset
(1 MH2z). The GFFSindicator is activated. The frequency at the RF OUTPUT connector is still

701 MHz.

Setting the RF Output Amplitude

Press Preset.
Observe the AVPLI TUDE area of the display.

The display reads the minimum power level of the signal generator. Thisisthe normal preset RF output
amplitude.

Press RF On/0ff.

The display annunciator changes from RF OFF to R ON. The RF signal is now being output at the
minimum power level at the RF OUTPUT connector.

Press Amplitude > —20 > dBm.

This changes the amplitude to —20 dBm. The new —20 dBm RF output power is now displayed in the
AVPLI TUDE area of the display and also in the active entry area.

Amplitude is still the active function until you press another front panel function key. You can also
change the amplitude using the up and down arrow keys and the knob.

Setting the Amplitude Reference and Amplitude Offset

The following procedure sets the RF output power as an amplitude reference to which all other amplitude
parameters are relative. The amplitude initially shown on the display will be 0 dB (the power output by the
hardware minus the reference power). Although the display changes, the output power does not change. Any
subsequent power changes are shown as incremental or decremental to 0 dB.

1. PressPreset.

2. Press Amplitude > -20 > dBm.

3. Press More (1 of 2) > Ampl Ref Set.
This activates the amplitude reference mode and sets the current output power (=20 dBm) as the
reference value. The AMPLI TUDE area displays 0. 00 dB, which isthe power output by the hardware
(20 dBm) minus the reference value (—20 dBm). The REF indicator is activated and the Ampl Ref Off On
softkey has toggled to On.
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4. PressRF On/0ff.

The display annunciator has changed from RF COFF to R O\ The power at the RF OUTPUT connector
is—20dBm.

5. Pressincr Set > 10 > dB.
This changes the amplitude increment value to 10 dB.
6. Usethe up arrow key to increase the output power by 10 dB.

The AMPLI TUDE areadisplays 10. 00 dB, which is the power output by the hardware (-20 dBm plus
10 dBm) minus the reference power (—20 dBm). The power at the RF OUTPUT connector changesto
-10 dBm.

7. Press Ampl Offset > 10 > dB.

Thisentersa 10 dB offset. The AMPLI TUDE area displays 20. 00 dB, which is the power output by the
hardware (—10 dBm) minus the reference power (—20 dBm) plus the offset (10 dB). The OFFS indicator
is activated. The power at the RF OUTPUT connector is still =10 dBm.

Configuring a Swept RF Output

The signal generator has two sweep types: step and list.

NOTE List sweep data cannot be saved within an instrument state, but can be saved to the memory
catalog. For instructions on saving list sweep data, see “ Storing Files’” on page 67.

During swept RF output, the FREQUENCY and AMPLI TUDE areas of the signal generator’s
display are deactivated, depending on what is being swept.

This section provides an explanation of the differences between step sweep and list sweep. You will learn
two ways to configure the signal generator’s RF output to sweep adefined set of frequency and amplitude
points. You will create a step sweep and then you will use these points as the basis for anew list sweep.

Step Sweep

When a step sweep is activated, the signal generator sweeps the RF output based on the values entered for
RF output start and stop frequencies and amplitudes, a number of equally spaced points (steps) to dwell
upon, and the amount of dwell time at each point. The frequency, amplitude, or frequency and amplitude of
the RF output will sweep from the start amplitude/frequency to the stop amplitude/frequency, dwelling at
equally spaced intervals defined by the # Points softkey value.

Step sweep provides alinear progression through the start-to-stop frequency and/or amplitude values. You
can toggle the direction of the sweep, up or down. When the Sweep Direction Down Up softkey is set to Up,
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values are swept from the start frequency/amplitude to the stop frequency/amplitude. When set to Down,
values are swept from the stop frequency/amplitude to the start frequency/amplitude.
Configuring and Activating a Single Step Sweep

In this procedure, you will create a step sweep with nine, equally spaced points and the following
parameters:

» frequency range from 500 MHz to 600 MHz
e amplitude from —20 dBmto 0 dBm
+ dwell time 500 msat each point
1. PressPreset.
2. Press Sweep/List.

This opens a menu of sweep softkeys.
3. Press Sweep Repeat Single Cont.

This toggles the sweep repeat from continuous to single.
4. Press Configure Step Sweep.
5. PressFreq Start > 500 > MHz.

This changes the start frequency of the step sweep to 500 MHz.
6. PressFreq Stop > 600 > MHz.

This changes the stop frequency of the step sweep to 600 MHz.
7. Press Ampl Start > -20 > dBm.

This changes the amplitude level for the start of the step sweep.
8. Press Ampl Stop > 0 > dBm.

This changes the amplitude level for the end of the step sweep.
9. Press# Points > 9 > Enter.

This sets the number of sweep pointsto nine.
10. Press Step Dwell > 500 > msec.

This sets the dwell time at each point to 500 milliseconds.
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11. Press Return > Sweep > Freq & Ampl.

This sets the step sweep to sweep both frequency and amplitude data. Selecting this softkey returns you
to the previous menu and turns on the sweep function.

12. Press RF On/Off.
The display annunciator changes from RF OFF to RF ON.
13. Press Single Sweep.

A single sweep of the frequencies and amplitudes configured in the step sweep is executed and available
at the RF OUTPUT connector. On the display, the SWEEP annunciator appears for the duration of the
sweep, and aprogress bar shows the progression of the sweep. The Single Sweep softkey can also be used
to abort a sweep in progress.

Activating Continuous Step Sweep

Press Sweep Repeat Single Cont.

Thistoggles the sweep from single to continuous. A continuous repetition of the frequencies and amplitudes
configured in the step sweep are now available at the RF OUTPUT connector. The SWEEP annunciator
appears on the display, indicating that the signal generator is sweeping, and progression of the sweep is
shown by a progress bar.

List Sweep

List sweep allowsyou to create alist of arbitrary frequency, amplitude, and dwell time values and sweep the
RF output based on the entriesin the List Mode Values table.

Unlike a step sweep that contains linear ascending/descending frequency and amplitude values spaced at
equal intervals throughout the sweep, list sweep frequencies and amplitudes can be entered at unequal
intervals, nonlinear ascending/descending, or random order.

For convenience, the List Mode Values table can be copied from a previously configured step sweep. Each
step sweep point’s associated frequency, amplitude and dwell time values are entered into arow in the List
Mode Values table, as the following exampleillustrates.

Configuring a List Sweep Using Step Sweep Data

In this procedure, you will leverage the step sweep points and change the sweep information by editing
severa pointsin the List Mode Values table editor. For information on using table editors, see “Using Table
Editors’ on page 46.

1. Press Sweep Repeat Single Cont.

This toggles the sweep repeat from continuous to single. The SWEEP annunciator is turned off. The
sweep will not occur until it istriggered.
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2. Press Sweep Type List Step.
Thistoggles the sweep type from step to list.
3. Press Configure List Sweep.

This opens another menu displaying softkeys that you will use to create the sweep points. The display
shows the current list data. (When no list has been previoudly created, the default list contains one point
set to the signal generator’s maximum freguency, minimum amplitude, and a dwell time of 2 ms.)

4. Press More (1 of 2) > Load List From Step Sweep > Confirm Load From Step Sweep.

The points you defined in the step sweep are automatically loaded into the list.

Editing List Sweep Points

1. PressReturn > Sweep > Off.

Turning the sweep off allows you to edit the list sweep points without generating errors. If sweep
remains on during editing, errors occur whenever one or two point parameters (frequency, power, and
dwell) are undefined.

2. Press Configure List Sweep.

This returns you to the sweep list table.

Use the arrow keys to highlight the dwell timein row 1.
4. PressEdit Item.

The dwell time for point 1 becomes the active function.
5. Press 100 > msec.

This enters 100 ms as the new dwell time value for row 1. Note that the next item in the table (in this
case, the frequency value for point 2) becomes highlighted after you press the terminator softkey.

6. Using the arrow keys, highlight the frequency valuein row 4.
7. PressEdit Iltem > 545 > MHz.

This changes the frequency value in row 4 to 545 MHz.
8. Highlight any column in the point 7 row and press Insert Row.

This adds a new point between points 7 and 8. A copy of the point 7 row is placed between points 7 and
8, creating a new point 8, and renumbering the successive points.
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9. Highlight the frequency item for point 8, then press Insert Item.

Pressing Insert Item shifts frequency values down one row, beginning at point 8. Note that the original
frequency values for both points 8 and 9 shift down one row, creating an entry for point 10 that contains
only afrequency value (the power and dwell time items do not shift down).

The frequency for point 8 is still active.
10. Press 590 > MHz.
11. Press Insert Item > -2.5 > dBm.

Thisinserts anew power value at point 8 and shifts down the original power values for points 8 and 9 by
one row.

12. Highlight the dwell time for point 9, then press Insert Item.
A duplicate of the highlighted dwell timeisinserted for point 9, shifting the existing value down to
complete the entry for point 10.

Activating List Sweep for a Single Sweep

1. PressReturn > Sweep > Freq & Ampl

Thisturnsthe sweep on again. No errors should occur if all parametersfor every point have been defined
in the previous editing process.

2. PressSingle Sweep.

The signal generator will single sweep the pointsin your list. The SWEEP annunciator activates during
the sweep.

3. Press More (1 of 2) > Sweep Trigger > Trigger Key.

This sets the sweep trigger to occur when you press the Trigger hardkey.
4. Press More (2 of 2) > Single Sweep.

This arms the sweep. The ARMED annunciator is activated.
5. Pressthe Trigger hardkey.

The signal generator will single sweep the pointsin your list and the SWEEP annunciator will be
activated during the sweep.
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Generating the Modulation Format

The modulation format can be turned on prior to or after setting your signa parameters. Perform the
following steps to turn the modul ation format on:

1. Accessthe first menu within the modulation format.

This menu will show a softkey that has the format’s name associated with off and on. For example, AM
Off On. For some formats, the off/on key may appear in additional menus other than the first one.

2. Pressthe modulation format off/on key until On is highlighted.

Figure 3-2 showsthe AM modul ation format’s first menu with off asthe format status, and Figure 3-3 shows
an example of the ESG display when the format is active.

The modulation format is now generated, however the carrier signal is not modulated until the Mod On/0ff
key has been set to on. Depending on the modulation format, the signal generator may require afew seconds
to build the signal. Within the digital formats, you may see aBaseBand Reconf i guri ng status bar
appear on the display. Once the signal is generated, an annunciator showing the name of the format will
appear on the display indicating that the modulation format is active. For digital formats, thel / Q
annunciator will appear in addition to the name of the modulation format.

Figure 3-2 Modulation Format Off
FREQUENCY AMPLITUDE At Path
20.000 000 000 000 &z | ~135.00 e e :
- . First AM Menu
rﬂ on Modulation Format is Off

| AM Depth

Hodulation Status Information .1

Hod State Depth/Dev Source Rate Uaveform

A Source,)
(Internall

AN _Rate
Lo0.0 Hz

AN Haveform,|
(5inel

Al Depth Couple
IITE On

56 Chapter 3



Basic Operation
Generating the Modulation Format

Figure 3-3 Modulation Format On
Active Modulation Format Annunciator
FREQLENCY AMPLITUDE AH Path
20.000 000 000 00Q %+ | -135.00 cen < _
rﬂ - First AM Menu
oH 0 . .
L1 o Modulation format is On
| AM Oepth
Nlodulation Status Information u.17
NMod State Depth/Dev Source Rate Uaveform
T 0.1% Internal  LDO.OHz Sine i, Sourcey
AM_Rate
Lo0.0 He
Ar NBUEFDI"I’H.
(Sing)
Al DEPtDuB%E
Chapter 3 57



Basic Operation
Modulating the Carrier Signal

Modulating the Carrier Signal

The carrier signal is modul ated when the Mod On/0ff key is set to on and a modulation format is active.
When the key is set to on, the MOD QN annunciator showsin the display. The MCD GOFF annunciator appears
when the key is set to off. The MOD ON annunciator may be showing even when there are no active
modulation formats. Thisjust indicates that the carrier signal will be modulated when amodulation format is
turned on.

To Turn the Modulation On

Press the Mod On/0ff key until the MOD ON annunciator appears in the display.

The carrier signal is now modulated with all active modulation formats. Thisis the factory default.

To Turn the Modulation Off

Press the Mod On/0ff key until the MOD OFF annunciator appearsin the display.

The carrier signal is no longer modulated or capable of being modul ated when amodulation format is active.

Figure 3-4 Carrier Signal Modulation Status
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Creating and Applying User Flatness Correction

User flatness correction allows the digital adjustment of RF output amplitude for up to 1601 frequency
pointsin any frequency or sweep mode. Using an Agilent E4416A/17A or E4418B/19B power meter
(controlled by the signal generator through GPIB) to calibrate the measurement system, a table of power
level correctionsis created for frequencies where power level variations or losses occur. These frequencies
may be defined in sequential linear steps or arbitrarily spaced.

If you do not have an Agilent E4416A/17A or E4418B/19B power meter, or if your power meter does not
have a GPIB interface, the correction values can be manually entered into the signal generator.

To allow different correction arrays for different test setups or different frequency ranges, you may save
individual user flatness correction tables to the signal generator’'s memory catalog and recall them on
demand.

Follow the stepsin the next sections to create and apply user flatness correction to the signal generator’s RF
output.

Afterward, follow the stepsin “Recalling and Applying a User Flatness Correction Array” on page 64 to
recall auser flatness file from the memory catalog and apply it to the signal generator’s RF output.

Creating a User Flatness Correction Array

In this example, you will create a user flatness correction array. The flatness correction array contains ten
frequency correction pairs (amplitude correction values for specified frequencies), from 1to 4 GHz in
1 GHz intervals.

An Agilent E4416A/17A/18B/19B power meter (controlled by the signal generator via GPIB) and E4413A
power sensor are used to measure the RF output amplitude at the specified correction frequencies and
transfer the results to the signal generator. The signal generator reads the power level datafrom the power
meter, calculates the correction values, and stores the correction pairsin the user flatness correction array.

If you do not have the required Agilent power meter, or if your power meter does not have a GPIB interface,
you can enter correction values manually.

Required Equipment

Adgilent E4416A/17A/18B/19B power meter
Adgilent E4413A E Series CW power sensor
GPIB interface cable

» adapters and cables, as required

Chapter 3 59



Basic Operation
Creating and Applying User Flatness Correction

Configure the Power Meter

1. Select SCPI asthe remote language for the power meter.

2. Zero and calibrate the power sensor to the power meter.

3. Enter the appropriate power sensor calibration factors into the power meter as appropriate.
4

Enable the power meter’s cal factor array.

NOTE For operating information on your particular power meter/sensor, refer to its operating
guide.

Connect the Equipment

Connect the equipment as shown in Figure 3-5 on page 61.

NOTE During the process of creating the user flatness correction array, the power meter is
controlled by the signal generator via GPIB. No other controllers are allowed on the GPIB
interface.
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Figure 3-5 User Flatness Correction Equipment Setup
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Configure the Signal Generator

1. PressPreset.

2. Configurethe signal generator to interface with the power meter.

a.  Press Amplitude > More (1 of 2) > User Flatness > More (1 of 2) > Power Meter > E4416A, E4417A, E4418B,
or E4419B.

b. Press Meter Address > enter the power meter’'s GPIB address > Enter.

c. For E4417A and E4419B power meters, press Meter Channel A B to select the power meter’s active
channel.

d. Press Meter Timeout to adjust the length of time before the instrument generates atimeout error if
unsuccessfully attempting to communicate with the power meter.

3. Press More (2 of 2) > Configure Cal Array > More (1 of 2) > Preset List > Confirm Preset.

This opens the User Flatness table editor and presets the cal array frequency/correction list.
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10.

Press Configure Step Array.

This opens a menu for entering the user flatness step array data.

Press Freq Start > 500 > MHz.

Press Freq Stop > 1 > GHz.

Press # of Points > 10 > Enter.

Steps 4, 5, and 6 enter the desired flatness-corrected frequencies into the step array.

Press Return > Load Cal Array From Step Array > Confirm Load From Step Sweep.

This populates the user flatness correction array with the frequency settings defined in the step array.
Press Amplitude >0 > dBm.

Press RF On/0ff.

This activates the RF output and the R= QN annunciator is displayed on the signal generator.

Perform the User Flatness Correction

NOTE If you are not using an Agilent E4416A/17A/18B/19B power meter, or if your power meter

does not have a GPIB interface, you can perform the user flatness correction manually. For
instructions, see “ Performing the User Flatness Correction Manually” on page 63.

1

Press More (1 of 2) > User Flatness > Do Cal.

This creates the user flatness amplitude correction value table entries. The signal generator enters the
user flatness correction routine and a progress bar is shown on the display.

When prompted, press Done.
This loads the amplitude correction values into the user flatness correction array.
If desired, press Configure Cal Array.

This opens the user flatness correction array, where you can view the stored amplitude correction values.
The user flatness correction array title displays User Fl at ness: ( UNSTORED) indicating that the
current user flatness correction array data has not been saved to the memory catalog.

62
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Performing the User Flatness Correction Manually

If you are not using an Agilent E4416A/17A/18B/19B power meter, or if your power meter does not have a
GPIB interface, complete the steps in this section and then continue with the user flatness correction tutorial.

1. Press More (1 of 2) > User Flatness > Configure Cal Array.

This opens the User Flatness table editor and places the cursor over the frequency value (1 GHz) for
row 1. The RF output changes to the frequency value of the table row containing the cursor and
1. 000 000 000 00 isdisplayed inthe AVPLI TUDE area of the display.

Observe and record the measured value from the power meter.
Subtract the measured value from 0 dBm.

Move the table cursor over the correction value in row 1.

o > W DN

Press Edit Item > enter the difference value from step 3 > dB.

The signal generator adjusts the RF output amplitude based on the correction value entered.

o

Repeat steps 2 through 5 until the power meter reads 0 dBm.

7. Usethe down arrow key to place the cursor over the frequency value
for the next row. The RF output changes to the frequency value of the table row containing the cursor, as
shown in the AMPLI TUDE area of the display.

8. Repeat steps 2 through 7 for every entry in the User Flatness table.

Save the User Flatness Correction Data to the Memory Catalog

This process allows you to save the user flatness correction datain the signal generator’s memory catal og.
With several user flatness correction files saved to the memory catalog, any file can be recalled, loaded into
the correction array, and applied to the RF output to satisfy specific RF output flatness requirements.

1. PressLoad/Store.

2. Press Store to File.

3. Enter thefile name FLATCAL1 using the a phanumeric softkeys, numeric keypad, or the knob.
The maximum file name length is 23 characters (al phanumeric and specia characters).

4. PressEnter.

The user flatness correction array file FLATCAL 1 is now stored in the memory catalog asa UFLT file.
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Applying a User Flatness Correction Array
Press Return > Return > Flatness Off On.

This applies the user flatness correction array to the RF output. The UF indicator is activated in the
AMVPLI TUDE section of the signal generator’s display and the frequency correction data contained in the
correction array is applied to the RF output amplitude.

Recalling and Applying a User Flatness Correction Array

Before performing the stepsin this section, complete “ Creating a User Flatness Correction Array” on
page 59.

1. PressPreset.

2. Press Amplitude > More (1 of 2) > User Flatness > Configure Cal Array > More (1 of 2) >
Preset List > Confirm Preset.

Press More (2 of 2) > Load/Store.
4. Ensurethat the file FLATCAL1 is highlighted.
Press Load From Selected File > Confirm Load From File.

This popul ates the user flatness correction array with the data contained in the file FLATCAL1. The user
flatness correction array title displays User Fl at ness: FLATCALL.

6. PressReturn > Flatness Off On.

This applies the user flatness correction data contained in FLATCAL 1.

Returning the Signal Generator to GPIB Listener Mode

During the user flatness correction process, the power meter is controlled by the signal generator via GPIB,
and no other controllers are allowed on the GPIB interface. The signal generator operatesin GPIB talker
mode, as a device controller for the power meter. In this operating mode, it cannot receive SCPI commands
viaGPIB.

NOTE Before interfacing the signal generator to aremote controller, the signal generator must be
in GPIB listener mode. Press the GPIB Listener Mode softkey to return the signal generator to
GPIB listener mode from GPIB talker mode.

If an RF carrier has been previously configured, you must save the present instrument state
before returning the signal generator to GPIB listener mode.

1. Saveyour instrument state to the instrument state register.

For instructions, see “ Saving an Instrument State” on page 69.
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2. PressGPIB Listener Mode.

This presets the signal generator and returnsit to GPIB listener mode. The signal generator can now
receive remote commands executed by a remote controller connected to the GPIB interface.

3. Recall your instrument state from the instrument state register.

For instructions, see “Recalling an Instrument State” on page 70.
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Using the Memory Catalog

The signal generator’s interface for stored files is the memory catalog. From the memory catalog, you can
view, store, and save files using the signal generator’s front panel or aremote controller. For more
information on the memory catalog and performing these tasks remotely, see the E4428C/38C ESG SCPI
Command Reference and the E4428C/38C ESG Vector Sgnal Generator Programming Guide.

The memory catalog may contain the following file types and their associated data:

BI N binary data

LI ST sweep data from the List Mode Values table including frequency, amplitude, and dwell
time
STAT instrument state data (controlling instrument operating parameters, such as frequency,

amplitude, and mode)

UFLT user flatness calibration correction pair data (user-defined frequency and corresponding
amplitude correction values)

NOTE You may have additional file types depending on which options you have installed in your
signal generator.

Viewing Stored Files

1. Press Utility > Memory Catalog > Catalog Type.

All filesin the memory catalog are listed in alphabetical order, regardless of which catalog type you
select. File information appears on the display and includes the file name, file type, file size, and thefile
modification date and time.

2. PressList
The Catalog of List Filesis displayed.
3. PressCatalog Type > State.
The Catalog of State Filesis displayed.
4. Press Catalog Type > User Flatness.
The Catalog of USERFLAT Filesis displayed.
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Storing Files

To store afile to the memory catal og, first create afile. For this example, use the default list sweep table.

1
2.

Press Preset.

Press Sweep/List > Configure L1list Sweep > More (1 of 2) > Load/Store.
This opens the Catalog of List Files.

Press Store to File.

This displays a menu of alphabetical softkeysfor naming thefile. St ore t o: isdisplayedinthe active
function area.

Enter the file name LI ST1 using the alphabetical softkeys and the numeric keypad.
The maximum file name length is 23 characters (al phanumeric and specia characters).
Press Enter.

Thefileis now displayed in the Catalog of List Files, showing the file name, file type, file size, and the
date and time the file was modified.
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Using the Instrument State Registers

The instrument state memory is a section of memory divided into 10 sequences (numbered O through 9).
Each sequence consists of 100 registers (numbered 00 through 99). Instrument state sequences and registers
save and recall signal generator settings, and provide a quick way to reconfigure the signal generator when
switching between different instrument and signal configurations.

The signal generator with Option 005 (internal hard drive) has approximately 4 GB available for storing
instrument state files, as well as other user data. Without Option 005, the signal generator has 20 MB
available for data and instrument state storage. Instrument state files vary in length, depending on the signal
generator’s configuration.

Data, such aswaveform files, arb settings, and table entries, are not stored in instrument state memory. Store
these data types to the signal generator’s memory. Instrument state memory only saves settings such as
frequency, attenuation, power, and so forth.

The following list shows additional signal generator settings that are not saved with the save operation.

FM Deviation List Mode Freq Hosthame FTP Server

RS-232 Baud Rate List Mode Power IP Address Web Server (HTTP)
Remote Language List Mode Dwell Subnet Mask Sockets SCPI (TELNET)
System Security Level List Mode Sequence  Default Gateway  VXI-11 SCPI

System Security Level Display  Display State On/Off MAC

System Security Level State PM Deviation Manual DHCP

Waveform datais stored in NVWFM. If you have awaveform file and want to save signal generator settings
associated with that file, you must first select the waveform in volatile waveform memory (WFM1). When
you save the signal generator settings associated with that file to instrument state memory, areferenceto the
waveform file name will also be saved. Refer to “ Storing and L oading Waveform Segments’ on page 110
for information on saving waveform files.

For more information on storing file data, such as waveform files, arb setups, and table entries, refer to
“Storing Files’ on page 67. Refer to the E4428C/38C ESG Sgnal Generator Programming Guide and the
E4428C/38C ESG Sgnal Generator Key and Data Field Reference for more information on the save and
recall function.

The following procedure demonstrates saving settings to the instrument state memory.
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Saving an Instrument State

1

Preset the signal generator, then turn on amplitude modulation (the AMannunciator will turn on):

a. PressFrequency > 800 > MHz.
b. Press Amplitude > 0 > dBm.
c. PressAM > AM Off On.

(Optional) If you want to associate these settings with awaveform file, load the waveform file into
WFM1 and select it. Refer to “ Storing and L oading Waveform Segments’ on page 110 for information
on loading waveform filesinto WFM 1.

Press Save > Select Seq > 1 > Enter.

The sequence number becomes the active function. The signal generator displaysthe last sequence used.
Using the arrow keys, set the sequence to 1.

Press Select Reg > 1 > Enter.

The register number in sequence 1 becomes the active function. The signal generator displays either the
last register used accompanied by thetext: (i n use), or (if no registersare in use) register 00
accompanied by thetext: (avai | abl e) . Usethe arrow keysto select register 01.

Press Save Seq[1] Reg[01].

This saves the instrument state, configured in step 1, to sequence 1, register 01 of the instrument state
register. If awaveformis selected or being played, then the name of the waveform file will also be saved
in sequence 1, register 01 of the instrument state register.

Press Add Comment to Seq[1] Reg[01].

This enables you to add a descriptive comment to sequence 1 register 01. The comment appearsin the
Saved States list when the Recall hardkey is pressed. If you have a waveform associated with the
instrument state, enter the name of the waveform in the comment field. You can then easily identify the
name of the waveform and associated instrument state when the Recall hardkey is pressed.

Using the letter softkeys, front-panel knob, or numeric keypad, enter acomment and press Enter.
Press Edit Comment In Seq[1] Reg[01].

If you wish, you can now change the descriptive comment for sequence 1 register O1.

Changes to a previously saved instrument state, for example an instrument state saved in Seq n, Reg nn, can
be re-saved by highlighting that register and pressing Re-SAVE Seq[n] Reg[nn]. The re-save function
overwrites previously saved instrument state settings, with the new settings configuration.
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Recalling an Instrument State

Using this procedure, you will learn how to recall instrument settings saved to an instrument state register.
Refer to the “Recalling an Instrument State for a Waveform File” on page 71 for recalling awaveform file
and associated signal generator settings.

1. PressPreset.
2. Pressthe Recall hardkey.
Notice that the Select Seq softkey shows sequence 1. (Thisisthe last sequence that you used.)
3. PressRECALL Reg.
The register to be recalled in sequence 1 becomes the active function. Press the up arrow key once to

select register 1. Your stored instrument state settings are recalled.

Saving an Instrument State for a Waveform File

This procedure applies to the E4438C with Option 001/601 or 002/602 and demonstrates saving signal
generator settings associated with awaveform file.

NOTE The save function saves only areference to awaveform file name; no waveform datais
stored. Use Save function to save signal generator settings and use the Store function to
save waveform data.

Signal generator settings such as frequency, power, attenuator level, and so forth, are not saved when a
waveform file is saved. Signal generator settings, associated with the waveform file, must be saved to the
instrument state memory. If thereisno waveform filein NVWFM, create one using the procedure, “ Creating
Waveform Segments’ on page 105.

You can save signal generator settings, associated with awaveform file, so that when you load the waveform
from NVWFM and play it, the same signal generator settings can be recalled and re-applied to the waveform
file.

Set Up the Signal Generator

Press Preset.

Press Frequency > 2 > GHz.

Press Amplitude > - 30 > dBm.

Press Mode > Dual ARB > Waveform Segments.

Scroll and highlight awaveform filein NVWFM.

o >~ w DN P
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6. PressLoad Segment From NVWFM Memory > Return.
7. Scroll to the waveform selected in step 3.

8. Press Select Waveform > ARB Off On to on. This causes the signal generator to play the waveform.

Saving the Instrument State

Instrument states can be saved to any one of the 10 sequences and 100 registersin instrument state memory.
In this procedure, sequence 01 and register 02 are used to store the signal generator settings associated with
the waveform file. The Save function saves instrument settings and the waveform file name but does not
save waveform data. Waveform data can only be saved to NVWFM with the Store function.

1. Press Save > Select Seq > 01 > Select Reg > 02 > Save Reg.

The signal generator settings associated with the waveform file and the name of the waveform file are now
saved in the instrument state memory. The section “Recalling an Instrument State for a Waveform File” on
page 71 describes how to recall thisinstrument state and associated waveform file.

Recalling an Instrument State for a Waveform File

This procedure appliesto signal generators with Option 001/601 or 002/602 and demonstrates recalling
signal generator settings associated with a waveform file. This procedure uses the same signal generator
settings and waveform file used in the previous section, “ Saving an Instrument State for a Waveform File”.

1. Press Mode > Dual ARB > Waveform Segments.

2. Scroll and select the waveform file used in the previous section.

3. PressLoad Segment From NVWFM Memory > Return > Select Waveform
4. Highlight thefile selected in step 3.

5. Press Select Waveform.

The next step recalls the signal generator settings associated with the waveform file. These settings were
saved to Seq 01 and Reg 02 in the previous procedure.

6. PressRecall > Select Seq > 01
7. PressRECALL Reg > 01 > Enter.

The signal generator is now setup with the same settings associated with the waveform previously saved to
NVWFM.
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Deleting Registers and Sequences

These procedures describe how to delete registers and sequences saved to an instrument state register.

Deleting a Specific Register within a Sequence

1
2.

Press Preset.

Press the Recall or Save hardkey.

Notice that the Select Seq softkey shows the last sequence that you used.

Press Select Seq and enter the sequence number containing the register you want to delete.

Press Select Reg and enter the register number you want to del ete.

Notice that the Delete Seq[n] Reg[nn] should be loaded with the sequence and register you want to delete.
Press Delete Seq[n] Reg[nn].

This deletes the chosen register.

Deleting All Registers within a Sequence

1
2.

Press Preset.

Press the Recall or Save hardkey.

Notice that the Select Seq softkey shows the last sequence that you used.

Press Select Seq and enter the sequence number containing the registers you want to delete.
Press Delete all Regs in Seq[n].

This deletes all registers in the selected sequence.

Deleting All Sequences

CAUTION Be sure you want to del ete the contents of all registers and all sequencesin the instrument

state register.

Press Preset.

Press the Recall or Save hardkey.

Notice that the Select Seq softkey shows the last sequence that you used.
Press Delete All Sequences.

This deletes all of the sequences saved in the instrument state register.
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Using Security Functions

This section describes how to use the ESG security functions to protect and remove classified proprietary
information stored or displayed in the instrument. All security functions described in this section aso have
an equivalent SCPI command for remote operation. (Refer to the “ System Subsystem (:SY STem)” chapter
of the E4428C/38C ESG Sgnal Generators SCPI Command Reference for more information.)

Understanding Memory Types

The ESG comprises several memory types, each used for storing a specific type of data. Before removing
sensitive data, it isimportant to understand how each memory typeis used in the signal generator. The
following tables describe each memory type used in the base instrument, optional baseband generator, and
optional hard disk.

Table 3-1 Base Instrument Memory
& E
25| S
Memory £8|go
Type and a §. £ % Purpose/Contents | Data Input Method | Location in Instrument and Remarks
Size 2= 188
8e | xc
b= E |l s 2
=2 |82
Main Yes No firmware operating | operating system CPU board
Memory memory (not user)
(SDRAM)
64 MB
Main Yes Yes factory calibration/ | firmware upgrades | CPU board (same chip as firmware
Memory configuration data | and user-saved data | memory, but managed separately)
(Flash) user file system, User datais not stored in this memory if
20MB which includes hard disk (Option 005) isinstalled.
ng;siifgilgrzanon’ Because this 32-MB memory chip
instrumentsta,teﬁ contains 20 MB of user data (described
' here) and 12 MB of firmware memory, a
waveforms ; . :
(including header full-chip erase isnot desirable. User data
and marker data) aress are selectively and completely
modulation ' sanitized when you perform the Erase and
definitions, and Sanitize function.
sweep lists
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Table 3-1 Base Instrument Memory (Continued)
& E
-5 | S
Memory £E8|ge
Type and a § -% % Purpose/Contents | Data Input Method | Location in Instrument and Remarks
Size 25 |2
EE|s&8
=2 |82
Firmware |No Yes main firmware factory installed or | CPU board (same chip as main flash
Memory image firmware upgrade | memory, but managed separately)
(Flash) . . :
During normal operation, this memory
12MB cannot be overwritten. It isonly
overwritten during the firmware
installation or upgrade process.
Because this 32-MB memory chip
contains 20 MB of user dataand 12 MB of
firmware memory (described here), a
full-chip erase is not desirable. User data
aress are selectively and completely
sanitized when you perform the Erase and
Sanitize function.
Battery Yes Yes user-editabledata | firmware operations | CPU board
Ezﬁ:g:y (teble editors) The battery can be removed to clear the
(SRAM) last instrument state memory, but must be reinstalled for the
and last instrument instrument to operate. The battery is
512 kB state backup located on the motherboard.
user-stored
instrument states
Bootrom No Yes CPU bootup factory programmed | CPU board
Memory program and During normal operation, this memory
(Flash) firmware X )
|oader/updater cannot be overwritten or erased. This
128 kB read-only datais programmed at the
factory.
Calibration | No Yes factory calibration/ |factory or service motherboard
Backup configurationdata | only
Memory backup
(Flasn) no user data
512 KB
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Table 3-1 Base Instrument Memory (Continued)
= &
28 |_ 32
Memory £8|g9
Type and a § -% % Purpose/Contents | Data Input Method | Location in Instrument and Remarks
Size 25 |2
SE|asg
=2 |82
Boards No Yes factory calibration | factory or service all RF boards, baseband generator, and
Memory and information only motherboard
(Flash) files, code images,
512 Bytes and self-test limits
no user data
Micro- Yes No CPU dataand memory ismanaged | CPU board
processor instruction cache by CPU, not user
Cache
(SRAM)
3kB
Table 3-2 Baseband Generator Memory (Options 001/601 and 002/602)
gl 8
o2 =
Memory £8 |39
Type and a § -% g Purpose/Contents  |Data Input Method |Remarks
Size 25 |2
E£E o5
=2 |8%2
Waveform | Yes No waveforms normal user User datais completely sanitized when you
Memory (including header operation perform the Erase and Sanitize function.
(SDRAM) and marker data) and
40-320 MB PRAM
BBG No Yes firmware imagefor |firmware upgrade
Firmware baseband generator
Memory
(Flash)
32MB
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Table 3-2 Baseband Generator Memory (Options 001/601 and 002/602) (Continued)
-~
< b=
25| S
Memory £E8|ge
Type and a §. £ % Purpose/Contents  |Data Input Method |Remarks
Size 2= |2 e
SE |5
= 5 = o
=2 |82
Coprocessor | Yes No operating memory of | During normal This memory is used during normal
Memory baseband operation, some user |baseband generator operation. It is not
(SRAM) coprocessor CPU information, such as |directly accessible by the user.
payload data, can
32MB remaininthe
memory.
Buffer No No support buffer normal user This memory is used during normal
Memory memory for ARB operation baseband generator operation. It is not
(SRAM) and real-time directly accessible by the user.
5x512kB gpplications
Table 3-3 Hard Disk Memory (Option 005)
~
< b=
o5 | S
Memory £E8|ge
Type and a §. £ £ |Purpose/Contents | Data Input Method | Remarks
Size 25 |2
SEE|asg
=2 |82
Media Yes Yes user files, including | user-saved data The magnetic residue requires several
Storage flatnesscalibrations, rewrite cycles or drive removal and
Built-in IQ calibration, destruction.
(
Hard Disk) \l/cztvrgfr:rernntsstat%, The hard disk is an option and is therefore
6 GB or . ' not installed in some instruments. If itis
(including header . .
10GB and marker data) installed, these files are stored on the hard
(4GB . ' disk instead of in flash memory.
ussblein modulation
both ) definitions, and User datais completely sanitized when
sweep lists you perform the Erase and Sanitize function.
Buffer No No buffer (cache) normal operation
Memory memory through hard disk
(DRAM)
512 kB
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Removing Sensitive Data from Memory

When moving the signal generator from a secure development environment, you can remove any classified
proprietary information stored in the instrument. This section describes several security functions you can
use to remove sensitive data from your instrument.

Erase All

This function removes all user files, user flatness calibrations, user I/Q calibrations, and resets all table
editors with original factory values, ensuring that user data and configurations are not accessible or
viewable. Theinstrument appearsasif itisinitsoriginal factory state, however, the memory is not sanitized.
This actionisrelatively quick, taking less than one minute.

To carry out this function, press Utility > Memory Catalog > More (1 of 2) > Security > Erase All > Confirm Erase.

NOTE This function is different than pressing Utility > Memory Catalog > More (1 of 2) >
Delete All Files, which deletes all user files, but does not reset the table editors.

Erase and Overwrite All

This function performs the same actions as Erase All and then clears and overwrites the various memory
types in accordance with Department of Defense (DoD) standards, as described bel ow.

SRAM - All addressable locations are overwritten with random characters.

CPU Flash — All addressable locations are overwritten with random characters and then the flash blocks
are erased. This accomplishes the same purpose of a chip erase, however, only the areas that are no
longer in use are erased and the factory calibration files are left intact.

DRAM - All addressable |ocations are overwritten with random characters.

Hard Disk — All addressable |ocations are overwritten with a single character. (This isinsufficient for
top secret data, according to DoD standards. For top secret data, the hard drive must be removed and
destroyed.)

To carry out this function, press Utility > Memory Catalog > More (1 of 2) > Security > Erase and Overwrite All >
Confirm Overwrite.
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Erase and Sanitize All

This function performs the same actions as Erase and Overwrite All and then adds more overwriting actions.
After executing this function, you must manually perform some additional steps for the sanitization to
comply with Department of Defense (DoD) standards. These actions and steps are described below.

SRAM - After applying this function, the instrument must remain in the secure areafor a period longer
than the classified data resided in memory. This measure is necessary to conform to DoD standard
5220.22-M. Alternatively, the SRAM battery can be removed then manually reinserted, however, this
reguires opening the instrument.

DRAM - All addressable locations are overwritten with a single character. You must then power off the
instrument to purge the memory contents.

Hard Disk — All addressable locations are overwritten with a single character and then a random
character. (Thisisinsufficient for top secret data, according to DoD standards. For top secret data, the
hard drive must be removed and destroyed.)

To carry out this function, press Utility > Memory Catalog > More (1 of 2) > Security > Erase and Sanitize All >
Confirm Sanitize.

Using the Secure Mode

The secure mode automatically applies the selected Security Level action the next time the instrument’s power
iscycled.

To set the level of the secure mode, press Utility > Memory Catalog > More (1 of 2) > Security > Security Level
and choose from the following selections:

None — equivalent to a factory preset, no user information islost
Erase — equivalent to Erase All

Overwrite — equivalent to Erase and Overwrite All

Sanitize — equivalent to Erase and Sanitize All

To activate the secure mode, press Utility > Memory Catalog > More (1 of 2) > Security > Enter Secure Mode >
Confirm. The Enter Secure Mode softkey changes to Secure Mode Activated.

CAUTION Once you select a security level action and activate secure mode by pressing Confirm, you
cannot deactivate or decrease the security level. The erasure actions for that security level
execute at the next power cycle. You can only increase the security level once the secure
mode is activated. For example, you can change Erase to Overwrite, but not the reverse.

NOTE After the power cycle, the security level selection remains the same, but the secure modeis
not activated.
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If Your Instrument is Not Functioning

If the instrument is not functioning and you are unable to use the security functions, you must physically
remove the processor board and optional hard disk, if installed, from the instrument. Once these assemblies
are removed, proceed as follows:

For the processor board, choose one of the following options:

» Discard the processor board and send the instrument to arepair facility. A new processor board will be
installed and the instrument will be repaired and calibrated. If the instrument is still under warranty, you
will not be charged for the new processor board.

« If you have another working instrument, install the processor board into that instrument and erase the
memory. Then reinstall the processor board back into the non-working instrument and send it to arepair
facility for repair and calibration. If you discover that the processor board does not function in the
working instrument, discard the processor board and note that it caused the instrument failure on the
repair order. If the instrument is still under warranty, you will not be charged for the new processor
board.

For the optional hard disk, choose one of the following options:

» Discard the hard disk and send the instrument to arepair facility. Indicate on the repair order that the
hard disk was removed and must be replaced. A new hard disk will be installed and the instrument will
be repaired and calibrated. If the instrument is still under warranty, you will not be charged for the new
hard disk.

» Keep the hard disk and send the instrument to arepair facility. When the instrument is returned, reinstall
the hard disk.

For procedures on removing and replacing the processor board and hard disk, refer to the E4428C/38C ESG
Sgnal Generators Service Guide.

Using the Secure Display

This function prevents unauthorized personnel from reading the instrument display and tampering with the
current configuration through the front panel. The display is blanked, except for the message*** SECURE
DI SPLAY ACTI VATED ***, and the front panel keys are disabled. Once this function is activated, the
power must be cycled to re-enable the display and front panel keys.

To apply thisfunction, press Utility > Display > More (1 of 2) > Activate Secure Display > Confirm Secure Display

Chapter 3 79



Basic Operation
Using Security Functions

Figure 3-6 ESG Screen with Secure Display Activated
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Enabling Options (E4438C Only)

You can retrofit asignal generator after purchase to add new capabilities. Some new optional features are

im

plemented in hardware that you must install. Some options are implemented in software but require the

presence of optional hardware in the instrument. This example shows you how to enable software options.

Enabling a Software Option

A license key (provided on the license key certificate) is required to enable each software option.

1. Access the Software Options menu:
Utility > Instrument Adjustments > Instrument Options > Software Options
The following is an example of the signal generator display, which lists any enabled software options,
and the software options that can be enabled:
FREQUENCY AMPLITUCE  Modifu
1.000 000 00000 &tz | -136.00 cen ioense e
noo
’7 oN
Softuare Option Selection Host I0 = 7Libce7s
Option Description
] | ./ SGPF FOD
LO1 CLO1127273C8 -+ COMA2000 AMD ISSSA
LOZ2 CSCB11716FCD + TOMA SUITE CGSM/EDGE/MOAC/POC/PHS/TETRA/DECT)
L0323 CECO10707ECA + AWGM
LOL BFOV17777BCTY + 1HEW
W05 CODS1E7EELCL v BOZ. 11E/HYPERLAN
LOE C103157577C8 + BLUETOOTH Proceed With))
LOv C205147470CE + 3GPP TOD Reconf igurat 1on
LO2 BBOF1B7YB23C3 -+ MMOS
| | 403 BCEL1AVAZSCO + GPS
2. Verify that the host ID shown on the display matches the host ID on the license key certificate.
The host 1D is unique for each instrument. If the host ID on the license key certificate does not match
your instrument, the license key cannot enable the software option.
3. Verify that any required hardware isinstalled. Software options are linked to specific hardware options,

so before a software option can be enabled, the appropriate hardware option must be installed. For
example, Option 400, W-CDMA, requires Option 001/601 or 002/602, Internal Baseband Generator. If
the software option that you intend to install is listed in agrey font, the required hardware may not be
installed (in the Hardware Options menu, look for an X in the “ Selected” column of the appropriate
hardware option).
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4. Enable the software option:

a. Highlight the desired option.

b. Press Modify License Key, and enter the 12-character license key (from the license key certificate).

c. Verify that you want to reconfigure the signal generator with the new option:

Proceed With Reconfiguration > Confirm Change

The instrument enables the option and reboots.

Waveform Licenses

The waveform license allows waveforms, created on one ESG, to be downloaded to another ESG. Encrypted

waveforms can be played by other ESG’s that have the same options and licenses.

A waveform license is written to the signal generator when a software application, that generates waveform

data, isinstalled on the PC.

1. Accessthe Waveform Licenses menu:

Utility > Instrument Adjustments > Instrument Options > Waveform Licenses
The following is an example of the signal generator display, which lists any time-limited licenses and
perpetual licenses, the days | eft on time-limited licenses, and the software description:

FREQUENCY

4.000 000 000 00 s

AMPLITUOE

L

136.00 den

8

Haveform Licenses
Have ID Days Left Description

01/12/2

22:54

Fage Up

Fage Down
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Using the Web Server

You can communicate with the signal generator using the Web Server. This service uses TCP/IP
(Transmission Control Protocol/Internet Protocol) to communicate with the signal generator over the
internet.

The Web Server uses a client/server model where the client is the web browser on your PC or workstation
and the server isthe signal generator. When you enable the Web Server, you can access aweb page that
resides on the signal generator.

The Web-Enabled ESG web page, shown in Figure 3-7, provides general information on your signal
generator and a means to control the instrument by using a remote front-panel interface or using SCPI
(Standard Communication for Programmable Instruments) commands. The web page also has links to
Agilent’s products, support, manuals, and website.

NOTE The Web Server serviceis compatible with the latest version of the Microsoft© Internet
Explorer web browser.

The Signal Generator Web Control menu button on the Web-Enabled ESG web page will access a second
web page. Thisweb page, shown in Figure 3-8, provides a virtual instrument interface that can be used to
control the signal generator. You can use the mouse to click on the signal generator’s front panel hardkeys,
softkeys and number pad. Thereis also atext box that can be used to send SCPI commands to the
instrument.

Activating the Web Server

Perform the following steps to access the Web Server.

1. Turnon the Web Server by pressing Utility > GPIB/RS-232 LAN > LAN Services Setup > Web Server On.
2. Pressthe Proceed With Reconfiguration softkey.

3. Pressthe Confirm Change (Instrument will Reboot) softkey. The signal generator will reboot.

4

Launch your PC or workstation web browser.

1. Microsoft is a registered trademark of Microsoft Corp.
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5. Enter the IP address of the signal generator in the web browser address field. For example,
http://101.101.101.101. Replace 101.101.101.101 with your signal generator’s | P address. Press the
Enter key on the computer’s keyboard.

NOTE

The IP (Internet Protocol) address can change depending on your LAN configuration.

Use the LAN Config Manual DHCP softkey to select a Manual or DHCP (dynamic host
communication protocol) LAN configuration. Refer to E4428C/38C ESG Signal Generator
Key and Data Field Reference for more information.

6. Pressthe enter key on the computer’s keyboard. The web browser will display the signal generator’s
homepage as shown below in Figure 3-7. Thisweb page displays information about the signal generator

and provides access to Agilent’s website.

Figure 3-7

Signal Generator Web Page

3 Welcome to Agilent Technologies Web-Enabled Site - Microsoft Internet Explorer provided by Agilent Technolog

File Edit View Favorites Tools  Help

ault html]

ek - = - (D ﬁ ‘ @5ear:h [SiFavortes ¢ BHistory ||§v i

Agilent Technologies

ESG Series Signal Generator

P Welcome to your

| veicome Page

Web-Enabled ESG

o fsianal Generater
Jwieb cortrol

Information about this Web-Enabled ESG:

Hostname:

541000118
Aqilent E4438C (LUS41000119)
GALLP3

]

Coo= g
IP Address: 141121 60173 = - Eﬁ"gg Q
9 ) o=se ¥
VISA TCPIP Connect String: TCPIPD:GALLP3INSTR E M 000 é
a SoC @ A
Firmware Revision: ©.04.10.3007 el ofol oo efe
L
Ethernet (MAC) Address: 00:10:83:78:64:F1
SCPI TCPIP Socket Port: 5025
SCPI Telnet Port: 5023
SICL Interface Name: gpikd
GPIB Address: 19 |
Use the navination bar on the left to access your signal generator and related information
@ Agilent Technalogies, Inc. 2002
4 LI_I
|&] Done |4 Internet v
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7. Click the Signal Generator Web Control menu button on the left of the page. A new web page will be

displayed as shown below in Figure 3-8.

Figure 3-8 Web Page Front Panel

Fle Edt Vew Favorkes Took Hep |

ik - o= - (D (2] At Qsearch [GFavortes Meda (# | By S B - o
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This web page remotely accesses all signal generator functions and operations. Use the mouse pointer to
click on the signal generator’s hardkeys and softkeys. The results of each mouse click selection will be

displayed on the web page. For example, click on the Frequency hardkey then use the front-panel key pad to

enter afrequency. You can also use the up and down arrow keys to increase or decrease the frequency.

You can use the SCPI Command text box at the bottom of the front-panel display to send commands to the
signal generator. Enter avalid SCPI command, then click the SEND button. The results of the command will
be displayed on a separate web page titled, “ SCPI Command Processed”. You can continue using this web

page to enter SCPI commands or you can return to the front panel web page.

NOTE It may be necessary to use the web browser Refresh function if the web page does not

update with new settings.
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4 Basic Digital Operation

This chapter provides digital operation information. These features are available only in E4438C ESG
Vector Signal Generators with Option 001/601or 002/602.

The following list shows the topics covered in this chapter:

“Custom Modulation” on page 88

“Arbitrary (ARB) Waveform File Headers’ on page 90

“Using the Dual ARB Waveform Player” on page 104

“Local Settings for ARB Waveform Formats and the Dual ARB Player” on page 112
“Using Waveform Markers’ on page 119

“Triggering Waveforms” on page 135

“Using Waveform Clipping” on page 144

“Using Waveform Scaling” on page 152

“Using Customized Burst Shape Curves’ on page 155

“Using Finite Impul se Response (FIR) Filters’ on page 162
“Modifying aFIR Filter Using the FIR Table Editor” on page 167
“Differential Encoding” on page 169

“User-Defined I/Q Maps” on page 177

“User-Defined FSK Modulation” on page 181

“Creating and Using Bit Files” on page 184
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Custom Modulation

For creating custom modulation, the signal generator offers two modes of operation: the Arb Waveform
Generator mode and the Real-Time |/Q Baseband mode. The Arb Waveform Generator mode has built-in
modul ation formats such as NADC or GSM and pre-defined modulation types such as BPSK and 16QAM
that can be used to create asignal. The Real-Time I/Q Baseband mode can be used to create custom data
formats using built-in PN sequences or custom-user files along with various modulation types and different
built-in filters such as Gaussian or Nyquist.

Both modes of operation are used to build complex, digitally modulated signals that simulate
communication standards with the flexibility to modify existing digital formats, define or create digitally
modulated signals, and add signal impairments.

Custom Arb Waveform Generator

The signal generator’s Arb Waveform Generator mode is designed for out-of-channel test applications. This
mode can be used to generate data formats that simulate random communication traffic and can be used as a
stimulus for component testing. Other capabilities of the Arb Waveform Generator mode include:

« configuring single or multicarrier signals. Up to 100 carriers can be configured.

creating waveform files using the signal generator’sfront panel interface. The waveform files, when created
as random data, can be used as a stimulus for component testing where device performance such as adjacent
channel power (ACP) can be measured. The AUTOGEN WAVEFCRM(file, that is automatically created when
you turn the Arb Waveform Generator on, can be renamed and stored in the signal generator’s non-volatile
memory. Thisfile can later be loaded into volatile memory and played using the dual ARB waveform player.

For more information, refer to the sections “ Using the Dual ARB Waveform Player” on page 104 and
“Modes of Operation” on page 22.
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Custom Real Time I/Q Baseband

The real -time mode simulates single-channel communication using user-defined modulation types along
with custom FIR filters, and symbol rates. Data can be downloaded from an external source into PRAM
memory or supplied as real time data using an external input. The Real-Time I/Q Baseband mode can also
generate pre-defined data formats such as PN9 or FIX4. A continuous data stream generated in this mode
can be used for receiver bit error analysis. Thismodeislimited to asingle carrier. The Real-Time I/Q
Baseband mode:

« has more data and modulation types available than the Arb Waveform Generator mode.
« supports custom 1/Q constellation formats.

« has the capability to generate continuous PN sequences for bit error rate testing (BERT).
* needs no waveform build time when signal parameters are changed.

For more information, refer to the custom arb section “Using the Arbitrary Waveform Generator” on page
354, the custom real time section “Using the Real Time I/Q Baseband Generator” on page 360 and the
section on “Digital Modulation” on page 22.
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Arbitrary (ARB) Waveform File Headers

ARB file headers are used to save a modulation format’s signal generator settings and parameters so that the
waveform can be replicated when it is again played back by the dual ARB player. Once a modulation format,
such as Custom real-time, has been turned off, the waveform file is available only to the dual ARB player.

File header settings and parameters can be defined and saved along with the waveform file in the signal
generator’s non-vol atile waveform memory (NVWFM). When you load a stored waveform file into volatile
waveform memory (WFM1), the file header information will be used to configure the ESG so that the dual
ARB player is set up the same way each time that the waveform fileis played.

A default file header is automatically created whenever awaveform is generated (turning on amodulation
format), a waveform sequence created, or a waveform file downloaded to the ESG (Refer to the
E4428C/38C ESG Sgnal Generators Programming Guide for details on downloading files).

The following ESG setting and parameter information can be saved to the file header:
* ARB sampleclock rate
* Runtime scaling (only in the dual ARB player)
* Marker 14 settings and routing functions (page 119)
— Polarity
— ALChold
— RF blanking
» High crest mode (only in the dual ARB player)
* Modulator attenuation
* Modulator filter
» 1/Q output filter (used when routing signals to the rear panel 1/Q outputs)
» Other instrument optimization settings (for files generated by the ESG) that cannot be set by the user.

File headers can also store a user-defined 32-character text description of the waveform or sequencefile. For
details on the file header settings and parameters, refer to “File Header Description” on page 93.

Creating a File Header

When you turn a modulation format on, the ESG automatically generates atemporary waveform file along
with a default marker file and default file header. The temporary waveform file residesin volatile waveform
memory (WFM1) and is named AUTOGEN WAVEFCRM The default file header has no signal generator
settings saved to it and the default marker file consists of all zeros. Refer to the E4428C/38C ESG Signal
Generators Programming Guide for more information on marker files.
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When you turn the modulation format off, the AUTOGEN WAVEFCRMfile remains in volatile waveform
memory (WFM 1) and can be selected again for playing only by the dual ARB player. If you turn on another
Arb modulation format or change ESG parameters and settings, the AUTOGEN WAVEFCRMfile will be
overwritten by anew AUTOGEN WAVEFCRM file header, and marker file.

If you want to keep the configuration setup in the AUTOGEN WAVEFCORM(file, saveit, using a different name,
to NVWFM. The associated file header and marker file will automatically be saved. For information on
storing files after the modulation format is turned off, see “ Storing Waveform Segments to Non-Volatile
Memory” on page 110.

NOTE Each time an ARB modulation format isturned on, anew AUTOGEN WAVEFCRMal ong with
adefault marker and default file header are generated which overwrites the previous
AUTCGEN WAVEFCRM(file, marker file and file header.

When the waveform file is stored to non-volatile memory (NVWFM), the associated file header information
isautomatically saved to the signal generator’s/ USER/ HEADER directory and the marker fileis
automatically saved to the signal generator’s / USER/ MARKERS directory. When awaveform file, residing
in WFM1, is selected for playback, the file header settings along with the marker file settings are
automatically applied to the ESG.

The following procedure will generate an AUTOGEN WAVEFCRMfile and file header using the ARB
CDMA 2000 modulation format. This procedure for generating an AUTOGEN WAVEFCRMfile and file header
appliesto all the Arb formats.

1. Turnon the ESG and then press Preset.
2. Press Mode > CDMA > Arb CDMA2000 > CDMA2000 Off On to On. See Figure 4-1 below.

The ESG createsthe AUTOGEN WAVEFCRM(file along with adefault file header and default marker filewhen
the modulation format, CDMA 2000 in this example, isturned on. At thistime, the file header does not have
signal generator settings or parameters for the currently playing AUTOGEN WAVEFCRM file. You must
modify the default file header settings and parameters for the active modulation and then save the file header
information using the Save Setup To Header softkey.
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Figure 4-1 First-Level Softkey Menu
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Modifying Header Information

This procedure builds on the previous procedure, explaining the different fields of afile header, and showing
how to access, modify, and save changes to the file header information.

In amodulation format, you can access afile header only while the modulation format is active (on). All
ARB modulation formats and the dual ARB player access the file header the same way, except that in some
modul ation formats, the menu may be on page two of the first-level softkey menu.

1. From thefirst-level softkey menu (shown in Figure 4-1), open the Header Utilities menu:
Press More (1 of 2) > ARB Setup > Header Utilities

Figure 4-2 on page 93 shows the default file header for the AUTOGEN WAVEFCRMCDM A 2000 digital
modulation waveform. The Header Fi el d column names the parameters for the file header. The
Saved Header Settings column, shows that the signal generator settings for the active format are
Unspeci f i ed, meaning that no settings have been saved to the file header.

TheQurrent Inst. Settings column shows the current signal generator settings for the active
modulation. These settings become the saved header settings when they are saved to the file header (as
demonstrated in Step 2).
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Save Setup

File Header Information: UFH1:AUTOGEH_UAUEFORH

Header Field Saved Header Settinos

Current. Inst. Settinos

To Header

Figure 4-2 CDMA2000 Default Header Display
Letsyou Enter/Edit the
FREQUENCY AMPLITUDE = Pyt
4000000000 00 s | ~136.00 wn | (omlih— Destmonriad
Deza D Clear Header Settings Column to Default
w 8| Gomm)— S

>\ Saves the Current Inst.
Settings Column to the

[ Description Saved Header Settings
. Column
Sample Rate Unspecified 11.0532000 rHz
Marker 1 Polaritu | Unspecified Pos Current Signaj Generator
Marker 2 Polarity | Unspecified Pos Settings
Marker 3 Polarity | Unspecified Pos P U g
Marker 4 Polarity | Unspecified Pos a0e Lp
ALC Hold Routing Unspecified None
| | Alt Ampl. Routino | Unspecified Mone \
Page Doun
N\
[] FF Blank Routing Unspecified Mone \
Page 1
Mod Attenuat ion Unspecified Auto
I/0 Mod Filter Unspecified Auto
I/0 Output Filter | Unspecified Auto
——— Page?2

\

\ Default Header Settings

NOTE

If asetting is unspecified in the file header, the signal generator’s current value for that
setting does not change when you select and play the waveform in the future.

2. Savetheinformationinthe Curr ent

Press Save Setup To Header.

Both the Saved Header Setti ngs columnandtheCQurrent |nst.

| nst.

Set t i ngs column to the file header:

Set ti ngs column now

display the same settings; the Saved Header Setti ngs column liststhe settings saved in thefile

header.

File Header Description

The file header contains the following information:

32-Character
Description:

softkeys and the numeric keypad to enter information.

Sample Rate:

The ARB sample clock rate.

A description entered for the header, such as athe waveform'’s function (saved/edited with
the Edit Description softkey, see Figure 4-2). You can use the displayed a pha/symbol
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Runtime Scaling:

Marker 1...4 Polarity:

ALC Hold Routing:

Alt Ampl. Routing

RF Blank Routing:

High Crest Mode

Mod Attenuation:

1/Q Mod Filter:

1/Q Output Filter:

The Runtime scaling value. Runtime scaling is applied in real-time while the waveformis
playing. This setting can be changed only for files playing in the dual ARB player.

The marker polarity, positive or negative (described on page 134).

Which marker, if any, implements the ESG’'s AL C hold function (described on page 121).
The ALC hold function holds the ALC at its current level when the marker signal islow.
All waveforms generated in the ESG have amarker on the first sample point. In order to
see the results from the three routing selections, you may need to select arange of sample
(marker) points. Setting the marker points is accomplished using the Set Marker on Range
of Points softkey located in the Marker Utilities softkey menu. See “ Setting Marker Points
in aWaveform Segment” on page 127 for more information.

Thiswill display which marker, if any, triggers the ESG’s alternate amplitude feature when
the marker signal is low. When the marker signal goes high, the trigger is terminated,
disengaging aternate amplitude. You still need to configure the alternate amplitude
parameters |located in the Amplitude hardkey menu.

Which marker, if any, implements the ESG'’s RF blanking function (described on page
132) when the marker signal islow. RF blanking also uses ALC hold. Thereis no need to
select the AL C Hold Routing for the same marker when you are using the RF Blank
Routing function. When the marker signal goes high, RF blanking is discontinued.

Thisfield displaysthe status of the high crest mode for the dual ARB player. The high crest
mode reduces AL C levels while playing ARB waveform files, resulting in the maximum
output level but reducing power level accuracy. This setting can only be changed for files
in the dual ARB player.

The I/Q modulator attenuation setting.

The 1/Q modulator filter setting. The modulator filter affects the 1/Q signal modulated onto
the RF carrier.

The 1/Q output filter setting. The 1/Q output filter is used for 1/Q signals routed to the rear
panel | and Q outputs.

Return to the ARB Setup menu: Press Return.

You are now in the ARB Setup softkey menu. From this menu you can access al the signal generator
settings that are saved to the file header. However, not all ESG settings are saved to the file header. For
example, the ARB Reference Ext Int softkey selection is not part of the saved header settings. Figure 4-3
shows the ARB Setup softkey menu and the softkey paths used in steps four through nine.
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Basic Digital Operation

Arbitrary (ARB) Waveform File Headers
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Set the ARB sample clock to 5 MHz: Press ARB Sample Clock > 5 > MHz.
Set the modulator attenuation to 15 dB:
Press More (1 of 2) > Modulator Atten n.nn dB Manual Auto to Manual > 15 > dB.
Set the 1/Q modulation filter to a through:
Press I/Q Mod Filter Manual Auto to Manual > Through.
Set marker one to blank the RF output at the set marker point(s):
Press More (2 of 2) > Marker Utilities > Marker Routing > Pulse/RF Blank > Marker 1.
For information on setting markers, see “Using Waveform Markers’ on page 119.
Set the polarity of Marker 1 negative:
Press Return > Marker Polarity > Marker 1 Polarity Neg Pos to Neg.
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9. Return to the Header Utilities menu: Press Return > Return > Header Utilities.

Noticethat theQurrent | nst.

Set t i ngs column now reflects the changes made in steps 4 through

8 to the current signal generator setup, but that the saved header values have not changed (as shown in

Values Differ between the
two Columns

Figure 4-4 below).
Figure 4-4 Differing Values between Header and Current Setting Columns
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COHAZK
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\ Page Doun
[] FF Blank Routing | Mone Marker 1 \ \ Page 1
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I/0 Mod Filter Auto 2.100 MHz [ Values Differ between the
I/0 Output Filter Auto AUto two Columns
———— Page2

10. Save the current settingsto the file header: Press the Save Setup To Header softkey.

The settingsfromthe Qurrent | nst .

Set ti ngs column now appear in the Saved Header

Set ti ngs column. The file header has been modified and the current instrument settings saved. Thisis
shown in Figure 4-5.
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Figure 4-5 Saved File Header Changes
FREQUEMCY AMPLITUDE Edit,)
Description
4.000 000 000 00 &= | -136.00 en
COHAZK HOD
Clear Header
1/0 o
| Save Setup
File Header Information: LIFML:AUTOGEN_IIAUEFORM Tor Header
Header Field Saved Header Settings  Current Inst. Settings
[[] Description
Sample Rate 5.0000 rHz 5.0000000 MHz
Marker 1 Polarituy  Neoative Heg
Marker 2 Polarity  Positive Pos
Marker 3 Polarity  Positive Pos P U
Marker 4 Polaritu  Positive Pos a0e Lp
ALC Hold Routing None None
|| Alt Ampl. Routing  None None
NG Page Doun
FF Blank Routing Marker 1 Marker 1 Pagel
Mod Attenuation 15.000 dB 15.00 dB
I/0 Mod Filter 2.1000 MHz 2.100 MHz
I/0 Output Filter Auto Auto
———— Page?2

While a modulation format is active (on), the AUTOGEN_ WAVEFCRMwaveform file plays and you can
modify the header information. Once you turn the modulation format off, the header information isavailable
only through the dual ARB player.

NOTE

If you turn the modulation format off and then on, you overwrite the previous

AUTOEEN WAVEFCRM file and itsfile header. To avoid this, rename the file before you turn
the modulation format back on (see “ Storing Waveform Segments to Non-Volatile

Memory” on page 110).
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Dual ARB Player Waveform Sequence File Headers

When you create a waveform sequence (described on page 106), the ESG automatically creates a default
file header, which takes priority over the headers for the waveform segments that compose the waveform
sequence. During a waveform sequence playback, the waveform segment headers are ignored (except to
verify that all required options are installed). When you store the waveform sequence, itsfile header is
stored with it.

Follow the procedure “ Creating a Waveform Sequence” on page 106 to generate a waveform sequence file
header.

Editing and Viewing File Headers in the Dual ARB Player

Before you can edit afile header in the dual ARB player, the associated waveform file must reside in volatile
waveform memory (WFM1). In addition, you cannot edit the AUTOGEN WAVEFCRM(file header in the dual
ARB player if the AUTOGEN_WAVEFORM fileis currently being played by another modulation format such
as Custom real-time. Turn off the modul ation format then play the AUTOGEN WAVEFCRM file using the dual
ARB player. You can then modify the file header.

If you want to edit afile header for awaveform file that residesin non-volatile memory (NFWFM), move it
to WFM1 and then play it. Refer to “ L oading Waveform Segments from Non-Volatile Memory” on page 111
for information on loading files from NVWFM.

Edits to file headers can only be performed when the waveform file is playing. After making changesto the
signal generator settings and parameters, you can apply these new settings to the waveform by pressing the
Save Setup To Header softkey and then resel ecting the waveform file for playback. When you do this, you will
seethevaluesfrom the Saved Header Sett i ngs columnoverwritethesettingsintheCurrent |nst.
Set ti ngs column. For information on selecting and playing waveform files, see “Playing a Waveform
Sequence” on page 107.

NOTE Edits to file headers can only be performed when the waveform fileis playing.

Modifying File Header Information

All file header descriptions listed in the procedure “ Modifying Header Information” on page 92 arevalid in
the dual ARB player. The following procedure selects awaveform file, accesses its file header, and then
refers you back to the af orementioned procedure to perform the edits. This procedure assumesthereisan a
user-defined waveform file or an AUTOGEN_ WAVEFCRM filein WFM 1. For information on creating the
AUTOEEN WAVEFCRM file and associated file header, refer to “ Creating a File Header” on page 90.

1. Press Mode > Dual ARB > Select Waveform.

2. Using the arrow keys, highlight the waveform file that needs its file header edited.
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Press the Select Waveform softkey.
Press ARB Off On to On.

Press ARB Setup > Header Utilities.
Edit the file header.

o a0 >

a. If you have a default file header, go to “Modifying Header Information” on page 92, read the
additional information for step one, and then perform the rest of the steps in the procedure.

b. If you need to edit an existing file header, start with step three in the “Modifying Header
Information” procedure on page 92.
Viewing the file header with the Dual ARB Player Off

One of the differences between the dual ARB player and other Arb formatsisthat you can view afile header
without the dual ARB being on (ARB Off On softkey set to Off). However, you cannot edit the displayed file
header. Thiswas done to prevent an accidental change to afile header for an AUTGGEN WAVEFORM file that
may be playing in a modulation format. With the dual ARB player turned off, perform the following steps.

1. PressMode > Dual ARB > Select Waveform.

2. Using the arrow keys, highlight the desired waveform file.
3. Pressthe Select Waveform softkey.

4. Press ARB Setup > Header Utilities.

Thefile header is displayed in the ESG display and you can see that the file header editing softkeys are
grayed-out (inactive) as shown in Figure 4-6 on page 100.
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Figure 4-6
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You can view file headers for other waveform files, even while the dual ARB player has awaveform
playing. However, you can edit afile header only when the associated waveform file is being played by the
dual ARB player. When you select another file header for viewing, the header editing softkeys are
grayed-out as shown in Figure 4-6.

This procedure will guide you through the available viewing choices.

1. Press Mode > Dual ARB > ARB Setup > Header Utilities > View Different Header

Notice that the waveform filesin the table are listed in alphabetical order.
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Figure 4-7 Waveform File List for Viewing a Different Header
FREQUENCY AMPLITUDE Vien
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u 51_B4EH_COMA B55360 0B/05/38 D0:00 | g Table
5 52_3CH_COMA ES5360 06/08/98 00:00
6 B53_9CH_COHA ES5360 06/08/98 00:00
7 RAMP_TEST_HFH 500 0B/05/95 00:00
8 SINE_TEST_WFH 500 0B/05/95 00:00
g TST_HiKA_2 ESS360  06/08/98 00:00

2. Pressthe Catalog Type softkey.

Now you have a choice of three waveform file types that can be displayed in the table accessed in step
one. These choices are shown in Figure 4-8.

Figure 4-8 Waveform File Type Selection
FREQUEMCY AMPLITUDE View
4.000 000 000 00 &= | -136.00 cen Header
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ol TR

Cataloo of WFH1 Files 5032336 butes used 128997376 butes fres MWLFH
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3 DOC_WFM_021105  WRML 1179843  06/05/35 00:00
L GI1_BLCH_COMA - HFAL 655360 0B/08/33 00:00
] GZ2_3CH_COMA WFHL 655360 0B/08/33 00:00 HUFHL
[i] G3_3CH_COMA WFML 655360 0B/08/33 00:00
7 RAMP_TEST_MFH  HFH1 800 0Oe/05/33 00:00
8 SINE_TEST_MFH  HFH1 800 0Oe/05/33 00:00
a TST_MKR_Z2  WFML 655360 06/08/98 00:00
NVWFM This choice will display all of the waveform segments currently stored in
non-volatile memory.
Seq This choice will display all of the waveform sequence files.
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WFM1 This choice will display all of the waveform segmentsthat currently residein
volatile memory.

3. Pressthe NVWFM softkey.

After pressing the softkey, you are returned to the waveform file listing table that now displaysthe
waveform files from non-volatile memory. Thisis shown in Figure 4-9.

Figure 4-9 NVWFM Waveform Files Showing
FREQUENCY AMPLITUDE view
4.000 000 000 00 &= | -136.00 cen Header
o Latalos-tiee — Current Waveform File
| Type
—_—
k[:atalog of HUUFRN Files.) 32336 butes used 8L3IESE3ZZE butes free /
File Hame / Tupe Size NModifj
1 UM MWULFIT 1179808 D1/72,7U (8:57
2 BT S0000# 70 05:01
3 DOC_MFH_D21105 11z 01/22/70 03:04
y 51_BLCH_COMA 555360 01/15/70 03:40 | < Table
5 52_9CH_COMA 555360 01/03/70 03:27
6 53_9CH_COMA 555350 01/21,/70 10:43
7 RAMP_TEST_HFH 800 01/10/70 07:58
8 SINE_TEST_HFH 800 01/09/70 09:27
9 TST_MKR_2 55350 01/16/70 10:43

4. Highlight awaveform file.
5. Pressthe View Header softkey.

Thefile header for the selected waveform fileis shown in the ESG display. If there was awaveform playing,
its header information is removed from the ESG display, but its settings are still used by the signal generator.
There are two ways to return to the header information for the playing waveform. One way is to pressthe
View Different Header, select the current playing waveform file, and press View Header. The second way isto
press Return and then Header Utilities.

Playing a Waveform File containing a Header

After awaveform file (AUTOGEN WAVEFCRM) has been generated by amodulation format and the format is
turned off, the AUTOGEN WAVEFCRM file is accessible to and can be played back only in the dual ARB
player. Thisis also true for downloaded waveform files.

The file header settings, associated with the waveform file, are used to configure signal generator settings
and parameters when the waveform is selected for playback in the dual ARB. Some of these settings will
appear as part of the softkey labels. In addition, some of the saved header settings will appear on the dual
ARB summary display. Thisis shown in Figure 4-10 on page 103. Follow the procedure “Playing a
Waveform Sequence”’ on page 107 to apply file header settings and to play back awaveform.
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Figure 4-10 File Header Settings Applied
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Using the Dual ARB Waveform Player

The dual arbitrary (ARB) waveform player is used to play back waveform files. There are two types of
waveform files: segments and sequences. A segment is awaveform file that is created using one of the
signal generator’s pre-defined ARB formats (Custom, W-CDMA, CDMA2000, etc.). A sequence can be
described as several segments strung together to create one waveform file. Waveform files can also be
created remotely using another signal generator or using computer programs and downloaded to the ESG for
playback by the dual ARB waveform player. For information on downloading waveforms, refer to the
E4428C/38C ESG Signal Generator Programming Guide. The dual ARB player is used to rename and store
waveform files and to load waveform files from the signa generator’s memory.

A waveform fileis automatically generated whenever an ARB modulation format is turned on. This
automatically generated file is named AUTOGEN WAVEFCORM Because this default file nameis shared among
all ARB formats, it must be renamed if you want to save the information contained in thefile. If thefileis
not renamed, it will be overwritten when another ARB format is turned on.

Before you can play or edit any waveform file, it must reside in volatile waveform memory. The signal
generator has two types of memory, WFM1 (volatile waveform memory) and NVWFM (non-volatile
waveform memory). Load a stored waveform file from NVWFM into volatile memory (WFM1) whereit
can be edited or played by the ARB waveform player.

The dual ARB waveform player provides markers (page 119), triggering (page 135), and clipping (page
144) capahilities.

Accessing the Dual ARB Player

Press Mode > Dual ARB.

Thefirst-level softkey menu is shown in the following figure. Most procedures start from this menu.

FREQUENCY

AMPLITUOE

ARE
4.000 000 000 00 &=z { -136.00 aen o b
noo Select,
OH Hawveform
| EaueFD{m'
eament.s
ARB  Selected Waveform: #NONE# =
Sample Clock: 100.0000000MHz I0 Mod Filter: Throush
Uff Fef Freq: 10.0000000MHz <Int) Haveform,|
Sequences
Trig Tupe: Continuous (Free Run) Retrigoer: On
Trig Source: Ext (Patt Trig In 1) Polaritu: HNeg
Delady: Off ARE Setupk
FPouer Search Reference: Fixed
Moize: Off Carrier to Moise: 0.00dB
Carrier Bandwidth: 1.000Hz Trigoer
RF Flat Moise Bandwidth > 80.000HHz (Continbons )

104 Chapter 4



Basic Digital Operation
Using the Dual ARB Waveform Player

Creating Waveform Segments

There are two ways to provide waveform segments for use by the waveform sequencer. You can either
download a waveform viathe remote interface, or generate a waveform using one of the Arb modulation
formats. For information on downloading waveforms via the remote interface, see the E4428C/38C ESG
Sgnal Generator Programming Guide.

The following procedure describes how to create waveform segments using |S-95A CDMA waveforms. In
this procedure, you generate two 1S-95A CDMA waveforms, a predefined 64 channel forward CDMA state
and apredefined 9 channel forward CDMA state. After the two waveform segments are named and stored in
memory, they are used to build awaveform sequence in the procedure, “ Creating a Waveform Sequence” on
page 106.

1. Generate the first waveform:

cooCo

Press Preset .

Press Mode > CDMA > Arb 1S-95A.

Press Setup Select > 64 Ch Fwd.

Press CDMA Off On until On is highlighted.

This generates a waveform named AUTOGEN WAVEFCRMwith the predefined 64 channel forward
link CDMA configuration. The 64 channel forward link AUTOGEN WAVEFCRMIis stored in volatile
waveform memory (WFM1). During waveform generation, the CDMA and |/Q annunciators are
shown on the ESG's front-panel display.

Press CDMA Off On until Off is highlighted.

The AUTOGEN WAVEFCRMfileisin use while the ARB modulation format is on; preventing you
from performing the modifications to the file as required in the following steps. When the
modulation format is turned off the AUTOGEN WAVEFCRMfile remainsin WFM1 and can be
modified and saved using a different file name.

2. Create the first waveform segment.

The AUTOGEN_WAVEFCORM created in the previous step, will be renamed and become the first waveform
segment.

a
b.
c
d

Press Mode > Dual ARB > Waveform Segments > Load Store to Store.

Highlight the default AUTOGEN WAVEFORM(ile using the front-panel arrow keys.

Press Rename Segment > Editing Keys > Clear Text.

Enter afile name (for example, FWWDCH _64), and press Enter > Store Segment To NVWFM Memory.
This renames the waveform segment, and stores a copy in non-volatile memory (NVWFM).

NOTE

Because there can be only one AUTOGEN WAVEFCRM waveform in WFM 1 at any given
time, you must rename thisfile to clear the way for a second waveform.
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3. Generate the second waveform:

a Press Mode > CDMA > Arb 1S-95A.

b. Press Setup Select >9 Ch Fwd.

c. Press CDMA Off On until On is highlighted.
d. Press CDMA Off On until Off is highlighted.

4. Create the second waveform segment:

Repeat Step 2, giving this segment a different descriptive name (for example, FWDCH_9).

Creating a Waveform Sequence

A waveform sequence is made up of segments but can also contain other sequences. Any number of
segments, up to 32768, can be used to create a sequence. Thislimit count is determined by the number of
segmentsin the waveform sequence. Segments and sequences can be repeated within a waveform sequence
and the total of all segments and repeated segments cannot exceed the limit count. Figure 4-11shows a
waveform sequence made up of two sequences and three segments. In this example the segment count is
eleven.

Figure 4-11 Waveform Sequence Diagram

Sequence B
Fepeated 4x

Seqment @
Sequence B____]:: Seqment T
Seqment M

The following procedure shows how to create, edit, and store awaveform sequence using the two waveform
segments created in the section “ Creating Waveform Segments” on page 105. This procedure assumes that
thewaveform segments FADCH_64 and FWDCH 9 are present in WFM 1. To use a segment in asequence, the
segment must reside in volatile memory; for information on loading waveform segments from non-volatile
to volatile memory, see page 111.

Sequence A

Wave form
Sequence

Building a Waveform Sequence
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1. Select the waveform segments:

Define a sequence as one repetition of the FWDCH 64 segment followed by one repetition of the
PWDCH_9 waveform segment.

a

b.

C.

d.

Press Mode > Dual ARB > Waveform Sequences > Build New Waveform Sequence > Insert Waveform.
Highlight the PADCH_64 waveform segment and press Insert Selected Waveform.
Highlight the PADCH_9 waveform segment and press Insert Selected Waveform.

Press Done Inserting

2. Optional: Enable markers as desired for the segments in the new sequence: see page 129.

3. Name and store the waveform sequence to the Cat al og of Seq Fi | es inthe memory catalog:

a

b.

C.

Press Name and Store.
Enter afile name (for example, FADCH_64+FWDCH_9).

Press Enter.

Playing a Waveform Sequence

You can play awaveform sequence or a waveform segment using this procedure. Both waveform types use
the same process.

If you have not created waveform segments and used them to build and store a waveform sequence,
complete the stepsin the previous procedures, “ Creating Waveform Segments’ on page 105 and “Creating a
Waveform Sequence” on page 106.

NOTE

A waveform segment must reside in volatile memory (WFM 1) before it can be played
individually or as part of awaveform sequence. Refer to “L oading Waveform Segments
from Non-Volatile Memory” on page 111 for more information.

1. Select awaveform sequence:

a  Press Mode > Dual ARB > Select Waveform.

b.

Highlight a waveform sequence (for this example, FWDCH_64+FWDCH_9) from the Sequence
column of the Sel ect \WWvef or mcatalog, and press Select Waveform.

The display shows the currently selected waveform (for example, Sel ect ed Wavef or m
SEQ FWDCH_64+FWDCH 9).
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2. Generate the waveform:
Press ARB Off On to On.

This plays the waveform sequence created in the previous procedures. During the waveform sequence
generation, the ARBand | / Qannunciator are displayed. The waveform is now modulating the RF carrier.

3. Configure the RF Output:

a. Set the RF carrier frequency.
b. Set the RF output amplitude.
c. Turn on the RF output.

The waveform sequence is now available at the signal generator’'s RF OUTPUT connector.

Editing a Waveform Sequence

This procedure shows how to edit waveform segments within a waveform sequence, and then save the
edited sequence with the segment changes. Within the editing display, you can change the number of times
each segment plays (repetitions), delete segments from a sequence, add segments to a sequence, toggle
markers on and off (described on page 129), and save changes. There are two ways to save changes, they
can be saved to the current waveform sequence or they can be saved using a different waveform segquence
name.

NOTE If you do not store changes to the waveform sequence before exiting the waveform
sequence editing display, changes will not be made.

Modifying the Sequence

Press Waveform Sequences.

Highlight the waveform sequence (for example, FWDCH_64+FWDCH 9.
Press Edit Selected Waveform Sequence.

Highlight the first waveform entry (for example, WFML: FWDCH_64).

o >~ w DN P

Press Edit Repetitions > 100 > Enter.

The number of repetitions for the first waveform entry changes to 100 and the cursor moves to the next
entry.

6. PressEdit Repetitions > 200 > Enter.

You have now changed the number of repetitions for each waveform segment entry from 1 to 100 and 200,
respectively. The following procedures show how to save these changes.
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Saving Changes to the Current Sequence Name
Press Name and Store > Enter

You have now changed the number of repetitions for each waveform segment entry from 1 to 100 and 200,
respectively. The sequence with the changesis stored under the same name to the Cat al og of Seq
Fi | es inthe signal generator’s memory catalog.

Saving Changes to a Different Sequence Name

1. Press Name and Store.
2. PressEditing Keys > Clear Text.

3. Enter afile name (for example, CGH64_100+CHI9_200) using the dpha/symbol softkeys and the numeric
keypad.

4. PressEnter.

A new waveform sequence, CH64_100+CHO_200 is now defined based on the original sequence. Itisa

copy of the original sequence, FADCH _64+FWDCH 9.

Adding Real-Time Noise to a Dual ARB Waveform (Option 403)

The signal generator with option 403 can apply additive white gaussian noise (AWGN) to acarrier in real
time while the modulating waveform file is being played by the dual ARB waveform player. The AWGN
can be configured using front-panel softkeys. The Carrier to Noise Ratio softkey allows you to specify the
amount of noise power relative to carrier power that is applied to the signal. The Carrier Bandwidth softkey
sets the bandwidth over which the noise isintegrated and the Noise Bandwidth Factor softkey allows you to
select aflat noise bandwidth. Refer to the E4428C/38C ESG SCPI Command Reference for remote operation
commands and the E4428C/38C ESG Signal Generator Key and Data Field Reference for key descriptions.

The following procedure sets up a carrier and modulates it using the pre-defined SI NE_TEST_WFM
waveform file. AWGN is then applied to the carrier.

Configuring AWGN

Preset the signal generator. Press the Preset hardkey.

Press the Frequency hardkey and enter 15 GHz.

Press the Amplitude hardkey and enter =10 dBm.

Press RF On Off to On.

Press Mode > Dual ARB > Select Waveform and select the SI NE_ TEST W-Mwaveform.

o a0 M 0w D P

Press Select Waveform.
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7. Press ARB Off On to On.

8. Press ARB Setup > ARB Sample Clock enter 50 MHz.

9. PressReal-time Noise Setup > Carrier to Noise Ratio and enter 30 dB.
10. Press Carrier Bandwidth and enter 40 MHz.

11. Press Real-time Noise Off On to On.

This procedure applies AWGN to the 15 GHz carrier. The displayed power level of the signal generator,
—10 dBm, will include the noise power which is set as a carrier to noiseratio (C/N) of 30 dB. Noise power,
for the purpose of C/N, is applied across a carrier bandwidth of 40 MHz. The default noise bandwidth factor
is 1, which provides aflat noise signal bandwidth of aleast 0.8 times the 50 MHz sample rate.

Storing and Loading Waveform Segments

Waveform segments can reside in volatile memory (WFM1), or they can be stored in non-volatile memory
(NVWFM), or both. However, to play or edit awaveform file, the file must reside in WFM 1. Because files
stored in volatile memory do not survive a power cycle, it isagood practice to store waveform files to
non-volatile memory and load them to volatile memory whenever you want to use them.

Storing Waveform Segments to Non-Volatile Memory

Recall that there are two types of files used in the dual ARB player, segments (a single waveform file) and
sequences (a series of waveform files). A sequenceis comprised of multiple segments and may include other
sequences. Refer to “ Creating a Waveform Sequence” on page 106 for more information on segments and
sequences.

The segments that compose awaveform sequence are not stored when the waveform sequence is stored. You
must save any segment or segments used to create a waveform sequence. Storing just the waveform
sequence will result in losing the waveform segments when the signal generator is turned off or rebooted
during an ESG firmware upgrade. When this occurs, you cannot play the waveform sequence until the
segments are recreated using the same file names that the sequence expects. If you attempt to play the
sequence without the segments, an error, ERROR: 629, File for mat invalid will be reported, since the dual
ARB player can no longer find the waveform segments that make up the sequence.

Waveform segments must reside in volatile memory (WFM1) to be edited or played individually and all
components, such as segments and other sequences, of a sequence must reside in WFM 1.

The following example demonstrates storing waveform segments. If you have not created waveform
segments, compl ete the steps in the previous section, “ Creating Waveform Segments’ on page 105. In this
example, the sequenceis stored to the Cat al og of Seq Fi | es and the segments are stored to the

Cat al og of NVWWFMfiles.

1. Press Mode > Dual ARB > Waveform Segments.

2. PressLoad Store to Store.
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3. Highlight the waveform segment you want to store.
4. |If the waveform segment needs to be renamed, follow steps athrough d, if not, proceed to step five.

a.  PressRename Segment > Editing Keys > Clear Text.

b. Enter aname for the waveform segment using the displayed alpha/symbol softkeys along with the
numeric keypad. The maximum length for afile nameis 23 characters (al phanumeric and special
characters).

c. PresseEnter.
d. Highlight the waveform segment that was renamed.
5. Press Store Segment to NVWFM Memory.
6. Repeat steps three through five for all segments that you want to store.
In addition to the above method for saving segmentsto NVWFM, the signal generator allowsyou to store all
files, residing in WFM1, into NVWFM. Thisis accomplished using the Store All to NVWFM Memory softkey.

Loading Waveform Segments from Non-Volatile Memory

Waveform segments must reside in volatile memory (WFM1) before they can be played, edited, or be
included in a sequence. In addition, you need to load segments into WFM1 whenever power is cycled to the
ESG or an action initiated that causes the ESG to reboot.

1. Press Mode > Dual ARB > Waveform Segments.
2. Highlight the waveform segment you want to load.
3. PressLoad Segment From NVWFM Memory.

In addition to the above method, the signal generator allows you to load all files, residing in NVWFM, into
WFM1. Thisis accomplished using the Load All From NVWFM Memory softkey.

Chapter 4 111



Basic Digital Operation
Local Settings for ARB Waveform Formats and the Dual ARB Player

Local Settings for ARB Waveform Formats and the Dual ARB Player

To provide you with the greatest convenience in optimizing and replicating waveforms for playback in the
dual ARB player, settings that were previously (pre-C.03.10 firmware release) found in only the dual ARB
player have now been incorporated into each of the ARB modulation formats. In addition, some of the I/Q
waveform settings previously found in the 1/Q and MUX hardkey menus are also present in the ARB
modulation formats and the dual ARB player. These settings are shown in the following list, and explained
in the sections that follow:

* 1/Q output filter

e |/Q modulator filter

e |/Q modulator attenuator

»  Waveform runtime scaling
» High crest mode

* ARB sample clock

«  Markers

I/Q Attenuator and Filters Settings

The I/Q output filter, modulator attenuator, and the 1/Q modulator filter parameters are now set locally
within each ARB modulation format (W-CDMA, CDMA2000, AWGN, Multitone, etc.) and the dual ARB
player. When you set these signal generator parameters within one modulation format, they will not apply to
the others. These settings are applied to the signal generator when the modulation format is turned on or the
saved waveform is selected in the dual ARB player. They can also be saved to the file header. The I/Q output
attenuator (1/Q Output Atten softkey located in the I7Q hardkey menu) still maintainsits original behavior in
that itisaglobal setting (appliesto all signal generator formats).

Front Panel Changes

In pre-C.03.10 firmware rel eases, the 1/Q output filter, modulator attenuator, and the I/Q modulator filter
parameters were set globally from the 17Q and/or the Mux hardkey menus using the 1/Q Mod Filter Manual
Auto, Modulator Atten nnn dB Manual Auto, 1/Q Output Filter Manual Auto, and the 1/Q Mod Filter Manual Auto
softkeys. These three softkeys now appear in each of the ARB formats and the dual ARB player. This
enables you to set these parameters locally within each ARB format and the dual ARB player. The three
softkeysin the 1/Q and mux menus now apply only to the real-time formats and externally applied 1/Q
signals. The real-time formats are the ones preceded with real-time on the ESG softkey labels and usually
have BBG as one of the SCPI command mnemonics. When an ARB format or the dual ARB player isactive,
the three softkeys in the I/Q and mux menus are grayed-out indicating that they do not apply to the ARB
format or the dual ARB player.
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Setting the three parameters, for the ARB formats or the dual ARB player, are accomplished by accessing
the ARB Setup softkey menu located in each of the ARB formats and the dual ARB player. The location of

this softkey menu is shown in Figure 4-12.

When you save the signal generator setup using the front panel Save hardkey function with an ARB format
or the dual ARB player, the local settings for the three parameters are also saved.

Figure 4-12 ARB 1/Q Filters and Attenuator Softkey Location
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SCPI Command Changes

New SCPI commands have been developed and included in the C.03.10 and later versions of the firmware.
These new commands allow you to set the three parameters discussed earlier for each of the ARB

modul ation formats and the dual ARB player. Commands have al so been changed for the three parametersin
the Digital Modulation subsystem to accommodate the local setting feature.

These new commands duplicate the behavior of the softkeys discussed in the previous section. The main
differenceisthat now you can set new values for the three parameters (available in the 1/Q and/or MUX
menus) while an ARB modulation format is active and playing. However, the new settings will not be
applied until the ARB format is turned off. Then they are used only if areal-time modulation format is
turned on or an external 1/Q signal is applied to the ESG

The pre-C.03.10 Digital Modulation subsystem filter and attenuator commands will still work and have the
same behavior, in that they apply changes globally. This meansthat if you configure alocal setting for an
ARB format using the new commands, and then executed the older commands from the Digital Modulation
subsystem, the older commands would override the local settings.

Waveform Runtime Scaling
Waveform runtime scaling enables you to set the scaling value that is applied to the waveform while it is
playing.

You can set waveform runtime scaling in the ARB Setup softkey menu located in the dual ARB player. The
location of this softkey is shown in Figure 4-12. This setting is only available for the dual ARB player.

When you save the signal generator setup using the front panel Save hardkey function with the dual ARB
player, the local setting for waveform runtime scaling is also saved.

High Crest Mode

High crest mode reduces AL C levels while processing ARB waveform files, resulting in signals with less
distortion and improved EVM. However, in the high crest mode, the maximum output level is reduced and
power level accuracy is degraded.

You can set this parameter by in the ARB Setup softkey menu located in the dual ARB player. The location of
this softkey is shown in Figure 4-12. This setting is only available in the dual ARB player.

When you save the signal generator setup using the front panel Save hardkey function with the dual ARB
player, the local setting for high crest mode is also saved.

ARB Sample Clock

Each ARB modulation format and the dual ARB player incorporate alocal ARB sample clock parameter.
For example, you can set the ARB CDMA2000 modul ation format’s ARB sample rate to 5 MHz, and this
parameter would apply only to the ARB CDMA 2000 waveform that is currently playing. The 5 MHz setting
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would not be used in any of the other ARB modulation formats or the dual ARB player. If you wereto turn

off the CDMA 2000 ARB format and then turn it back on, the factory setting would be applied until you once
again change the ARB sample clock value. This setting can be saved to the file header. In thisway you can

set the ARB sampl e clock while in the ARB modulation format, and have that same setting applied when the
waveform is selected for playback in the dual ARB player.

The accessibility and setting of the ARB sample clock differs between the ARB modulation formats and the
dua ARB player. Within the ARB formats, this parameter can be changed only when the format is active
(on). Any value you enter while the format is active, will be replaced with the factory optimized value when
the format is turned off and then back on. While the ARB format is off, the ARB Sample Clock softkey is
grayed-out. In the dual ARB player, the ARB sample clock setting is accessible even when the dual ARB is
off. You can al so set the ARB sample clock when the dual ARB is off and the new setting is applied when
thedual ARB player isturned on. This setting will survive toggling the dual ARB player off and on.

Figure 4-12 on page 113 shows the location for the ARB Sample Clock softkey which is on thefirst page of the
ARB Setup softkey menu. Even though the figure is for the ARB W-CDMA modulation format, the key path
isthe same for all ARB formats and the dual ARB player.

Waveform Markers

Waveform markers are used to mark specific points on awaveform and are available for usein all ARB
modul ation formats. The signal generator provides four markers. Each marker can be associated with the RF
blanking function, the ALC hold function, and the alternate amplitude triggering function. A marker can
implement one or all three functions. For more information, refer to the section, “ Using Waveform Markers’
on page 119.

NOTE In the Bluetooth modulation format, markers one and two are automatically set when
payload data types are selected and the waveform is generated. See “Bluetooth Marker
Behavior” on page 118 for more information.

You can set each marker’s polarity and the marker points (first sample point or arange of sample points).
Each marker provides arear panel output signal using the event connector (EVENT 1, 2, 3, or 4) that
corresponds to the marker number. The EVENT 3 and 4 connectors are actually pins located on the AUX
I/O connector. For more information on the AUX /O connector, see” Rear Panel Overview” on page 35.

The ALC hold marker function holds the ALC modulator at its current level when the marker signal islow.
When the marker signal goes high, the ALC hold function is discontinued.

ALC hold isautomatically incorporated in the RF blanking marker function. So if you select the RF
blanking marker function (Pulse/RF Blank softkey), there is no need to select the AL C hold marker function
for the same marker number. You can use the AL C hold function by itself when you have awaveform signal
that incorporates idle periods or when the increased dynamic range encountered with RF blanking is not
desired. The ALC hold should only be used for short periods of time of less than 100 ms. Extended periods
of using the ALC hold feature may affect the waveform'’s output amplitude.

Chapter 4 115



Basic Digital Operation
Local Settings for ARB Waveform Formats and the Dual ARB Player

The alternate amplitude marker function triggers the Alternate Amplitude feature located in the Amplitude
hardkey menu. You still need to set up the alternate amplitude parameters. The trigger selection for the
alternate amplitude feature in the Amplitude hardkey menu should be set to internal .When the marker signal
goes low, the alternate amplitude function istriggered. When the marker signal goes high, the trigger is
terminated disengaging alternate amplitude.

Marker settings are located in the Marker Utilities softkey menu. The location of this softkey and the marker
softkey menus are shown in Figure 4-13. Even though the figure is for the ARB W-CDMA modulation
format, the key path is the samefor all ARB formats and the dual ARB player.
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Figure 4-13 ARB Marker Location and Softkey Menus
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Bluetooth Marker Behavior

Bluetooth markers one and two have predetermined settings that are implemented when a payload data type
is selected and the waveform is generated. A waveform is regenerated when anew payload datatypeis
selected while the modulation format is on. These predetermined settings will override the current marker
settings if they are different. However they do not affect the ALC hold and the alternate amplitude marker
functions. But they will affect the RF blanking function. After the waveform has been
generated/regenerated, you can modify the predetermined settings to suit your measurement needs. The
following list explains the predetermined settings for marker one and two according to the selected payload

datatype:

Truncated PN9 or 8-bit  Marker one outputs a five-sample-point wide pulse (500 ns) at the EVENT
pattern 1 rear panel connector, and marker two implements RF blanking during
the time that the Bluetooth signal is low.

Continuous PN9 Marker one outputsa 1l MHz clock signal at the EVENT 1 rear panel
connector, and marker two outputs a 216 us gated pulse signal at the
EVENT 2 rear panel connector that aligns with the transmission of the
payload data.
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Using Waveform Markers

The signal generator provides four waveform markers to mark specific points on a waveform segment.
When the signal generator encounters an enabled marker, an auxiliary output signal is routed to the rear
panel event connector (described in the “Rear Panel Overview” on page 35) that corresponds to the marker
number. You can use this auxiliary output signal to synchronize another instrument with the waveform, or as
atrigger signal to start a measurement at a given point on a waveform.

You can also configure markersto initiate ALC hold, or RF Blanking (which includes ALC hold). Refer to
“Waveform Markers’ on page 115 for more information.

Creating a waveform segment (page 105) also creates a marker file that places a marker point on the first
sample point of the segment for markers one and two. When awaveform file is downloaded that does not
have a marker file associated with it, the signal generator creates a marker file without any marker points.
Factory-supplied segments have a marker point on the first sample for all four markers.

The following procedures demonstrate how to use markers while working in the dual ARB player, but the
process is the same when working in any ARB format.

These procedures al so discuss two types of points: a marker point and a sample point. A marker pointisa
point at which a given marker is set on awaveform; you can set one or more marker points for each marker.
A sample point is one of the many points that compose a waveform.

There are three basic stepsto using waveform markers:

“Clearing Marker Points from a Waveform Segment” on page 126
“Setting Marker Points in a Waveform Segment” on page 127
“Controlling Markersin a Waveform Sequence (Dual ARB Only)” on page 129
This section a so provides the following information:

*  “Waveform Marker Concepts’ on page 120

» “Accessing Marker Utilities’ on page 124

*  “Viewing Waveform Segment Markers’ on page 125

*  “Viewing aMarker Pulse” on page 131

» “Using the RF Blanking Marker Function” on page 132

e “Setting Marker Polarity” on page 134
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Waveform Marker Concepts

The signal generator’s ARB formats provide four waveform markers to mark specific points on awaveform
segment. You can set each marker’s polarity and marker points (on a single sample point or over arange of
sample points). Each marker can also perform ALC hold or RF Blanking and ALC hold.

E— J—L Positive 43 EVENT N
Marker
File > O | Marker N
BitN —_— RF Blank Off On
Set Marker Marker - Marker N
E— ; Negative /
On Off Polarit |, BlanksRF
y O_ when Marker
. is Low
When the signal generator encounters an enabled marker (described on 1 RF Blank Only: includes ALC Hold
page 129), an auxiliary output signal is generated and routed to the rear : Marker N
panel event connector that corresponds to the marker number (N). /(V)_ Holds ALC
The EVENT 3 and 4 connectors are pins on the AUXILIARY 1/O connector when Marker
(connector locations are shown in Figure on page 39). is Low
Marker N

ALC Hold Off On

Marker File Generation

Generating awaveform segment (see page 105) automatically creates a marker file that places a marker
point on the first sample point of the segment for markers one and two.

Downloading awaveform file (as described in the E4428C/38C ESG Sgnal Generators Programming
Guide) that does not have a marker file associated with it causes the signal generator to automatically create
amarker file but does not place any marker points.

Marker Point Edit Requirements

Before you can modify a waveform segment’s marker points, the segment must reside in volatile memory
(WFM1). Refer to the section, “L oading Waveform Segments from Non-Volatile Memory” on page 111 for
more information.

In the dual ARB player, you can modify awaveform segment’s marker points either without playing the
waveform, or while playing the waveform in an ARB modulation format. In an ARB modulation format,
you must play the waveform before you can modify a segment’s marker points.

Saving Marker Polarity and Routing Settings

Marker polarity and routing settings remain until you reconfigure them, preset the signal generator, or cycle
the ESG power. To ensure that a waveform uses the correct settings when it is played, set the marker
polarities or routing (RF Blanking and ALC Hold), and save the information to the file header (page 90).
Thisis especially important when the segment plays as part of a sequence because the previously played
segment could have different marker and routing settings.
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ALC Hold Marker Function

While you can set a marker function (described as Marker Routing on the softkey |abel) either before or after
you set marker points (page 127), setting a marker function before setting marker points may cause power
spikes or loss of power at the RF output.

Use the AL C hold function by itself when you have a waveform signal that incorporatesidle periods, or
when the increased dynamic range encountered with RF blanking (page 132) isnot desired.

The ALC hold marker function holds the ALC circuitry at the average (RMS) value of the sampled points
set by the marker(s). For both positive and negative marker polarity, the AL C samples the RF output signal
(the carrier plus any modulating signal) when the marker signal goes high:

Positive: The signal is sampled during the on marker points.
Negative The signal is sampled during the off marker points.

The marker signal has aminimum of atwo sample point delay in itsresponse rel ative to the waveform signal
response. To compensate for the marker signal delay, offset marker points from the waveform sample at
which you want the ALC sampling to begin.

NOTE Because it can affect the waveform’s output amplitude, do not use the AL C hold for longer than
100 ms. For longer time intervals, refer to “ Power Search Mode” on page 630.

Markers set early in time
to account for marker response

g
-‘F. .

RF OUTPUT : >

==
Marker n >3 H
- ) . << .
Positive Polarity .
E“- 100 ms :E
. Max ALC hold time '
CAUTION Incorrect ALC sampling can create a sudden unleveled condition that may create aspikein

the RF output, potentially damaging aDUT or connected instrument. To prevent this
condition, ensure that you set markersto let the ALC sample over an amplitude that
accounts for the higher power levels encountered within the signal.
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Example of Correct Use

Waveform: 1022 points
Marker range: 95-97
Marker polarity: Positive

This example shows a marker set to sample the waveform'’s area of
highest amplitude. Note that the marker is set well before the
waveform’s area of lowest amplitude. This takes into account the
response difference between the marker and the waveform signal.

Close-up of averaging

The AL C samples the waveform when the marker signal goes
high, and uses the average of the sampled waveform to set the
ALC circuitry.

Here the AL C samples during the on marker points (positive
polarity).

Example of Incorrect Use

Waveform: 1022 points
Marker range: 110-1022
Marker polarity: Positive

This example shows a marker set to sample the low part of the — I ol o il A S
same waveform, which sets the ALC modulator circuitry for Marker l Marker
that level; this usually resultsin an unleveled condition for the

signal generator when it encounters the high amplitude of the /
pulse. Pulse Unleveled
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Example of Incorrect Use

Waveform: 1022 points
Marker range: 110-1022
Marker polarity: Negative
Thisfigure shows that a negative polarity marker goes low during —

the marker on points; the marker signal goes high during the off g Marker on L Maker | on ~
points. The ALC samples the waveform during the off marker SR o i P S S W b
points.

Sample range begins on first point of signal

Sampling both on and off time sets the modulator circuitry
incorrectly for higher signal levels. Note the increased amplitude

at the beginning of the pulse.

Marker Marker
<« Marker On Of =~ On *~

Negative range set between signal and
off time
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Accessing Marker Utilities

Usethe following procedure to display the marker parameters. This procedure usesthe dual ARB player, but
you can access the marker utilities through the ARB Setup softkey in all ARB formats.

1. Select the ARB waveform player:

press Mode > Dual ARB

2. Press ARB Setup > Marker Utilities.

ARE Sample Clock
100, 0000000 MHz
Select
Hawaform ARE EE{BP%HEB
Haveform,)
Seaments
Haveform,
seausrces! Rk
ARE Setup - " -TE-'E‘-‘BW
ilities
Trigoer
(Cont inbons )™ UtiT???gg’
More
(1 of 21

Marker Polaritus

Marker Routingh

Set Markersh

>/

When using an ARB format other than
dual ARB, you must turn on the format
to enable the Set Markers softkey.

NOTE

Most of the proceduresin this section begin at the Marker Utilities softkey menu.
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Markers are applied to waveform segments. Use the following steps to view the markers set for a segment
(this example uses the factory-supplied segment, SI NE_ TEST WM.

1. Inthe Marker Utilities menu (page 124), press Set Markers.

2. Highlight the desired waveform segment. In an ARB format such as Custom Arb Waveform Generator,
thereis only one file (AUTOGEN_ WAVEFCRM) and it is highlighted.

3. Press Display Markers > Zoom in Max. The maximum zoom in range is 28 points.

Experiment with the Zoom functions to see how they display the markers.

The display can show a maximum of 460 points; displayed waveforms with a sample point range greater

than 460 points may not show the marker locations.

FRECUEMCY

4.000 000 000 00 &tz

Marker Polaritum

L

Marker Routingh

AP
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8
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The Set Marker display -
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The display below shows the | and Q components of the waveform, and

the marker points set in a factory-supplied segment. ‘ First sample
IE_\t“\/point shown on
irs .
FREQUENCY AMPLITUOE Carole boieE display
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Zoom In
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Each press of the
softkey changes
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Zoom Out Max

point Sample Point

28 a factor of two
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Clearing Marker Points from a Waveform Segment

When you set marker points they do not replace points that already exist, but are set in addition to existing
points. Because markers are cumulative, before you set points, view the segment (page 125) and remove
any unwanted points. With all markers cleared, the level of the event output signal isOV.

Clearing All Marker Points

1
2.

5.

In the Marker Utilities menu (page 124), press Set Markers.

Highlight the desired waveform segment.
In an ARB format, there is only one file (AUTOGEN WAVEFCRM) and it is already highlighted.

Highlight the desired marker number:
Press Marker 12 3 4.

For the selected marker number, remove all marker pointsin the selected segment:
Press Set Marker Off All Points.

Repeat from Step 2 3 for any remaining marker points that you want to remove.

Clearing a Range of Marker Points

The following exampl e uses awaveform with marker points (Marker 1) set across points 10-20. This makes
it easy to see the affected marker points. The same process applies whether the existing points are set over a
range or asindividual points (page 120).

1
2.

In the Marker Utilities menu (page 124), select the desired marker (for this example, Marker 1).

Set the first sample point that you want off (for this example, 13):
Press Set Marker Off Range Of Points > First Mkr Point > 13 > Enter.

Set the last marker point in the range that you want off to avalue less than or equal to the number of
points in the waveform, and greater than or equal to the value set in Step 2 2 (for this example, 17):
Press Last Mkr Point > 17 > Enter > Apply To Waveform > Return.

Thisturns off al marker points for the active marker within the range set in Steps 2 and 3, as shown in
the following figure.

Arb laveform Markers
UFITL :RAMP_TEST_UFTI

F WM O

1 Sample Point 28

Viewing markers is described on page 125
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Clearing a Single Marker Point

Use the steps described in “Clearing a Range of Marker Points’ on page 126, but set both the first and last
marker point to the value of the point you want to clear. For example, if you want to clear a marker on point
5, set both the first and last value to 5.

Setting Marker Points in a Waveform Segment

To set marker points on a segment, the segment must reside in volatile memory (page 111).

When you set marker points, they do not replace points that already exist, but are set in addition to existing
points. Because markers are cumulative, before you set marker points within a segment, view the segment
(page 125) and remove any unwanted points (page 120).

Placing a Marker Across a Range of Points

1. Inthe Marker Utilities menu (page 124), press Set Markers.

2. Highlight the desired waveform segment.
In an ARB format, there is only one file (AUTOGEN WAVEFCRM) and it is already highlighted.

3. Highlight the desired marker number:
Press Marker 12 3 4

4. Set thefirst sample point in the range (in this example, 10):
Press Set Marker On Range Of Points > First Mkr Point > 10 > Enter.

5. Set thelast marker point in the range to avalue less than or equal to the number of pointsin the
waveform, and greater than or equal to the first marker point (in this example, 20):

Press Last Mkr Point > 20 > Enter.
6. Press Apply To Waveform > Return.

This sets a range of waveform marker points. The marker signal starts on sample point 10, and ends on
sample point 20, as shown in the following figure.

Arb laveform Markers
UFITL :RAMP_TEST_UFTI

F WM O

1 Sample Point 28

Viewing markers is described on page 125

Chapter 4 127



Basic Digital Operation
Using Waveform Markers

Placing a Marker on a Single Point

On the First Point

1. Inthe Marker Utilities menu (page 124), press Set Markers.

2. Highlight the desired waveform segment.
In an ARB format, there is only one file (AUTOGEN WAVEFCRM) and it is already highlighted.

3. Highlight the desired marker number:

Press Marker 12 3 4.
4. Press Set Marker On First Point.

This sets amarker on the first point in the segment for the marker number selected in Step 2 3.
On Any Poaint

Use the steps described in “ Setting Marker Points in a Waveform Segment” on page 127, but set both the
first and last marker point to the value of the point you want to set. For example, if you want to set a marker
on point 5, set both the first and last value to 5.

Placing Repetitively Spaced Markers

The following example sets markers across a range of points and specifies the spacing (skipped points)
between each marker. You must set the spacing before you apply the marker settings; you cannot apply
skipped points to a previously set range of points.

1. Remove any existing marker points (page 120).
2. Inthe Marker Utilities menu (page 124), press Set Markers.

3. Highlight the desired waveform segment.
In ARB formats there is only one file (AUTOGEN WAVEFCORM) and it is already highlighted.

4. Highlight the desired marker number: Press Marker 12 3 4.

5. Set the first sample point in the range (in this example, 5):
Press Set Marker On Range Of Points > First Mkr Point > 5 > Enter.

6. Set thelast marker point in the range to a value less than the number of points in the waveform, and
greater than or equal to the first marker point (in this example, 25):
Press Last Mkr Point > 25 > Enter.

7. Enter the number of sample points that you want skipped (in this example, 1):
Press # Skipped Points > 1 > Enter.
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8. Press Apply To Waveform > Return.

This causes the marker to occur on every other point (one sample point is skipped) within the marker point
range, as shown below.

Arb laveform Markers
UFITL :RAMP_TEST_UFTI

F WM O

1 Sample Point 28

Viewing markers is described on page 125

One application of the skipped point feature is the creation of a clock signal as the auxiliary output.

Controlling Markers in a Waveform Sequence (Dual ARB Only)

In awaveform segment, an enabled marker point generates an auxiliary output signal that is routed to the
rear-panel event connector (described in “Rear Panel Overview” on page 35) corresponding to that marker
number. For a waveform sequence, you enable or disable markers on a segment-by-segment basis; this
enables you to output markers for some segmentsin a sequence, but not for others. Unless you change the
marker settings or cycle the power, the setting remains the same for the next loaded sequence.

As You Create a Waveform Sequence

After you select the waveform segments to create a waveform sequence, and before you name and save the
sequence, you can enable or disable each segment’s markers independently. Enabling a marker that has no
marker points (page 127) has no effect on the auxiliary outputs.

1. Select the waveform segments (Step 2 1 on page 107).
2. Toggle the markers as desired:

a. Highlight the first waveform segment.
b. PressEnable/Disable Markers.

c. Asdesired, press Toggle Marker 1, Toggle Marker 2, Toggle Marker 3, and Toggle Marker 4.
Toggling a marker that has no marker points (page 127) has no effect on the auxiliary outputs.

An entry in the Mkr column (see figure below) indicates that the marker is enabled for that segment;
no entry in the column means that all markers are disabled for that segment.

d. Inturn, highlight each of the remaining segments and repeat Step 2 c.

3. PressReturn.
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4. Name and store the waveform sequence “ Storing Waveform Segments to Non-Volatile Memory” on
page 110.

The following figure shows a sequence built reusing the same factory-supplied waveform segment; a
factory-supplied segment has a marker point on the first sample for all four markers. In this example,
Marker 1is enabled for the first segment, Marker 2 is enable for the second segment, and markers 3 and 4
are enabled for the third segment.

Togole Marker 3

SINE_TEST_WFM| (UHSTORED) UNTITLED
(1/2) 5 t 5 e| (1/1) Haveform  Repsg/Hkr
ALTOGEN_PRAM_1 ZKKLZKEM WFM1:SINE_TEST_LIFM 11 Tooole Marker L

RAMP_TEST_HFHM A WFM1:SINE_TEST_LIFM 1
STHE_TEST_UFN ARZ2 LIFM1:SINE _TEST LIFM

Sequence Marker Column

This entry shows that

@l ) markers 3 and 4 are enabled

for this segment.

B
COMPLEX

For each segment, only the markers enabled for that segment produce arear-panel auxiliary output signal. In
this example, the Marker 1 auxiliary signal appears only for the first segment, because it is disabled for the
remaining segments. The Marker 2 auxiliary signal appears only for the second segment, and the marker 3
and 4 auxiliary signals appear only for the third segment.

In an Existing Waveform Sequence

If you have not already done so, create and store a waveform sequence that contains at least three segments
(page 106). Ensure that the segment or segments are available in volatile memory (page 111).

1. PressMode > Dual ARB > Waveform Sequences, and highlight the desired waveform sequence.
2. PressEdit Selected Waveform Sequence, and highlight the first waveform segment.

3. PressEnable/Disable Markers > Toggle Marker 1, Toggle Marker 2, Toggle Marker 3, and Toggle Marker 4.
Toggling a marker that has no marker points (page 127) has no effect on the auxiliary outputs.

Anentry inthe Mkr column indicates that the marker is enabled for that segment; no entry in the column
means that all markers are disabled for that segment

4. Highlight the next waveform segment and toggle the desired markers (in this example, markers 1 and 4).

5. Repeat Step 2 4 asdesired (for this example, select the third segment and toggle marker 3).
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6. PressReturn > Name And Store > Enter.

The markers are enabled or disabled per your selections, and the changes have been saved to the selected
sequencefile.

FFEQUENCY AMFLITUOE Insert
4.000 000 000 00 &tz | ~136.00 dan [sciecten teveiom
rop
(I /Sequence Marker Column
FAMP_TEST_HFM|  CUNSTORED) UNTITLED /
(171 Segment 8 e| (1/1) Uaveforn _ Repsty Tk
eSS FHOCH_ G5 +FHOCH_9 LT :RANP_TEST_LIFN 1l1zau| Done Inserting
STNE_TEST_MFH RO_DATA HFML:STME_TEST_HFM 11 L

AQ_S SEQ:AQ_DATA 13
TGR_TST_2 SeUBFDm’ )
TST_RM \Th|s entry shows that only

marker 3 is enabled for this

Fage U
mas e segment.

=== PROT0 CODE #= NOT FOR CUSTOMER USE == 01/21/2070 13:39 Fage Down

Viewing a Marker Pulse

When awaveform plays (page 107), you can detect a set and enabled marker’s pulse at the rear panel event
connector that corresponds to that marker number. This example demonstrates how to view amarker pulse
generated by awaveform segment that has at least one marker point set (page 127). The processisthe same
for awaveform seguence.

This procedure uses the factory-supplied segment, SI NE_TEST _WMin the dual ARB Player.
Factory-supplied segments have a marker point on the first sasmple point for all four markers, as shown.

Arb laveform Markers
UFITL :STHE_TEST_UFTI

Marker points on
first sample point of
waveform segment

rme —
[

Sample Point 28

Viewing markers is described on page 125
1. PressMode > Dual ARB > Select Waveform, and highlight the SI NE_ TEST WFMsegment.
2. Press ARB Off On to On.
3. Connect the ESG's rear-panel Q QUT output to the oscilloscope’s channel 1 input.
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4. Connect the ESG's rear-panel EVENT 1 output to the oscilloscope’'s channel 2 input. When marker 1is
present, the ESG outputs asignal on the EVENT 1 connector as shown in the following example.

RF Output

Marker pulse on the Event 1 signal.

Using the RF Blanking Marker Function

While you can set a marker function (described as Marker Routing on the softkey label) either before or after
setting the marker points (page 127), setting amarker function before you set marker points may change the
RF output. RF Blanking includes AL C hold (described on page 121, note Caution regarding unleveled
power). The signal generator blanks the RF output when the marker signal goes low.

1. Using the factory-supplied segment SI NE_ TEST WM set Marker 1 across points 1-180 (page 127).
2. From the Marker Utilities menu (page 124), assign RF Blanking to Marker 1.

132 Chapter 4



Basic Digital Operation
Using Waveform Markers

Press Marker Routing > Pulse/RF Blank > Marker 1.
Marker Polarity = Positive

RF Signal When marker polarity is positive (the
default setting), the RF output is blanked
during the off maker points.
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Marker Polarity = Negative

When marker polarity is negative, the
RF output is blanked during the on
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Setting Marker Polarity
Setting a negative marker polarity inverts the marker signal.

1. Inthe Marker Utilities menu (page 124), press Marker Polarity.

2. Select the marker polarity as desired for each marker number.

: Marker 1 Polgritd
Marker Polarit > . o
Arker Folaritd Neo Nzl Default Marker Polarity = Positive

; Marker 2 Polarit
Marker Routingh Heg lﬁ o
Set each marker polarity independently.
Marker 3 Polarit
Set. Markersh e |

) See Also: “Saving Marker Polarity and Routing Settings” on page 120.
Marker hNgSlarlti

|
As shown on page 132:
Positive Polarity: ~ On marker points are high (=3.3V).
Negative Polarity: On marker points are low (OV).
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Triggering Waveforms

Triggering is available in both ARB and real-time formats. ARB triggering controls the playback of a
waveform file; real-time custom triggering controls the transmission of a data pattern. The examples and
discussions in this section use the dual ARB Player, but the functionality and methods of access (described
on page 137) aresimilar in al ARB and real-time formats.

Triggers control data transmission by telling the ESG when to transmit the modulating signal. Depending on
the trigger settings, the data transmission may occur once, continuously, or the ESG may start and stop the
transmission repeatedly (Gated mode).

A trigger signal comprises both positive and negative signal transitions (states), which are also called high
and low periods; you can configure the ESG to trigger on either state. It iscommon to have multipletriggers,
also referred to as trigger occurrences or trigger events, occur when the signal generator requires only a
single trigger. In this situation, the ESG recognizes the first trigger event and ignores the rest.

When you select atrigger mode, you may lose the signal (carrier plus modulation) from the RF output until
you trigger the modulating signal. This is because the ESG setsthe | and Q signalsto zero volts prior to the
first trigger event, which suppresses the carrier. If you create a data pattern with the initial | and Q voltages
set to values other than zero, this does not occur. After the first trigger event, the signal’sfinal | and Q levels
determine whether you see the carrier signal or not (zero = no carrier, other values = visible carrier). At the
end of most data patterns, the final | and Q points are set to avalue other than zero.

There are four parts to configuring a waveform trigger:

»  Source determines how the ESG receives the trigger that initiates waveform play.

* Mode determines the waveform’s overall behavior when it plays.

* Response determines the specifics of how the waveform responds to a trigger.

» Polarity determines the state of the trigger to which the waveform responds (used only with an external
trigger source); you can set either negative, or positive.
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Source

The figure below shows the dual ARB mode trigger menu.

Tricger Keu 4@——The Trigger hardkey

Eus y@——A command sent through the rear-panel GPIB, LAN, or Auxiliary (RS-232) interface

An external trigger signal applied to either the PATTERN TRIG IN connector, or the PATT TRIG IN 2

Ext 1 pin on the AUXILIARY 1/O connector (connector locations are shown in Figure on page 39).

(Patt '%;5"195%'"%. The following parameters affect an external trigger signal:

» The source (Input connector) of the external trigger signal (see page 137)
Ext Polarity

Pos » The polarity of the external trigger (described on page 138)
Ext Delay « Any desired delay between when the ESG receives an external trigger and when the
an waveform responds to it (see page 137).

Mode and Response

The arbitrary waveform player provides four trigger modes; each mode has one or more possible responses:

Single plays the waveform once. Arb formats have the following re-triggering options:

— Off ignores triggers received during play; atrigger received after playback completes restarts the
playback.

— On causes atrigger received during play to repeat the waveform after the current play compl etes.

— Immediate causes atrigger received during play to immediately restart the waveform.

Gated causes the waveform to wait for the first active trigger signal state to begin transmission, then
repeatedly starts and stopsin response to an externally applied gating signal (example on page 138).
You select the active state with the Gate Active Low High softkey (see page 138).

In an ARB format, the waveform plays during the inactive state, and stops during the active state.
In real-time Custom, behavior depends on whether the signal uses framed or unframed data.

Because the ESG provides only unframed data, to transmit a framed data signal you must create an
external file that incorporates the framing and download it to the ESG (see the E4428C/38C ESG Signal
Generators Programming Guide).

— Unframed data transmits during active states, and stops during inactive states. The signal stops at the
last transmitted symbol and restarts at the next symbol.

— Framed data starts transmitting at the beginning of a frame during active states, and stops at the end
of aframe when the end occurs during inactive states. If the end of the frame extends into the next
active state, the signal transmits continuoudly.
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» Segment Advance (dual ARB only) causes a segment in a sequence to require atrigger to play. Thetrigger
source controls how play moves from segment to segment (example on page 140). A trigger received
during the last segment loops play to the first segment in the sequence. You have two choices as to how

the segments play:

— Single causes a segment in a sequenceto play once, after which the dual ARB player stops and waits
for atrigger before advancing to the next segment, and playing that segment to completion. Triggers
received during play cause the current segment to finish, the dual ARB player advances to the next
segment, and plays that segment to completion.

— Continuous causes a segment in a sequence to play continuously until the waveform receives another
trigger. Triggers received during play cause the current segment to finish, then play advances to the
next segment, which plays continuously.

» Continuous repeats the waveform until you turn the signal off or select another waveform, trigger mode,

or response. Continuous has the following functions:

— Free Run immediately triggers and plays the waveform; triggers received during play areignored.

— Trigger & Run plays the waveform when atrigger is received; subsequent triggers are ignored.

— Reset & Run (not available in real-time Custom) plays the waveform when atrigger is received;
subsequent triggers restart the waveform.

Accessing Trigger Utilities

The following figures show the menus for the trigger parameters. These figures show the dual ARB player,
but you can access the trigger utilities through the Trigger softkey in all ARB formats, and the Pattern Trigger

softkey in the Real Time 1/Q Baseband (Custom) format.
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» Todisplay thetrigger modes, press Mode > Dual ARB > Trigger.

PATTERN TRIG IN connector

Patt Trio In 1

Fatt Trio In 2

PAT TRIG IN 2 pin on
the AUXILARY 1/O connector

Active only when
Ext is selected.

Chapter 4

137



Basic Digital Operation
Triggering Waveforms

« Todisplay the response selections available for a given trigger mode, press Trigger Setup, then select the
desired trigger mode. To see the selections for Single mode in an ARB format, select Retrigger Mode; in
real-time Custom, selecting Single mode causes the data pattern to play once when triggered.

» Todisplay thetrigger source options, press Trigger Setup > Trigger Source.
Setting the Polarity of an External Trigger

Gated Mode

The selections available with the gate active parameter refer to the low and high states of an external trigger
signal. For example, when you select High, the active state occurs during the high of the trigger signal.

ARB Formats When the active state occurs, the ESG stops the waveform file playback at the last
played sample point, and restarts the playback at the next sample point when the
inactive state occurs.

Real-Time Custom When the active state occurs, the ESG transmits the data pattern. When the inactive
state occurs, the transmission stops at the last transmitted symbol, and restarts at the
next symbol when the active state occurs.

Continuous, Single, or Segment Advance Modes

The Ext Polarity Neg Pos softkey selections refer to the low (negative) and high (positive) states of an external
trigger. With Neg selected (the default), the ESG responds during the low state of the trigger signal.

Using Gated Triggering

Gated triggering enables you to define the on (playback) and off states of a modulating waveform. This
exampl e uses the factory supplied segment, SI NE_ TEST WM

1. Connect the output of afunction generator to the signal generator’s rear-panel PATTERN TRIG IN, as
shown in the following figure.
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This connection is applicable to all external triggering methods. The optional oscilloscope connection
enables you to see the effect that the trigger signal has on the RF output.

Preset the signal generator.

Configure the carrier signal output:

e Set the desired frequency.
e Set the desired amplitude.
e Turn on the RF output.

Select awaveform for playback (sequence or segment):

a. Preset the signal generator.

b. Press Mode > Dual ARB > Select Waveform.

¢. Highlight awaveform file (for this example, SI NE_TEST WFMN).
d. Press Select Waveform.

Select the waveform trigger method:

a  PressTrigger > Gated.

b. PressTrigger > Trigger Setup and note that for the Gate Active Low High softkey, the default selection is
High, which is the selection used in this example.

Select the trigger source and rear panel input:

a. For the Trigger Source softkey, the default selection isExt, which is the selection used in this example
(gated triggering requires an external trigger).
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b. PressTrigger Source and notethat for the Ext Source softkey, the default selection is Patt Trig In 1, which
isthe selection used in this example.

7. Generate the waveform:

Press ARB Off On to On.
8. On the function generator, configurea TTL signal for the external gating trigger.
9. (Optional) Monitor the current waveform:

Configure the oscilloscope to display both the output of the signal generator, and the external triggering
signal. You will see the waveform modulating the output during the gate inactive periods (low).

The following figure shows an example display.

Modulating Waveform RFE Output

o
S IV WM~ MW

-

Externally Applied Gating Signal
Gate Active = High

NOTE In the real-time Custom mode, the behavior is reversed: when the gating signal is high, you
see the modul ated waveform.

Using Segment Advance Triggering

Segment advance triggering enables you to control the segment playback within a waveform sequence. The
following example uses a waveform sequence that has two segments.

If you have not created and stored a waveform sequence, complete the stepsin the sections, “ Creating
Waveform Segments’ on page 105, and “ Creating a Waveform Sequence” on page 106.

1. Preset the signal generator.
2. Configure the RF output:
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e Set the desired frequency.
e Set the desired amplitude.
e Turn on the RF output.

3. Select awaveform sequence for playback:
a. Press Mode > Dual ARB > Select Waveform.
b. Highlight awaveform sequencefile.
C. Press Select Waveform.

4. Select the waveform trigger method and trigger source:

a. PressTrigger > Segment Advance.

b. PressTrigger > Trigger Setup and note that the Seg Advance Mode softkey displays the default selection
(Continuous), which is the selection used in this example.

c. PressTrigger Source > Trigger Key.

5. Generate the waveform sequence:
Press Return > Return > ARB Off On to On.

6. Trigger the first waveform segment to begin playing repeatedly:
Press the Trigger hardkey.

7. (Optional) Monitor the current waveform:

Connect the output of the signal generator to the input of an oscilloscope, and configure the oscill oscope
so that you can see the output of the signal generator.

8. Trigger the second segment:
Press the Trigger hardkey.

The second segment in the sequence now plays. Pressing the Trigger hardkey causes the current playback
to finish and the next segment to start; when the last segment plays, pressing the Trigger hardkey causes
the first segment in the waveform sequence to start when the current segment finishes.

Using External Triggering

Using this procedure, you learn how to utilize an external function generator to apply a delayed
single-trigger to a custom multicarrier CDMA waveform.

Required Equipment
Agilent 33120A Function Generator
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Connecting the Equipment

Connect the signal generator to the function generator, as shown in Figure 4-14.

Figure 4-14

FUNCTION
GENERATOR

€

1
pooooooog ©
ooooonng ¢

QuUTPUT

SIGNAL GENERATOR

Configuring a Custom Multicarrier COMA State
1. PressPreset.

2. Press Mode > CDMA > Arb IS-95A.

3. Toggle Multicarrier Off On to On.
4

Press Setup Select > 4 Carriers.

Configuring the Waveform Trigger

1. PressTrigger > Single.

2. PressTrigger > Trigger Setup >Trigger Source > Ext.
3. PressExt Polarity Neg Pos until Posis highlighted.
4. PressExt Delay Off On to On.

5. PressExt Delay Time > 100 > msec.

The waveform will now trigger once 100 milliseconds after it detectsachangein TTL state from low to high
at the PATT TRIG IN rear panel connector.

Configuring the Function Generator

Set the function generator waveform to a0.1 Hz square wave at an output level of 0 to 5V.

Generating the Waveform

Press Mode > CDMA > Arb 1S-95A > CDMA Off On to On.
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This generates a waveform with the custom multicarrier CDMA state configured in the previous section.
The display changesto Mul ti carri er Setup: 4 CARR ERS. During waveform generation, the COVA
and | / Qannunciators activate and the new custom multicarrier CDMA state is stored in volatile ARB
memory. The waveform is now modulating the RF carrier.

Configuring the RF Output

1. Set the RF output frequency to 890.01 MHz.
2. Set the output amplitude to —10 dBm.
3. PressRF On/0ff to On.

The externally single-triggered custom multicarrier COMA waveform is now available at the signal
generator's RF OUTPUT connector 100 msec after receiving achangein TTL state from low to high at the
PATT TRIG IN, provided by the function generator output.
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Using Waveform Clipping

Waveforms with high power peaks can cause intermodul ation distortion, which generates spectral regrowth
(acondition that interferes with signalsin adjacent frequency bands). The clipping function enables you to
reduce high power peaks by clipping the | and Q data to a selected percentage of its highest peak.

The clipping feature is available only with the dual ARB mode.

How Power Peaks Develop

To understand how clipping reduces high power peaks, it isimportant to know how the peaks develop asthe
signal is constructed.

1/Q waveforms can be the summation of multiple channels (see Figure 4-15). Whenever most or all of the
individual channel waveforms simultaneously contain a bit in the same state (high or low), an unusually
high power peak (negative or positive) occurs in the summed waveform. This does not happen frequently
because the high and low states of the bits on these channel waveforms are random, which causes a
cancelling effect.

Figure 4-15 Multiple Channel Summing

Uy

Multiple Channels to be
Summed Into One Tor Q
Waveform

i

Summed Ior Q Waveform
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The | and Q waveforms combine in the 1/Q modulator to create an RF waveform. The magnitude of the RF

envelope is determined by the equation /12+Q2, where the squaring of | and Q always resultsin a positive
value.

Asshown in Figure 4-16, simultaneous positive and negative peaksin the | and Q waveforms do not cancel
each other, but combine to create an even greater peak.

Figure 4-16 Combining the | and Q Waveforms
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How Peaks Cause Spectral Regrowth

Because of the relative infrequency of high power peaks, awaveform will have a high peak-to-average
power ratio (see Figure 4-17). Because atransmitter’s power amplifier gain is set to provide a specific
average power, high peaks can cause the power amplifier to move toward saturation. This causes
intermodulation distortion, which generates spectral regrowth.

Figure 4-17 Peak-to-Average Power

———————————————— Peak Power

Average Power

Spectral regrowth is arange of frequencies that develops on each side of the carrier (similar to sidebands)
and extends into the adjacent frequency bands (see Figure 4-18). Consequently, spectral regrowth interferes
with communication in the adjacent bands. Clipping can provide a solution to this problem.

Figure 4-18 Spectral Regrowth Interfering with Adjacent Band
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How Clipping Reduces Peak-to-Average Power

You can reduce peak-to-average power, and consequently spectral regrowth, by clipping the waveform.
Clipping limits power peaksin waveforms by clipping the | and Q datato a selected percentage of its highest
peak. The ESG Vector Signal Generator provides two different methods of clipping: circular and
rectangular. Circular clipping is defined as clipping the composite I/Q data (1 and Q data are equally
clipped). Rectangular clipping is defined as independently clipping the | and Q data.

During circular clipping, clipping is applied to the combined | and Q waveform (]I +jQJ). Notice in Figure
4-19 that the clipping level is constant for all phases of the vector representation and appears asacircle.
During rectangular clipping, clipping is applied to the | and Q waveforms separately (1|, |Q). Noticein
Figure 4-20 on page 148 that the clipping level is different for | and Q; therefore, it appears asarectanglein
the vector representation. With either method, the objectiveisto clip the waveform to alevel that effectively
reduces spectral regrowth, but does not compromise theintegrity of the signal. Figure 4-21 on page 149 uses
two complementary cumulative distribution plots to show the reduction in peak-to-average power that
occurs after applying circular clipping to awaveform.

The lower you set the clipping value, the lower the peak power that is passed (or the morethe signal is
clipped). Often, the peaks can be clipped successfully without substantially interfering with the rest of the
waveform. Datathat might be lost in the clipping processis salvaged because of the error correction inherent
in the coded systems. If you clip too much of the waveform, however, lost dataisirrecoverable. You may
have to try several clipping settings to find a percentage that works well.

Figure 4-19 Circular Clipping
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Figure 4-20 Rectangular Clipping
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Configuring Circular Clipping

This procedure shows you how to configure circular clipping. The circular setting clips the composite I/Q
data (I and Q data are clipped equally). For more information about circular clipping, refer to “How Clipping
Reduces Peak-to-Average Power” on page 147.

1

© © N o

10.

Press Preset > Mode > Custom > Arb Waveform Generator > Digital Modulation Off On to On. This generates a
custom arbitrary waveform for use in this procedure. You can aso use a previously stored or
downloaded waveform.

Press Mode > Dual ARB > Select Waveform and ensure that AUTOGEN WAVEFCRMI s highlighted on the
display. AUTOGEN WAVEFCRMis the default name assigned to the waveform you generated in the
previous step.

Press Select Waveform. This selects the waveform and returns you to the previous softkey menu.

Press ARB 0Off On to On. The dual Arb player must be turned on to display the CCDF plot in the following
steps.

Press ARB Setup > Waveform Utilities > Waveform Statistics and ensure that AUTOGEN WAVEFCRMis
highlighted on the display.

Press CCDF Plot and observe the position of the waveform’s curve, which is the darkest line.
Press Return > Return > Clipping.
Ensure that the Clipping Type |1+jQ] |1],1Q] softkey isset to |1+jQ], whichis circular clipping.

Press Clip |1+jQ] To > 80 > % > Apply to Waveform. The | and Q data are both clipped by 80%. Once
clipping is applied to the waveform it cannot be undone. Repeated use of the clipping function has a
cumulative effect on the waveform.

Press Waveform Statistics > CCDF Plot and observe the waveform'’s curve. Notice the reduction in
peak-to-average power, relative to the previous plot, after applying clipping.
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Configuring Rectangular Clipping

This procedure shows you how to configure rectangular clipping. The rectangular setting clipsthe | and Q
dataindependently. For more information about rectangular clipping, refer to “How Clipping Reduces
Peak-to-Average Power” on page 147.

1. PressPreset > Mode > Custom > Arb Waveform Generator > Digital Modulation Off On to On. This generates a
custom arbitrary waveform for use in this procedure. You can aso use a previously stored or
downloaded waveform.

2. Press Mode > Dual ARB > Select Waveform and ensure that AUTOGEN WAVEFCRMi s highlighted on the
display. AUTOGEN WAVEFCRMis the default name assigned to the waveform you generated in the
previous step.

Press Select Waveform. This selects the waveform and returns you to the previous softkey menu.

4. PressARB Off On to On. The dual Arb player must be turned on to display the CCDF plot in the following
steps.

5. Press ARB Setup > Waveform Utilities > Waveform Statistics and ensure that AUTOGEN WAVEFCRMis
highlighted on the display.

6. PressCCDF Plot and observe the position of the waveform'’s curve, which is the darkest line.
7. PressReturn > Return > Clipping.

8. Ensure that the Clipping Type |1+jQ] |1],1Q] softkey isset to |1],]Q]. This activates the Clip |1] To and
Clip |Q| To softkeys that enable you to configure rectangular (independent) | and Q data clipping.

9. PressClip |1] To > 80 > %.

10. Press Clip | Q] To > 40 > % > Apply to Waveform. The | and Q data are individually clipped by 80% and
40%, respectively. Once clipping is applied to the waveform it cannot be undone. Repeated use of the
clipping function has a cumulative effect on the waveform.

11. Press Waveform Statistics > CCDF Plot and observe the waveform'’s curve. Notice the reduction in
peak-to-average power, relative to the previous plot, after applying clipping.
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Using Waveform Scaling

Waveform scaling is used to eliminate DAC over-range errors. The ESG provides two methods of waveform
scaling. You can perform runtime scaling, which enables you to make real -time scaling adjustments of a
currently playing waveform, or you can permanently scale a non-playing waveform file residing in volatile
memory. This section describes how DAC over-range errors occur and how you can use waveform scaling to
eliminate these errors effectively.

The scaling feature is available only with the dual ARB mode.

How DAC Over-Range Errors Occur

The ESG utilizes an interpolator filter in the conversion of the digital | and Q baseband waveforms into
analog waveforms. The clock rate of the interpolator is four times that of the baseband clock. The
interpolator therefore cal cul ates sample points between the incoming baseband samples to equal the faster
clock rate and smooth out the waveform, giving it a more curve-like appearance (see Figure 4-22).

Figure 4-22 Waveform Interpolation
INTERPOLATED SAMPLES

\ / / ' —— '

BASEBAND SAMPLES

Theinterpolation filters in the DAC's have overshoot. If a baseband waveform has afast-rising edge, the
interpolator filter's overshoot or frequency response becomes a component of the interpolated baseband
waveform. This response causes aripple or ringing effect at the peak of therising edge. If this ripple exceeds
(or overshoots) the upper limit of the DAC'srange, the interpolator calcul ates erroneous sample points and
is unable to replicate the true form of the ripple (see Figure 4-23). As aresult, the ESG reportsa DAC
over-range error.
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Figure 4-23
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How Scaling Eliminates DAC Over-Range Errors

Scaling reduces or shrinks a baseband waveform’s amplitude while maintaining its basic shape and
characteristics, such as peak-to-average power ratio. If the fast-rising baseband waveform is scaled enough
to allow an adequate margin for the overshoot, the interpolator filter is then able to calculate sample points
that include the ripple effect, thereby eliminating the over-range error (see Figure 4-24).

Figure 4-24
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Although scaling maintains the basi ¢ shape of the waveform, too much scaling can compromise itsintegrity
because the bit resolution can be so low that the waveform becomes corrupted with quantization noise.
Maximum accuracy and optimum dynamic range are achieved by scaling the waveform just enough to
remove the DAC over-range error. Optimum scaling varies with waveform content.

Scaling a Currently Playing Waveform (Runtime Scaling)

This procedure enables you to make real-time scaling adjustments to a currently playing waveform. This
type of scaling does not affect the waveform file and is well suited for eliminating DA C over-range errors.

1. PressPreset > Mode > Custom > Arb Waveform Generator > Digital Modulation Off On to On. This generates a
custom arbitrary waveform for use in this procedure. You can aso use a previously stored or
downloaded waveform.

2. Press Mode > Dual ARB > Select Waveform and ensure that AUTOGEN WAVEFCRMi s highlighted on the
display. AUTOGEN WAVEFCRMis the default name assigned to the waveform you generated in the
previous step.

3. Press Select Waveform. This selects the waveform and returns you to the previous softkey menu.
4. Press ARB Off On to On. This plays the selected waveform.

5. Press ARB Setup > More (1 of 2) > Waveform Runtime Scaling and adjust the front panel knob or use the
number keys to enter a new value. The new scaling value isinstantly applied to the playing waveform.
Runtime scaling adjustments are not cumulative, as the values are always relative to original amplitude
of the waveform file.

Scaling a Waveform File in Volatile Memory

This procedure enables you to permanently scale awaveform file. You can then store the scaled waveform
segment to non-volatile memory for future use. Scaling is cumulative and non-reversible.

1. PressPreset > Mode > Custom > Arb Waveform Generator > Digital Modulation Off On to On. This generates a
custom arbitrary waveform for use in this procedure. You can aso use a previously stored or
downloaded waveform.

2. Press Mode > Dual ARB > Select Waveform and ensure that AUTOGEN WAVEFCRMi s highlighted on the
display. AUTOGEN WAVEFCRMis the default name assigned to the waveform you generated in the
previous step.

3. Press Select Waveform. This selects the waveform and returns you to the previous softkey menu.
4. Press ARB Setup > Waveform Utilities and ensure that AUTOGEN WAVEFORMI s highlighted on the display.

5. Press Scale Waveform Data > Scaling > 70 > % > Apply to Waveform. The waveform is now reduced to 70
percent of its original amplitude. Once this type of scaling is applied to the waveform it cannot be
undone. Repeated scaling applications have a cumulative effect on the waveform.
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Using Customized Burst Shape Curves

You can adjust the shape of the rise time curve and the fall time curve using the R se Shape and Fal |
Shape editors. Each editor allows you to enter up to 256 values, equidistant in time, to define the shape of
the curve. The values are then resampled to create the cubic spline that passes through al of the sample
points.

TheR se ShapeandFal | Shape tableeditors are available for custom real-time 1/Q baseband generator
waveforms and real -time I/Q baseband generator TDMA waveforms. They are not available for waveforms
generated by the dual arbitrary waveform (dual ARB) generator.

For instructions on modifying rise and fall times and delays, see “ Configuring the Burst Rise and Fall
Parameters’ on page 362.

Understanding Burst Shape

The default burst shape of each format isimplemented according to the standards of the format sel ected. You
can, however, modify the following aspects of the burst shape:

Risetime the period of time, specified in bits, where the burst increases from
aminimum of =70 dB (0) to full power (1).

Fall time the period of time, specified in bits, where the burst decreases from
full power (1) to aminimum of =70 dB (0).

Rise delay the period of time, specified in bits, that the start of the burst rise is
delayed. Rise delay can be either negative or positive. Entering a
delay other than zero shiftsthe full power point earlier or later than
the beginning of the first useful symboal.

Fall delay the period of time, specified in bits, that the start of the burst fall is
delayed. Fall delay can be either negative or positive. Entering a
delay other than zero shiftsthe full power point earlier or later than
the end of the last useful symboal.

User-defined burst shape up to 256 user-entered values which define the shape of the curvein
the specified rise or fall time. The values can vary between 0 (no
power) and 1 (full power) and are scaled linearly. Once specified,
the values are resampl ed as necessary to create the cubic spline that
passes through all of the sample points.
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year Defined User-Defined
Values
1
g Rise Rise Fall Fall
& Delay Time Delay Time
0 o
Time —»

Burst shape maximum rise and fall time values are affected by the following factors:

e thesymbol rate

» themodulation type

When therise and fall delays equal 0, the burst shape is attempting to synchroni ze the maximum burst shape
power to the beginning of the first valid symbol and the ending of the last valid symbol of the timeslot. The
following figure illustrates a bursted signal in an EDGE frame with arise delay of 0 and afall delay of

+1 bit.
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The signal generator firmware computes optimum burst shape based on the settings you’ ve chosen for
modulation. You can further optimize burst shape by lining up the data portion with the modulation. For
example, if you' re designing a new modulation scheme, do the following:

» Adjust the modulation and filtering to set the spectrum you want.

e Turn on framing.

» Adjust the burst rise and fall delay and rise and fall time for the timeslots.

If you find that the error vector magnitude (EVM) or adjacent channel power (A CP) increases when you turn

bursting on, you can adjust the burst shape to assist with troubleshooting.

Creating a User-Defined Burst Shape Curve

Using this procedure, you learn how to enter rise shape sample values and mirror them as fall shape values
to create a symmetrical burst curve.

This section teaches you how to perform the following tasks:
* “Accessing the Table Editors’ on page 158
» “Entering Sample Values’ on page 158
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Accessing the Table Editors

1. PressPreset.

2. Perform the following keypress sequence required for your format type.

For Custom Format

Press Mode > Custom > Real Time 1/Q Base Band > Burst Shape.

For TMDA Formats

Press Mode > Real Time TDMA > desired format > More (1 of 2) > Modify Standard >
Burst Shape.

3. Press Define User Burst Shape > More (1 of 2) > Delete All Rows > Confirm Delete Of All Rows.

Entering Sample Values

Use the sample values in the following table.

Rise Shape Editor

Sample Value Sample Value

0 0.000000 5 0.900000
1 0.400000 6 0.950000
2 0.600000 7 0.980000
3 0.750000 8 0.990000
4 0.830000 9 1.000000

Highlight the value (1. 000000) for sample 1.
Press .4 > Enter.
Press .6 > Enter.

Enter the remaining values for samples 3 through 9 from the table above.

o~ w NP

Press More (2 of 2) > Edit Fall Shape > Load Mirror Image of Rise Shape >
Confirm Load Mirror Image Of Rise Shape.

This changes the fall shape valuesto amirror image of the rise shape values, as shown in Figure 4-25 on
page 159.
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Figure 4-25
FREQUENCY AMPLITUOE Edit Ttem
4.000 00000000 &z | -135.00 den
1 Hﬂl] Insert Rou
| Delete Row
Rise Shape Editor (UHSTORED) Fall Shape Editor (UHSTORED)
Sample Value Sanple Ualue
1] 0.000000 1] 1. 0000 Goto Roue
1 0.400000 1 0.5930000
2 0.600000 2 0.5930000
3 0.750000 3 0.5950000 Edit. Rise Shape
L 0.830000 L 0.3900000
9 0.900000 9 0.830000
] 0.350000 ] 0. 750000 Load Hirror Image
7 0.580000 7 0. s00000 of Rise Shape
8 0.950000 8 0. 400000
a9 1. 000000 a9 0.00000a0

More
(1 of 23

Display the Burst Shape

Press More (1 of 2) > Display Burst Shape.

This displays agraphical representation of the waveform’srise and fall characteristics, as shown in Figure

4-26.
Figure 4-26
FHEDUENEYA.OoO 00000000 sz ‘QTL]:_[TSU%UO dBn
1

[

Burst Shape

Burst Rise Shape

Burst Fall Shape

=

LR = =T~

To return the burst to the default conditions, press the following keys:

Return > Return > Confirm Exit From Table Without Saving > Restore Default Burst Shape.
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Storing a User-Defined Burst Shape Curve

1

3.

Press Define User Burst Shape > More (1 of 2) > Load/Store > Store To File.

If thereis already afile name fromthe Cat al og of SHAPE Fi | es occupying the active entry
area, press the following keys:

Editing Keys > Clear Text
Enter afile name (for example, NEWBURST) using the alpha keys and the numeric keypad.
The maximum file name length is 23 characters (a phanumeric and specia characters).

Press Enter.

The contents of the current R se Shape and Fal | Shape table editors are stored to the Cat al og of
SHAPE Fi | es. Thisburst shape can now be used to customize a modulation or as abasis for a new burst
shape design.

Recalling a User-Defined Burst Shape Curve

Once a user-defined burst shape fileis stored in memory, it can be recalled for use with real-time 1/Q
baseband generated digital modulation.

This example requires a user-defined burst shape file stored in memory. If you have not created and stored a
user-defined burst shape file, complete the steps in the previous sections, “ Creating a User-Defined Burst
Shape Curve” on page 157 and “ Storing a User-Defined Burst Shape Curve” on page 160.

1
2.

Press Preset.

Perform the following keypress sequence required for your format type.

For Custom Format

Press Mode > Custom > Real Time 1/Q Base Band > Burst Shape > Burst Shape Type > User File.

For TMDA Formats

Press Mode > Real Time TDMA > desired format > More (1 of 2) > Modify Standard >
Burst Shape > Burst Shape Type > User File.

Highlight the desired burst shape file (for example, NEWBURST).
Press Select File.

The selected burst shape file is now applied to the current real-time 1/Q baseband digital modulation
state.
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Generating the Waveform

Perform the following keypress sequence required for your format type.

For Custom Format

Press Return > Custom Off On.

For TMDA Formats
Press Return > Return > More (2 of 2) > desired format Off On.

This generates the custom modulation or TDMA state with user-defined burst shape created in the previous
sections. During waveform generation, the CUSTOM(or appropriate TDMA) annunciator and | / Q
annunciator activate. The waveform is now modulating the RF carrier.

Configuring the RF Output

1. Set the RF output frequency to 800 MHz.
2. Set the output amplitude to —10 dBm.
3. PressRF On/0ff.

The current real-time |/Q baseband digital modulation format with user-defined burst shape is now available
at the signal generator’s RF OUTPUT connector.
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Using Finite Impulse Response (FIR) Filters

Finite Impulse Response filters can be created and used with both dual arbitrary waveform generated
waveforms and real -time baseband generated waveforms. For this example, the filter is defined within the
CDMAZ2000 digital communications format, a dual arbitrary waveform generated state.

Creating a User-Defined FIR Filter Using the FIR Table Editor

In this procedure, you usethe FI R Val ues table editor to create and store an 8-symbol, windowed sync

fun

ction filter with an oversampleratio of 4.

Accessing the Table Editor

1. PressPreset.
2. Press Mode > CDMA > Arb CDMA2000.
3. Press More (1 of 2) > CDMA2000 Define > Filter > Define User FIR.
4. Press More (1 of 2) > Delete All Rows.
Thiswill initialize the table editor as shown in Figure 4-27.
Figure 4-27
FREQUENCY AMPLITUDE
Load /St
4,000 000 000 00 & | -136.00 den e
’7 ﬂ Load Default |
oH FIR
| Delete All Rous
FIR Ualues Oversample Ratio: L
Coeff. Ualue
] 0 | —————————— |
— More
01/21/2070 21:13 2 of 2)
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Entering the Coefficient Values

1. Pressthe Return softkey to get to the first page of the table editor.
2. Usethe cursor to highlight the Val ue field for coefficient O, then press Edit Item.

3. Usethe numeric keypad to type the first value (—0.000076) from Table 4-1. Asyou press the numeric
keys, the numbers are displayed in the active entry area. (If you make a mistake, you can correct it using
the backspace key.)

4. Continue entering the coefficient values from the table in step 1 until all 16 values have been entered.

Table 4-1

Coefficient Value Coefficient Value

0 -0.000076 8 -0.035667
1 -0.001747 9 -0.116753
2 -0.005144 10 -0.157348
3 -0.004424 1 -0.088484
4 0.007745 12 0.123414
5 0.029610 13 0.442748
6 0.043940 14 0.767329
7 0.025852 15 0.972149

Duplicating the First 16 Coefficients Using Mirror Table

In awindowed sinc function filter, the second half of the coefficients are identical to the first half in reverse
order. The signal generator provides a mirror table function that automatically duplicates the existing
coefficient values in the reverse order.

1. Press Mirror Table. The last 16 coefficients (16 through 31) are automatically generated and the first of
these coefficients (humber 16) highlights, as shown in Figure 4-28 on page 164.
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Figure 4-28
FREQUENC AMPLITUDE
. Edit TItem
4.000 000 000 00 &z | ~136.00 den
non Insert Row
| Delete Rouw
FIR Ualues (UNSTORED) Owersample Ratio: L
Coeff. Ualue
] 10 -0. 157348 Goto Rowk
11 -0.088L84
12 0. 123410
13 0.LL27LE Mirror Table
14 0.767329
15 0.9721L3
16 [.972149 Oversample Ratio
17 0.767329 L
18 0.LL2748
| 19 0. 123410 Mare
01/21/2070 21:28 tlof 2)

Setting the Oversample Ratio

The oversample ratio (OSR) is the number of filter coefficients per symbol. Acceptable values range from 1
through 32; the maximum combination of symbols and oversampling ratio allowed by the table editor is
1024. Theinstrument hardware, however, is actually limited to 32 symbols, an oversample ratio between 4
and 16, and 512 coefficients. So if you enter more than 32 symbols or 512 coefficients, the instrument is
unable to use thefilter. If the oversampleratio is different from the internal, optimally selected one, then the
filter is automatically resampled to an optimal oversampleratio.

For this example, the desired OSR is 4, which is the default, so no action is necessary.

Displaying a Graphical Representation of the Filter

The signal generator has the capability of graphically displaying the filter in both time and frequency
dimensions.

1. PressMore (1 of 2) > Display FFT (fast Fourier transform).

Refer to Figure 4-29 on page 165.
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Figure 4-29
FREQUENMCY AMPLITUDE
4.000 000 000 00 &z | ~136.00 den
B
|
FFT
0
d
B
-100
[1] Sumbol Rate 2
01/21/2070 21:L3

2. PressReturn.
3. Press Display Impulse Response.
Refer to Figure 4-30.

Figure 4-30

FREQUENCY

4.000 000 000 00 &=

AMPLITUOE

-136.00 dn
o

Inpulse Response

Oversample Ratio: L4

n Coefficient

31

01/21,/2070 21:43

4. PressReturn to return to the menu keys.
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Storing the Filter to Memory
Use the following steps to store thefile.

1. PressLoad/Store > Store To File. The catalog of FIR files appears along with the amount of memory
available.

2. Asdescribed in “ Storing a Component Test Waveform to Memory” on page 304, name and store this
fileasFI R 1.

The FI R 1 fileisthefirst file name listed. (If you have previously stored other FIR files, additional file
names are listed below FI R _1.) Thefiletypeis FIR and the size of thefile is 260 bytes. The amount of
memory used is also displayed. The number of filesthat can be saved depends on the size of the files and the
amount of memory used. Refer to Figure 4-31.

Figure 4-31

FREQUENCY AMFLITUDE Load From

_136 00 dBn Selected File
’7 ﬂ Store Toy)
0OH File

Oelete File

4.000 000 000 00 &=

Catalog of FIR Files 520 butes used B8L30E037YE butes free
File Hame  Tupe Size Nodified
] 1 FIR_1 FIR 260 01721770 20:10 Goto Rouk
Ph0 01/21/70 22:02
Page Up
Page Down

01/21,/2070 2z:03

Memory is aso shared by instrument state files and list sweep files.

Thisfilter can now be used to customize a modulation or it can be used as abasis for a new filter design.
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Modifying a FIR Filter Using the FIR Table Editor

FIR filters stored in signal generator memory can easily be modified using the FIR table editor. You can load
the FIR table editor with coefficient values from user-defined FIR files stored in non-volatile memory or
from one of the default FIR filters. Then you can modify the values and store the new files.

Loading the Default Gaussian FIR File

Press Preset.

Press Mode > CDMA > Arb CDMA2000 > More (1 of 2) > CDMA2000 Define.
Press Filter > Define User FIR > More (1 of 2) > Load Default FIR > Gaussian.
Press Filter BbT > 0.300 > Enter.

Press Filter Symbols > 8 > Enter.

o o A W DN P

Press Generate.

NOTE The actual oversample ratio during modulation is automatically selected by the instrument.
A value between 4 and 16 is chosen dependent on the symbol rate, the number of bits per
symbol of the modulation type, and the number of symbols.

7. Press Display Impulse Response (refer to Figure 4-32).

Figure 4-32

FREQUENCY

4.000 000 000 00 s
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8. PressReturn.
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Modifying the Coefficients

1. Using the front-panel arrow keys, highlight coefficient 15.
2. Press0 > Enter.

3. Press Display Impulse Response.

Figure 4-33
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Refer to Figure 4-33 on page 168. The graphic display can provide a useful troubleshooting tool (in this
case, it indicates that a coefficient value is missing, resulting in an improper Gaussian response).

. PressReturn.

4
5. Press More (2 of 2).

6. Highlight coefficient 15.
7

. Press1 > Enter.

Storing the Filter to Memory

The maximum file name length is 23 characters (a phanumeric and special characters).
1. PressLoad/Store > Store To File.

2. Namethefile NEWFIR2.

3. PressEnter.

The contents of the current FIR table editor are stored to afile in non-volatile memory and the catalog of FIR
filesis updated to show the new file.
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Differential Encoding

Differential encoding is a digital-encoding technique whereby a binary value is denoted by a signal change
rather than a particular signal state. Using differential encoding, binary datain any user-defined 1/Q or FSK
modul ation can be encoded during the modulation process via symbol table offsets defined in the
Differential State Map.

For example, consider the signal generator’s default 4QAM 1/Q modulation. With a user-defined modulation
based on the default 4QAM template, thel / Q Val ues table editor contains data that represent four
symbols (00, 01, 10, and 11) mapped into the I/Q plane using two distinct values, 1.000000 and —1.000000.
These four symbols can be differentially encoded during the modulation process by assigning symbol table
offset values associated with each data value. The following illustration showsthe 4QAM modulation in the
I/ Q Val ues table editor.

FREQUENCY AMPLITUDE Load/Storen
4.000 00000000 & | -136.00 den
noo Lomd Default,
oH 1/0 Map
| Oelete All Rows
I1/0 Values
Data I Value 0 Value DiFFErenELal
00000000 1.000000 Enceding
00000001 -1.000000 1.000000 on
00000010 ~1.000000 ~1.000000 :
00000011 1.000000 -1.000000 Difronfiagre |
00000100 Encoding
Offset 0
on
Mare
01413/ 18:26 (2 of 2)
NOTE The number of bits per symbol can be expressed using the following formula. Because the

equation isa ceiling function, if the value of x contains a fraction, x is rounded up to the
next whole number.

x= lhqé;(jg)

Where x = bits per symbol, and y = the number of differential states.
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The following illustration shows a4QAM modulation 1/Q State Map.

2nd Symbol 1st Symbol
Data = 00000001 Data = 00000000
Distinct values: -1, +1 Distinct values: +1, +1
I/0 State Nap
. I/0 States: L
+116 e
]
U
a
1
u
e
e L
=1 I Ualue +

3rd Symbol
Data = 00000010
Distinct values: -1, -1

4th Symbol
Data = 00000011
Distinct values: +1, -1

Differential Data Encoding

In real-time 1/Q baseband digital modulation waveforms, data (1's and 0's) are encoded, modulated onto a
carrier freguency, and subsequently transmitted to areceiver. In contrast to differential encoding (described
on page 169), differential data encoding modifies the data stream prior to 1/Q mapping. Where differential
encoding encodes the raw data by using symbol table offset values to manipulate 1/Q mapping at the point of
modulation, differential data encoding uses the transition from one bit value to another to encode the raw
data

Differential data encoding modifies the raw digitized data by creating a secondary, encoded data stream that
is defined by changesin the digital state, from 1 to O or from O to 1, of the raw data stream. This
differentially encoded data stream is then modulated and transmitted.

In differential data encoding, achangein araw databit'sdigital state, from 1to O or from O to 1, produces a
1in the encoded data stream. No change in digital state from one bit to the next, in other words a bit with a
value of 1 followed by another bit with avalue of 1 or abit with avalue of O followed by the same, produces
a0in the encoded data. For instance, differentially encoding the data stream containing 01010011001010
renders 1111010101111.

Differential data encoding can be described by the following equation:

transmittedbit(i)= databit(i —1) O databit(i)
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For abit-by-hit illustration of the encoding process, see the following illustration.
0101001100101

raw (unencoded) data I I I I \ I I I I

} . \

change =
nochange= —~-------- -

\ \ \
1111010101111

differentially encoded data ...l I I I I I

How Differential Encoding Works

Differential encoding employs offsets in the symbol table to encode user-defined modulation schemes. The
Dfferential State Map tableeditorisused tointroduce symbol table offset values which in turn
cause transitions through the 1/Q State Map based on their associated data value. Whenever adatavalueis
modul ated, the offset value stored in the Differential State Map is used to encode the data by transitioning
through the I/Q State Map in a direction and distance defined by the symbol table offset value.

Entering avalue of +1 will cause a 1-state forward transition through the 1/Q State Map, as shown in the
following illustration.

NOTE Thefollowing I/Q State Map illustrations show all of the possible state transitions using a
particular symbol table offset value. The actual state-to-state transition would depend upon
the state in which the modulation had started.

As an example, consider the following data/symbol table offset values.

Table 4-2
Data Offset Value
00000000 +1
00000001 -1
00000010 +2
00000011 0
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These symbol table offsets will result in one of the transitions, as shown.

Data Value 00000000
with Symbol Table Offset +1
transition 1 state forward

I/0 State Map
I/0 States: L

+1 |
‘\_/

]

1)

d

1

u

e
A\

-119

-1 I Ualue +1

Data Value 00000001
with Symbol Table Offset -1
transition 1 state backward

Data Value 00000010
with Symbol Table Offset +2
transition 2 statesforward

I/0 State Map
) I/0 States: L4

+1

-l = = —J

A
L

-1 I Value +1

Data Value 00000011
with Symbol Table Offset 0
no transition

I/0 State Map
I/0 States: L

+1

Lol = = T — ]

-1 14 Q
=1 I Ualue +1

I/0 State Map
I/0 States: L

+1 [

N2

-1 I Value +1

L=l — ol - — Y — ]

£\

When applied to the user-defined default 4QAM 1/Q map, starting from the 1st symbol (data 00), the
differential encoding transitions for the data stream (in 2-bit symbols) 0011100001 appear in the following
illustration.
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J 1st Symbol 5th Symbol
+1 ¥ 3rd Symbol ¥
u Data = 0011100001
u 2nd Symbol 4th Symbol
i |
1 DataValue  Symbol Table Offset
u 00 +1
01 -1
e 10 +2
11 +0
=11

Asyou can see from the previous illustration, the 1st and 4th symbols, having the same data value (00),
produce the same state transition (forward 1 state). In differential encoding, symbol values do not define
location; they define the direction and distance of atransition through the I/Q State Map.

For instructions on configuring differential encoding, see “Using Differential Encoding” on page 173.

Using Differential Encoding

Differential encoding is a digital-encoding technique that denotes a binary value by asignal change rather
than a particular signal state. It isavailable for custom real-time I/Q baseband generator waveforms and
real-time 1/Q baseband generator TDMA waveforms. It is not available for waveforms generated by the dual
arbitrary waveform generator.

The signal generator’'sDi f ferenti al State Map table editor enables you to modify the differential
state map associated with user-defined 1/Q and user-defined FSK modulations. In this procedure, you create
a user-defined 1/Q modulation and then configure, activate, and apply differential encoding to the
user-defined modulation. For more information, see “ Differential Encoding” on page 169.
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Configuring User-Defined 1/Q Modulation

1. PressPreset.

2. Perform the following keypress sequence required for your format type.

For Custom Format
Press Mode > Custom > Real Time 1/Q Base Band > Modulation Type > Define User 1/Q >
More (1 of 2) > Load Default I/Q Map > QAM > 4Q0AM

For TMDA Formats

Press Mode > Real Time TDMA > desired format > More (1 of 2) > Modify Standard >
Modulation Type > Define User I/Q > More (1 of 2) > Load Default 1/Q Map > QAM > 4Q0AM

Thisloads a default 4QAM 1/Q modulation and displaysit in the 1/Q table editor.

The default 4QAM 1/Q modulation contains data that represent 4 symbols (00, 01, 10, and 11) mapped into
the 1/Q plane using 2 distinct values (1.000000 and —1.000000). These 4 symbols will be traversed during
the modulation process by the symbol table offset val ues associated with each symbol of data. Refer to
Figure 4-34.

Figure 4-34
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00000001 -1.000000 1.000000 on

00000010 -1.000000 -1.000000 .

00000011 1.000000 -1.000000 pipronfloure
00000100 Encoding
Offset 0]

I On

More

10/15/2001 13:43 (2 of 2)
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Accessing the Differential State Map Table Editor
Press Configure Differential Encoding.

ThisopenstheDi fferential State Map tableeditor, as shown. At this point, you see the datafor the
1st symbol (00000000) and the cursor prepared to accept an offset value.You are now prepared to create a
custom differential encoding for the user-defined default 4QAM 1/Q modulation. Refer to Figure 4-35 on
page 175.

Figure 4-35
Data Symbol Table Offset Values Entry Area

AMPLITUDE

“:””E““Zl.ooo 00000000 s/ | -135.00 o
|

HRD Insert Rou

Delete Row

Differential State Hap
Data Sumbol Table Dffs:

00000000 == Goto Fou

Oelete ALl Rows

Editing the Differential State Map

1. Press1 > Enter.

This encodes the first symbol by adding a symbol table offset of 1. The symbol rotates forward through
the state map by 1 value when a data value of 0 is modulated.

2. Press+/->1 > Enter.

This encodes the second symbol by adding a symbol table offset of —1. The symbol rotates backward
through the state map by 1 value when a data value of 1 is modulated.

NOTE At this point, the modulation has one bit per symbol. For the first two data values
(00000000 and 00000001) only the last bits (the 0 and the 1, respectively) are significant.
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3. Press2 > Enter.

This encodes the third symbol by adding a symbol table offset of 2. The symbol rotates forward through
the state map by 2 values when a data value of 10 is modulated.

4. Press0 > Enter.

This encodes the fourth symbol by adding a symbol table offset of 0. The symbol does not rotate through
the state map when a data value of 11 is modulated.

NOTE At this point, the modulation has two bits per symbol. For the data values 00000000,
00000001, 00000010, 00000011, the symbol values are 00, 01, 10, and 11 respectively.

Applying Custom Differential Encoding
Press Return > Differential Encoding Off On.

This applies the custom differential encoding to a user-defined modulation.

NOTE Noticethat (UNSTORED) appearsnexttoDi fferential State Map onthe signal
generator’s display. Differential state maps are associated with the user-defined modulation
for which they were created.

In order to save acustom differential state map, you must store the user-defined modulation
for which it was designed. Otherwise the symbol table offset data is purged when you press
the Confirm Exit From Table Without Saving softkey when exiting from the I/Q or FSK table
editor.
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User-Defined 1/Q Maps

In modulation schemes defined by standards (such as TDMA and CDMA), symbols appear in default
positionsin the I/Q plane. Using the | / Q Val ues table editor, you can define your own symbol map by
changing the position of one or more symbols. Thel / Q Val ues isavailable for custom real-time 1/Q
baseband generator waveforms and real-time 1/Q baseband generator TDMA waveforms. It is not available
for waveforms generated by the dual ARB waveform generator.

Creating a User-Defined 1/Q Map

This section teaches you how to perform the following tasks:

» “Accessing and Clearing the 1/Q Table Editor” on page 177

» “Entering | and Q Values’ on page 178

» “Displaying the 1/Q Map” on page 178

Use the following procedure to create and store a 4-symbol unbalanced QPSK modulation.

Accessing and Clearing the 1/Q Table Editor

1. PressPreset.

2. Perform the following keypress sequence required for your format type.

For Custom Format

Press Mode > Custom > Real Time 1/Q Base Band > Modulation Type > Define User 1/Q >
More (1 of 2) > Delete All Rows > Confirm Delete All Rows.

For TMDA Formats

Press Mode > TDMA > desired format > More (1 of 2) > Modify Standard > Modulation Type > Define User 1/Q >
More (1 of 2) > Delete All Rows > Confirm Delete All Rows.

This loads a default 4QAM 1/Q modulation and clearsthe | / Q Val ues table editor.
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Entering | and Q Values

Enter the | and Q values listed in the following table.

Symbol Data Bits | Value Q Value

0 0000 0.500000 1.000000
1 0001 -0.500000 1.000000
2 0010 0.500000 -1.000000
3 0011 -0.500000 -1.000000

1. Press.5> Enter.
2. Press1 > Enter.
3. Enter theremaining | and Q values.

Asthe | value updates, the highlight moves to the first Q entry (and provides a default value of 0), and an
empty row of data appears below the first row. Asthe Q value updates, and the highlight movesto the next |
value. Asyou press the numeric keys, the numbers display in the active entry area. If you make a mistake,
use the backspace key and then retype.

Also note that 0. 000000 appears as thefirst entry inthe list of D sti nct Val ues, and that 0. 500000
and 1. 000000 are listed as the distinct values.
Displaying the 1/Q Map
1. PressDisplay 17Q Map
An 1/Q map generated using the current valuesinthe | / Q Val ues table editor is displayed.

The map in this example has four symbols. The map uses the following four unique values: 0.5, 1.0,
-0.5, and —1.0 to create the four symbols. It is not the number of values that defines how many symbols
amap has, but how those values are combined.

2. PressReturn.

When the contents of atable editor have not been stored, 1 / Q Val ues ( UNSTCORED) appears on the
display. Follow the instructions in the next section to store the custom 1/Q table.
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Storing a User-Defined 1/Q Map File

In this example, you learn how to store a user-defined 1/Q map. If you have not created a user-defined I/Q
map, complete the steps in the previous sections, “ Accessing and Clearing the I/Q Table Editor” on page
177 and “Entering | and Q Values’ on page 178.

1

3.

Press More (1 of 2) > Load/Store > Store To File.

If there is already afile name from the Cat al og of 1 Q Fi | es occupying the active entry area, press
the following keys:

Edit Keys > Clear Text
Enter afile name (for example, NEWAQAMN) using the al pha keys and the numeric keypad.
The maximum file name length is 23 characters.

Press Enter.

The user-defined 1/Q map isnhow stored inthe Cat al og of 1Q Fil es.

Moving I/Q Symbols

Use the following procedure to manipul ate symbol locations to simulate magnitude and phase errors. In this
example, you edit a4QAM constellation to move one symbol closer to the origin.

Loading the Default 4QAM 1/Q Map

1
2.

Press Preset.

Perform the following keypress sequence required for your format type.

For Custom Format

Press Mode > Custom > Real Time 1/Q Base Band > Modulation Type > Define User 1/Q >
More (1 of 2) > Load Default I/Q Map > QAM > 4QAM.

For TMDA Formats

Press Mode > TDMA > desired format > More (1 of 2) > Modify Standard > Modulation Type > Define User 1/Q >
More (1 of 2) > Load Default I/Q Map > QAM > 4QAM.

This loads a default 4QAM 1/Q modulation into thel / Q Val ues table editor.
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Editing | and Q Values

1. Press.235702 > Enter.
2. Press.235702 > Enter.

Asyou enter the numbers using the numeric keypad, they are displayed in the active entry area. If you
make a mistake, use the backspace key and then retype. The | value updates and the highlight moves to

thefirst Q entry. Next, the Q value updates and the highlight movesto the following | entry.

Displaying the 1/Q Map

Press More (2 of 2) > Display 1/Q Map.

Note that one symbol has moved, as shown.

FREQUEMCY

4.000 000 000 00 &z

‘HHPLITUDE

136.00 den

B

+1

L-F—l - — R —]

I/0 State Map
I/0 States: 5

+

+

+

/

+

-1

I Value

+1

02/31/2001 11:57

For instructions on storing this modified 1/Q map to the signal generator’s memory catalog, see “ Storing a
User-Defined 1/Q Map File” on page 179.
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User-Defined FSK Modulation

Using the Fr equency Val ues table editor, you can define, modify and store user-defined frequency shift
keying modulation.

The Fr equency Val ues table editor is available for custom real-time |/Q baseband generator waveforms
and real-time 1/Q baseband generator TDMA waveforms. It is not available for waveforms generated by the
dual arbitrary waveform generator.

Modifying a Default FSK Modulation

In this example, you learn how to add errorsto a default FSK modulation.

Loading the Default 4-Level FSK

1. PressPreset.

2. Perform the following keypress sequence required for your format type.

For Custom Format

Press Mode > Custom > Real Time 1/Q Base Band > Modulation Type > Define User FSK >
More (1 of 2) > Load Default FSK.

For TMDA Formats

Press Mode > TDMA > desired format > More (1 of 2) > Modify Standard > Modulation Type > Define User FSK >
More (1 of 2) > Load Default FSK.

3. PressFreq Dev > 1.8 > kHz.

4. Press4-Lvl FSK.
This sets the frequency deviation and opensthe Fr equency Val ues table editor with the 4-level FSK
default values displayed. The frequency value for data 0000 is highlighted.

Modifying Frequency Deviation Values

1. Press-1.81 > kHz.
2. Press-590 > Hz.
3. Press1.805 > kHz.
4. Press610 > Hz.
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As you modify the frequency deviation values, the cursor moves to the next data row. An unstored file of
frequency deviation valuesis created for your custom 4-level FSK file. For instructions on storing the file,
see the next section.

Storing an FSK Modulation

In this example, you learn how to store an FSK modulation. If you have not created an FSK
modulation, complete the steps in the previous section, “Modifying a Default FSK Modulation” on page
181.

1. PressLoad/Store > Store To File.

If thereisalready afilenamefromthe Cat al og of FSK Fi | es occupying the active entry area, press
the following keys:

Edit Keys > Clear Text
2. Enter afile name (for example, NEWFSK) using the al pha keys and the numeric keypad.
3. PressEnter.
The user-defined FSK modulation is now stored inthe Cat al og of FSK Fi | es.

Creating a User-Defined FSK Modulation

Accessing and Clearing the Table Editor

1. PressPreset.

2. Perform the following keypress sequence required for your format type.

For Custom Format

Press Mode > Custom > Real Time 1/Q Base Band > Modulation Type > Define User FSK >
More (1 of 2) > Delete All Rows > Confirm Delete All Rows.

For TMDA Formats

Press Mode > TDMA > desired format > More (1 of 2) > Modify Standard > Modulation Type > Define User FSK >
More (1 of 2) > Delete All Rows > Confirm Delete All Rows.

This accesses the Fr equency Val ues table editor and clears the previous values.
Entering Frequency Deviation Values

1. Press600 > Hz.
2. Press1.8 > kHz.
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3. Press-600 > Hz.
4. Press-1.8 > kHz.

This sets the frequency deviation for data 0000, 0001, 0010, and 0011 to configure a user-defined FSK
modulation. Each time you enter avalue, the Dat a column increments to the next binary number, up to a
total of 16 datavalues (from 0000 to 1111).

For instructions on storing this user-defined FSK modulation to the memory catal og, see “ Storing an FSK
Modulation” on page 182.
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Creating and Using Bit Files

This procedure teaches you how tousetheBit Fi |l e Edit or to create, edit, and store user-defined files
for data transmission within real-time 1/Q baseband generated modulation. For this example, auser fileis
defined within a custom digital communications format.

User files (user-defined data files) can be created on a remote computer and moved to the signal generator
for subsequent modification, or they can be created and modified using the signal generator’'sBit File
Editor.

These user files can then be applied as the transmitted data within aframed TDMA modulation, transmitted
as a continuous unframed data stream according to the protocol of the active TDMA format, transmitted as
the data for a custom modulation or real-time CDMA format, or for GPS applications. User files are not
available for signals generated by the dual ARB waveform generator.

A real-time digital modulation personality must be selected when desired real-time for mat appearsin the
key press path.

NOTE For information on creating user-defined data files on a remote computer, see the
E4428C/38C ESG Sgnal Generator Programming Guide.

Creating a User File

Accessing the Table Editor

1. PressPreset.
2. Press Mode > desired real-time format > Data > User File > Create File.

ThisopenstheBit File Editor.TheBit File Editor containsthree columns: O f set,
Bi nary Dat a, and Hex Dat a, aswell ascursor position (Posi t i on) and file name (Nane) indicators,
as shown in the following figure.
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Creating and Using Bit Files

Offset Bit Data Cursor Hexadecimal Data File Nameindicator
(in Hex) Position
indicator
\ (in Hex)
FRECLBNCY / AMPLITUCE
4.000 00000000 s | -136)00 cen
’7 ﬂ Inserty
Bit File‘Editnrv{ Pos:0 Size:l ENTITLEDB feletey
Offset Binary Data Hex Nata
o 1 GotoM
APPly Bit ErrorsH
More
(1 of 2)
NOTE When you create new file, the default name appears as UNTI TLED, or UNTI TLED1, and so

forth. This prevents overwriting previous files.
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Entering Bit Values

1. Refer to the following figure.

Enter These Bit Values Cursor Hexadecimal Data
Position
Indicator /
i
FREQUENCY AMPLITUDE

4.0008.000 000 00 &

-136.00 dn

Hoo

OH

Bit File Editor Pos:SF ize:96 UW&ITLEDS
Offset Binary Data Hex Data
] 0 0110 1101 1011 0110 1110 1101 1011 0110 EOBEEDBG
20 1101 1011 0110 1101 1011 0110 1101 1011 DBE0OBEDB
Lo 0111 0110 1101 0100 0110 1101 1011 0110 7EOLEDBEE

60

Inserty
Deleteny
Gat.on

Apply Bit Errorsy

Mare
(1 of 23

2. Enter the 32 bit values shown.

Bit datais entered into the table editor in 1-bit format. The current hexadecimal value of the binary datais
shown in the Hex Dat a column, and the cursor position (in hexadecimal) is shown in the Posi ti on

indicator.

Renaming and Saving a User File

In this example, you learn how to store a user file. If you have not created a user file, complete the stepsin
the previous section, “ Creating a User File” on page 184.

1. Press More (1 of 2) > Rename > Editing Keys > Clear Text.

2. Enter afile name (for example, USER1) using the alpha keys and the numeric keypad.

3. PressEnter.

The user file has now been renamed and stored to the Bi t memory catal og with the name USERL1.
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Recalling a User File

In this example, you learn how to recall a user-defined data file from the memory catalog. If you have not
created and stored a user-defined data file, complete the stepsin the previous sections, “ Creating a User
File” on page 184 and “Renaming and Saving a User File” on page 186.

1. PressPreset.
2. Press Mode > desired real-time format > Data > User File.
3. Highlight the file USERL.
4. PressEdit File.
TheBit File Editor opensthefile USERIL.

Modifying an Existing User File

In this example, you learn how to modify an existing user-defined datafile. If you have not created, stored,
and recalled a user-defined data file, complete the stepsin the previous sections, “Creating a User File” on
page 184, “Renaming and Saving a User File” on page 186 and “Recalling a User File” on page 187.
Navigating the Bit Values

Press Goto > 4 > C > Enter.

This moves the cursor to bit position 4C in the table, as shown in the following figure.

Cursor movesto new position Position indicator changes

FRECLENCY AMPLITUDE
4.000 00000000 &=z | -136.00" dn
’7@ Inserty
| / Delsteb
Bit File Editor Pos:LC Size: 9k USERL
Of fset Binary Data Hex Data

0 0110 1101 1Dfé‘0110 1110 1101 1011 0110 &DBEEOBG GotoM
20 1101 1011 0110N1101 1011 0110 1101 1011 ODBE0BEDE

Lo 0111 0110 1101 E100 0110 1101 1011 0110 7EOLE0EE
60 APply Bit Errorsk

More
(1 of 23
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Inverting Bit Values

1. Press1011.

Thisinverts the bit values that are positioned 4C through 4F. Notice that hex datain this row has now
changed to 76DB6DBS6, as shown in the following figure.

Bits 4C through 4F inverted Hex Data changed
FREQUEMCY AMPLITUOE
4.00Q 000 000 00 &z | -136.00 den
“D Inserte
| // Oeleter
Bit. File Editor Pos:G0 Size:ge SERL
Dffset Binary Data Hex Da
0 0110 1101 1DI§\0110 1110 1101 1011 0110 GOBREMEG Gotor
20 1101 1011 0111101 1011 0110 1101 1011 OBROESCE

Lo 0111 0110 1101 1041 0110 1101 1011 0110 TEODBEDEE

60 [ ] APPlY Bit Errorsk

Mare
(1 of 20

Applying Bit Errors to a User File

In this example, you learn how to apply bit errors to a user-defined data file. If you have not created and
stored a user-defined data file, complete the steps in the previous sections, “ Creating a User File” on page
184 and “Renaming and Saving a User File” on page 186.

1. Press Apply Bit Errors.

2. PressBit Errors > 5 > Enter.

3. Press Apply Bit Errors.

Notice both Bit Errors softkeys change value as they are linked.
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5 AWGN Waveform Generator

This chapter contains examples for using the additive white gaussian noise (AWGN) waveform generator.
The AWGN waveform generator is available only for the E4438C Vector Signal Generator with
Option 001/601or 002/602 and Option 403:

e “Arb Waveform Generator AWGN” on page 190
e “Rea Timel/Q Baseband AWGN"” on page 191

For adding real-time AWGN to waveforms using the Dual ARB player, see “Adding Real-Time Noiseto a
Dua ARB Waveform (Option 403)” on page 109
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Configuring the AWGN Generator

The AWGN (additive white Gaussian noise) generator is available for the Arb Waveform Generator mode
and the Real Time 1/Q Baseband mode. The AWGN generator can be configured with user-defined noise
bandwidth, noise waveform length, and noise seed parameters.

+ Bandwidth — the noise bandwidth can be set from 50 kHz to 15 MHz.

»  Waveform Length — the waveform length is the length in samples of the noise waveform. Longer
waveform lengths provide more statistically correct noise waveforms.

» Noise Seed — the noise seed selection can be either random or fixed. The noise seed determines whether
the noise waveform datais repeatabl e (using the fixed selection) or random (using the random selection).

When the AWGN generator is active, an annunciator, labeled AWGN, is displayed on the front panel of the
signal generator.

Arb Waveform Generator AWGN

Press Preset.

Press Mode > More (1 of 2) > AWGN > Arb Waveform Generator AWGN
Press Bandwidth > 1.25 > MHz.

Press Waveform Length > 131072.

o A WD

Press Noise Seed Fixed Random until Random is highlighted.

Configuring the RF Output

1. Set the RF output frequency to 500 MHz.
2. Set the output amplitude to —10 dBm.
3. PressRF On/0ff.

This configures arandomly seeded AWGN waveform with abandwidth of 1.25 MHz and awaveform length
of 131072 hits.

The AWGN waveform is now available at the signal generator’s RF OUTPUT connector.
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Generating the Waveform
Press AWGN Off On until On is highlighted.

This generates an AWGN waveform with the parameters defined in the previous procedure. During
waveform generation, the AWEN and | / Qannunciators activate and the AWGN waveform is stored in
volatile ARB memory. The waveform is now modulating the RF carrier.

Real Time 1/Q Baseband AWGN

1. PressPreset.
2. Press Mode > More (1 of 2) > AWGN > Real Time 1/Q Baseband AWGN
3. PressBandwidth > 10 > MHz.

Configuring the RF Output

1. Set the RF output frequency to 500 MHz.

2. Set the output amplitude to —10 dBm.

3. PressRF On/Off.

The AWGN waveform is now available at the signal generator’s RF OUTPUT connector.

Generating the Waveform
Press AWGN Off On until On is highlighted.

This generates an AWGN waveform with the parameters defined in the previous procedure. During
waveform generation, the AWAN and | / Qannunciators activate and the AWGN waveform is stored in
volatile ARB memory. The waveform is now modulating the RF carrier.
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Configuring the AWGN Generator

1. PressPreset.

2. Press Mode > More (1 of 2) > AWGN > Arb Waveform Generator AWGN

3. PressBandwidth > 1.25 > MHz.

4. Press Waveform Length > 131072,

5. Press Noise Seed Fixed Random until Random is highlighted.

This configures arandomly seeded AWGN waveform with a bandwidth of 1.25 MHz and awaveform length
of 131072 hits.

Generating the Waveform

Press AWGN Off On until On is highlighted.

This generates an AWGN waveform with the parameters defined in the previous procedure. During
waveform generation, the AWGN and | / Qannunciators activate and the AWGN waveform is stored in
volatile ARB memory. The waveform is now modulating the RF carrier.

Configuring the RF Output

1. Set the RF output frequency to 500 MHz.

2. Set the output amplitude to —10 dBm.

3. PressRF On/Off.

The AWGN waveform is now available at the signal generator’s RF OUTPUT connector.
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Analog Modulation Waveforms

The signal generator can modul ate the RF carrier with four types of analog modulation: amplitude,
frequency, phase, and pulse.

Available internal waveforms include:

Sine sine wave with adjustable amplitude and frequency

Dual-Sine dual-sine waves with individually adjustable frequencies and a percent-of-
peak-amplitude setting for the second tone (available from function generator only)

Swept-Sine swept-sine wave with adjustable start and stop frequencies, sweep time, and sweep
trigger settings (available from function generator only)

Triangle triangle wave with adjustable amplitude and frequency

Ramp ramp with adjustable amplitude and frequency

Square sguare wave with adjustable amplitude and frequency

Noise noise with adjustable amplitude generated as a peak-to-peak value (RMSvalueis

approximately 80% of the displayed value)
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Configuring AM

Using these procedures, you will learn how to generate an amplitude-modulated RF carrier.

Setting the Carrier Frequency

1. PressPreset.

2. PressFrequency > 1340 > kHz.

Setting the RF Output Amplitude

Press Amplitude > 0 > dBm.

Setting the AM Depth and Rate

1. Pressthe AM hardkey.
2. Press AM Depth > 90 > %.
3. Press AM Rate > 10 > kHz.

The signal generator is now configured to output a 0 dBm, amplitude-modulated carrier at 1340 kHz with
the AM depth set to 90% and the AM rate set to 10 kHz. The shape of the waveform is a sine wave (notice
that sine is the default for the AM Waveform softkey).

Turning on Amplitude Modulation
Follow these remaining steps to output the amplitude-modulated signal.
1. Pressthe AM Off On softkey to On.

2. Pressthe front panel RF On Off key.

The AMand RF ONannunciators are now displayed. Thisindicates that you have enabled amplitude
modulation and the signal is now being transmitted from the RF OUTPUT connector.
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Wideband AM (E4438C)

Wideband AM offers bandwidth (up to 40 MHZz) beyond that of standard internal AM (10 kHz) by utilizing
an external modulating signal. The external modulating signal is connected to the front-panel 1 INPUT
connector. The input impedance for the | INPUT connector can be set to 50 ohms or 600 ohms using the
Mux 1/Q Source menu selections. Selecting wideband AM automatically selectsthe AM source | input. The
following steps set up wideband AM:

1. Pressthe AM hardkey.
2. Press AM Path 12 WB to WB.

3. Connect an external AM source to the front-panel | INPUT connector and turn the external modulation
on. The maximum | input level is 1 volt rms and 10 volt peak. AM sensitivity isfixed at .5V = 100%.
The AM modulation depth is alinear function of the input voltage so that .25 V = 50%.

4. Press AM Off On to On.
Refer to the ESG data sheet for AM wideband specifications.
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Configuring FM

Using this procedures, you will learn how to create a frequency-modulated RF carrier.

Setting the RF Output Frequency

1. PressPreset.

2. PressFrequency > 1> GHz.

Setting the RF Output Amplitude

Press Amplitude > 0 > dBm.

Setting the FM Deviation and Rate

1. Pressthe FM/®M hardkey.
2. PressFM Dev > 75 > kHz.
3. PressFM Rate > 10 > kHz.

The signal generator is now configured to output a0 dBm, frequency-modulated carrier at 1 GHz with a
75 kHz deviation and a 10 kHz rate. The shape of the waveform is a sine wave. (Notice that sineisthe
default for the FM Waveform softkey. Press More (1 of 2) to see the softkey.)

Activating FM

1. PressFM Off On to On.
2. PressRF On/Off.

The FMand RF ONannunciators are now displayed. Thisindicates that you have enabled frequency
modulation and the signal is now being transmitted from the RF OUTPUT connector.
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Configuring ®M

Using this procedures, you will learn how to create a phase-modulated RF carrier.

Setting the RF Output Frequency

1. PressPreset.

2. PressFrequency > 3 > GHz.

Setting the RF Output Amplitude

Press Amplitude > 0 > dBm.

Setting the FM Deviation and Rate

1. Pressthe FM/®M hardkey.
2. Pressthe FM ©M softkey.
3. PressFM Dev > .25 > pi rad.
4. PressFM Rate > 10 > kHz.

The signal generator is now configured to output a 0 dBm, phase-modulated carrier at 3 GHz witha0.25 p
radian deviation and 10 kHz rate. The shape of the waveform is a sine wave. (Notice that sine is the default
for the FM Waveform softkey. Press More (1 of 2) to see the softkey.)

Activating FM

1. PressFM Off On.
2. PressRF On/Off.

The FMand RF ONannunciators are now displayed. Thisindicates that you have enabled phase modulation
and the signal is now being transmitted from the RF OUTPUT connector.
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Configuring Pulse Modulation

Using the following procedures, you will learn how to create a pulse-modulated RF carrier.

Setting the RF Output Frequency

1. PressPreset.

2. PressFrequency > 2 > GHz.

Setting the RF Output Amplitude

Press Amplitude > 0 > dBm.

Setting the Pulse Period and Width

1. PressPulse > Pulse Period > 100 > usec.
2. PressPulse > Pulse Width > 24 > usec.

The signal generator is now configured to output a0 dBm, pulse-modulated carrier at 2 GHz with a
100-microsecond pulse period and 24-microsecond pulse width. The pulse sourceis set to Internal Pulse.
(Noticethat Internal Pulseis the default for the Pulse Source softkey.)

Activating Pulse Modulation

Follow these remaining steps to output the pulse-modulated signal.
1. PressPulse Off On to On.

2. PressRF On/Off.

The Pul se and RF ONannunciators are now displayed. Thisindicates that you have enabled pulse
modulation and the signal is now being transmitted from the RF OUTPUT connector.
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Configuring the LF Output

The signal generator has alow frequency (LF) output. The LF output’s source can be switched between an
internal modulation source or an internal function generator.

Using internal modulation (Internal Monitor) as the LF output source, the LF output provides areplica of the
signal from the internal source that is being used to modulate the RF output. The specific modulation
parameters for this signal are configured through the AM, FM, or FM menus.

Using function generator as the LF output source, the function generator section of the internal modulation
source drives the LF output directly. Frequency and waveform are configured from the L F output menu, not
through the AM, FM, or FM menus. You can select the waveform shape from the following choices:

Sine sine wave with adjustable amplitude and frequency

Dua-Sine dual-sine waves with individually adjustable frequencies and a percent-of-
peak-amplitude setting for the second tone (available from function generator only)

Swept-Sine a swept-sine wave with adjustable start and stop frequencies, sweep time, and sweep
trigger settings (available from function generator only)

Triangle triangle wave with adjustable amplitude and frequency

Ramp ramp with adjustable amplitude and frequency

Square sguare wave with adjustable amplitude and frequency

Noise noise with adjustable amplitude generated as a peak-to-peak value (RMSvalueis
approximately 80% of the displayed value)

DC direct current with adjustable amplitude

NOTE The LF Out Off On softkey controls the operating state of the LF output. However when the

LF output source selection is Internal Monitor, you have three ways of controlling the output.
You can use the modulation source (AM, FM, or FM) on/off key, the LF output on/off key,
or the Mod On/0ff softkey.

The RF On/0ff hardkey does not apply to the LF OUTPUT connector.
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Configuring the LF Output with an Internal Modulation Source

In this example, the internal FM modulation is the LF output source.

NOTE Internal modulation (Internal Monitor) is the default LF output source.

Configuring the Internal Modulation as the LF Output Source

1. PressPreset.

2. Pressthe FM/®M hardkey.

3. PressFM Dev > 75 > kHz.

4. PressFM Rate > 10 > kHz.

5. PressFM Off On.

You have set up the FM signal with arate of 10 kHz and 75 kHz of deviation. The FMannunciator is
activated indicating that you have enabled frequency modulation.

Configuring the Low Frequency Output

1. PressthelLF Out hardkey.
2. PressLF Out Amplitude > 3 > Vp.
3. PressLF Out Off On.

You have configured the LF output signal for a 3 volt sine wave (default wave form) output which is
frequency modulated using the Internal Monitor source selection (default source).

Chapter 6 201



Analog Modulation
Configuring the LF Output

Configuring the LF Output with a Function Generator Source

In this example, the function generator isthe LF output source.

Configuring the Function Generator as the LF Output Source

1
2.
3.

Press Preset.
Pressthe LF Out hardkey.

Press LF Out Source > Function Generator.

Configuring the Waveform

1
2
3.
4

Press LF Out Waveform > Swept-Sine.
Press LF Out Start Freq > 100 > Hz.
Press LF Out Stop Freq > 1 > kHz.
Press Return > Return.

This returns you to the top LF Output menu.

Configuring the Low Frequency Output

1

2.

The LF output is now transmitting a signal using the function generator that is providing a
3 Vp swept-sine waveform. The waveform is sweeping from 100 Hz to 1 kHz.

Press LF Out Amplitude > 3 > Vp.
This setsthe LF output amplitude to 3 Vp.
Press LF Out Off On.
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[ Digital Signal Interface Module

This chapter provides information on the N5102A Baseband Studio Digital Signal Interface Module. These
features are available only in E4438C ESG Vector Signal Generators with Options 003/004 and 601/602.
Functions, features and operation of the N5102A are explained and demonstrated.

e “Clock Timing” on page 204

= “DataTypes’ on page 220

= “Connecting the Clock Source and the Device Under Test” on page 218

= “Operating the N5102A Module in Output Mode” on page 222

= “Operating the N5102A Modulein Input Mode” on page 231
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Clock Timing

This section describes how clocking for the digital datais provided. Clock timing information and diagrams
are supplied for the different port configurations (serial, parallel, or parallel interleaved data transmission)
and phase and skew settings. All settings for the interface module are available on the signal generator user
interface (Ul).

Clock and Sample Rates

A sampleisagroup of bits where the size of the sample is set using the Word Size softkey. The clock isthe
signal that tells when the bits of asample are valid (in anon-transition state). The clock and sample rates are
displayed in the first-level and data setup softkey menus. The clock rate and sample rate are usually the
same. They will differ when serial mode is selected, or when there are multiple clocks per sample.

Figure 7-1 Data Setup Menu for a Parallel Port Configuration
FREQUENCY AMPLITUDE Diracti
4,000 000 00000 &= | -136.00 @ | =
DIG BUS HCDiA noo
Rl oH
| Hord Size
16 bits
i Clack_| r
38 1 pata ¥ 8
218 5 ) pat,
R 0 a:X K: Mumer ic FD!"‘ITEt,
(2s Complement )M
I/0 Data Bit Alicnment Clock Rate: 100.0000 MHz -
. Sional Tupe
LS E 78 91011121314 15 Sample Rate: 100.0000 MHz IF
8 0 0 S S > -
A (1 of 2
N o _ N I _
Least significant bit Most significant bit Clock and sample rates

The N5102A module clock rateis set using the Clock Rate softkey and has arange of 1 kHz to
400 MHz. The samplerateis automatically calculated and has arange of 1 kHz to 100 MHz. These ranges
can be smaller depending on logic type, data parameters, and clock configuration.

Maximum Clock Rates

The N5102A module maximum clock rate is dependent on the logic and signal type. Table 7-1 and
Table 7-2 show the warranted rates and the maximum clock rates for the various logic and signal types.
Notice that LVDS in the output mode using an IF signal is the only logic type where the warranted and
maximum rates are the same.
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Table 7-1 Warranted Parallel Output Level Clock Rates and Maximum
Clock Rates
Warranted Level Clock Rates Maximum Clock Rates (typical)
Logic Type
1Q Signal Type IF Signal Type! 1Q Signal Type IF Signal Type
LVTTL and CMOS | 100 MHz 100 MHz 150 MHz 150 MHz
LVDS 200 MHz 400 MHz 400 MHz 400 MHz

1. The IF signal type is not available for a serial port configuration.

Table 7-2 Warranted Parallel Input Level Clock Rates and Maximum Clock
Rates

Logic Type Warranted Level Clock Rates Maximum Clock Rates (typical)

LVTTL and CMOS | 100 MHz 100 MHz

LVDS 100 MHz 400 MHz

The levels will degrade above the warranted level clock rates, but they may still be usable.

Serial Port Configuration Clock Rates

For a seria port configuration, the lower clock rate limit is determined by the word size (word size and
sampl e size are synonymous), while the maximum clock rate limit remains constant at 150 MHz for LVTTL
and CMOS logic types, and 400 MHz for an LVDS logic type.

Thereverseistrue for the sample rate. Thelower sample (word) rate value of 1 kHz remains while the upper
limit of the sample rate varies with the word size. For example, a five-bit ssmple for an LVTTL or CMOS
logic type yields the following values in serial mode:

= Clock rate of 5 kHz through 150 MHz
= Samplerate of 1 kHz through 30 MHz
Refer to Table 7-3 and Table 7-4, for the seria clock rates.
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Table 7-3 Output Serial Clock Rates
Logic Type Minimum Rate Maximum Rate
LVDS 1 x (word size) kHz 400 MHz
LVTTL and CMOS 1 x (word size) kHz 150 MHz

Table 7-4 Input Serial Clock Rates
Logic Type Data Type Minimum Rate Maximum Rate
LVDS Samples 1 x (word size) kHz 400
Pre-FIR 1 x (word size) kHz the smaller of: 50t x (word size) MHz
Samples or
400 MHz
LVTTL and CMOS | N/A 1 x (word size) kHz 150 MHz

1. The maximum sample rate depends on the selected filter when the data rate is Pre-FIR Samples. Refer to “Input Mode” on page

220 for more information.

Parallel and Parallel Interleaved Port Configuration Clock Rates

Parallel and parallel interleaved port configurations have ather limiting factors for the clock and sample

rates:

= logictype

= Clocks per sample selection

« 1Qor IF digita signal type

Clocks per sample (clocks/'sample) isthe ratio of the clock to sample rate. For an 1Q signal type, the sample
rateisreduced by the clocks per sample value when the value is greater than one. For an | F signal or an input
signal, clocks per sample is always set to one. Refer to Table 7-5 for the Output mode parallel and parallel

interleaved port configuration clock rates.
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Table 7-5 Output Parallel and Parallel Interleaved Clock Rates
Logic Type | Signal Type | Minimum Rate Maximum Rate
LVDS 1Q 1 x (clocks/sample) kHz | the smaller of: 100 x (clocks /sample) MHz
Z[)O MHz
IF 4 kHz 400 MHz
Other 1Q 1 x (clocks/sample) kHz | the smaller of: 100 x (clocks /sample) MHz
g.)rSO MHz
IF 4 kHz 150 MHz

For Input mode, the maximum clock rate is limited by the following factors:

e samplesize
- datatype
= selected filter for Pre-FIR Samples

Refer to Table 7-6 for the Input mode parallel and parallel interleaved port configuration clock rates.

Table 7-6 Input Parallel and Parallel Interleaved Clock Rates
Logic Type Data Type Minimum Rate Maximum Rate
N/A Samples 1kHz 100 MHz
Pre-FIR Samples 1kHz 501 MHz

1. The maximum sample rate depends on the selected filter when the data rate is Pre-FIR Samples. Refer to “Input Mode”
on page 220 for more information.

Clock Source
The clock signal for the N5102A module is provided in one of three ways through the following selections:

= Internal: generated internally in the interface module (requires an externa reference)
= External: generated externally through the Ext Clock In connector
= Device: generated externally through the Device Interface connector
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The clock source is selected using the N5102A module Ul on the signal generator, see Figure 7-2.

Figure 7-2 Clock Source Selection
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When you select a clock source, you must let the N5102A module know the frequency of the clock signal
using the Clock Rate softkey. Inthe internal clock source mode, use this softkey to set theinternal clock rate.
For device and external clock sources, this softkey must reflect the frequency of the applied clock signal.

When the clock source is Internal, afrequency reference must be applied to the Freq Ref connector. The
frequency of this applied signal needs to be specified using the Reference Frequency softkey, unless the
current setting matches that of the applied signal.

The selected clock source provides the interface module output clock signal at the Clock Out and the Device
Interface connectors.

Common Frequency Reference

The clocking flexibility of the digital signal interface module allows the setting of arbitrary clock rates for
the device under test. In general, the clock rate inside the ESG will be different from the interface module
clock rate, so the interface module performs a rate conversion. An important aspect of this conversionisto
have accurate clock rate information to avoid losing data. The module relies on relative clock accuracy,
instead of absolute accuracy, that must be ensured by using a single frequency reference for all clock rates
involved in the test setup. This can be implemented in various ways (see the five drawings in Figure 7-3 on
page 210), but whatever way it isimplemented, the clock inside the signal generator must have the same
base frequency reference as the clock used by the device under test.

208 Chapter 7



Digital Signal Interface Module
Clock Timing

ESG Frequency Reference Connections

When afrequency reference is connected to the signal generator, it is applied to one of two rear panel
CONnectors:

« 10MHzIN
= BASEBAND GEN REFIN

The BASEBAND GEN REF IN connector will accept afrequency referencein therange of 1to 100 MHz. If
the external or device under test clock source cannot provide or accept afrequency reference, that clock
signal can be applied to this connector and used as the frequency reference (as long as the frequencies are
within the specified range).

Whenever an external clock signal or frequency reference is connected to the BASEBAND GEN REF IN
connector, its frequency needs to be entered into the current signal generator modul ation format. For
information on the BASEBAND GEN REF IN connector refer to Chapter 2, “E4438C Vector Signal
Generator Overview,” on page 19. For information on the associated softkeys and fields for entering the
frequency of the applied clock signal or frequency reference, refer to the Key and Data Field Reference.
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Figure 7-3 Frequency Reference Setup Diagrams for the N5102A Module Clock Signal
Internally Generated Clock
Data -
Data g
»| N5102A Module DUT
10 MHz OUT ESG/PSG - Clock >
Freq Ref
10 MHz Frequency Reference
Device (DUT) Supplied Clock
Data -
Data | N5102A Module "I our
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10 MHz Frequency Reference
BB GEN REF IN Data
............. ) Data o N5102A Module —>
10 MHz IN_ ESG/PSG > __ Clock but
»~ -

10 MHz Frequency Reference

1-100 MHz Frequency Reference

NOTE: Use only one of the two signal generator frequency reference inputs.
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Data
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Digital Signal Interface Module

10 MHz Frequency Reference

A

P External Clock

ESG/PSG
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Data

Clock Timing
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Data -
N5102A Module Clock N DUT
Ext Clk In

Data -

»

»1 N5102A Module Clock g DUT
»
Ext Clk In

1-100 MHz Frequency Reference

External Clock

NOTE: Use only one of the two signal generator frequency reference inputs.

Clock Timing for Parallel Data

Some components require multiple clocks during a single sample period. (A sample period consists of an |
and Q sample). For parallel data transmissions, you can select one, two, or four clocks per sasmple. For
clocks per sample greater than one, the | and Q samples are held constant to accommodate the additional
clock periods. This reduces the sample rate relative to the clock rate by afactor equal to the clocks per
sample selection. For example, when four is selected, the sample rate is reduced by afactor of four (sample
rate to clock rate ratio). Figure 7-4 demonstrates the clock timing for each clocks per sample selection. For
input mode, the clocks per sample setting is always one.

Chapter 7

211



Digital Signal Interface Module

Clock Timing
Figure 7-4 Clock Sample Timing for Parallel Port Configuration
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2 Clocks Per Sample
Sample rate decreases by a factor of two
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Clock Timing for Parallel Interleaved Data

The N5102A module provides the capahility to interleave the digital | and Q samples. There are two choices
for interleaving:

« 1Q, wherethe | sampleistransmitted first
= QlI, where the Q sampleistransmitted first

When parallel interleaved is selected, all samples are transmitted on the | data lines. This effectively
transmits the same number of samples during a sample period on half the number of data lines as compared
to non-interleaved samples. (A sample period consists of an | and Q sample.) Clocks per sampleis till a
valid parameter for parallel interleaved transmissions and creates a reduction in the sample rate relative to
the clock rate. The clocks per sample selection is the ratio of the reduction. Figure 7-5 shows each of the
clocks per sample selections, for aparallel 1Q interleaved port configuration, using aword sized of four bits
and the clock timing relative to the | and Q samples. For aparalle QI interleaved port configuration, just
reverse the | and Q sample positions. For input mode, the clocks per sample setting is always one.

Figure 7-5 Clock Timing for a Parallel IQ Interleaved Port Configuration

1 Clock Per Sample

The | sample is transmitted on one clock transition and the Q sample is transmitted on the
other transition; the sample and clock rates are the same.
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2 Clocks Per Sample

The | sample is transmitted for one clock period and the Q sample is transmitted during the second
clock period; the sample rate decreases by a factor of two.

1 Sample Period

I 2 Clocks I I
e E— |
coek | L[ L [ [ | [ |
X 0 0 K 0 0 X 0
) 1 K1 1 K1
2 2 K2 2} 2
X 3
|

| sample Q sample
4 bits per word 4 bits per word

4 Clocks Per Sample

The | sample is transmitted for the first two clock periods and the Q sample is transmitted during the second two
clock periods; the sample rate is decreased by a factor of four.

1 Sample Period
4 Clocks

<
A

Clock
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S >em s L

|

| sample Q sample
4 bits per word 4 bits per word
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Clock Timing for Serial Data

Figure 7-6 shows the clock timing for aserial port configuration. Notice that the serial transmission includes
frame pulses that mark the beginning of each sample where the clock delineates the beginning of each bit.
For serial transmission, the clock and the bit rates are the same, but the sample rate varies depending on the
number of bits per word that are entered using the Word Size softkey. The number of bits per word is the same
as the number of bits per sample.

Figure 7-6 Clock Timing for a Serial Port Configuration
| |
|-t 1 Sample |
Frame Marker |
cok || | [ | L] | |
Data Bits >K 0 1 2 3 X 0

R//’/

4 bits per word

Clock Timing for Phase and Skew Adjustments

The N5102A module provides phase and skew adjustments for the clock relative to the data and can be used
to align the clock with the valid portion of the data. The phase has a 90 degree resolution (0, 90, 180, and
270 degree selections) for clock rates from 10 to 200 MHz and a 180 degree resolution (0 and 180 degree
selections) for clock rates below 10 MHz and greater than 200 MHz.

The skew is displayed in nanoseconds with a maximum range of +5 ns using a maximum of £127 discrete
steps. Both the skew range and the number of discrete steps are variable with a dependency on the clock rate.
The skew range decreases as the clock rate is increased and increases as the clock rate is decreased. The
maximum skew rangeis reached at a clock rate of approximately 99 MHz and is maintained down to a clock
rate of 25 MHz. For clock rates below 25 MHz, the skew adjustment is unavailable.

A discrete step is calculated using the following formula:

1
256 x Clock Rate

The number of discrete steps required to reach the maximum skew range decreases at lower frequencies. For
example, at aclock rate of 50 MHz, 127 steps would exceed the maximum skew range of 5 ns, so the actual
number of discrete steps would be less than 127.

Figure 7-7 isan example of aphase and skew adjustment and shows the original clock and its phase position
relative to the data after each adjustment. Notice that the skew adjustment adds to the phase setting.
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Figure 7-7 Clock Phase and Skew Adjustments
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Connecting the Clock Source and the Device Under Test

As shown in Figure 7-3 on page 210, there are numerous ways to provide a common frequency reference to
the system components (ESG, N5102A module, and the device under test). Figure 7-8 shows an example
setup where the signal generator supplies the common frequency reference and the N5102A moduleis
providing the clock to the device.

CAUTION The Device Interface connector on the interface module communicates using high speed
digital data. Use ESD precautions to eliminate potential damage when making connections.

Figure 7-8 Example Setup using the ESG 10 MHz Frequency Reference

Signal generator 10 MHz Out

LieessassnnunERene

Common Freq Ref cable

Freq Ref connector
Device under test
Break-out board

Device interface connection User furnished ribbon cable(s) connect
between the device and break-out board.
The clock to the device is in the ribbon
cable.

NOTE You must disconnect the digital bus cable and the digital module while downloading
firmware to the ESG.
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1. Refer to the five setup diagramsin Figure 7-3 on page 210 and connect the frequency reference cable
according to the clock source.

2. If anexternal clock sourceisused, connect the external clock signal to the Ext Clock In connector on the
interface module.

3. Select the break-out board that has the output connector suited for the application.

NOTE If the Device Interface mating connector is used with the device under test, refer to Figure
7-8for the device interface connection and connect the device to the N5102A module. Then
proceed to “ Operating the N5102A Module in Output Mode” on page 222 or “Operating
the N5102A Module in Input Mode” on page 231.

4. Refer to Figure 7-8. Connect the break-out board to the Device Interface connector on the N5102A
module.

5. Connect the device to the break-out board.
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The following block diagram indicates where in the ESG signal generation process the datais injected for
input mode or tapped for output mode.

Output
Mode
Pre-FIR
Samples Samples
A A
.
Data FIR 1,Q RF
> > 1/Q
Generator [~ A - Filtering A DACs Modulator >
Pre-FIR Samples
Samples
Ingut
Mode

Output Mode
When using an ARB format, the data type is always Samples and no filtering is applied to the data
samples.The samples are sent to the digital module at the ARB sample clock rate.

For real-time formats, choosing Samples as the data type will send filtered samples to the digital module at a
rate between 50 MHz and 100 MHz. Selecting Pre-FIR Samples, sends unfiltered samplesto the digital
modul e at arate equal to the sample rate of the current format.

Input Mode

When the data type is Samples, the data samples coming through the digital module are injected at a point
that bypasses the filtering process.

If Pre-FIR Samplesis selected, the data samples are injected before the filtering process. The maximum rate
will be determined by the selected filter. Refer to Table 7-7.
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Maximum Sample Rate for Selected Filter

Filter

Maximum Rate

Gaussian

Nyquist

Root Nyquist
Rectangle

Edge

UN3/4 GSM Gaussian
1S-95

IS 95 W/EQ

50 MHz

IS-95 Mod
I1S-95 Mod W/EQ

25 MHz

APCO 25 C4FM

12.5 MHz

The Filter softkey accesses a menu that enables you set the desired filtering parameters.
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Operating the N5102A Module in Output Mode

This section shows how to set the parameters for the N5102A module using the signal generator Ul in the
output direction. Each procedure contains a figure that shows the softkey menu structure for the interface
modul e function being performed.

Setting up the Signal Generator Baseband Data

The digital signal interface module receives data from a baseband source and outputs adigital 1Q or digital
IF signal relative to the selected logic type. Because an ESG provides the baseband data, the first procedure
in operating the interface module is configuring the ESG using one of the real-time or ARB modulation
formats, or playing back a stored file using the Dual ARB player. For information on configuring the ESG,
refer to Chapter 4, “Basic Digital Operation,” on page 87.

1. Preset the signal generator.
2. Select the modulation format (TDMA, Custom, and so forth) and set the desired parameters.
3. Turn-on the modulation format.

Accessing the N5102A Module User Interface

Press Aux Fctn > N5102A Interface.

This accesses the Ul (first-level softkey menu shown in Figure 7-9) that is used to configure the digital
signal interface module. Notice the graphic, in the ESG display, showing a setup where the N5102A module
isgenerating its own internal clock signal. This graphic changes to reflect the current clock source selection.

Figure7-9 First-L evel Softkey Menu
FRECLENCY AMPLITUDE - NSi02A
4.000 000 000 00 &= | -136.00 cen o o
HCDHA nop Logic_Tupe,
10 OH (3.3 CMOS)
| Port Config,
(Parallel)
Clock

Signal Generator NS102A P OUT Data Setup»
Freqg. FleF; T Clock Setupk

Clock Rate: 100.0000 MHz ) )
Sample Rate: 100.0000 MHz Dimanosticsk
Pass Through
\ Preset

\ Line is grayed out until the N5102A module interface is turned on
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Choosing the L ogic Type and Port Configuration

Figure 7-10 Logic and Port Configuration Softkey Menus
FREQUENCY ANPLITUDE - Nsi0za LuDS
4.000 000 000 00 &z | -136.00 den W o
DA non Logic Tupe LvTTL
/0 OH (3.37 crosyt| ——— >
| Port Config, | 3.3V CHOS
tParallel)
Clock 2.5¢ CHOS
Signal Gererator NS5102A 3 Ut Data Setupk :
Fred. Fef T Clock Setupe L.8v CH0S
Clock Rate: 100.0000 MHz ) ) 1.5 CHOS
Samele Rate: 100.0000 HHz Dimonost icse
Pass Through Parallel
Freset

Serial

Par I0 Intrled

Far OI Intrlwd

1. Refer to Figure 7-10. Press the Logic Type softkey.
From this menu, choose alogic type.

CAUTION Changing thelogic type can increase or decrease the signal voltage level going to the device
under test. To avoid damaging the device and/or the N5102A module, ensure that both are
capable of handling the voltage change.

2. Select the logic type required for the device being tested.

A caution message is displayed whenever a change is made to the logic types, and a softkey selection
appears requesting confirmation.

3. Refer to Figure 7-10. Press the Port Config softkey.
In this menu, select either a seria, parallel, or parallel interleaved data transmission.

NOTE Within the data and clock setup softkey menus, some softkeys function relative to the
current configuration. Softkeys that are grayed out are not available for the current setup.
Refer to the help text to determine which parameter is causing the softkey to be unavailable.
Press the Help hardkey on the ESG front panel and then the softkey that is unavailable.
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4. Select the port configuration for the device.

Selecting the Output Direction

Press Data Setup > Direction Input Output to Output and press Return.

NOTE If Option 003 isthe only option installed, the direction softkey will be unavailable and the
mode will always be output. With both Option 003 (output mode) and Option 004 (input
mode) installed, the default direction is output.

Selecting the Data Parameters

This procedure guides you through the data setup menu. Softkeys that have self-explanatory names are
generally not mentioned. For example, the Word Size softkey. For more information on all of the softkeys,
refer to Key and Data Field Reference.

1. Refer to Figure 7-11. Press the Data Setup softkey.

Figure 7-11 Data Setup Menu L ocation
FRECUENCY AMPLITUDE e
4.000 000 000 00 &z | -136.00 den WIEE o0
_ucona | Hon Logic_Tupe,
10 (] (3.3 CHES)
| Port Config,
(Parallel)
Clock
Siomal Gemerator NS102A > ouT Data Setups|-@— Accesses the data setup menu

Fregq. Ref T Clock Setupe

Clock Rate: 100.0000 MHz ) )
Sample Rate: 100.0000 HHz Disonost icse
Pass Through
Preset

This softkey menu accesses the various parameters that govern the data received by the device under
test. The status area of the display shows the number of datalines used for both | and Q aong with the
clock position relative to the data. When the port configuration is parallel or parallel interleaved, the
number of datalinesindicated is equivalent to the word (sample) size. When the port configuration is
serial, the display will show that only one | and one Q dataline is being used along with the frame
marker that delineates the beginning of a sample. Figure 7-12 shows the data setup menu structure.
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Figure 7-12 Data Setup Softkey Menu with Parallel Port Configuration
FREQUENC'Y PLITUOE Direction Inactive for ARB formats
4.000000 000 00 we [~136.00 @ | vouifisié
lconA non Data Tupe
10| OH (Samples) Samples
| Hord Size
16 bits Pre-FIR Sameles
H Clock | [ Inactive for word
85 1 pata Y C < size = 16 bits
2f18 5 o Data:X )(:
R Mumeric Format
(275 Cotelement T ®|  2°s Comelement
I/0 Data Bit Alignment Clock Aate: 100.0000 MHz ;
. Sigpal Tupe
LEE 7O 91011121314 15 Sample Rate: 100.0000 MHz IF ‘\ Offset. Binary
||-| | | N O O O Hore Inactive for a serial port
(1 of 23 configuration

Frame polarity is active — g}

for a serial port configuration

Available only while in

output mode

2.

A

Bit Order
MSE

——pp Gain, Offset
#'scaling”

I Gain
100.00 =

Data Megationk|— Neogate I Oata
an > 0 Gain
100.00 =

wia o Negate 0 [ata
On I Offset
0.00 =
0 Offset
0.00 =

I0 Polarit
Heg lﬁ

Mare
(2 of 21

when an ARB modulation format is turned on.)

In this menu, select whether the real-time baseband data from the signal generator is either filtered
(Samples) or unfiltered (Pre-FIR Samples). The selection is dependent on the test needs. The Samples
selection provides FIR filtered baseband samples according to the communication standard of the active
modulation format. Thisis the preset selection and the one most commonly used. However if the device
being tested already incorporates FIR filters, the Pre-FIR Samples selection should be used to avoid

double filtering.

Select the data type that is appropriate for the test.
Press the Numeric Format softkey.

Scaling
70,00 %

Fotat ion
0.0 deg

If areal-time modulation format is being used, press the Data Type softkey. (This softkey isinactive

From this menu, select how the binary values are represented. Selecting 2's complement allows both
positive and negative data values. Use the Offset Binary selection when components cannot process

negative values.
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5. Select the numeric format required for the test.
6. Pressthe More (1 of 2) softkey.

From this softkey menu, select the bit order, swap | and Q, select the polarity of the transmitted data, and
access menus that provide data negation, scaling, gain, offset, and 1Q rotation adjustments.

7. Pressthe Data Negation softkey.

Negation differs from changing the | and Q polarity. Applied to a sample, negation changes the affected
sample by expressing it in the two's complement form, multiplying it by negative one, and converting the
sample back to the selected numeric format. This can be done for | samples, Q samples, or both.

The choice to use negation is dependent on the device being tested and how it needs to receive the data.

8. Pressthe Gain, Offset & Scaling softkey.

Use the softkeysin this menu for the following functions:

= reduce sample valuesfor both | and Q using the Scaling softkey

= increase or decrease the sample values independently for | and Q using the | Gain and Q Gain

softkeys

= compensate for or add a DC offset using the | Offset and Q Offset softkeys

= rotate the data on the IQ plane using the Rotation softkey

9. Make any required scaling, gain, offset, or rotation adjustments to properly test the device.

10. Press Return > Return to return to the first-level softkey menu.

Configuring the Clock Signal

1. Refer to Figure 7-13. Press the Clock Setup softkey.

Figure7-13 Clock Setup Menu L ocation
FRECLENC AMPLITUDE  NS10EA
4.000 000 000 00 &z | ~136.00 den e o
HCDHA nop Loglc Tupe,
1/0 OH (3.3V CMOS)
| Port Config,
(Parallel)
Clock

Sional Generator MN5102A > OUT Data Setupw
Freq. Ref T Clock Setup

Clock Rate: 100.0000 MHz ) _
Sample Rate: 100.0000 MHz Dimgnosticse
Pass Through
Preset

-¢— Accesses the Clock Setup Menu
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From this softkey menu, set all of the clock parameters that synchronize the clocks between the N5102A
module and the ESG. You can a so change the clock signal phase so the clock occurs during the valid
portion of the data. Figure 7-14 shows the clock setup menu.

Figure 7-14 Clock Setup Softkey Menu for a Parallel Port Configuration
Inactive for a serial port configuration and the IF signal type
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Done
The top graphic on the display shows the current clock source that provides the output clock signal at the
Clock Out and Device Interface connectors. The graphic changes to reflect the clock source selection
discussed later in this procedure. The bottom graphic shows the clock position relative to the data. The
displayed clock signal will change to reflect the following:

= clocks per sample selection
= clock phase choice

< clock skew adjustment

< clock polarity selection

If the device or external clock does not match the frequency, one of the following error messages will
appear on the ESG:

805 Digital module output FIFO overflow error; There are more samples being produced than can be

consumed at the current clock rate. Verify that the digital module clock is set up properly.
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This error is reported when the output FIFO is overflowing in

the digital module. This error can be generated if an external clock
or itsreferenceis not set up properly, or if theinternal VCOis
unlocked.

806 Digita module output FIFO underflow error; There are not enough samples being produced for the
current clock rate. Verify that the digital module clock is set up properly.

This error is reported when the output FIFO is underflowing in the digital module.
Thiserror can be generated if an external clock or itsreferenceis not set up properly,
or if theinternal VCO is unlocked.

2. If the port configuration is parallel or paralldl interleaved, using an IQ signal type, press the
Clocks Per Sample softkey.

Notice that multiple clocks per sample can be selected. Some DA Cs require the ability to clock multiple
times for each sample; having a clocks per sample vaue greater than one reduces the sample rate by a
factor equal to the selected number of clocks per sample. The samplerateisviewed on thefirst-level and
Data Setup softkey menus.

3. Select the clocks per sample value to fit the test.
4. Pressthe Clock Source softkey.

From this menu, select the clock signal source. With each selection, the clock routing display in the
signal generator clock setup menu will change to reflect the current clock source. Thiswill be indicated
by a change in the graphic.

5. Select the clock source.
If External or Deviceis Selected
Press the Clock Rate softkey and enter the clock rate of the externally applied clock signal.

NOTE The clock phase and clock skew may need to be adjusted any time the clock rate setting is
changed. Refer to “Clock Timing for Phase and Skew Adjustments” on page 216.

For the External selection, the signal is supplied by an external clock source and applied to the Ext Clock
In connector. For the Device selection, the clock signal is supplied through the Device Interface
connector, generally by the device under test.

If Internal is Selected
Using an external frequency reference, the N5102A module generates its own internal clock signal. The
reference frequency signal must be applied to the Fregq Ref connector on the digital module.

a. Pressthe Reference Frequency softkey and enter the frequency of the externally applied frequency
reference.
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b. Pressthe Clock Rate softkey and enter the appropriate clock rate.

Table 7-8 provides a quick view of the settings and connections associated with each clock source
selection.

Table 7-8 Clock Source Settings and Connectors
Clock Source Softkeys N5102A M odule Connection
Reference Clock Rate! |Freq Ref |Ext Clock In [Device Interface
Frequency
External ° °
Device ° °
Internal? ° ° °

1. For the Internal selection, this sets the internal clock rate. For the External and Device selections, this

tells the interface module the rate of the applied clock signal.

2. There should be no clock signal applied to the Ext Clock In connector.

6.

Press the Clock Phase softkey.

From the menu that appears, you can adjust the phase of the clock relative to the datain 90 degree
increments. The selections provide a coarse adjustment for positioning the clock on the valid portion of
the data. Selecting 180 degrees is the same as selecting a negative clock polarity.

The 90 degree and 270 degree selections are not available when the clock rateis set below 10 MHz or
above 200 MHz. If 90 degrees or 270 degrees is selected when the clock rateis set below 10 MHz or
above 200 MHz, the phase will change to O degrees or 180 degrees, respectively.

NOTE The clock phase and clock skew may need to be adjusted any time the clock rate setting is

changed. Refer to “Clock Timing for Phase and Skew Adjustments” on page 216.

7. Enter the required phase adjustment.
8. Pressthe Return softkey to return to the clock setup menu.
9. Pressthe Clock Skew softkey.

This provides a fine adjustment for the clock relative to its current phase position. The skew is a phase
adjustment using increments of time. This enables greater skew adjustment capability at higher clock
rates. For clock rates below 25 MHz, this softkey isinactive.

The skew has discrete values with arange that i s dependent on the clock rate. Refer to “ Clock Timing for
Phase and Skew Adjustments’ on page 216 for more information on skew settings.
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10. Enter the skew adjustment that best positions the clock with the valid portion of the data.
11. Pressthe Clock Polarity Neg Pos softkey to Neg.

This shifts the clock signal 180 degrees, so that the data starts during the negative clock transition. This
has the same affect as selecting the 180 degree phase adjustment.

12.Make the clock polarity selection that isrequired for the device being tested.
13. Press the Return hardkey to return to the first-level softkey menu.

The clock source selection is aso reflected in the first-level softkey menu graphic. For example, if the
deviceisthe new clock source, the graphic will show that the frequency reference is now connected to
the DUT and the DUT has an input clock line going to the N5102A module.

Generating Digital Data

Press the N5102A Off On softkey to On.

Digital datais now being transferred through the N5102A module to the device. The green status light
should be blinking. Thisindicates that the datalines are active. If the status light is solidly illuminated (not
blinking), all the datalines are inactive. The status light comes on and stays on (blinking or solid) after the
first time the N5102A module is turned on (N5102A Off On to On). The status light will stay on until the
modul e is disconnected from its power supply.

The interface module can only be turned on while a modulation format is active. If the modulation format is
turned off while the module is on, the module will turn off and an error will be reported.

NOTE If changes are made to the baseband data parameters, it is recommended that you first
disable the digital output (N5102A Off On softkey to Off) to avoid exposing your device and
the N5102A module to the signal variations that may occur during the parameter changes.
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Operating the N5102A Modulein Input Mode

This section shows how to set the parameters for the N5102A module using the signal generator Ul in the
input direction. Each procedure contains a figure that shows the softkey menu structure for the interface
module function being performed.

Refer to “ Connecting the Clock Source and the Device Under Test” on page 218 and configure the test
setup.

Accessing the N5102A Module User Interface

All parameters for the N5102A module are set with softkeys on the ESG signal generator.
Press Aux Fctn > N5102A Interface.

This accesses the Ul (first-level softkey menu shown in Figure 7-15) that is used to configure the digital
signal interface module. Notice the graphic, in the ESG display, showing a setup where the N5102A module
isgenerating its own internal clock signal. This graphic changes to reflect the current clock source selection.

Figure 7-15 First-L evel Softkey Menu
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Selecting the Input Direction

If both Option 003 (output mode) and Option 004 (input mode) are installed, you must select the input
direction.

Press Data Setup > Direction Input Output to Input and press Return.

NOTE If only Option 004 isinstalled, the direction softkey will be unavailable and the mode will
always be input.

Choosing the Logic Type and Port Configuration

Figure 7-16 Logic and Port Configuration Softkey Menus
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1. Refer to Figure 7-16. Press the Logic Type softkey.
From this menu, choose alogic type.

CAUTION Changing the logic type can increase or decrease the signal voltage level. To avoid
damaging the device and/or the N5102A module, ensure that both are capable of handling
the voltage change.
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A caution message is displayed whenever a change is made to the logic types, and a softkey selection

appears asking for confirmation.

3. Refer to Figure 7-16. Press the Port Config softkey.

In this menu, select either a seria, parallel, or parallel interleaved data transmission.

NOTE Within the data and clock setup softkey menus, some softkeys function relative to the
current configuration. Softkeys that are grayed out are not available for the current setup.
Refer to the help text to determine which parameter is causing the softkey to be unavailable.
Press the Help hardkey on the ESG front panel and then the softkey that is unavailable.

4. Select the port configuration for the device being tested.

Configuring the Clock Signal

1. Refer to Figure 7-17. Press the Clock Setup softkey.

Figure7-17 Clock Setup Menu L ocation
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-@— Accesses the Clock Setup Menu

From this softkey menu, set all of the clock parameters that synchronize the data between the N5102A
module and the device. From this menu, the clock signal phase can be changed so the clock occurs
during the valid portion of the data. Figure 7-18 shows the clock setup menu.

If the device or external clock does not match the frequency, one of the following error messages will

appear on the ESG:

803 Digital moduleinput FIFO overflow error; There are more samples being produced than can be
consumed at the current clock rate. Verify that the digital module clock is set up properly.
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This error is reported when the digital module clock setup is not
synchronized with the rate the samples are entering the digital
module. Verify that the input clock rate matches the specified
clock rate under the clock setup menu.

Inactive for clock rates below 25 MHz

Active for only the Internal clock source selection

Inactive for clock rates below
10 MHz and above 200 MHz

180 deg

Done

804 Digital module input FIFO underflow error; There are not enough samples being produced for the current
clock rate. Verify that the digital module clock is set up properly.
This error is reported when the digital module clock setup is not
synchronized with the rate the sampl es are entering the digital
module. Verify that the input clock rate matches the specified
clock rate under the clock setup menu.
Figure 7-18 Clock Setup Softkey Menu for a Parallel Port Configuration
Inactive for Input mode
\\\\\
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The top graphic on the display shows the current clock source that provides the output clock signal at the
Clock Out and Device Interface connectors. The graphic changes to reflect the clock source selection
discussed later in this procedure. The bottom graphic shows the clock edges relative to the data. The
displayed clock signal will change to reflect the following:

clock phase choice
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= clock skew adjustment
= clock polarity selection

2. Pressthe Clock Source softkey.

From this menu, select the clock signal source. With each selection, the clock routing display in the
signal generator clock setup menu will change to reflect the current clock source. Thiswill be indicated
by a change in the graphic.

3. Select the clock source.
If External or Deviceis Selected
Pressthe Clock Rate softkey and enter the clock rate of the externally applied clock signal.

NOTE The clock phase and clock skew may need to be adjusted any time the clock rate setting is
changed. Refer to “Clock Timing for Phase and Skew Adjustments” on page 216.

For the External selection, the signal is supplied by an external clock source and applied to the Ext Clock
In connector. For the Device selection, the clock signal is supplied through the Device Interface
connector, generally by the device being tested.

If Internal is Selected

Using an external frequency reference, the N5102A module generates its own internal clock signal. The

reference frequency signal must be applied to the Fregq Ref connector on the digital module.

a. Pressthe Reference Frequency softkey and enter the frequency of the externally applied frequency
reference.

b. Pressthe Clock Rate softkey and enter the appropriate clock rate.

Table 7-9 provides a quick view of the settings and connections associated with each clock source
selection.
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Table 7-9 Clock Source Settings and Connectors

Clock Source Softkeys N5102A M odule Connection
Reference Clock Rate! |Freq Ref |Ext Clock In [Device Interface
Frequency

External ° °

Device ° °

Internal? ° ° °

1. For the Internal selection, this sets the internal clock rate. For the External and Device selections, this

tells the interface module the rate of the applied clock signal.

2. There should be no clock signal applied to the Ext Clock In connector when Internal is being used.

4,

Press the Clock Phase softkey.

From the menu that appears, the phase of the clock relative to the data can be changed in 90 degree
increments. The selections provide a coarse adjustment for positioning the clock on the valid portion of
the data. Selecting 180 degrees is the same as selecting a negative clock polarity.

The 90 degree and 270 degree selections are not available when the clock rateis set below 10 MHz or
above 200 MHz. If 90 degrees or 270 degrees is selected when the clock rateis set below 10 MHz or
above 200 MHz, the phase will change to O degrees or 180 degrees, respectively.

NOTE The clock phase and clock skew may need to be adjusted any time the clock rate setting is

changed. Refer to “Clock Timing for Phase and Skew Adjustments’” on page 216.

Enter the required phase adjustment.

. Pressthe Return softkey to return to the clock setup menu.

7. Pressthe Clock Skew softkey.

This provides a fine adjustment for the clock relative to its current phase position. The skew is a phase
adjustment using increments of time. This enables greater skew adjustment capability at higher clock
rates. For clock rates below 25 MHz, this softkey isinactive.

The skew has discrete values with arange that is dependent on the clock rate. Refer to “ Clock Timing for
Phase and Skew Adjustments’ on page 216 for more information on skew settings.

Enter the skew adjustment that best positions the clock with the valid portion of the data.
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9. Pressthe Clock Polarity Neg Pos softkey to Neg.

This shifts the clock signal 180 degrees, so that the data starts during the negative clock transition. This
has the same affect as selecting the 180 degree phase adjustment.

10. Make the clock polarity selection that is required for the device being tested.
11. Press the Return hardkey to return to the first-level softkey menu.

The clock source selection is aso reflected in the first-level softkey menu graphic. For example, if the
deviceisthe new clock source, you will see that the frequency reference is now connected to the DUT
and the DUT has an input clock line going to the N5102A module.

Selecting the Data Parameters

This procedure guides you through the data setup menu. Softkeys that have self-explanatory names are
generally not mentioned. For example, the Word Size softkey. For more information on all of the softkeys,
refer to the Key and Data Field Reference.

1. Refer to Figure 7-19. Press the Data Setup softkey.

Figure 7-19 Data Setup Menu L ocation
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This softkey menu accesses the various parameters that govern the data received by the ESG The status
area of the display shows the number of data lines used for both | and Q along with the clock position
relative to the data. Figure 7-20 shows the data setup menu structure.

Chapter 7 237



Digital Signal Interface Module
Operating the N5102A Module in Input Mode

Figure 7-20 Data Setup Softkey Menu with Parallel Port Configuration
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2. Pressthe Data Type softkey.

In this menu, select the data type to be either filtered (Samples) or unfiltered (Pre-FIR Samples). The
selection is dependent on the test needs and the device under test. However if the device being tested
aready incorporates FIR filters, the Pre-FIR Samples selection should be used to avoid double filtering.
Refer to “Data Types’ on page 220, for moreinformation.

3. Select the datatype that is appropriate for the test needs.
Press the Numeric Format softkey.

From this menu, select how the binary values are represented. Selecting 2's complement allows both
positive and negative data values. Use the Offset Binary selection when components cannot process
negative values.

5. Select the numeric format required for the test.
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. Pressthe More (1 of 2) softkey.

From this softkey menu, select the bit order, swap | and Q, the polarity of the data, and access menus that
provides data negation, scaling, and filtering parameters.

. Pressthe Data Negation softkey.
Negation differs from changing the | and Q polarity. Applied to a sample, negation changes the affected

sample by expressing it in the two's complement form, multiplying it by negative one, and converting the
sample back to the selected numeric format. This can be done for | samples, Q samples, or both.

The choice to use negation is dependent on the device being tested.

. Toaccess |/Q scaling and filter parameters, press Return > N5102A Off On to On. Thiswill invoke the
real time Custom format in the ESG baseband generator. This is needed to set the filter parameters when
Pre-FIR Samplesis selected as the data type.

. Pressthe Baseband Setup softkey.

Use this softkey menu to adjust the 1/Q scaling and access filter parameters. If the selected datatypeis
Samples, the Filter softkey is grayed out (inactive). For more information on user-defined filtering, refer
to the “Using Finite Impulse Response (FIR) Filters’ on page 162 and “Modifying a FIR Filter Using
the FIR Table Editor” on page 167.

Digital Data

If the N5102A digital moduleis not on, press Return > Return > N5102A Off On to On.

Digital datais now being transferred through the N5102A module to the ESG. The green status light should
be blinking. Thisindicates that the data lines are active. If the status light is solidly illuminated (not
blinking), all the datalines are inactive. The status light comes on and stays on (blinking or solid) after the
first time the N5102A module is turned on (N5102A Off On to On). The status light will stay on until the
module is disconnected from its power supply.

NOTE If changes are made to the baseband data parameters, it is recommended that you first

disable the digital output (N5102A Off On softkey to Off) to avoid exposing the device and
the N5102A module to the signal variations that may occur during the parameter changes.
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8 Bluetooth Signals

Thisfeature is available only in E4438C ESG Vector Signal Generators with Option 001/601or 002/602.
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Accessing the Bluetooth Setup Menu on the ESG

Accessing the Bluetooth Setup Menu on the ESG

Option 406 is required to perform the following procedure.

This chapter will show you how to set up a sample Bluetooth packet with impairments that include additive
white gaussian noise (AWGN) using the front panel keys of the ESG. The proceduresin this chapter build on
each other and are designed to be used sequentially.

1. PressPreset, then press Mode > More (1 of 2) > Wireless Networking > Bluetooth.

NOTE For this section, the frequency and amplitude are set to typical Bluetooth values.

2. PressFrequency > 2.402 > GHz > Amplitude > 10 > dBm > Mode Setup.

The following figure shows a display of the Bluetooth menu.
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Setting Up Packet Parameters

The stepsin this procedure build upon the previous procedure.

The signal generator uses a DH1 (Data-High rate) packet for the Bluetooth format. The DH1 packet isa
single bundle of information transmitted within a piconet and covers a single timeslot. This packet consists
of 3 entities: the access code, the header, and the payload.

In the following example you will set the parameters of the DH1 packet.
1. PressPacket (DH1).
This accesses a menu that enables you to set the packet parameters.

The following figure displays the packet menu.
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2. PressBD_ADDR > 000000 00 1000 > Enter.

This modifies the hexadecimal Bluetooth device address. Each Bluetooth transceiver is allocated a
unique 48-bit Bluetooth device address. This address is derived from the IEEE802 standard.

For addresses with alpha characters, use the softkeys along with the keypad for data entry.
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3. Press AM_ADDR > 4 > Enter.

This sets the active member address and is used to distinguish between the active members participating
on the piconet.

NOTE

The all-zero AM_ADDR isreserved for broadcast messages.

4. Press Payload Data > 8 Bit Pattern > 10101010 > Enter.

This selects a repeating 8-bit pattern as the payload data.

The following figure now displays the new packet parameters.
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Setting up Impairments

The steps in this procedure build upon the previous procedure. This procedure teaches you how to set up the
parameters for the impairment function.

1

Press Return > Return > Impairments.

This accesses a menu which enables you to set up impairments.
Press Freq Offset > 25 > kHz.

Press Freq Drift Type Linear Sine.

This setsthe frequency drift typeto linear. Linear frequency drift will occur across a period of time equal
to the duration of one fully loaded DH1 packet, regardless of the packet length. The default setting isthe
sine drift deviation which is plus or minus from the carrier center frequency.

Press Drift Deviation > 25 > kHz.
This sets the maximum deviation of the frequency drift of the carrier frequency.
Press Mod Index >.325 > Enter.

Modulation index is defined as the ratio of peak-to-peak frequency deviation to the bit rate. When
modifying the Mod Index parameter, the peak-to-peak frequency deviation only is changed.

Press Symbol Timing Err > 1 > ppm.
This sets the symbol timing error in parts per million.
Press AWGN.

This accesses a menu from which you can select the parameters of the additive white Gaussian noise
(AWGN) to be applied as an impairment to the Bluetooth signal. The following parameters may be
changed while AWGN is off, but will not be applied unless AWGN and Impairments are both turned on.

a. PressC/N [1MHZz] > 20 > dB.
This sets the carrier-to-noise ratio for a 1 MHz bandwidth.
b. PressNoise Seed > 2 > Enter.

This sets the noise seed value used to assign a specific sequence of noise to be added to the basic
Bluetooth signal. The noise seed is used to initialize the 16-bit shift register used for noise
generation. Different noise seeds generate different combinations of noise.

c. Press AWGN Off On to On.

This turnsthe AWGN, as a Bluetooth impairment, on.
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8. PressReturn > Impairments Off On to On.

This returns you to the Impairments menu and turns the impairments function on.
The following figure displays the impairment parameters.
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Using Burst

The stepsin this procedure build upon the previous procedure.
1. PressReturn to return to the top-level Bluetooth menu.
2. Notice that Burst Off On is set to On.

When burst is on, the signal power ramps up prior to transmitting the packet and then ramps down at the end
of the packet transmission. When burst is off, the transmitted packets link in a series with no power ramping.
The default burst setting is on, but for troubleshooting you may want to turn bursting off.

For this example burst isleft in the on position.

Setting the Burst Power Ramp

This procedure builds upon the previous procedure.
Press Burst Power Ramp > 4 > Symbols.

This sets the duration of the power ramp to 4 symbols prior to transmitting the first symbol of the packet.
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Using Clock/Gate Delay

The stepsin this procedure build upon the previous procedure.

This function is available only when the payload data is continuous PN9 and is intended to be used during
bit error rate (BER) testing.

1. PressPacket (DH1) > Payload Data > Continuous PN9 > Return.
This activates the configuration that generates clock and gate signals relative to the Bluetooth signal.
2. PressClock/Gate Delay > 4 > Symbols.

The clock and gate will be delayed 4 symbols to synchronize with the demodulated data signal from the
device under test (DUT) at the input of the BER analyzer.
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Turning On a Bluetooth Signal

This procedure builds upon the previous procedure.

Press Bluetooth Off On to On.

This turns the operating state of the Bluetooth signal generator on.

The front panel | / Qand BLUETTH annunciators appear, and the signal builds.

The following figure displays the Bluetooth signal parameters.
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9 BERT

Thisfeature is available only in E4438C ESG Vector Signal Generators with Option 001/601or 002/602.
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Setting Up a PHS Bit Error Rate Test (BERT)

This section shows how to make BERT measurements on a personal handyphone system (PHS) radio using
the ESG Signal Generator with Option UN7.

The following procedures explain how to set up the ESG for making BERT measurements:

» “Connecting the Test Equipment” on page 253

» “Setting the Carrier Frequency and Power Level” on page 254
» “Selecting the Radio Data Format” on page 254

» “Setting the Radio to a Receiver Mode” on page 255

» “Selecting the BERT Data Pattern and Total Bits’ on page 255
» “Selecting the BERT Trigger” on page 255

e “Starting BERT measurements’ on page 256

Required Equipment

The following equipment is required to make BERT measurements.

» ESG Signal Generator, model E4438C with Options 001/601or 002/602, 402, and UN7
» anexternal controller to control the radio under test

» aninterfacelevel matching circuit for interfacing between the radio under test and the signal generator
when the radio signal specifications are different from those of the signal generator
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Connecting the Test Equipment

Refer to Figure 9-1.

1. Connect the cables between your radio and the ESG as follows:

Figure 9-1 Setup for a PHS Bit Error Rate Test
BER
DATA IN
~
BER 1\
CLKIN
RF OUTPUT
Antenna
Interface
Level
Matching
Radio L | clock
Under : :
Test : ; Data
Controller
conn_2
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Setting the Carrier Frequency and Power Level

1
2.

Press the Preset hardkey.

Press the Frequency hardkey. Using the numeric keypad, set the signal generator RF output carrier
frequency to 1.89515 GHz.

Press the Amplitude hardkey. Using the numeric keypad, set the signal generator RF output amplitude to
-100 dBm.

The amplitude can also be set using an Amplitude softkey, located in the Baseband BERT softkey menu, that
is accessed by pressing the Aux Fctn > BERT > Baseband BERT softkeys.

Selecting the Radio Data Format

1. Press Mode > Real Time TDMA > PHS
This selects the PHS communications standard.

2. Toggle the Data Format Pattern Framed softkey to Framed.
When you select Framed for bursting the frame envelope, you will be transmitting framed data. This
means that you will be bursting the timeslots that you have activated and there will be no RF carrier
during the off timeslots.
Notice that the Configure Timeslots softkey has become an active softkey.
Observe the display and notice that the normal preset condition for downlink timeslot #1 has the timesl ot
turned on and configured as a traffic channel (TCH).

3. Press Configure Timeslots.
The Timeslot # softkey shows that downlink timeslot #1 is selected as the active timeslot. The
Timeslot Off On softkey shows that downlink timeslot #1 isturned on. The Timeslot Type softkey shows that
downlink timeslot #1 is configured as a traffic channel.

4. Press Configure TCH.
The TCH softkey shows that PN9 is selected as a data pattern.

5. PressReturn > Return > PHS Off On.
At thistime the internal baseband generator will generate the internal data patterns that you have
configured for Downlink timeslot 1 and Uplink timeslot 1. A message is displayed while this processis
taking place. Notice, also, that the PHS, | / Q and ENVLP display annunciators are turned on.

6. PressRF On/0ff to toggle RF on.
Notice that the display annunciator changes from RF OFF to RF ON.  The modulated signal is now
available at the RF OUTPUT connector.
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Setting the Radio to a Receiver Mode

Set the PHS radio to receive the signal of the specified carrier frequency and the timeslot 1, and output the
data used for the bit error rate measurements.

Selecting the BERT Data Pattern and Total Bits

1

2.

Access the BERT function.

For an ESG with Option UN7 Installed
Press Aux Fctn > BERT > Configure BERT.

For an ESG with Options UN7 and 300 Installed
Press Aux Fctn > BERT > Baseband BERT > Configure BERT.

If the Data softkey does not show that PN9 is the selected data pattern, press
Data > PNO.

The selected PN sequence must match the data PN sequence used on the channel being measured. For
exampleif the DCH (DTCH) is using PN9 data, then the data selection in the BERT function must also
be PNO.

Press Total Bits > 100000 > Bits.

Selecting the BERT Trigger

1

Press Return > Configure Trigger.

If the BERT Trigger softkey does not show Trigger Key as the selected trigger, press
BERT Trigger > Trigger Key.

Press Return > BERT Off On.
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Starting BERT measurements

Press the front panel Trigger hardkey to start the BERT measurement. You will see the measurement result
values of the Total Bits, Error Bits, and BERT on the signal generator display.

NOTE If you encounter problems making a BERT measurement, check the following:

Make sure that the cable connections are properly configured.

Make sure that the data pattern for the BERT measurement, specified by the Data
softkey, matches the data pattern in the traffic channel (TCH) for the RF signal being
input to the radio under test.

Make sure that the RF is turned on.
Make sure that the amplitude is set to the correct level.

Make sure that the radio under test is controlled to receive the signal of the specified
carrier frequency and the timeslot.
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Measuring RF Loopback BERT with Option 300

The following procedure uses the data looped back from the base transceiver station (BTS) to measure the
bit error ratio introduced by the BTS receiver when it is receiving coded data from the test equipment.
Timing synchronization must first be achieved between the BTS and the test equipment so that data can be
transmitted and received at the expected times. Synchronization is achievable either to areceived broadcast
channel (BCH), to areceived full rate speech traffic channel (TCH) in the GSM format, or a packet data
channel (PDCH) in the EDGE format.

Required Equipment

The following equipment is required to make |oopback BERT measurements.

» VSA Series Transmitter Tester, model E4406A, with the following required options:
— Option BAH - GSM Measurement Personality

NOTE Option 202 replaces Option BAH in the VSA if EDGE support is required.

— Option 300 — 321.4 MHz IF Output
» ESG Vector Signal Generator, model E4438C

— Option 300 — GSM/EDGE base station loopback BERT test capability (requires Options UN7,
001/6010r 002/602, 402)

Connecting the Test Equipment

Refer to Figure 9-2 for connections to the ESG, VSA, and base station.

CAUTION If the base station output power is to be greater than the VSA input power specification
(+30 dBm), an external attenuator needs to be inserted prior to the RF INPUT connector on
the VSA.
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Figure 9-2 BTS Loopback Test Equipment Setup

321.4 MHz
10 MHz OUT IF OUT EXT REF IN
321.4 1IN 10 MHz IN

RF OUTPUT
J
g £ 2
T
=
s
BTS
NOTE This example uses an ARFCN of 124 for the BCH and synchronizesto the TCH midamble

intimeslot 2 on ARFCN 124. You can substitute as appropriate for your BTS.
All key presses assume factory defined defaults at preset.
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Configuring GSM Mode on the Agilent Technologies E4406A VSA Series Transmitter Tester
The following steps will show you how to set up the vector signal analyzer (VSA) for synchronization.
1. To preset the VSA:

Press Preset.

2. Toselect GSM mode:
Press MODE > GSM.

3. Toset up GSM mode for BTS test:

Press Mode Setup > Radio > Band > P-GSM > Return.
Toggle Device BTS MS until BTS is underlined.
Toggle Freq Hopping On Off until Off is underlined.

4. To set the frequency:

Press FREQUENCY Channel > ARFCN 124.
Center Fregq will show 959. 800 Mz.
Select Burst Type > Normal.

Toggle TSC (Std) until Auto is underlined.

5. Tolock the VSA and ESG to the BTS 13 MHz reference:
Press System > Reference > Freq Ref > 13 > MHz.
Toggle Freq Ref Int Ext until Ext is underlined.
Toggle 10 MHz Out Off On until On is underlined.
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Configuring GSM Mode on the ESG Vector Signal Generator

Thefollowing stepswill show you how to configure atimesl ot with multiframe data, set up traffic channel 1,
and set the frequency and amplitude in GSM mode on the signal generator.

When configuring atimeslot in this procedure, keep the following pointsin mind:

» Prior to synchronization, the transmitter must be configured to generate multiframe data in the timeslot
to be tested.

» TCH synchronization requires that the training sequences match between the ESG timesl ot configuration
and the timeslot sent by the base station. The default for the ESG, which is TSCO, can be modified.

1. PressPreset.

2. Press Aux Fctn > BERT > BTS BERT GSM Loopback > Configure Measurement >
Transmit Settings.

3. Press GSM On Off to On > Data Format Pattern Framed to Framed > Configure Timeslots.
Refer to Figure 9-3. The GSM timeslot pattern is displayed on the screen.

Figure 9-3
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Oon Timeslot Tupe)
CHormall
Configure,)
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4. Press Timeslot Off On to Off.
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5. PressTimeslot # > 2 > Enter.
Press Timeslot Type > Normal.

Press Configure Normal > E > Multiframe Channel > TCH/FS > PN9 or PN15.

NOTE If the default training sequence (TSCO) does not match the training sequence sent by the
BTS, pressReturn > Return > TS and select the proper training sequence.

6. PressReturn > Return > Return > Timeslot Off On to On.

7. PressTimeslot# > 1 > Enter.
Press Timeslot Type > Normal > Configure Normal > E > Multiframe Channel > TCH/FS > PN9 (or PN15).
Press Return > Return > Return > Timeslot Ampl Main Delta to Delta > Timeslot Off On to On.
Repeat these steps for timeslot 3.

8. Press Amplitude > More (1 of 2) > Alternate Amplitude > Alt Ampl Delta > 50 > dB.

9. To set up traffic channel 124 in GSM mode:
Press Frequency > More (1 of 2) > Freq Channels.
Press Device (BTS MS) to MS > Channel Band > GSM/EDGE Bands > P-GSM Mobile.
Press Freq Channels Off On to On.
Press Channel Number > 124 > Enter.

Refer to Figure 9-4. The active entry area displays the following:
Channel : 124 (914. 80000000MHz)

Chapter 9 261



BERT
Measuring RF Loopback BERT with Option 300

Figure 9-4
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10. Press Amplitude > —95 > dBm.

The amplitude can also be set using an Amplitude softkey, located in the Baseband BERT softkey menu, that
is accessed by pressing the Aux Fctn > BERT > Baseband BERT softkeys.

11. Press Mode Setup > RF On/Off.

Refer to Figure 9-5. The screen now displays channels 1, 2, and 3 turned on and channels 1 and 3 with a
50 dB alternate amplitude setting. Also, the RF annunciator is turned on, and the new power level is

shown in the amplitude area of the display.

Figure 9-5
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Synchronizing to the BCH Then the TCH

The following steps show you how to synchronize to the broadcast channel (BCH). Set up the base station
and start sending the BCH signal now. The BCH is only required to contain the synchronization logical
channel (SCH).

1. Follow the instructions under “ Configuring GSM Mode on the Agilent Technologies E4406A V SA
Series Transmitter Tester” and “ Configuring GSM Mode on the ESG Vector Signal Generator” in this
chapter, to prepare the test equipment for synchronization.

2. Press Aux Fctn > BERT > BTS BERT GSM Loopback.

3. Press Sync Source BCH TCH/PDCH to BCH.

4. Press GSM BERT Off On to On > Synchronize to BCH/TCH/PDCH. Refer to Figure 9-6 on page 263. You will
briefly see Synchr oni zi ng t o BCHflashing on the display.

Figure 9-6
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Once synchronization is achieved, the ESG will expect to receive aTCH to decode and, accordingly, will
display theVi ti ng for TCHmessage. Refer to Figure 9-7.
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Figure 9-7
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5. Turn off the BCH signal. and set up the base station to send the TCH signal.

6. Set up the base station and start sending the TCH signal now. The TCH isonly required to contain a

valid midamble.

7. Onthe ESG, press Configure Measurement > Timeslot # > 2 > Enter.

This sets the ESG to expect the TCH in timeslot 2.

8. PressReturn > Synchronize to BCH/TCH/PDCH to begin synchronization to the TCH.

NOTE For the EDGE format, do the following to achieve TCH Sync Lock:
Press Configure Measurement > Timeslot # > 2 > Enter > Return > Adjust Gain.

Thenyouwill see Synchr oni zi ng t o TCHflashing on the display followed by the Synchr oni zi ng

t o PNmessage.
Once synchronization is achieved, the Ready TCH Sync Lock messageis displayed. Refer to Figure
9-8.
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Figure 9-8
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Synchronizing to the TCH

The following steps show you how to synchronize to the traffic channel. The TCH is only required to
contain avalid midamble. If appropriate for your base station, this synchronization can be performed
without prior BCH synchronization.

NOTE If the base station is transmitting a BCH signal, turn it off at thistime.

1. Follow the instructions under “ Configuring GSM Mode on the Agilent Technologies E4406A V SA
Series Transmitter Tester” and “ Configuring GSM Mode on the ESG Vector Signal Generator” in this
chapter, to prepare the test equipment for synchronization.

2. Set up the base station and start sending the TCH signal now. The TCH isonly required to contain a
valid midamble.

On the ESG, press Aux Fctn > BERT > BTS BERT GSM Loopback.
4. Press Sync Source BCH TCH/PDCH to TCH/PDCH.
Press Configure Measurement > Timeslot # > 2 > Enter.

This sets the ESG to expect the TCH in timeslot 2.
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6. PressReturn > GSM BERT Off On to On.

NOTE If the following error message is generated:
522 Denodul at or Unl evel ed; | nput anplitude underrange

thisindicates that the TCH signal is not being received.

7. Press Synchronize to BCH/TCH/PDCH to begin synchronization to the TCH.

Thenyouwill see Synchr oni zi ng t o TCHflashing on the display followed by the Synchr oni zi ng

t o PNmessage.
Once synchronization is achieved, the Ready TCH Sync Lock messageis displayed. Refer to Figure
9-9.
Figure 9-9
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Making Loopback BERT Measurements

The following procedure shows you how to configure the frame count, set pass/fail limits and set early stop

criteriafor loopback BERT measurements.

1. Press Configure Measurement > Measurement Mode BER/BLER% Search to BER/BLER%.

2. Press BER/BLER% Configure > BER% TCH/FS Configure.

3. PressFrame Count > 100 > Enter.
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4. PressPass/Fail Limits > Class Il RBER > 2 > %,

5. PressReturn > Threshold # of Events to Stop > Class Il Bit Error > 300 > Enter.

Notice that the Class Il Bit Error softkey is highlighted, 300 eventsis displayed beneath the softkey, and

Stop Thrs: d1(300) appearsin the status area of the display.

Figure 9-10
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6. Pressthe Trigger hardkey to start the measurement:

You will see Pass or Fai | displayed on the lower left corner of the screen, when either of the following

OCCurs:

¢ The measurement completes normally; in this case, after 100 frames.

* The measurement terminates early, due to the designated number of eventsto stop being reached.

Refer to Figure 9-11 on page 268.
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Figure 9-11
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NOTE To select an aternate trigger mode (for example, Immediate):

Press Return three times, then press Configure Triggers >

BERT Trigger Source > Immediate.

Using Amplitude Sensitivity Search

This procedure shows you how to set a pass amplitude with high and low amplitude boundaries, and how to

set both the target error percentage, and the frame count for an amplitude sensitivity search.

1. Press Aux Fctn > BERT > BTS BERT GSM Loopback.

2. Press Configure Measurement > Measurement Mode BER/BLER% Search to Search.

Notice that the Configure Sensitivity Search and Arm Sensitivity Search softkeys are enabled.

3. Press Configure Sensitivity Search to access the softkey menu for configuring the sensitivity search. Refer

to Figure 9-12 on page 2609.
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Figure 9-12
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Press Frame Count > 100 > Enter.
Press Target % > 2 > %.
Press Pass Amplitude > —95 > dBm.

Press High Amplitude > -86 > dBm.

© © N o 0 &

Press Low Amplitude > -104 > dBm.

Press Return > Arm Sensitivity Search. Sensitivity search is now armed, refer to Figure 9-13.
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Figure 9-13
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10. Press Trigger to start the measurement:

After the search is complete, Pass or Fai | isdisplayed on the lower |eft corner of the screen, when

either of the following occurs:

e Theresult equals or isless than the target percent within the high to low amplitude range.

e Thehigh or low amplitude level is passed at the target% BER/RBER.

Refer to Figure 9-14.
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Figure 9-14

CHAMMEL FRECQLEMCY Stop Sensigiuitg

124 914.80000 mz | -95.00 o

EXT REF ash AF | noo
ARHED BERT EHULP| I/0 OH | OH

SM Frame Count: 100 Timeslot #2 BERT Trigoer: Keu
Target X: 2.00003 Search Class: CIT
BERT ras= Amo1:-95.00dem Lo Amel:-105.00dBm

on
Sanplaes Evants RBER
Frame 0 Frame
Class Ib 0 Bits 0 Bits 0.0000 *
Class II 0 Bits 0 Bits 0.0000 *
Haiting for Trigger PASS Oownlink Errar Last Result
TCH Sunc Lock 0 Frames -97.6 dBn

Sensitivity Search Armed, KEY trigoer, DCL or STOP to abort

11. Press Stop Sensitivity Search to terminate a measurement:

NOTE To select an aternate trigger mode (for example, Immediate):

Press Return > Configure Triggers > BERT Trigger Source > Immediate.

NOTE For efficiency, the search routine uses shorter measurements initially with the final
measurements being over the frame length selected.
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Using the External Frame Trigger Function with the EDGE Format

NOTE This function is available only when the Frame Trigger Source BCH PDCH is set to PDCH.

The External Frame Trigger Function is used to adjust the burst timing at PDCH synchronization. This

requires calculating a delay value and then adjusting the initial value.

Measuring the Initial Delay Value

1. Configurethe BTS and the VSA setup. Refer to Figure 9-15.

Figure 9-15 System Configuration for Measuring External Delay Value
BTS
Frame
Trigger Out
e N
Rx =

e = =ER=-
Tx Ext Trigger  |[° VSA ESl58 g2,

e = Q8.

Olo oo oooo|==E=

5

Onthe VSA, press Mode > EDGE w/GSM.
Press Measure > Waveform (Time Domain).
Press Meas Setup > Trig Source > Ext Front.

Press Makers.

N o g b~ w DN

Set up the BTS to transmit the frame trigger EDGE burst at timeslot O.

and the starting edge of the midamble. Refer to Figure 9-16 on page 273.

RF INPUT

Use the marker function to find the offset value (D), in microseconds, between the BTS frame trigger

272



BERT
Using the External Frame Trigger Function with the EDGE Format

Figure 9-16
D
>
X | 227.8usec _i
. ¥ |
" 2
BTS Ftrg I |
BTS RF

X Actual Timing gap between Frame trigger and RF Start point of midamble

0 (Beginning of burst signal)

measure_delay

8. Calculate the offset value X using the following equation:
X(symbols) = (D —227.8)/3.693
Where, in the EDGE mode, 3.693 usis equal to 1 symbol.
Adjusting the Delay Value

1. Configurethe ESG, BTS, and V SA setup. Refer to Figure 9-17 on page 274.
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Figure 9-17
PATT 321.4 MHz
TRIG 1omMHz ouT|  |\F out EXT REF IN
IN 321.4IN  J10MHz IN J ~
o S lcoooog
I == IEEEE
=00 aog
VSA E|35..55°
o = (9888
.e oooooo
RF OUTPUT Bla oo cooa| = RF INPUT
-—

13 MHz Ref =\

R
\.
EXTERNAL FRAME
TRIGGER
BTS

bts_loopback

Press Aux Fctn > BERT > BTS BERT EDGE Loopback.
Press EDGE BERT to On > Configure Triggers.
Press Frame Trigger Source BCH PDCH to PDCH.

Press Configure Triggers > Frame Trigger Source Int Ext to Ext.

o 0 M 0w N

Press Ext Frame Trigger Delay and enter the X value calculated in the previous section.

NOTE If the frame trigger isin the forward direction of timeslot 0, as shown in Figure 9-16 on
page 273, enter the X value as a negative value.

7. PressReturn > Synchronize to BCH/PDCH.

Synchronization should occur and display a Ready status. However, if Synchr oni zi ng keepsflashing
or the Ready status appearsfor lessthan a second, increase or decrease the delay value by 2 symbols and
press the Synchronize to BCH/PDCH softkey again. Repeat this process until the Ready status
(synchronization) becomes stable.
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8. Press Configure Triggers > Ext Frame Trigger Delay.

9. Change the delay value by rotating the knob slowly to find the range of delay values that display a
Ready status.

NOTE Although the delay value can be entered in 0.25 units, the actual uplink burst position can
be changed in 1.0 symbol units.

10. If the PDCH is synchronized by adelay value within a+3 symbol range, choose the center valueto set as
the frame trigger delay.
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Bit Error Rate Tester—Option UN7

The bit error rate test (BERT) capability allows you to perform bit error rate (BER) analysis on digital
communications equipment. This enables functional and parametric testing of receivers and components
including sensitivity and selectivity.

Block Diagram

When measuring BER, a clock signal that corresponds to the unit under test (UUT) output data must be
input to the BER CLK IN connector. If the clock is not available from the UUT, use the DATA CLK OUT
signal from the ESG baseband modulator.

Figure 9-18
ESGC
signal generator
Unframed
RF signal
RFsignal | RF OUTPUT with PRBS uuT
source 14% > (digital
demodulator)
A
Baseband |oTACLKOUT Demodulated
modulator | DATA OUT ﬂ data (PRBS)
—b
) BER CLK IN
rgt'ifg:t; BER DATAIN Level
UN7 CLK GATE IN matching

blk-dia_esg-c

Clock Gate Function

When you use the clock gate function, the clock signal to the BER CLK IN connector isvalid only when the
clock gate signal to the BER GATE IN connector is ON.

Press the Clock Gate Off On softkey to toggle the clock gate function off and on.The Clock Gate Polarity Neg Pos
softkey sets the input polarity of the clock gate signal supplied to the rear panel BER GATE IN connector.
When you select Pos (positive), the clock signal is valid when the clock gate signal is high; when you select
Neg (negative), the clock signal is valid when the clock gate signal is|ow.
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The following figure shows an example of the clock gate signal.

Figure 9-19

Clock Gate Signal to
the BER GATE IN:

s LI LI

Data Signal to
the BER DATA IN:

*  When the Clock Gate Off On softkey is set to Off:

The clock signal in both“A” and “B” partsis effective and no gate function is required. Therefore, the
bit error rate is measured using the clock and data signal in both “A” and “B” parts.

* When the Clock Gate Off On softkey is set to On, and the Clock Gate Polarity Neg Pos softkey is set to Pos:

The clock signal in“A” part is effective. Therefore, the bit error rate is measured using the clock and
datasignalsin“A” part.

*  When the Clock Gate Off On softkey is set to On, and the Clock Gate Polarity Neg Pos softkey is set to Neg:
The clock signal in “B” part is effective. Therefore, the bit error rate is measured using the clock and
datasignalsin“B” part.

Clock/Gate Delay Function

This function enables you to restore the timing relationship between the clock/gate timing asit passes
through the unit under test (UUT) and the packet data.

The shifted clock signal is emitted from pin 20 of the AUX 1/O rear panel connector. When you use the
clock delay function, the clock signal to the BER CLK IN connector is delayed by the clock delay function.
When you use the gate delay function with the clock gate function, the clock signal is gated by the gate
signal which is delayed by the gate delay function.

To seethe signa flow using the clock and gate functions, refer to Figure 9-20.
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Figure 9-20

Signal Flow

! (LEfGHTE Belay Tunctien '
: CLK Delog il :

hi{

GATE onort
“W BER_TEST OUT

i
H
BER_CLKIN [+

OTSMHZ  Divider

@m_

GATE Delay covmel
hifl regi

1

,
BER_GETE IN |;
;
i
i
:

Clk L
Tima i

GATEzanpling
chock £e kot

Clock Delay Function

In this example, the clock delay function is off. Figure 9-21 shows the input of the internal error detector of
UN?7 through AUX 1/O and indicates that the datais delayed from the clock.
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Figure 9-21

CH1

CH2

CH1: BER TEST OUT (pin 20 of AUX 1/O connector)
CH2: BER MEAS END (pin 1 of AUX 1/O connector)

In this example, the clock delay functionis on. Therising edge of the clock was delayed by 200 ns and was
adjusted to the center of the data. Figure 9-22 indicates the result of the using the clock delay function.

Figure 9-22

CH1

CH2
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Gate Delay Function in the Clock Mode

To use this function, the clock must be set to continuous mode.

In this example, the clock is used to delay the gate function. The clock of the internal error detector was
gated by the gate signal which isdelayed by two clocks. Figure 9-23 shows that CHO and CH1 are the input
of the clock and data from the rear panel input connectors of UN7. CH2 isthe gated clock through the AUX
I/O connector.

Figure 9-23

CHO

CH1

CH2

CHO: BER CLK IN (rear panel SMB connector)
CH1: BER GATE IN (rear panel SMB connector)
CH2: BER TEST OUT (pin 20 of AUX 1/O connector)

Triggering

This section describes the operating principles of the triggering function for Option UN7. To see the signal
flow of the triggering function refer to Figure 9-24.
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l

FM Generator

h J

Drata

BERT

Bit Error Rate Tester—Option UN7

Triaqer

l ....... .......

Trigger Controler

Counter
Ensble

Errar Detector

Errar Bit Counter

F

Total Bit Counter

In this example, the triggering sequence is where you have an incoming data clock and data bit sequences,
the trigger is active, and the BERT measurement begins. Refer to Figure 9-25.
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Figure 9-25

i Trigger
PRBS=PN9 = G
Sync Start
MMM ““““““
Deta 1 1 1 1 O SRPOPPoee

i

Store (9bits) { Compare
Internal SW PH Generator —
(@ -> (b) [Shift Register)

]

Start to -_—|_’—|_|_|_|_|_|7 ““““““

Qqenerate

In this example, synchronization occurs after receiving atrigger.

The reference datais generated by stored data bits. If the BERT measurement accepts data bits immediately
after receiving atrigger, set the trigger delay to On and the trigger delay count to a value corresponding to
the data format. For PN9 set the delay to 9. Refer to Figure 9-26.

Figure 9-26
PRBS = PN9
Sync Start
...........
Data I L N T

Store (9bits)
P Generator internal SW
(Shift Register) (B} -> {b)

N
Start to

generate

Trigger Delay

{9 Bits)

In this example, the triggering sequence is where the trigger delay is active with a cycle count.
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The reference datais generated by stored data bits. If the BERT measurement accepts data bits immediately
after receiving atrigger, set the trigger delay to On and the trigger delay count to a value corresponding to
the dataformat. For PN9 set the delay to 9. If the cycle count is set to more than 1, it is not necessary to store
data bits and no unnecessary delay occurs. Refer to Figure 9-27 and “Repeat Measurements’ on page 284.

Figure 9-27

2nd cycle or after :
PRBS = PN9 B

Data Clock

Sync Start

FR Generator

e
i Generate
hd
—|_’—|_|_L —L'—U_LM ........
Trigger Delay
T T@sis)” T

Data Processing

Data Rates

Data rates up to 60 MHz are supported for BERT analysis on un-framed or framed PN sequences. Note that
the BERT analyzer supports only continuous PN sequences.

Synchronization

Immediately after the trigger event, the DSP for the BERT measurement tries to establish synchronization
using the first incoming bit stream.

If the Bit Delay Off On softkey is set to On, the number of bits specified by the Delayed Bits are ignored. The
synchronization checking is repeated using an error-free bit string, lengthened by the Delayed Bits, until
synchronization is established.

When the BERT Resync Off On softkey is set to On, the BERT measurements will automatically be restarted if
the intermediate BERT measurement result exceeds the value specified by the BERT Resync Limits.
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Special Pattern Ignore Function

The special pattern ignore function is especially useful when performing BERT analysis on radios that
generate consecutive 0's or 1's data for traffic channels when they fail to detect the Unique Word or lose
synchronization. If 160 or more consecutive incoming data bits are either 1'sor 0's, and the Spcl Pattern
Ignore Off On softkey is set to On, then all of the consecutive O's or 1's are ignored. Select either O's or 1'sas
the data to ignore by using the Spcl Pattern 0’s 1's softkey. The following figure shows an example of the
specia pattern ignore function.

Figure 9-28

‘ 160 bits of consecutive 1's

010011111 ...... 111111111111110100

Data to be ignored

spignore

The 160 or more ignored bits can be anywhere in the PN sequence. The signal generator ignoresthese bitsas
error, but they are counted in the PN sequence bit count.

Pass/Fail Judgement

There are two pass/fail judgement update modes: cycle end and fail hold. With cycle end selected, either
pass or fail judgement is made for the results of each measurement cycle. With fail hold selected, the fail
judgement is retained whenever a failure occurs during one loop of BERT repeat measurements. Fail hold
mode allows you to determine when afailure occurs at least once during an entire cycle of measurements.

Repeat Measurements

When the Cycle Count softkey is set to more than 1, the synchronization performed before the start of each
measurement is only executed the first time; then it keeps track of the clock signal and the PRBS generation
for the incoming data. This function can reduce the total time for BERT measurements. Also, once
synchronization is established, it isretained even if the BERT measurement result degrades. You may wish
to adjust the signal level to find a specific BERT value. However, once synchronization islost in arepeat
sequence, it will not be restored until the initiation of a new sequence. The following figure shows an
example of the repeat measurements.
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Cycle Count =1

Cycle Counter : 1/1 1/1

BERT
Bit Error Rate Tester—Option UN7

1/1

|D|S| Meas. L IDISI Meas. |,,|D|s| Meas. o |D|S| Meas.
Trigger Event : * * * *
Cycle Count =N
Cycle Counter : 1/N 2/N 3/N N/N
IDIS . Meas. N IJ_)I Meas 1__|Dl Meas. | IDI Meas |
Trigger Event : * * + *

D: Delay time

S: Synchronization

Testing Signal Definitions

repeatl

The timing diagram Figure 9-30, “ Testing Signal Definitions,” shows the relationships between a trigger
event and the output signals at the BER MEAS END and BER TEST OUT connectors.

If aBER MEASEND signal stays high following atrigger event, the BERT measurement isin progress and

other trigger events are ignored. This state is stored in the status regi

ster and can be queried.

Figure 9-30 Testing Signal Definitions
T1 T2 T3
Trigger Event
(Bus/Trigger Key/Ext.)
BER MEAS END Nth-1 \ Nth measurement J
BER TEST OUT Result of Nth - 1 Result of Nth

timing
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« Tlisafirmware handling time measured from a Trigger event to the rising edge of aBER MEAS END
signal.

» T2isafirmware handling time measured from thefalling edge of aBER TEST OUT signal to thefalling
edge of the BER MEAS END signal.

e T3isaminimum requirement time measured from the falling edge of the BER MEAS END signal to the
next trigger event. T3 should be greater than 0 second.

The pulse output of the BER TEST OUT for the Nth-1 test result ends prior to the falling edge of the BER
MEAS END signal for the Nth measurement; so you can use this edge to start latching the Nth test result.
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RF Loopback BER-Option 300

Synchronization

Synchronizing the test equipment to the base transceiver station (BTS) is a prerequisite to the BTS looping
back the selected traffic channel (TCH). This can be achieved in two ways: BCH Sync or TCH Sync.

BCH Sync

TCH Sync

The BTSis set to transmit to the test equipment a BCH on timeslot 0 of a selected
absolute radio frequency channel number (ARFCN). The test equipment uses the BCH
signal to determineits required TCH transmit timing.

On completion, the BTS may be switched into loopback mode on any selected ARFCN
and timesl ot number.

Thisisavery quick mode of synchronization, but take care initially to set the receiver to
the correct timeslot number being transmitted by the BTS.

In this mode the base station must transmit asignal on the selected timeslot prior to data
being looped back. In some base stations thiswill happen as soon as atimeslot is set to
loopback, regardless of whether the signal to the BTS has the correct timing. In other
base stations, the BTS may need to be set to transmit asignal in the selected timeslot
prior to achieving synchronization.

The test equipment can lock to this signal if it contains the correct midamble. Once
synchronized, the test equipment uses this information to determine the required TCH
transmit timing. If the BTS is set accordingly, any timeslot can be transmitted with the
correct timing to enable it to be looped back by the BTS to the receiver (VSA/ESG).

NOTE

The TCH sync mode relies on the user to set the correct timeslot number into both ESG
transmitter and receiver during synchronization. Thereafter, the ESG can correctly test any
timeslot sinceits relative timing is defined.

This capability can be used to speed up testing of consecutive timeslots in manufacture.
TCH sync mode can be used to test all timeslots consecutively without changing asingle
setting on the ESG/V SA. All that is required is to consecutively loopback each timeslot
using the BTS man-machine interface (MMI) and resynchronize and trigger the ESG.

PN synchronization is also a prerequisite to BERT measurements. This is automatic but is dependent on
prior BCH or TCH synchronization.

The pattern to be recognized (PN9 or PN15) is determined by the corresponding transmit timeslot pattern

selection.
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Erased Frame Detection

When an incorrect CRC in an uplink speech frame is detected by a BTS conforming to the GSM standards,
the BTS substitutes an all-zero speech frame.

In the loopback mode, the BTS transmitter then recodes this substituted zero speech frame before
transmission back to the test equipment receiver (VSA/ESG).

The ESG receiver detects any coded all-zeros speech frames in the returned downlink signal and increments
the (erased) frame event count.

Downlink Errors

The loopback method of measuring BTS receiver BERT quality requires a high quality downlink return path
which introduces no errors.

To cater for the situation where the downlink path is faulty, the V SA/ESG provides a measure of downlink
quality based on TCH payload errors detected by convolutional decoding of the return path. This records
errorsintroduced into the TCH between the downlink coding (BTS transmitter) and decoding (V SA/ESG)
processes and should normally be zero. For any payload errors detected during a measurement, the
measurement is extended by a speech frame for every downlink error detected.

If adownlink problem resultsin errorsintroduced into the downlink midamble, the measurement aborts,
providing further security against downlink problems.

Frame Structure

GSM Frame Structure

26-frame TCH multiframe structure.
Frames: Frame 12 (SACCH) and frame 25 (idle) empty.
Identical repetitive frames. Content as per ESG GSM capability.

GSM Received Data

The Table 9-1 shows the minimum requirements for the GSM received data frame structure during
synchronization to the BTS and during measurements.

Table 9-1 GSM Received Data

During BCH Synchronization

TS0 51-frame BCH Multiframe Structure

SCHinframes1, 11, 21, 31, 41
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Table 9-1 GSM Received Data (Continued)

During BCH Synchronization

TS1-7 No SCH, but otherwise, don't care

During TCH Synchronization

TSX 26-frame TCH Multiframe Structure

Frame 25idle

Frame 12 don't care

Other frames TCH

During Measurements

Timeslot under test 26-frame full-rate voice TCH Multiframe Structure

TCH Content determined by transmitted signal (looped by BTS except
Frames0-11, 13-24 | for errored speech frames, i.e. speech frames with bad CRC)

Frames 12, 25 Don’'t care

GSM Transmit Data

The minimum GSM transmit data requirements for the loopback test are a fully GSM-coded 26-channel
multiframe with either PN9 or PN15 in the payload. Thisis selected on the ESG by setting the timeslot
under test to normal and selecting the PN9 or PN15 multiframe PN pattern.

To meet the GSM standards requirementsfor full conformance, the adjacent timeslots should be loaded with
fully GSM-coded data. The ESG offers full flexibility of loading all timeslots.

Edge Frame Structure
52-frame PDCH multiframe structure.

Frames: 12 blocks of 4 frames, 2 idle frames, and 2 frames used for the PTCCH.
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Verifying BERT Operation

This procedure verifies the operation of the signal generator’s bit error rate test (BERT) function. This test
can be performed as part of adaily validation routine or can be used whenever you want to check the validity
of your BERT measurements. This procedure only checks the signal generator’s BERT operation and does
not ensure system performance to specifications.
Verification Setup
The following steps set up the signal generator for the BERT measurement validation.
1. Refer to the figures below and make the following connections on the signal generator’s rear panel.

e DATA QOUT (Aux |/ Oconnector pin 8) to BER DATA IN (SMB connector).

« DATA CLK QUT (Aux |/ Oconnector pin 7) to BER CLK IN (SMB connector).

DIGITAL
B

)i

pk704c
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AUX 1/0 Pin Configuration

GND —

GND —

GND —

GND —

PARALLEL DATA 2*—
PARALLEL DATA 3*—
PARALLEL DATA 4*—
PARALLEL DATA 5°—
PARALLEL DATA 6*—
PARALLEL DATA 7*—
GND —

GND —

GND —

GND —

GND —

BER MEAS TRIG / BER NO DATA —
BER ERR OUT —
BER TEST QUT —

w
~

Y
o\
QOOOOC'OOCOO—j
<)

0000000

Scooco0oo0oo0oo00O0
OC0000O0O0O0

—EVENT 3
—EVENT 4
—BATT TRIG IN 2
— ALT PWR IN
PARALLEL DATA 17
—GND
—GND
—GND
—GND
|— PARALLEL DATA 8"
— PARALLEL DATA CLK*
|— DATA OUT l—
|— DATA CLK OUT ~lf———
[— S¥M SYNC OUT
|—BER SYNC LOSS
—GND (BER)  —f———
—GND (BER)  -wl——
BER MEAS END

View looking into
rear panel connector

Press the Mode hardkey.

Press the Aux Fctn hardkey.

{’M

!
\=

Press Real TDMA > PHS > Data Format to Pattern.
Press Data > PN Sequence > PN9 > PHS Off On to On.

* Future Capability

The following steps configure BERT measurement parameters.

8. Press Configure BERT > Total Bits to 100000 > Special Pattern Ignore Off On to Off.

9. Press More (1 of 2) > BERT Resync Off On to Off > Pass/Fail Off On to Off.

10. Press Return > 1/0 Setup > Gate Off On to Off > Impedance 75 Ohm High to High.

Press the Preset hardkey. This configures the signal generator to a pre-defined state.

Press BERT > BERT Off On to On > Display BER % Exp to % > Display Update Cycle End Cont to Cont.

11. Press Polarity Setup > Clock Polarity Pos Neg to Neg > Data Polarity Pos Neg to Pos.

12. Press Return > Return > Configure Trigger > Cycle Count 0 > Enter.
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13. Press Bit Delay Off On to Off > BERT Trigger to Trigger Key.

14. Press the Trigger hardkey. The following figure shows the signal generator’s front-panel display after
completion of the these steps.

FREQLEMCY AMPLITUCOE BERT Tri
4.000000000 00 &= | -136.00 @n | i i
B
BERT 1/0 OH
‘ Cucle Count
BER Data: PNI Total Bits: 100000 Resunc: Off .
Trigger: Key lUpdate Display: Cont Clock Pol: Mea
[]n Cucle Count: O Spcl Pattern Ignore: OfFf Data Pol: Pos Bit [Oelau
Oelau: Off FUE OFF Gate: OFF on
Threshold: 1.LY ' Impedance: Hiah
Aux I/0 Out: Error Clock Delad: Off
TotalBits Error Bits BER
0Bits 0Bits 0.00000000 %
Cucle Counter
0/0
BERT Verification

1. PressBERT Trigger to Immediate.

Notice the cycle counter updating in the lower left-hand corner of the signal generator display.
Disconnect the cable connecting the DATA OUT to BER DATA IN connectors.

Noticethe No Dat a annunciator in the lower |eft corner of the display and the BER result is
approximately 50%. The Error Bits counter updates the error bit count. Re-establishing the connection

turns the annunciator off, and sets the error bits count to 0 bits and BER 0.00000000%.

Disconnect the cable connecting the DATA CLK OUT to BER CLK IN connectors.

Noticethe No O ock annunciator in the lower left corner of the display. This annunciator turns off
when you re-connect the cable, but the error bits counter and BER % readings indicate | oss of
synchronization.
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4. PressReturn.

Toggle the BERT Off On softkey to Off and to On. You will see the new BER result as shown in the
previous front-panel display with the Error Bits counter reading O Bits and BER 0.00000000%.

If the verification procedures produce the expected results, then the signal generator BERT measurement
function is operating correctly. If the above procedure produces unexpected results, then contact the Agilent
Service Center. For alist of Agilent Service Centers, refer to the E4428C/38C ESG Sgnal Generators
Installation Guide.
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Thisfeature is available only in E4438C ESG Vector Signal Generators with Option 001/601or 002/602.
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cdma2000 Forward Link Modulation for Component Test

This section teaches you how to build forward link cdma2000 waveforms for testing component designs.
The waveforms are generated by the signal generator’sinternal dual arbitrary waveform generator.

Activating a Predefined CDMA Forward Link State
This procedure teaches you how to perform the following tasks:

» “Selecting acdma2000 Forward Link Predefined Setup” on page 296
* “Generating the Waveform” on page 296
» “Configuring the RF Output” on page 296

Selecting a cdma2000 Forward Link Predefined Setup

1. PressPreset.

2. Press Mode > CDMA > Arb CDMA2000.

3. Press CDMA2000 Select > Pilot.

This selects a pilot cdma2000 forward link waveform. The display changesto PAD CDVA2000 Set up:
SR1 Pil ot . Forward link isthe default setting for link direction, and therefore does not need to be set.
Generating the Waveform

Press CDMA Off On until Onis highlighted.

This generates the predefined pilot CDMA forward link waveform. During waveform generation, the CDVA
and | / Qannunciators appear and the waveform is stored in volatile Arb memory. The waveform is now
modul ating the RF carrier.

Configuring the RF Output

1. Set the RF output frequency to 2.17 GHz.
2. Set the output amplitude to —10 dBm.
3. PressRF On/0ff until On is highlighted.

The predefined CDMA forward link signal is now available at the RF OUTPUT connector of the signal
generator.
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Creating a User-Defined CDMA Forward Link State

This procedure teaches you how to perform the following tasks:

» “Accessing the Table Editor with the Default Forward Link Setup” on page 297
e “Editing cdma2000 Forward Link Channel Parameters’ on page 297

* “Inserting Additional cdma2000 Forward Link Traffic Channels’ on page 299

Accessing the Table Editor with the Default Forward Link Setup

1. PressPreset.
2. Press Mode > CDMA > Arb CDMA2000.
3. Press More (1 of 2) > CDMA200 Define > Edit Channel Setup.

The table editor is now displayed, as shown in Figure 10-1. Notice that the default predefined channel
configuration is forward link with 9 channels at spread rate 1. The vertical scroll bar at the side of the screen
indicates that there are more rows on the second page. Use the down arrow key to move the cursor to view
additional rows.

Figure 10-1
FREQUENCY AHMPLITUDE Edit Ttem
4.000 000 000 00 &=z | -136.00 den
HHD Insert Rouw
| Oelete RAowl
Spreadino: SR1 Total Pouer: -0.00dB
Link: Foruard
Adjust
Rate Pouer PH ;
Tupe Config bps  lalsh dB Offset Data |F°de Domain Power
1 ilot  N/A o -7.00 0 00000000 DisoL

2 Paging  N/A 1 -6.72 0 RANDON Display,)
3 Traffic 3 5500 8 -12.72 0 Renoor |Code Domain Power

U SupiTrf 3 19200 17 -9.72 o RANDON
5 SUpLTrFf 3 19200 18 -9.72 o RANDOM Soto Foud
6 Traffic 3 9600 g  -12.72 o RANDOM B0 hHod

7 SupiTrf c! 19200 19 -9.72 o RANDOM

8 SuplTrf 3 19200 20 -9.72 0 RANDON
Mare
(1 of 2)

Editing cdma2000 Forward Link Channel Parameters

1. Usethearrow keysto move the cursor to the traffic channel located in table row 3.
2. Highlight the Rat e bps value (9600).
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N o o A~ W

Press Edit Item > 4800.
Highlight the Vil sh code value (8) in table row 3.
Press Edit Item > 3 > Enter.

Highlight the Power value (-12. 72) in table row 3.
Press Edit Item > -10 > dB.

The display shows that the total power isnow at 0. 19 dB. You can rescale the total channel power to

0 dB by pressing Adjust Code Domain Power > Scale to 0 dB.
8. Highlight the Dat a value (RANDOM) in table row 3.
9. PressEdit Item > 11001100 > Enter.

The forward link channel parameters have now been modified, as shown in Figure 10-2.

Figure 10-2
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10. PressReturn.

Thetext areadisplays FAD CDVA2000 Setup: SRL 9 Channel
configuration. You now have a modified traffic channel with adatarate of 4800, a Walsh code of 3 and a
power level of —10.00 dB transmitting 11001100.

To store a custom cdma2000 state, see “ Storing a Component Test Waveform to Memory” on page 304.

(Modi fi ed) asthe current
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Inserting Additional cdma2000 Forward Link Traffic Channels

1. PressEdit Channel Setup.

CDMA Digital Modulation
cdma2000 Forward Link Modulation for Component Test

2. Move cursor to the bottom row and press Insert Row > Traffic > Channels > 20 > Enter.

3. PressDone.

The channel table editor now contains the 20 additional channels. The first page displays only channels one
through nine. To see the additional channels, press the following key sequence:

Return > Goto Row > Page Up.

The display shows that the total power is now at 13.22 dB. You can rescale the total channel power to 0 dB
by pressing Adjust Code Domain Power > Scale to 0 dB.

PressReturn. The text area displays the current configuration, FAD CDMA2000 Set up: SR1 9 Channel

(Modi fi ed), asshownin Figure 10-3.

Figure 10-3
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To store a custom cdma2000 state, see “ Storing a Component Test Waveform to Memory” on page 304.
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cdma2000 Reverse Link Modulation for Component Test

This section teaches you how to build reverse link cdma2000 waveforms for testing component designs. The
waveforms are generated by the signal generator’sinternal dual arbitrary waveform generator.

Activating a Predefined cdma2000 Reverse Link State
This procedure teaches you how to perform the following tasks:

» “Selecting a Predefined cdma2000 Reverse Link Setup” on page 300
* “Generating the Waveform” on page 300
e “Configuring the RF Output” on page 300

Selecting a Predefined cdma2000 Reverse Link Setup

1. PressPreset.

2. Press Mode > CDMA > Arb CDMA2000.

3. PressLink Forward Reverse until Reverse is highlighted.

4. Press CDMA2000 Select > Pilot.

This selects a pilot cdma2000 reverse link waveform. The display changesto FAD CDVA2000 Set up:
SR1 Pilot.

Generating the Waveform

Press CDMA Off On until Onis highlighted.

This generates the predefined pilot cdma2000 reverse link waveform. During waveform generation, the
CDMA and | / Qannunciators appear and the waveform is stored in volatile Arb memory. The waveformis
now modulating the RF carrier.

Configuring the RF Output

1. Set the RF output frequency to 2.17 GHz.
2. Set the output amplitude to —10 dBm.
3. PressRF On/0ff until On is highlighted.

The predefined cdma2000 reverse signal is now available at the RF OUTPUT connector of the signal
generator.

300 Chapter 10



CDMA Digital Modulation
cdma2000 Reverse Link Modulation for Component Test

Creating a User-Defined cdma2000 Reverse Link State

This procedure teaches you how to perform the following tasks:

» “Accessing the Table Editor with the Default Reverse Link Setup” on page 301
e “Editing cdma2000 Reverse Link Channel Parameters’ on page 301

* “Inserting Additional cdma2000 Reverse Link Traffic Channels’ on page 302

Accessing the Table Editor with the Default Reverse Link Setup

1. PressPreset.

2. Press Mode > CDMA > Arb CDMA2000.

3. PressLink Forward Reverse until Reverse is highlighted.
4. Press More (1 of 2) > CDMA200 Define > Edit Channel Setup.

The table editor is now displayed, as shown in Figure 10-4. Notice that the default predefined channel
configuration isreverse link with 5 channels at spread rate 1.

Figure 10-4
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Editing cdma2000 Reverse Link Channel Parameters

1. Usethearrow keysto move the cursor to the traffic channel located in table row 3.
2. Highlight the Rat e bps value (9600).
3. PressEdit Item > 4800.
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4. Highlight the Power value (—17.36) in table row 3.
5. PressEdit Item > -10 > dB.

The display shows that the total power isnow at 0. 34 dB. You can rescale the total channel power to
0 dB by pressing Adjust Code Domain Power > Scale to 0 dB.

6. Highlight the Dat a value (RANDOM) in table row 3.
7. PressEdit Item > 00110011 > Enter.

The forward reverse channel parameters have now been modified, as shown in Figure 10-5.

Figure 10-5
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8. PressReturn.

Thetext areadisplays RVS CDVA2000 Setup: SRL 5 Channel (Mbdified) asthecurrent
configuration. You now have amodified traffic channel with adatarate of 4800 and a power level of —10.00
dB transmitting 00110011.

To store a custom cdma2000 state, see “ Storing a Component Test Waveform to Memory” on page 304.

Inserting Additional cdma2000 Reverse Link Traffic Channels

1. PressEdit Channel Setup.
2. Move cursor to the bottom row and press Insert Row > Supplemental? Traffic.

3. PressDone.
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The channel table editor now contains the an additional supplemental2 traffic channel.

The display showsthat the total power isnow at 1.37 dB. You can rescale the total channel power to 0 dB by
pressing Adjust Code Domain Power > Scale to 0 dB.

Press Return > Return.
The text area displays the current configuration, RVS CDMA2000 Setup: SR1 5 Channel
(Modi fi ed), asshownin Figure 10-6.

Figure 10-6
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To store a custom cdma2000 state, see “ Storing a Component Test Waveform to Memory” on page 304.
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Storing a Component Test Waveform to Memory
In this section, you will learn how to store the component test waveform.

1. PressMode Setup hardkey to return to the top-level menu.
2. Perform the following keypress sequence required for your format type.

For CDMA2000 Waveform Format

a. PressMore (1 of 2) > CDMA2000 Define (Multicarrier Define when Multicarrier Off On is On) > Store Custom
CDMA State (Store Custom Multicarrier when Multicarrier Off On is On) > Store To File.

If there is already afile name occupying the active entry area, press the following keys:
Edit Keys > Clear Text

b. Using the aphabetic menu and the numeric keypad, enter the file name using a maximum length of
23 characters.

C. Pressenter.

For CDMA Waveform Format

a. Press CDMA Define (Multicarrier Define when Multicarrier Off On is On) > Store Custom State (Store Custom
Multicarrier when Multicarrier Off On is On > Store To File.

If there is already afile name occupying the active entry area, press the following keys:
Edit Keys > Clear Text

b. Using the aphabetic menu and the numeric keypad, enter the file name.

c. PressEnter.

Your user-defined CDMA state file is now saved to the signal generator memory.

NOTE The RF output amplitude, frequency, and operating state settings are not stored as part of a
user-defined CDMA statefile.
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Recalling a Component Test Waveform

In this section, you will learn how to recall a component test waveform.

1. PressMode Setup hardkey to return to the top-level menu.

2. Perform the following keypress sequence required for your format type.

For CDMA2000 Waveform Format

a

Press CDMA2000 Select > Custom CDMA2000 State (Custom CDMA2000 Multicarrier when Multicarrier Off
OnisOn).

Highlight the desired file.
Press Select File.
Press CDMA2000 Off On until On is highlighted.

For CDMA Waveform Format

a

b.

C.

d.

Press Setup Select > Custom CDMA State (Custom CDMA Multicarrier when Multicarrier Off On is On).
Highlight the desired file.
Press Select File.

Press CDMA Off On until On is highlighted.

The firmware generates the user-defined CDMA waveform in volatile memory. After waveform generation,
the user-defined CDMA state is available to be modulated on the RF output.
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Creating a Custom Multicarrier cdma2000 Waveform

The signal generator provides a quick and easy way to create custom multicarrier cdma2000 waveforms:
rather than building an entire 4-carrier setup from scratch, you can start with a4-carrier cdma2000 template
and modify the template’s default values as desired.

This section teaches you how to perform the following tasks:

“Opening the Multicarrier cdma2000 Setup Table Editor” on page 306
“Modifying a Multicarrier cdma2000 4-Carrier Template” on page 307
“Activating a Custom Multicarrier cdma2000 Setup” on page 308
“Storing a Component Test Waveform to Memory” on page 304
“Recalling a Component Test Waveform” on page 305

Opening the Multicarrier cdma2000 Setup Table Editor

1. PressPreset.
2. Press Mode > CDMA > Arb CDMA2000 > Multicarrier Off On until On is highlighted.
3.
4

Press CDMA2000 Select > 4 Carriers.

. Press More (1 of 2) > Multicarrier Define.

This opens the Multicarrier cdma2000 Setup table editor. The 4-carrier cdma2000 template is automatically
placed in the table editor, as shown in Figure 10-7 on page 307.
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Figure 10-7

CDMA Digital Modulation
Creating a Custom Multicarrier cdma2000 Waveform
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Modifying a Multicarrier cdma2000 4-Carrier Template

Use the tasks to modify the standard 4-carrier cdma2000 template that was |oaded in the previous procedure.

1
2
3
4.
5
6

Highlight the second channel carrier in table row 2.

PressEdit Item > SR3 Direct Pilot.
Highlight the value —625. 000 kHz inthe Fr equency O f set field.

Press Edit Item > —825 > kHz.
Highlight the value 0.00 dB in Power field of the second row.

Press Edit Item > -10 > dB.

This modifies the 4-carrier cdma2000 template, as shown in Figure 10-8 on page 308.
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Figure 10-8
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Activating a Custom Multicarrier cdma2000 Setup

Using the custom 4-carrier cdma2000 setup from the previous procedure, perform the following task to

activate the custom multicarrier cdma2000 signal .

1. PressReturn > More (2 of 2) > CDMA2000 Off On until Oniis highlighted.

2. PressRF On/Off.

Figure 10-9
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After waveform generation, the new multicarrier cdma2000 waveform is stored in volatile memory. The
CDMA2K and | / Qannunciators appear on the display and t he RF ONannunciator replaces the RF OFF
annunciator, as shown in the following figure. The modulated signal is now present at the RF OUTPUT
connector.

To store a custom multicarrier waveform, refer to “ Storing a Component Test Waveform to Memory” on
page 304.

To recall acustom multicarrier waveform, refer to “Recalling a Component Test Waveform” on page 305.
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cdma2000 Forward Link Modulation for Receiver Test

This section teaches you how to build cdma2000 forward link signals for testing maobile receiver designs.
The signals are generated by the internal real-time | Q baseband generator. The proceduresin this section
build on each other and are designed to be used sequentially.

Editing the Base Station Setup

1. PressPreset.

2. Press Mode > CDMA > Real Time CDMA2000.

NOTE The forward link is the signal generator’s default setting for link direction and, therefore,
does not need to be set.

3. Press BaseStation Setup.

4. Movethe cursor to highlight thefi | t er field.

5. PressEdit Item > Select > 1S-95 and 1S-2000 > 1S-95.

6. PressReturn > Return.

7. Press BaseStation Setup.

8. Movethe cursor to highlight the PN O f set field.

9. Press9 > Enter.

The cdma2000 forward link global parameters have now been modified so that you are using an | S-95 filter
and a PN offset of 9.

Editing Channel Setups

The tasksin this procedure build upon the previous procedure. This procedure teaches you how to perform
the following tasks:

e “Changing Channel States’ on page 311
*  “Modifying Channel Parameters’ on page 311
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Changing Channel States

This task teaches you how to quickly configure the operating states of the forward link channels.
1. Press Mode Setup to return to the top-level real-time cdma2000 menu.

2. PressLink Control > Channel State Quick Presets > All (Except FQPCH).

You have now turned on all forward link channels, except for the forward link quick paging channel
(F-QPCH). The Channel State Quick Presets menu enables you to configure the operating states of al
channels with a single keypress. You can aso change the operating state of the selected channel using the
Channel State Off On softkey, or by editing the St at e field among the Channel Setup parameters.
Modifying Channel Parameters

This task teaches you how to edit the parameters for the selected channel.

1. Move the cursor to highlight the forward fundamental channel (F-FCH).
2. PressChannel Setup.

3. Movethe cursor to highlight the Radi o Conf i g field.

4

. Press 4 > Enter.

NOTE An important change from earlier ESG models is that radio configuration is now
independent between fundamental and supplemental channels.

5. Movethe cursor to highlight the Dat a field.
6. PressEdit Item > FIX4 > 1010 > Enter > Return.
7. Movethe cursor to highlight the Power field.
8. Press-10> dB.

9. Movethe cursor to highlight the EbNo field.
10. Press 12 > dB > Return.

You have now modified the forward fundamental channel parameters so that the radio configuration is 4, the
datais afixed 4-bit pattern of 1010, the relative channel power is —10 dB, and EbNo value is 12 dB.
Figure 10-10 on page 312 shows what the display should look like when this task is completed.
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Figure 10-10 Forward Fundamental Channel (F-FCH) Setup
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Note that the ESG allows you to set the relative channel power for each active channel. To display the
normalized relative channel power after completing the setup, it is recommended that you perform the steps
in*“Adjusting Code Domain Power” on page 312. Also note that varying the EbNo value on one channel will
affect the EbNo values on all active channels. Refer to “Managing Noise” on page 313 to learn how to make
final noise adjustments.

Adjusting Code Domain Power

The tasksin this procedure build upon the previous procedure. This procedure teaches you how to perform
the following tasks:

e “Scalingto0dB” on page 312
e “Setting Equal Channel Powers’ on page 313

Scaling to 0 dB

After changing the relative power level for a channel, the ESG automatically scales the total power to 0 dB,
while preserving the relative channel power levels. The displayed power levels remain unchanged so the
user can complete the relative power adjustments. This task teaches you how to update the display to show
the normalized relative channel power for each channel after completing the setup.

1. Press Mode Setup to return to the top-level real-time cdma2000 menu.

2. PressLink Control > Adjust Code Domain Power > Scale to 0 dB.
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The power level displayed for each channel is now changed to show the normalized relative channel power.
Figure 10-11 shows the displayed power levels before and after the Scale to 0 dB softkey is pressed.

Figure 10-11
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Setting Equal Channel Powers

Thistask teaches you how to set the relative power level for al active channelsto be equal, for atotal power
level of 0 dB. The normalized relative power level of each channel depends on the number of active
channels. Thistask isan alternative to scaling to 0 dB.

Press Adjust Code Domain Power > Equal Powers.

All active channels have now been set to equal powers. Figure 10-12 shows the displayed normalized
relative power levels after the Equal Powers softkey is pressed with seven active channels.

Figure 10-12
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Managing Noise
The tasks in this procedure build upon the previous procedure.

The following tasks teach you how to set the overall carrier-to-noise (C/N) ratio for the forward link
cdma2000 setup and to set the EbNo value for individual physical channels.

e “Setting the Carrier to Noise Ratio” on page 314
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» “Setting EbNO” on page 314

Setting the Carrier to Noise Ratio

1. Press Mode Setup to return to the top-level real-time cdma2000 menu.

2. Press Noise Setup > C/N > 10 > dB.

3. Press Noise Off On to On.

You have now set the overall carrier to noiseratio to 10 dB and turned on noise. Thisis doneto apply a
discernible level of noise across the entire channel space.

Setting EbNo

EbNo can be set in the Noise Setup menu or the Channel Setup table editor (see “Modifying Channel
Parameters’ on page 311). Thistask teaches you how to make quick EbNo adjustments using the EbNo
softkey in the Noise Setup menu.

1. Press Channel Number and move the cursor to highlight the forward fundamental channel (F-FCH).
2. PressEbNo > 20 > dB.

You have now set the EbNo value for the F-FCH channel to 20 dB. Note that modifying the EbNo value for
achannel will change the overall carrier to noise ratio and the EbNo value for al other active channels. For
reliable results when making hand calculations to determine or verify EbNo values, it is recommended that

you first scale the code domain power to 0 dB to display the normalized relative channel power levels (see

“Scaling to 0 dB” on page 312).

Generating the Baseband Signal

This procedure builds upon the previous procedure.
Press CDMA2000 Off On to On.

This generates the real-time forward link cdma2000 signal. The signal generator may require several
seconds to build the signal. During thistime, Baseband Reconf i guri ng appears on the display. After
the reconfiguration is complete, the display reads COVA2000 On and the CDVA2K and | / Qannunciators
appear. The signal is now modulating the RF carrier.

The signal’s configuration dataresides in volatile memory and is not recoverable after an instrument preset,
power cycle, or reconfigured signal generation.
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Configuring the RF Output
The stepsin this procedure build upon the previous procedure.

1. Set the RF output frequency to 2.14 GHz.
2. Set the output amplitude to —30 dBm.
3. PressRF On/0ff to On.

The user-defined, real-time forward link cdma2000 signal is now available at the signal generator’s RF
OUTPUT connector.

To store this real-time 1/Q baseband digital modulation state to the instrument state register, see “Using the
Instrument State Registers’ on page 68.

To recall areal-time1/Q baseband digital modulation state, see “Recalling an Instrument State” on page 70.
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cdma2000 Reverse Link Modulation for Receiver Test

This section teaches you how to build cdma2000 reverse link signals for testing base station receiver
designs. The signals are generated by the internal real-time |Q baseband generator. The proceduresin this
section build on each other and are designed to be used sequentially.

Editing the Mobile Setup

Press Preset.

Press Mode > CDMA > Real Time CDMA2000 > Link Forward Reverse to Reverse.
Press Mobile Setup.

Move the cursor to highlight thefi I t er field.

Press Edit Item > Select > 1S-95 and 1S-2000 > 1S-95 Mod.

Press Return > Return.

Press Mobile Setup.

Move the cursor to highlight the Long Code Mask field.

9. Press 3FFF0000000 > Enter.

© N oo g > wDd PP

The cdma2000 reverse link global parameters have now been changed so that you are using a modified
IS-95 filter and along code mask of 3FFFO000000.

Editing Channel Setups

The tasksin this procedure build upon the previous procedure. This procedure teaches you how to perform
the following tasks:

* “Changing the Operating Mode’ on page 316
* “Changing Channel States’ on page 317
*  “Maodifying Channel Parameters’ on page 317

Changing the Operating Mode

This task teaches you how to select a predefined reverse link channel configuration.

1. Press Mode Setup to return to the top-level real-time cdma2000 menu.
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2. PressLink Control > Operating Mode > RadioConfig 1/2 Access.

Notice that the display shows a single reverse access channel. Thisis an 1S-2000 standard channel
configuration. For learning purposes, we will change back to RadioConfig 3/4 Traffic, which isthe
default operating mode.

3. Press Operating Mode > RadioConfig 3/4 Traffic.
You have now selected RadioConfig 3/4 Traffic as the current operating mode.

Changing Channel States
This task teaches you how to quickly configure the operating states of the reverse link channels.
Press Channel State Quick Presets > All.

You have now turned on all reverse link channels. The Channel State Quick Presets menu enables you to
configure the operating states of all channelswith a single keypress. This menu is only available for the
reverse link when the RadioConfig 3/4 Traffic operating mode is selected. You can also change the operating
state of the selected channel using the Channel State Off On softkey, or by editing the St at e field among the
Channel Setup parameters.

Modifying Channel Parameters

This task teaches you how to edit the parameters for the selected channel.
1. Move the cursor to highlight the reverse fundamental channel (R-FCH).
2. PressChannel Setup.

3. Movethe cursor to highlight the Radi o Confi g field.

4

. Press 4 > Enter.

NOTE An important change from earlier ESG modelsisthat radio configuration is now
independent between fundamental and supplemental channels.

Move the cursor to highlight the Dat a field.

. PressEdit Item > FIX4 > 1010 > Enter > Return.

5
6
7. Movethe cursor to highlight the Power field.
8. Press-10> dB.

9

Move the cursor to highlight the EbNo field.
10. Press 12 > dB > Return.
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You have now modified the reverse fundamental channel parameters so that the radio configuration is 4, the
datais afixed 4-bit pattern of 1010, the relative channel power is —10 dB, and EbNo value is 12 dB.
Figure 10-13 shows what the display should look like when this task is compl eted.

Figure 10-13 Reverse Fundamental Channel (R-FCH) Setup
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Adjust |
Code Domain Power

Note that the ESG allows you to set the relative channel power for each active channel. To display the
normalized relative channel power after completing the setup, it is recommended that you perform the steps
in“Adjusting Code Domain Power” on page 318. Also note that varying the EbNo value on one channel will
affect the EbNo values on all active channels. Refer to “Managing Noise” on page 319 to learn how to make
final noise adjustments.

Adjusting Code Domain Power

The tasksin this procedure build upon the previous procedure. This procedure teaches you how to perform
the following tasks:

e “Scalingto 0 dB” on page 318
* “Setting Equal Channel Powers’ on page 319

Scaling to 0 dB

After changing the relative power level for a channel, the ESG automatically scales the total power to 0 dB,
while preserving the relative channel power levels. The displayed power levels remain unchanged so the
user can complete the relative power adjustments. This task teaches you how to update the display to show
the normalized relative channel power for each channel after completing the setup.

1. Press Mode Setup to return to the top-level real-time cdma2000 menu.
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2. PressLink Control > Adjust Code Domain Power > Scale to 0 dB.

The power level displayed for each channel is now changed to show the normalized relative channel power.
Figure 10-14 shows the displayed power levels before and after the Scale to 0 dB softkey is pressed.

Figure 10-14
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Setting Equal Channel Powers

Thistask teaches you how to set the relative power level for al active channelsto be equal, for atotal power
level of 0 dB. The normalized relative power level of each channel depends on the number of active
channels. Thistask isan alternative to scaling to O dB.

Press Adjust Code Domain Power > Equal Powers.

All active channels have now been set to equal powers. Figure 10-15 shows the displayed normalized
relative power levels after the Equal Powers softkey is pressed with five active channels.

Figure 10-15
1 2 | 3 | L 9
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Managing Noise
The tasksin this procedure build upon the previous procedure.

The following tasks teach you how to set the overall carrier-to-noise (C/N) ratio for the reverse link
cdma2000 setup and to set the EbNo value for individual physical channels.
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e “Setting the Carrier to Noise Ratio” on page 320
e “Setting EbN0” on page 320

Setting the Carrier to Noise Ratio

1. Press Mode Setup to return to the top-level real-time cdma2000 menu.

2. Press Noise Setup > C/N > 10 > dB.

3. Press Noise Off On to On.

You have now set the overall carrier to noiseratio to 10 dB and turned on noise. Thisis doneto apply a
discernible level of noise across the entire channel space.

Setting EbNo

EbNo can be set in the Noise Setup menu or the Channel Setup table editor (see “Modifying Channel
Parameters’ on page 317). This task teaches you how to make quick EbNo adjustments using the EbNo
softkey in the Noise Setup menu.

1. Press Channel Number and move the cursor to highlight the reverse fundamental channel (R-FCH).
2. PressEbNo > 20 > dB.

You have now set the EbNo value for the R-FCH channel to 20 dB. Note that modifying the EbNo value for
achannel will change the overall carrier to noise ratio and the EbNo value for al other active channels. For
reliable results when making hand calculations to determine or verify EbNo values, it is recommended that
you first scale the code domain power to 0 dB to display the normalized relative channel power levels (see
“Scaling to 0 dB” on page 318).

Generating the Baseband Signal

This procedure builds upon the previous procedure.
Press CDMA2000 Off On to On.

This generates the real -time reverse link cdma2000 signal. The signal generator may require several seconds
to build the signal. During thistime, Baseband Reconf i guri ng appears on the display. After the
reconfiguration is complete, the display reads COMA2000 (n and the COMA2K and | / Qannunciators appear.
The signal is now modulating the RF carrier.

The signal’s configuration dataresides in volatile memory and is not recoverable after an instrument preset,
power cycle, or reconfigured signal generation.
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Configuring the RF Output
The stepsin this procedure build upon the previous procedure.

1. Set the RF output frequency to 2.14 GHz.
2. Set the output amplitude to —30 dBm.
3. PressRF On/0ff to On.

The user defined, real-time reverse link cdma2000 signal is how available at the signal generator’'s RF
OUTPUT connector.

To store this real -time I/Q baseband digital modulation state to the instrument state register, see “ Saving an
Instrument State” on page 69.

To recall areal-time1/Q baseband digital modulation state, see “Recalling an Instrument State” on page 70.
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Applying a User-Defined FIR Filter to a cdma2000 Waveform

Custom FIR filters can be created using the FIR table editor feature or they can be created externally and
downloaded into signal generator memory. Once afilter is stored in memory, you can select it for usewith a
custom modulation state. This example requires that at least one FIR file already be stored in memory. For
an example of creating and storing aFIR filter, see “ Creating a User-Defined FIR Filter Using the FIR Table
Editor” on page 162.

1. PressPreset.

2. Press Mode > CDMA > Arb CDMA2000 > More (1 of 2) > CDMA2000 Define.

3. PressFilter > Select > User FIR.
In this example, there are two FIR files listed: NEWFI R1L and NEWFI R2. (These files were created in the
examplesin Chapter 4, “Basic Digital Operation,” on page 87.)
Figure 10-16
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4. Scroll downinthelist until NEWFI R2 is highlighted.
Press Select File.

The highlighted filter is now selected for use in your custom modulation state, as shown in Figure 10-17
on page 323.
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Figure 10-17
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Thefilter you selected is NEWFIR2. You can see the name displayed below the Select softkey. In the
Fi | t er field, near the left of the display, User FI Risdisplayed to indicate that a user-defined FIR
filter has been selected.

Once you have set the other modulation parameters to your satisfaction, turn on Custom and the RF
output and your user-defined filter isin use.

NOTE The actual oversample ratio during modulation is automatically selected by the instrument.
A value between 4 and 16 is chosen dependent on the symbol rate, the number of bits per
symbol of the modulation type, and the number of symboals.
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IS-95A Modulation

This section teaches you how to build dual arbitrary waveform generated |S-95A CDMA modulation for
testing component designs.

Creating a Predefined CDMA State
This section teaches you how to perform the following tasks:
» “Selecting a Predefined CDMA Setup” on page 324

* “Generating the Waveform” on page 324
e “Configuring the RF Output” on page 324

Selecting a Predefined CDMA Setup

1. PressPreset.
2. Press Mode > CDMA > Arb IS-95A.
3. Press Setup Select > 64 Ch Fwd.

Generating the Waveform
Press CDMA Off On.

This generates a predefined 64 channel forward CDMA waveform. The display changesto CDVA Set up:
64 Ch Fwd. During waveform generation, the CDVA and | / Qannunciators appear and the predefined
digital modulation state is stored in volatile ARB memory. The waveform is now modulating the RF carrier.

Configuring the RF Output

1. Set the RF output frequency to 890.01 MHz.
2. Set the output amplitude to —10 dBm.
3. PressRF On/Off.

The predefined 64 channel forward CDMA signal is now available at the signal generator’'s RF OUTPUT
connector.
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Creating a User-Defined CDMA State

In this procedure, you learn how to customize a predefined CDMA setup, starting with aforward 32 channel
CDMA setup and modifying the setup by adding one channel and changing some of the setup’s default
values.

This section teaches you how to perform the following tasks:
» “Selectinga CDMA Setup” on page 325

* “Inserting an Additional Channel” on page 325

»  “Maodifying the Walsh Code” on page 325

* “Maodifying the Data’ on page 325

* “Madifying the Code Domain Power” on page 326

* “Generating the Waveform” on page 326

e “Configuring the RF Output” on page 326

Selecting a CDMA Setup

1. PressPreset.

2. Press Mode > CDMA > Arb IS-95A.

3. Press Setup Select > 32 Ch Fwd.

Inserting an Additional Channel

1. Press CDMA Define > Edit Channel Setup.

2. Highlight Tr af f i ¢ inthe Type column of row 8.
3. PressInsert Row > Traffic > Return.

Modifying the Walsh Code

1. Highlight the Vil sh value (38) on table row 8.
2. PressEdit Item > 45 > Enter.

Modifying the Data

1. Highlight the Dat a value (RANDQOV) on table row 8.
2. PressEdit Item > 00001000 > Enter.
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Modifying the Code Domain Power
Press Adjust Code Domain Power > 1S-97 Levels.

You now have a custom, forward 33 channel CDMA signal at |S-97 power levels, with an inserted traffic
channel carrying user-defined data at a Walsh code of 45 on table row 8, as shown in the following figure.
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Generating the Waveform
Press Return > Return > CDMA Off On.

This generates a waveform with the custom CDMA state created in the previous sections. The display
changesto CDMA Set up: 32 Ch Fwd (Modi fi ed) . During waveform generation, the COMAand | / Q
annunciators appear and the predefined digital modulation state is stored in volatile memory. The waveform
is now modulating the RF carrier.

For instructions on storing this custom CDMA state to the non-volatile memory of the signal generator, see
“Storing a Component Test Waveform to Memory” on page 304.

Configuring the RF Output

1. Set the RF output frequency to 890.01 MHz.

2. Set the output amplitude to —10 dBm.

3. PressRF On/Off.

The custom CDMA signal is now available at the RF OUTPUT connector.
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Applying Changes to an Active CDMA State

If the CDMA format is currently in use (CDMA Off On set to On) while changes are made in the CDVA
Channel Set up table editor, you must apply the changes before the updated waveform will be generated.

From the CDVA Channel Set up table editor, press the following keys to apply the changes and generate a
new user-defined CDMA waveform based on the updated values:

Return > Apply Channel Setup.
To store acustom CDMA statefile, refer to “ Storing a Component Test Waveform to Memory” on page 304.
To recall acustom CDMA state file, refer to “Recalling a Component Test Waveform” on page 305.

Creating a User-Defined Multicarrier COMA State

In this procedure, you learn how to customize a predefined multicarrier CDMA setup. Rather than building a
4-carrier setup one carrier at atime, you start with a predefined 3-carrier CDMA setup and modify the setup
by adding an additional carrier and changing some of the default val ues.

This section teaches you how to perform the following tasks:
e “Selecting aMulticarrier CDMA Setup” on page 327

e “Adding aCarrier” on page 327

*  “Modifying Carrier Frequency Offset” on page 328

*  “Modifying Carrier Power” on page 328

e “Generating the Waveform™ on page 328

e “Configuring the RF Output” on page 329

Selecting a Multicarrier COMA Setup

1. PressPreset.
2. Press Mode > CDMA > Arb 1S-95A.

3. Press Multicarrier Off On > Multicarrier Define.

Adding a Carrier

1. Highlight the 9 channel forward carrier in table row 2.

2. PressiInsert Row > Pilot > Return.
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Modifying Carrier Frequency Offset

1. Highlightthe Freq O f set value (0. 00 kHz) for the new pilot carrier in row 3.

2. PressEdit Item > -625 > kHz.

Modifying Carrier Power

1. Highlight the Power value (0. 00 dB) for the new pilot carrier in row 3.

2. PressEdit Item > -10 > dB.

You now have a user-defined 4-carrier CDMA waveform with an inserted pilot carrier at afrequency
offset of -625 kHz and a power level of -10.00 dBm, as shown in the following figure.
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Generating the Waveform

Press Return > CDMA Off On.

This generates a waveform with the user-defined multicarrier CDMA state created in the previous sections.
The display changestoMul ticarrier Setup: 3 Carriers (Mdified).Duringwaveform

generation, the COMA and | / Qannunciators appear and the user-defined multicarrier CDMA stateis stored
in volatile memory. The waveform is now modulating the RF carrier.

For instructions on storing this user-defined multicarrier CDMA state to non-volatile memory, see“ Storing a
Component Test Waveform to Memory” on page 304.
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Configuring the RF Output

1. Set the RF output frequency to 890.01 MHz.

2. Set the output amplitude to —10 dBm.

3. PressRF On/Off.

The user-defined multicarrier CDMA signal is now available at the RF OUTPUT connector.

Applying Changes to an Active Multicarrier CDMA State

If the CDMA format is currently in use (CDMA Off On set to On) while changes are made in the
Mul ticarrier CDVA Set up table editor, you must apply the changes before the updated waveform will
be generated.

FromtheMil ticarrier CDVA Set up table editor, press the following keys to apply the changes and
generate a new user-defined multicarrier CDMA waveform based on the updated values:

Return > Apply Multicarrier.

To store acustom multicarrier CDMA state file, refer to, “ Storing a Component Test Waveform to Memory”
on page 304.

To recall acustom multicarrier CDMA state file, refer to “ Recalling a Component Test Waveform” on
page 305.
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Thisfeature is available only in E4438C ESG Vector Signal Generators with Option 001/601or 002/602.
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Option Overview

This real-time personality simulates GPS satellite transmissions for single channel receiver testing. The
following list shows some of the features for building a basic signal:

P code generation at 10.23 Mcps with the standard GPS 10.23 Mcps reference
C/A code generation at 1.023 Mcps with the standard GPS 10.23 Mcps reference

navigation data output at 50 bps using PN9, PN 15, afixed 4-bit pattern, user file, or default data (TLM
mode) for encoding with the C/A code or the C/A + P code

three selectable ranging codes: C/A, P, or C/A+P
satellite ID range of 1 to 32 with an additional range of 33 to 37 for other uses

three selectable data modes that include a TLM mode, which uses a formatted handover word (HOW)
and telemetry (TLM) word (refer to “Data Modes and Subframe Structures’ on page 334 for more
information)

simulated doppler shifting with a 250 kHz range

selectable internal or external chip clock reference source

A basic signal setup is provided when the signal generator is preset using factory-defined attributes (C/A
ranging code, satellite ID of 1, zero doppler shift, and the Raw data mode using PN9 data with the standard
10.23 Mcps reference clock). These attributes are available when Normal is selected using the Preset Normal
User softkey. Refer to the Key and Data Field Reference for more information.

The satellite ID numbers operate according to the GPS standards; they match the pseudorandom numbers
(PN) that are used to generate the C/A and P codes and they also dictate the amount of chip delay.

More advanced features are available for modifying the basic signal to match your testing needs. The
following isalist of some of these features:

P code power adjustment (—40 to 0 dB)

adjustable chip clock reference (1 kepsto 12.5 Mcps)

selectable 1/Q phase

selectable filters and the ability to create user-defined filters using the ESG features
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GPS Concepts

Signal Generation Block Diagram

Figure 11-1 shows how the GPS signal is generated within the ESG. Notice that the C/A code is modulated
onto the L-band signal using the | axis of the I/Q modulator, and the P code is modulated using the Q axis.
The data provided by the data generator is selected by using the Data softkey or by choosing the TLM mode.

Figure 11-1 GPS Signal Generation Diagram
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Data Modes and Subframe Structures

The GPS personality |ets you transmit data three different ways using the C/A or C/A+P ranging code
selection:

« A raw (Raw) data mode which enables the continuous transmission of 300 bits of data per subframe
without incorporating parity bits. Thisiswell suited for BER and low-level demodulation testing.

* Anencoded (Enc) data mode which enables the continuous transmission of 10 words (30-bits each) per
subframe, with each word containing 24 bits of raw data along with 6 trailing parity bits computed from
the selected data by the ESG

» Thetelemetry (TLM) mode which enables the continuous transmission of aformatted TLM and
handover word (HOW) along with default navigation data as outlined in the GLOBAL POS TIONING
SYSTEM STANDARD POSI TIONING SERVICE SIGNAL SPECIFICATION, 2nd Edition, June 2, 1995.
Thisisagood mode for testing receiver functionality. For example, the C/No can be determined by
testing the sensitivity of the receiver accepting the data.

Figure 11-2 shows the subframe structures for each data mode.

Figure 11-2 Subframe Structures
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The TLM word, which is 30-bitslong, is structured using the preamble for the first 8-bits, 16 reserve bits (9
through 24, all set to zero), and the 6 parity bits for bit locations 25 through 30.

The HOW also contains 30-bits where the first 17 represent the most significant bits (MSBs) for an
incrementing time-of-week (TOW) count. Additionally, the HOW message contains the two bits (bits 23 and
24) used for parity computation along with the 6 parity bits.

During a GPS signal transmission, a pulse signal is generated every 6 seconds at the

EVENT 1 rear panel connector. This pulse coincides with the beginning of each subframe starting with the
second subframe. The pulseis synchronized to the RF output, which compensates for any internal signal
delays.

Chip Clock Reference

The GPS reference clock (chip clock) has the advanced feature of being adjustable with a factory set value
of 10.23 Mcps (the GPS standard). You also have the convenience of using the internal chip clock or having
an external source provide the reference. When an external referenceis used, it is applied to the DATA
CLOCK input connector.

NOTE Whenever an external source is providing the chip clock reference, it isimperative that its
frequency matches the value set with the GPS Ref (f0) softkey.

The P and C/A code chip rates are dependent on the value set using the GPS Ref (f0) softkey whether you are
using the internal or an external chip clock reference. The P code chip rate matches the reference clock rate
and the C/A code chip rate is one-tenth of the reference value (.1 x reference clock rate). Refer to

Figure 11-1 on page 333 for ablock diagram showing how the GPS signal is generated within the ESG.

Rear Panel Signal Synchronization

Figure 5-1 illustrates the timing rel ationships for the GPS signals available at the signal generator rear panel.
SYMBOL SYNC OUT, DATA CLOCK OUT, and DATA OUT are AUX 1/0 connector signals (refer to,
“13. AUX 1/O Connector” on page 39 for moreinformation). EVENT 1 and EVENT 2 are BNC connectors.
If the signal generator is configured with Option 1IEM, EVENT 1 and EVENT 2 connectors are changed
from aBNC to an SMB connector.
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Figure 11-3
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User Files

Like the other data types, user files require a selection for the data mode (see “ Data Modes and Subframe
Structures’ on page 334 for more information on data modes). User files are created either internally to the
ESG or externally and downloaded, but file sizes are limited to the amount of available ESG memory. If files
are created externally and contain a structure that incorporates parity bits, then the raw data mode should be
used. Thiswould enable the transmission of thefileinitsorigina form. Conversely, if your file did not have
parity bits and you desired to have parity bits incorporated into the signal transmission, then you would
select the encoded (Enc) data mode. This enables the ESG to compute the parity bits for the last 6-bits of
each word.
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NOTE If the encoded mode is selected with a user file that incorporates parity bits, the parity bits
will be recomputed and their values changed.

Externally developed user files let you define signal structures that may not be available internally to the
ESG. For example, if your needs require afully coded signal consisting of frames structured according to the
GPS standards (1 frame consisting of 5 subframes and 25 pages), this structure could be devel oped
externally and downloaded into the ESG, making it available for use.

User files can be created and accepted by the ESG in either binary or bit format.

Bit Error Rate Test Measurements

Bit error rate test (BERT) measurements are accomplished using the ESG with Option UN7 (Baseband
BERT) installed or a customer-supplied, external BER meter. The GPS signal can be configured using either
aPN9 or PN15 sequence. The Raw data mode is used so parity bits are not computed for the subframe. If the
encoded (Enc) mode was selected, 6 parity bits would be computed for every 24-bits of data. This would
disrupt the PN sequence.

When BERT measurements are made using an externally supplied BER meter, the ESG provides the GPS
signal to the UUT (unit under test) and the BER meter would compute the error results. If the ESG with
Option UN7 is used, the ESG will provide the signal and make the BERT measurements. When the ESG is
making the BERT measurement, it will accept a clock and gate signal from the UUT along with the data. If
the UUT does not have the capability to provide adata clock signal, the ESG can provide aclock signal from
the rear panel Aux 1/0O connector (refer to “13. AUX 1/0O Connector” on page 39 for information on this
connector). When the clock signal from the ESG is used, a delay must be added to the signal that
corresponds to UUT’s processing time. For information on setting up BERT measurements refer to “ Setting
Up aGPS Bit Error Rate Test” on page 342, and for further information on BERT, refer to “Bit Error Rate
Tester—Option UN7” on page 276.
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GPS Operation

This section guides you through the basic operation for using the real-time GPS option.

Setting Up the GPS Signal

If the signal generator isin the factory-defined preset mode, (Utility > Power On/Preset > Preset Normal User to
Normal) abasic GPS signal will automatically be set up when the Preset key is pressed, then performing step
2 and steps 6 through 8 will generate asignal at the RF OUTPUT connector. To set up asignal using
additional features of the GPS personality, complete this procedure starting with step 1.

1. PressPreset.

Press Mode > More (1 of 2) > Real Time GPS.
Press Satellite ID > 8 > Enter.

Press Doppler Shift > 2.5 > kHz.

Press Data Mode Enc TLM to Enc.

o o A~ W DN

Press Data > PN Sequence > PN15.
To create a user file, refer to “Creating a User File” on page 184.

~

Press Real-time GPS Off On to On.

8. Pressthe Frequency hardkey. Using the numeric keypad, set the signal generator RF output frequency to
1.57542 GHz (L1 carrier frequency).

9. Pressthe Amplitude hardkey. Using the numeric keypad, set the signal generator RF output amplitude to
-120 dBm.

10. Turn the RF output on by pressing the RF On/0ff hardkey on the signal generator front panel.

The real-time GPS signal is now available at the signal generator RF OUTPUT connector. Figure 11-4 on
page 339 shows what the signal generator display should like after all steps have been completed. Notice the
@GS, | / Q and RF ONannunciators are on and the parameter settings for the signal are displayed in the
status area of the signal generator display.

Thistask sets up a GPS signal that incorporates a subframe structure using 10 words, each with 24 raw data
bits and 6 parity bits computed from the data source. This subframe structure was accomplished by selecting
Enc as the data mode and using a PN 15 sequence. The PN15 sequence was encoded with the C/A code at
50 bps. Using factory preset settings, the C/A chip rateis 1.023 Mcps with a clock reference of 10.23 Mcps.
A 2.5 kHz doppler shift was added to simulate the rel ative motion of the satellite with respect to the receiver.
For more information on the GPS option, refer to “ Option Overview” on page 332.
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Figure 11-4
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Configuring the External Reference Clock

1. Accessthe real-time GPS personality.

2. Press More (1 of 2) > GPS Ref Clk Ext Int to Ext.

3. PressGPS Ref (f0) > 11.03 > kcps.

4. Connect the external reference clock source to the DATA CLOCK INPUT connector.
The maximum clock rate for thisinput connector is 50 MHz with a voltage range of
-05t055V.

5. Set the external reference clock source to the chip rate value entered in 3.

The maximum datarate for this input connector is 50 Mb/s with a voltage range of
-05t055V.

NOTE The chip rate of the external source must match the chip rate value set using the GPS Ref (f0)

softkey.

Figure 11-5 on page 340 shows what the signal generator display should look like after all the steps have
been completed. The CA Chip Rate,P Chip Rate, GPS Ref (f0),andGS Ref d k fields, inthe
status area of the display, show the new parameters for this external reference procedure. Notice the settings
Satellite I D Doppler Shift,Data,andData Mde, reflect the steps in the previous procedure,

“Setting Up the GPS Signa” on page 338.
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Figure 11-5
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This task supplied an external source for use as the reference clock signal. In addition, the expected
reference frequency was modified from the GPS standard of 10.23 Mcpsto 11.03 keps. This change in the
reference signal frequency also affectsthe P and C/A code chip rates. Since the P code chip rate matches the
reference frequency, its chip rate is now 11.03 kcps and the C/A code, which is one-tenth of the reference
frequency, is now 1.103 kcps. For more information on the GPS option, refer to “ Option Overview” on

page 332.
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|
Testing Receiver Sensitivity
Refer to Figure 11-6.

1. Connect the cables between the receiver and the ESG as shown in Figure 11-6.

Figure 11-6 Setup for a Receiver Sensitivity Test

RF OUTPUT]

UL

rec_serl

Set the GPS datamode to TLM.

Set the power level on the ESG

Set the L-band frequency on the ESG

Set up the UE (user equipment) to receive the signa from the ESG.

o g A~ W D

Turn on the GPS personality and the RF output on the ESG
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Setting Up a GPS Bit Error Rate Test

This section shows how to make GPS BER measurements using the ESG Signal Generator with
Option UN7.

The following procedures explain how to set up the ESG for making BER measurements:
» “Connecting the Test Equipment” on page 343

e “Setting the Carrier Frequency and Power Level” on page 343

» “Selecting the Data Format” on page 344

» “Setting Up the GPS Receiver” on page 344

» “Selecting the BERT Data Pattern and Total Bits’ on page 344

» “Selecting the BERT Trigger” on page 345

e “Starting BERT measurements’ on page 345

Required Equipment

The following equipment is required to make BER measurements.

» ESG Signal Generator, model E4438C with Options 001/601or 002/602, 409, and UN7
» anexternal controller to control the receiver under test

* 20dB attenuator

» aninterfacelevel matching circuit for interfacing between the receiver under test and the signal
generator when the receiver signal specifications are different from those of the signal generator
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Connecting the Test Equipment
Refer to Figure 11-7.

1. Connect the cables between your receiver and the ESG as follows:

Figure 11-7 Setup for a GPS Bit Error Rate Test
BER
DATA IN
~
BER N
CLK IN
Zz
o
sl ESG
o RF OUTPUT
20dB Attenuator
Antenna
Interface
Level
Matching
Radio ----------- : Clock
Under
Test : : Data
Controller
gps_bert

Setting the Carrier Frequency and Power Level

1. Pressthe Preset hardkey.

2. Pressthe Frequency hardkey. Using the numeric keypad, set the signal generator RF output carrier
frequency to 1.57542 GHz.

3. Pressthe Amplitude hardkey. Using the numeric keypad, set the signal generator RF output amplitude to
-135dBm.
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Selecting the Data Format

1
2.

4.
5.

Press Mode > More (1 or 2) > Real Time GPS.

Ensure that Raw is the selected data mode.

If Raw is not the current data mode, press Data Mode Raw Enc TLM to Raw.
Ensure that PN9 is the selected data sequence.

If PN9 is not the current data sequence, press Data > PN Sequence > PN9.
Press Real-time GPS Off On to On.

Press RF On/0ff to toggle the RF output on.

The modulated signal is now available at the RF OUTPUT connector. Notice that the display annunciators
for @S and | / Q are on and the display annunciator RF OFF has changed to RF O\

Setting Up the GPS Receiver

Setup the GPS receiver to accept the carrier frequency and output the data and clock signal used for the bit
error rate measurements.

Selecting the BERT Data Pattern and Total Bits

1. Accessthe BERT function.
For an ESG with Option UN7 Installed
Press Aux Fctn > BERT > Configure BERT.
For an ESG with Options UN7 and 300 Installed
Press Aux Fctn > BERT > Baseband BERT > Configure BERT.
If the Data softkey does not show that PN9 is the selected data pattern, press
Data > PNO.
The selected PN sequence must match the data PN sequence used on the channel being measured. For
exampleif the DCH (DTCH) is using PN9 data, then the data selection in the BERT function must also
be PNO.
2. PressTotal Bits > 1000 > Bits.
1000 bits at 50 bps per second takes 20 seconds to test.
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Selecting the BERT Trigger

1. PressReturn > Configure Trigger.

If the BERT Trigger softkey does not show Trigger Key as the selected trigger, press
BERT Trigger > Trigger Key.

2. PressReturn > BERT Off On to On.
Starting BERT measurements

Press the front panel Trigger hardkey to start the BER measurement. You will see the measurement result
values of the Total Bits, Error Bits, and BER on the signal generator display.

NOTE If you encounter problems making a BER measurement, check the following:

» Make sure that the cable connections are properly configured.

» Make surethat the data pattern for the BER measurement, specified by the Data softkey,
matches the data pattern of the receiver under test.

* Make sure the data mode selected for the BER measurement is Raw.
* Make sure that the RF is turned on.
* Make sure that the amplitude is set to the correct level.

» Make sure that the receiver under test is controlled to receive the signal of the specified
carrier frequency.

» Make sure the chip rate of the external source matches the chip rate set using the
GPS Ref (f0) softkey.
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Thisfeature is available only in E4438C ESG Vector Signal Generators with Option 001/601or 002/602.
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Creating a Custom Multitone Waveform

UsingtheMul tit one Set up table editor, you can define, modify and store user-defined multitone
waveforms. Multitone waveforms are generated by the dual arbitrary waveform generator.

This section teaches you how to perform the following tasks:

» “Initializing the Multitone Setup Table Editor” on page 348
» “Configuring Tone Powers and Tone Phases’ on page 348
*  “Removing aTone” on page 348

* “Generating the Waveform” on page 349

» “Configuring the RF Output” on page 349

Initializing the Multitone Setup Table Editor

1. PressPreset.

2. Press Mode > More (1 of 2) > Multitone

3. Pressnitialize Table > Number of Tones > 5 > Enter.
4. PressFreq Spacing > 20 > kHz.

5. PressDone.

You now have a multitone setup with five tones spaced 20 kHz apart. The center tone is placed at the carrier

frequency, while the other four tones are spaced in 20 kHz increments from the center tone.

Configuring Tone Powers and Tone Phases

1. Highlight the value (0 dB) in the Power column for the tonein row 2.
2. Presskdit Item > -4.5 > dB.

3. Highlight the value (0) in the Phase column for the tonein row 2.

4. PressEdit Item > 123 > deg.

Removing a Tone

1. Highlight the value (On) in the St at e column for the tonein row 4.
2. PressToggle State.
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Generating the Waveform

Press Multitone Off On until On is highlighted.

This generates the multitone waveform with the parameters defined in the previous sections. During
waveform generation, the M TONE and | / Qannunciators activate and the multitone waveform is stored in
volatile ARB memory. The waveform is now modulating the RF carrier.

Configuring the RF Output

1. Set the RF output frequency to 100 MHz.
2. Set the output amplitude to 0 dBm.
3. PressRF On/0ff.

The multitone waveform is now available at the signal generator’'s RF OUTPUT connector.
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Applying Changes to an Active Multitone Signal

If the multitone generator is currently in use (Multitone Off On set to On) while changes are made in the
Mul titone Setup table editor, you must apply the changes before the updated waveform will be
generated.

FromtheMil tit one Set up table editor, press the following key to apply the changes and generate a
multitone waveform based on the updated values:

Apply Multitone

Storing a Multitone Waveform

In this example, you learn how to store a multitone waveform. If you have not created a multitone
waveform, complete the steps in the previous section, “ Creating a Custom Multitone Waveform™” on
page 348.

1. PressMore (1 of 2) > Load/Store > Store To File.

If thereis already afile name from the Cat al og of MIONE Fi | es occupying the active entry
area, press the following keys:

Edit Keys > Clear Text

2. Enter afile name (for example, 5TONE) using the alpha keys and the numeric keypad with a maximum
length of 23 characters.

3. PressEnter.

The multitone waveform is now stored in the Cat al og of MIONE Fi | es.

NOTE The RF output amplitude, frequency, and operating state settings are not stored as part of a
multitone waveform file.
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Recalling a Multitone Waveform

Using this procedure, you learn how to recall a multitone waveform from the signal generator’s memory
catalog.

If you have not created and stored a multitone waveform, complete the steps in the previous sections,
“Creating a Custom Multitone Waveform” on page 348 and “ Storing a M ultitone Waveform” on page 350,
then preset the signal generator to clear the stored multitone waveform from volatile ARB memory.

1. Press Mode > Multitone.

2. Press More (1 of 2) > Load/Store.

3. Highlight the desired file (for example, 5TONE).

4. PressLoad From Selected File > Confirm Load From File.

5. Press More (2of 2) > Multitone Off On until On is highlighted.

The firmware generates the multitone waveform in ARB memory. After waveform generation, the multitone
waveform is available to be modulated on the RF output.

For instruction on configuring the RF output, see “ Configuring the RF Output” on page 349.
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13 Custom Digital Modulation

Thisfeature is available only in E4438C ESG Vector Signal Generators with Option 001/601or 002/602.
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Using the Arbitrary Waveform Generator

This section teaches you how to build dual arbitrary (ARB) waveform generated custom TDMA digital
modulation for testing component designs.

Custom ARB digital modulation creates waveforms using modulation types, filtering, symbol rates, and
other parameters defined by digital communications standards. These waveforms are formatted as unframed
data

Using Predefined Custom TDMA Digital Modulation
This section teaches you how to perform the following tasks:
» “Selecting a Predefined EDGE Setup” on page 354

* “Generating the Waveform” on page 354
e “Configuring the RF Output” on page 354

Selecting a Predefined EDGE Setup

1. PressPreset.
2. Press Mode > Custom > ARB Waveform Generator.

3. Press Setup Select > EDGE.

Generating the Waveform
Press Digital Modulation Off On.

This generates a waveform with the pre-defined EDGE state selected in the previous section. The display
changesto D g Mbd Set up: EDGE During waveform generation, the DIl GMODand | / Qannunciators
appear and the pre-defined digital modulation state is stored in volatile memory (WFM1). The waveformis
now modulating the RF carrier.

Configuring the RF Output

1. Set the RF output frequency to 891 MHz.

2. Set the output amplitude to -5 dBm.

3. PressRF On/Off.

The predefined EDGE signal is now available at the signal generator’'s RF OUTPUT connector.
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Creating a Custom TDMA Digital Modulation State

In this procedure, you learn how to set up asingle-carrier NADC digital modulation with customized
modulation type, symbol rate, and filtering.

This section teaches you how to perform the following tasks:

e “Selecting aDigital Modulation Setup” on page 355

* “Maodifying the Modulation Type and Symbol Rate” on page 355
* “Maodifying the Filter” on page 355

» “Configuring the RF Output” on page 356

Selecting a Digital Modulation Setup

1. PressPreset.
2. Press Mode > Custom > ARB Waveform Generator.

3. Press Setup Select > NADC.

Modifying the Modulation Type and Symbol Rate

1. PressDigital Mod Define > Modulation Type > PSK > QPSK and OQPSK > QPSK.
2. Press Symbol Rate > 56 > ksps.

Modifying the Filter

1. PressFilter > Select > Nyquist.

2. PressReturn > Return.

Generating the Waveform
Press Digital Modulation Off On.

This generates a waveform with the custom single-carrier NADC digital modulation state created in the
previous sections. The display changesto D g Mbd Set up: NADC (Modi fi ed) . During waveform
generation, the Dl GMODand | / Qannunciators appear and the custom single-carrier digital modulation state
is stored in volatile memory. The waveform is now modulating the RF carrier.

For instructions on storing this custom single-carrier NADC digital modulation state to non-volatile memory
catalog, see“ Storing a Custom TDMA Digital Modulation State” on page 356.
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Configuring the RF Output

1. Set the RF output frequency to 835 MHz.

2. Set the output amplitude to 0 dBm.

3. PressRF On/Off.

The user-defined NADC signal is now available at the RF OUTPUT connector.

Storing a Custom TDMA Digital Modulation State

Using this procedure, you learn how to store a custom digital modulation state and a custom multicarrier
digital modulation state to non-volatile memory.

If you have not created a custom single-carrier digital modulation state, complete the stepsin the previous
section, “Creating a Custom TDMA Digital Modulation State” on page 355.

1. Returnto thetop-level Digital Modulation menu, where Digital Modulation Off On is the first softkey.
2. Press Digital Mod Define > Store Custom Dig Mod State > Store To File.

If thereis already afile name from the Cat al og of DMCID Fi | es occupying the active entry
area, press the following keys:

Edit Keys > Clear Text

3. Enter afile name (for example, NADOQPSK) using the alpha keys and the numeric keypad with a
maximum length of 23 characters.

4. PressEnter.

The user-defined single-carrier digital modulation state is now stored in non-volatile memory.

NOTE The RF output amplitude, frequency, and operating state settings are not stored as part of a
user-defined digital modulation state file.

Recalling a Custom TDMA Digital Modulation State

Using this procedure, you learn how to recall a custom digital modulation state from signal non-volatile
memory.

If you have not created and stored a user-defined single-carrier digital modulation state, compl ete the steps
in the previous sections, “ Creating a Custom TDMA Digital Modulation State” on page 355 and “ Storing a
Custom TDMA Digital Modulation State” on page 356, then preset the signal generator to clear the stored
user-defined digital modulation waveform from volatile ARB memory.

1. Press Mode > Custom > ARB Waveform Generator.
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2. Press Setup Select > More (1 of 2) > Custom Digital Mod State.
3. Highlight the desired file (for example, NADOGPSK).

4. Press Select File.

5. Press Digital Modulation Off On until On is highlighted.

The firmware generates the custom digital modul ation waveform in volatile memory. After waveform
generation, the custom digital modulation waveform is available to be modulated on the RF output.

For instruction on configuring the RF output, see “ Configuring the RF Output” on page 356.

Creating a Custom Multicarrier TDMA Digital Modulation State

In this procedure, you learn how to customize a predefined multicarrier digital modulation setup by creating
acustom 3-carrier EDGE digital modulation state.

This section teaches you how to perform the following tasks:

» “Creating aMulticarrier Digital Modulation Setup” on page 357
* “Maodifying Carrier Frequency Offset” on page 357

*  “Maodifying Carrier Power” on page 358

* “Generating the Waveform” on page 354

» “Configuring the RF Output” on page 358

Creating a Multicarrier Digital Modulation Setup

1. PressPreset.

2. Press Mode > Custom > Arb Waveform Generator.
3. Press Multicarrier Off On.
4

Press Multicarrier Define > Initialize Table > Carrier Setup > EDGE > Done.

Modifying Carrier Frequency Offset

1. Highlightthe Freq O f set value (500. 000 kHz) for the carrier in row 2.
2. PressEdit Item > -625 > kHz.
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Modifying Carrier Power
1. Highlight the Power value (0. 00 dB) for the carrier in row 2.

2. PressEdit Item > -10 > dB.

You now have a custom 2-carrier EDGE waveform with a carrier at a frequency offset of -625 kHz and
apower level of —10.00 dBm, as shown in the following figure.
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Generating the Waveform
Press Return > Digital Modulation Off On.

This generates a waveform with the custom multicarrier EDGE state created in the previous sections. The
display changestoDi g Mbd Setup: Milticarrier (Mdified).Duringwaveform generation, the
Dl GVCDand | / Qannunciators appear and the new custom multicarrier EDGE state is stored in volatile
memory. The waveform is now modulating the RF carrier.

For instructions on storing this custom multicarrier EDGE state to non-volatile memory, see“ Storing a
Custom Multicarrier TDMA Digital Modulation State” on page 359.

Configuring the RF Output

1. Set the RF output frequency to 890.01 MHz.

2. Set the output amplitude to —10 dBm.

3. PressRF On/0Off.

The custom multicarrier EDGE signal is how available at the RF OUTPUT connector.
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Storing a Custom Multicarrier TDMA Digital Modulation State

Using this procedure, you learn how to store a custom multicarrier TDMA digital modulation state to
non-volatile memory.

If you have not created a custom multicarrier digital modulation state, complete the steps in the previous
section, “Creating a Custom Multicarrier TDMA Digital Modulation State” on page 357.

1. Returnto thetop-level Digital Modulation menu, where Digital Modulation Off On is the first softkey.
2. Press Multicarrier Define > More (1 of 2) > Load/ Store > Store To File.

If thereis already afile name from the Cat al og of MDMID Fi | es occupying the active entry
area, press the following keys:

Edit Keys > Clear Text

3. Enter afile name (for example, EDGEML) using the al pha keys and the numeric keypad with a maximum
length of 23 characters.

4. PressEnter.

The user-defined multicarrier digital modulation state is now stored in non-volatile memory.

NOTE The RF output amplitude, frequency, and operating state settings are not stored as part of a
user-defined digital modulation state file.

Applying Changes to an Active Multicarrier TDMA Digital Modulation State

If the digital modulation format is currently in use (Digital Modulation Off On set to On) while changes are
madeintheMul ticarrier Set up tableeditor, you must apply the changes before the updated waveform
will be generated.

FromtheMil ti carri er Set up table editor, press Apply Multicarrier to apply the changes and generate a
new custom multicarrier digital modulation waveform based on the updated values.
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Using the Real Time 1/Q Baseband Generator

The custom real-time format enables you to create unframed digital modulation with user-defined data,
filtering, symbol rate, modulation type, burst shape, differential data encoding, and other format parameters.

You can choose a predefined mode where filtering, symbol rate and modulation type are defined by the
digital modulation standard, or a user-defined custom modulation.

Selecting Predefined Custom Modulation Modes

1. PressPreset.
2. Press Mode > Custom > Real Time 1/Q Base Band.
3. Press More (1 of 3) > More (2 of 3) > Predefined Mode > APCO 25 w/C4FM.
4. Press More (3 of 3).
This selects a predefined mode where filtering, symbol rate and modulation type are defined by the
APCO 25 w/C4FM digital modulation standard and returns you to the top-level custom modulation
menu. To configure data, burst shape, and differential data encoding parameters, see the next section,
“Creating User-Defined Custom Modulation.”
To output this predefined custom modulation, complete the stepsin “ Generating the Waveform” on
page 362 and “ Configuring the RF Output” on page 362.
NOTE To deselect a predefined mode, press the following keys:
Mode > Custom > Real Time 1/Q Base Band > More (1 of 3) > More (2 of 3) > Predefined Mode >
None
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Creating User-Defined Custom Modulation

This section teaches you how to perform the following tasks:

e “Selecting Data’ on page 361

e “Configuring the Filter” on page 361

» “Selecting a Symbol Rate” on page 361

» “Selecting the Modulation Type” on page 361

» “Configuring the Burst Rise and Fall Parameters’ on page 362
» “Activating Differential Data Encoding” on page 362

* “Generating the Waveform” on page 362

» “Configuring the RF Output” on page 362

Selecting Data
1. PressPreset.

2. Press Mode > Custom > Real Time 1/Q Base Band > Data > FIX4.

3. Press 1010 > Enter > Return.

Configuring the Filter
1. PressFilter > Select > Gaussian.

2. PressFilter BbT.

3. Press.45 > Enter > Return.

Selecting a Symbol Rate

1. Press Symbol Rate.
2. Press 25 > ksps > Return.

Selecting the Modulation Type
Press Modulation Type > Select > QAM > 32QAM > Return.

For information on user-defined 1/Q mapping, see “ User-Defined I/Q Maps’ on page 177. For information
on user-defined FSK modulation, see “User-Defined FSK Modulation” on page 181.
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Configuring the Burst Rise and Fall Parameters

1. PressBurst Shape > Rise Time.

2. Press5.202 > bits.

3. PressRise Delay > .667 > bits.

4. PressFall Time > 4.8 > bits.

5. PressFall Delay > .667 > bits.

This configures the burst shape for the custom real-time 1/Q baseband digital modulation format. For
instructions on creating and applying user-defined burst shape curves, see “Using Customized Burst Shape
Curves’ on page 155.

Activating Differential Data Encoding

Press Return.

Press More (1 of 3) > Diff Data Encode Off On.

This activates differential data encoding for the current real-time 1/Q baseband digital modulation format.
For more information, see “ Differential Encoding” on page 169.

To generate and output the custom digital modulation, complete the stepsin the following sections.

Generating the Waveform
Press More (2 of 3) > More (3 of 3)
Press Custom Off On until On is highlighted.

This generates the custom real-time 1/Q baseband waveform with the parameters defined in the previous
sections. During waveform generation, the CUSTOMand | / Qannunciators activate and the custom
waveform is stored in pattern RAM. The waveform is now modulating the RF carrier.

Configuring the RF Output

1. Set the RF output frequency to 500 MHz.
2. Set the output amplitude to 0 dBm.
3. PressRF On/Off.

The custom real-time 1/Q baseband waveform is now available at the signal generator’s
RF OUTPUT connector.
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14 Real Time TDMA Formats

In the following sections, this chapter provides the following information. These features are available only
in E4438C ESG Vector Signal Generators with Option 001/601or 002/602.

This chapter contains procedures on operating the real-time TDMA formats. The ESG generates the
modulation for these formats using the ESG'’s internal baseband generator. This chapter includes the
following sections:

“EDGE Framed Modulation” on page 364

“GSM Framed Modulation” on page 368

“Enhanced Observed Time Difference (E-OTD)” on page 370
“DECT Framed Modulation” on page 383

“PHS Framed Modulation” on page 385

“PDC Framed Modulation” on page 387

“NADC Framed Modulation” on page 389

“TETRA Framed Modulation” on page 391
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EDGE Framed Modulation

This section describes how to build framed, real-time 1/Q baseband generated EDGE and GM SK
modulation for testing receiver designs. Each timeslot provides the flexibility of changing from the current
modulation type to a GM SK modulation. The GM SK timesl ot selection provides anormal GSM timelsot.
The proceduresin this section build on each other, so perform them sequentially.

For optimizing signal integrity when using EDGE and GM SK times| ots together, use the 3GPP standard
settings supported by the ESG for the EDGE timeslots. Modifying the standard settings can affect the proper
operation of the combined timeslots. For example, changing the EDGE filter can cause undesirable frame
alignment. While you can change the EDGE modulation type when you have both EDGE and GM SK
timeslots, changing the modulation type does not change the GMSK timeslot modulation.

NOTE When using EDGE and GM SK,, or multiframe EDGE, limit the symbol rate to no more than
271 ksps. Although higher rates may work, they are not supported.

To build only a GSM signal, see “GSM Framed Modulation” on page 368.

Understanding External Data Connections

NOTE The external data selection is not a choice for aGMSK timeslot. When GMSK timeslots are
part of the signal, the Ext data selection for EDGE timeslots is unavailable.

The ESG provides various timesl ot data selections. One of these selections, the Ext softkey, provides the
capability to use an external datasignal connected to the front panel DATA connector. There are two waysto
time the external data, by a bit clock or a symbol synchronization signal. Select the timing option with the
Ext Data Clock Normal Symbol softkey.

The Normal choice notifies the ESG that the datatiming is done at the bit level using an external data clock.
Connect the data clock signal to the front panel BNC connector labeled DATA CLOCK. In addition to the
data clock timing signal, connect a single or continuous pulsed symbol synchronization signal to the front
panel BNC connector labeled SYMBOL SYNC. The symbol synchronization signal aligns the first symbol
in the transmission.

The Symbol choice notifies the ESG that the data timing is done at the symbol level using an external
symbol synchronization signal. Connect a continuous pulsed synchronization signal to the front panel BNC
connector labeled SYMBOL SYNC. There is no data clock connection.
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Activating Framed Data Format

1. PressPreset.

2. Press Mode > Real Time TDMA > EDGE > Data Format Pattern Framed.

Configuring the EDGE Timeslots

Press Configure Timeslots > Timeslot Type > Custom.
Press Configure Custom > Data > FIX4.

Press 1010 > Enter > Return > Return.

Press Timeslot # > 1 > Enter.

Press Configure Timeslots > Timeslot Type > Normal.

Press Configure Normal > TS > TSC1 > Return.

N o g &~ w DN

Press Timeslot Off On to On.

Configuring timeslot zero did not require atimeslot selection, because timeslot zero is the factory preset
timeslot selection. Thisis shown in step one where the timesl ot type selection happened without first
selecting the timeslot number. Notice that a data selection (FIX4) was made for timeslot zero, but that none
was made for timeslot one. This means that timeslot one will use the default data selection of PN9.

Configuring GMSK Timeslots

Press Timeslot # > 2 > Enter.

Press Timeslot Type > GMSK.

Press Configure GMSK > E > PN Sequence > PN15.

Press TS > TSC2 > Return.

Press Timeslot Off On to On.

Press Timeslot # > 3 > Enter.

Press Timeslot Type > GMSK.

Press Configure GMSK > E > Other Patterns > 32 1’s & 32 0’s.

© © N o g A~ W DN P

Press TS > TSC4 > Return.
10. Press Timeslot Off On to On.

The GMSK timedlot selection provides anormal GSM timelsot. Thisis the same normal timeslot found in
the GSM modulation format.

Chapter 14 365



Real Time TDMA Formats
EDGE Framed Modulation

Disabling Timeslot Ramping

1. PressTimeslot # > 2 > Enter.
2. Press Multislot Off On to On.
3. PressReturn.

Turning multislot on disables ramping between the current and the next higher numbered (adjacent)
timeslot. A line underscores the timeslots where ramping is disabled. For this procedure, ramping will not
occur between timeslots two and three (GM SK timeslots). The multisiot choice is a setting for each timedlot.

NOTE Disabling ramping between EDGE and GM SK timesl ots produces spectral components that
may not be desired. Thisis due to the transition between the two modulation types without
ramping.

Generating the Baseband Signal

Press EDGE Off On to On.

This generates an EDGE signal with an active custom timeslot, an active normal timeslot, and two active
GMSK modulated timeslots. While the ESG builds the signal, a status bar appears on the display. After the
signal building process, the EDGE, ENVLP, and | / Qannunciators appear, indicating that the signal is
modul ating the RF carrier.

Configuring the RF Output

1. PressFrequency > 891 > MHz.

2. Press Amplitude > -5 > dBm.

3. PressRF On/0ff to On.

The user-defined EDGE signal is now available at the signal generator’s RF OUTPUT connector.

To store this real-time I/Q baseband digital modulation state to the instrument state register, see “ Saving an
Instrument State” on page 69.

To recall area-time 1/Q baseband digital modulation state, see “Recalling an Instrument State” on page 70.

Adjusting the Power Level Between Timeslots

1. Press Amplitude > More (1 of 2) > Alternate Amplitude > Alt Amp Delta > -15 > dB.

2. Press Mode Setup > Configure Timeslots > Timeslot # > 1 > Enter.
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3. PressTimeslot Ampl Main Delta to Delta.

The power level for timeslot one is now 15 dB lower than the other active timeslots. To return the timeslot
oneto its previous power level, select Main on the Timeslot Ampl Main Delta softkey. The delta amplitude
choiceisavailable for each timeslot, however all timeslots use the same delta value set in the Alternate
Amplitude softkey menu.
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GSM Framed Modulation

This section describes how to build framed, real-time 1/Q baseband generated GSM modulation for testing
receiver designs. The procedures in this section build on each other, so perform them sequentially.

NOTE When using multiframe, limit the symbol rate to no more than 271 ksps. Although higher
rates may work, they are not supported.

To build and EDGE and GM SK modulated signal, see “EDGE Framed Modulation” on page 364.

Activating Framed Data Format

1. PressPreset.

2. Press Mode > Real Time TDMA > GSM > Data Format Pattern Framed.

Configuring the First Timeslot

1. Press Configure Timeslots > Timeslot Type > Access.
2. Press Configure Access > E > FIX4.

3. Press 1010 > Enter > Return > Return.

Configuring the Second Timeslot

1. PressTimeslot # > 1 > Enter.

2. PressTimeslot Type > Custom.

3. Press Configure Custom > Other Patterns > 8 1’s & 8 0’s.
4

Press Timeslot Off On to On > Return.

Configuring the Third Timeslot

1. PressTimeslot # > 2 > Enter.

2. PressTimeslot Type > Normal.

3. Press Configure Normal > E > PN Sequence > PN15.
4

Press Timeslot Off On to On > Return.
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Disabling Timeslot Ramping

1. PressTimeslot # > 1 > Enter.
2. Press Multislot Off On to On.
3. PressReturn.

Turning multisiot on disables ramping between the current and the next higher numbered (adjacent)
timeslot. A line underscores the timeslots where ramping is disabled. For this procedure, ramping will not
occur between timeslots one and two. The multislot choice is a setting for each timeslot.

Generating the Baseband Signal

Press GSM Off On to On.

This generates a GSM signal with an active access timeslot, an active custom timeslot, and an active normal
timeslot. The signal generator may require several secondsto build the signal. During thistime, Baseband
Reconf i guri ng appears on the display. After the reconfiguration is complete, the display reads GSM
and the GSM ENVLP, and | / Qannunciators appear indicating that the signal is modulating the RF carrier.

Configuring the RF Output

1. Set the RF output frequency to 891 MHz.

2. Set the output amplitude to —5 dBm.

3. PressRF On/0ff to On.

The user-defined GSM signal is now available at the signal generator’s RF OUTPUT connector.

To store this real-time I/Q baseband digital modulation state to the instrument state register, see “ Saving an
Instrument State” on page 69.

To recall area-time 1/Q baseband digital modulation state, see “Recalling an Instrument State” on page 70.

Adjusting the Power Level Between Timeslots

1. Press Amplitude > More (1 of 2) > Alternate Amplitude > Alt Amp Delta > -15 > dB.
2. Press Mode Setup > Configure Timeslots > Timeslot # > 1 > Enter.
3. Press Timeslot Ampl Main Delta to Delta.

The power level for timeslot one is now 15 dB lower than the other active timeslots. Selecting Main on the
Timeslot Ampl Main Delta softkey returns the timeslot to its previous power level. The delta amplitude choice
isavailable for each timeslot, however al timeslots use the same delta value set in the Alternate Amplitude
softkey menu.
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Enhanced Observed Time Difference (E-OTD)

Overview

The Enhanced Observed Timing Difference (E-OTD) positioning method relies upon measuring the time at
which signals from the Base Transceiver Station (BTS) arrive at two geographically dispersed locations-the
mobile phone/station (MS) and a fixed measuring point known as the L ocation Measurement Unit (LM U)
whose location is known. The position of the MSis determined by comparing the time differences between
the two sets of timing measurements.

Multiple ESGs are used with aremote interface to provide mobile manufactures the ability to test handsets
equipped with the E-OTD feature. The system will simulate area world network compl ete with a serving
cell (Agilent E5515C (8960 Series 10) Wireless Communications Test Set) and neighboring cells (ESG
Vector Signal Generator) that can be used to test E-OTD equipped handsets.

The ESG has no front panel user interface for the E-OTD feature, so signal setup is done using the GPIB
interface.

Basic GSM Frame Structure

TDMA Time Slot

A TDMA frameis composed of eight 577 micro second time slots (0-7). The basic TDMA frameduration is
4.615 msec. Each time dot contains 148 hits of information and contains a guard period of 8.25 bits. This
guard period is provided for the mobile station transmission to be attenuated between bursts as defined in the
3GPP standard. Of the 148 bits, some are used to carry data, others are used for control and synchronization.
Refer to Figure 14-1 on page 371.
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Figure 14-1 1 TDMA Frame Structure
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Each time slot when transmitted by the base transceiver station (BTS) or mobile phone station (MS) isa
radio burst. There are four types of GSM RF burst. Three of these burst types are in a category called full
duration and the fourth type is a short time duration burst. The three full duration bursts are: normal,
frequency correction, and synchronization. Both the base station and mobile station use the normal burst.
The remaining two sub-types, frequency correction and synchronization, are used only by the base station,
and only transmitted on the first time dlot (labeled zero). The forth type isashort burst (88 bits) called the
random access burst (RACH) and only used by the mobile station to make connection with the base station.
The remaining time is padded with guard bits to keep the timing of a slot consistent.

The frame structure for the base station and mobile station are the same. However, the slot numbers are
intentionally offset by three time slots so the mobile station does not have to transmit and receive at the same
time. Refer to Figure 14-1 on page 371.

GSM Multiframe Structure

The TDMA frames are grouped into larger structures called multiframes. These multiframe structures are
necessary to allow the partitioning of physical channelsinto logical channels.
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26 Frame Multiframe

The most basic of GSM multiframesis the traffic channel multiframe. Thisis made up of 26 frames and has
atimeinterval of 120 msec. Each frame of the 26-frame multiframe has an eight time slot TDMA frame
(4.62 msec). Thefirst 12 frames are used to transmit traffic data. Then one frameis used by the Slow
Associated Control Channel (SACCH) which provides channel maintenance. Then another 12 frames of
traffic datafollowed by an IDLE frame where not datais sent. This IDLE frame allows the mobile station to
perform other tasks such as measuring the signal strength of other neighboring cells. Refer to Figure 14-2 on
page 373.

51 Frame Multiframe

The 51-frame multiframe is comprised of 51 TDMA frames and has a duration of 235.4 ms. This multiframe
isused for control channels. Control channels always occur on the master frequency in the downlink
direction from the BTS to the mobile station. Different formats exist for the makeup of the 51-frame
multiframe but for E-OTD, type |V and V are used. The common features of these channels are the
frequency correction burst (FCCH), the synchronization burst (SCH), and the broadcast control channel
(BCCH). These different channel types allow the mobile station to synchronize to the base station in the
frequency domain and the time domain and provide information about the current broadcast channel. Refer
to Figure 14-2 on page 373.

Superframe

A superframe is composed of 51 26-frame multiframe or 26 51-frame multiframes which is equal to 1326
frames which is the lowest common denominator and is the least number of frames that can absorb the
contents of all the 26 or 51 multiframes and finish with no spare timeslots. Refer to Figure 14-2 on page 373.

Hyperframe

Thetimeinterval of the hyperframeis over three hourslong which is much longer than the typical telephone
connection. The encryption process used is not likely to repeat itself during a call of reasonable length and
the privacy is not compromised. The hyperframe is made up of 2048 superframes. Refer to Figure 14-2 on
page 373.
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Figure 14-2 Multiframe Hierarchy
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Broadcast Channel (BCH)

In abroadcast channel a51-frame multiframe is transmitted on time slot zero and provides the mobile
station with system information which the mobile station needs to gain access to the network. The broadcast
channel needsto remain at a constant power so other mobile stations can distinguish the broadcast channels
from normal channels. Therefore all eight time slots need to be used during each TDMA frame.
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Non-combined Broadcast Channel

The broadcast channel can be used in two different modes. The first is called non-combined mode where a
51 frame multiframe is used. The basic components of the non-combined broadcast channel are the
frequency control channel (FCCH) which provides a mobile station with a frequency reference for the base
station and allow the mobile station to lock on to the beacon frequency, the synchronization channel (SCH)
which allows the mobile station to synchronize in the time domain, the broadcast control channel (BCCH)
which contains more information needed for the mobile station to connect to the base station, and the
common control channel (CCCH) which contains the information to provide the channel setups and can
originate from the base station or the mobile. Refer to Figure 14-3 on page 374.

Figure 14-3 GSM Multiframe Structure
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Combined Broadcast Channel

Two separate 51-frame multiframes are used to form arepeating 102 frame sequence. The main difference
between the combined broadcast channel and the non-combined broadcast channel is that some of the
CCCH channels are replaced with standal one dedicated control channels (SDCCH/4) and slow associated
control channels (SACCH/4). Standal one dedicated control channels are intended for the transfer of
signaling information between a mobile and a base station. The purpose of the slow associated control
channel isto provide channel maintenance. The combined broadcast channel on the ESG simulates the
situation when no datais required to be transmitted to the mobile station but the logical channels are made
available. When this situation occurs a real base station would send dummy bursts, the ESG will therefore
also use dummy bursts. Refer to Figure 14-3 on page 374.
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Broadcast Control Channel (BCCH)

The broadcast control channel (BCCH) informs the mobile station about specific system parametersit needs
to identify the network. These messages include among others, Location Area Code (LAC) and the Mobile
Network Code (MNC). The BCCH appears once every 51-frame multiframe and lasts for four frames
(occurring in frames 2,3,4, and 5). System information messages contain various information for a mobile
station and are transmitted on the BCCH at different times. The ESG implementation will include only the
system information 3 (Sl 3) message repeated once per 51-frame multiframe. The SI3 message for the ESG
implementation will have four user definable fields and the rest will be fixed. The user definable parameters
are cell identity, which identifies a cell within alocation area and the location area identification. The
location identification is made up of the three parameters listed below:

MNC The mobile network code consists of 12 bits of data. Normally eight bits are used but for
PCS1900 NA, federal regulation mandatesthat a 3-digit MNC will be used. If two digits
are used then the upper 4 bits of thefield arefixed to 1111. For the ESG implementation
the upper four bits are set to 1111 and the field range is 0-255. Thisfield identifies the
network operator.

LAC The location area code provides 16 bits to allow network administrator to define a
location.
MCC The mobile country code defines the country the base station isin.

The following SCPI commands can be used to modify or query the system information 3 (SI3) user
definable parameters:

[: SOURce] : RADI o[ 1] | 2| 3| 4: GSM SLOTO: NORMal : ENCRypt i on: BCH: CELLi d <val >
[: SOURce] : RADI o[ 1] | 2| 3| 4: GSM SLOTO0: NORMal : ENCRypt i on: BCH: CELLi d?

[: SOURce] : RADI o[ 1] | 2| 3| 4: GSM SLOTO: NORMal : ENCRypt i on: BCH. MNC <val >

[: SOURce] : RADI o[ 1] | 2| 3| 4: GSM SLOTO: NORMal : ENCRypt i on: BCH: MNC?

[: SOURce] : RADI o[ 1] | 2| 3| 4: GSM SLOTO: NORMal : ENCRypt i on: BCH: MCC <val >

[: SOURce] : RADI o[ 1] | 2| 3| 4: GSM SLOTO: NORMal : ENCRypt i on: BCH: MCC?

[: SOURce] : RADI o[ 1] | 2| 3| 4: GSM SLOTO: NORMal : ENCRypt i on: BCH: LAC <val >

[: SOURce] : RADI o[ 1] | 2| 3| 4: GSM SLOTO: NORMal : ENCRypt i on: BCH: LAC?
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E-OTD Measurement System Synchronization

To allow an Enhanced Observed Time Difference (E-OTD) measurement to be made it isimportant that all
the instrumentsin the system are synchronized. To do thisa PSA is used to measure the time from the trigger
pulseto TO - where TO is defined as the middle of the training sequence. The ESG will always produce RF
quicker than the PSA dueto abuilt in delay for the ESG.

Below is an equipment diagram and SCPI command procedure to measure the trigger to TO (TO = middle of
the midamble of aburst) measurement. Some of the SCPI commands used in this procedure to set up the
instruments and make the measurements do not have a front panel equivalent key press. The features are
only available using the remote GPIB interface.

Figure 14-4
E5515C (8960 Series 10)

Wireless Communication
Test Set

Symb | 10 MHz
Ck Out | Ref Out

Trig ||e
In

ANALYZER

RF Cable

SIGNAL Out
GENERATOR
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GPIB commandsto set up the ESG.
//Select Frequency band, channel, and power.

: FREQuency: CHANnel s: BAND BPGSm

: FREQuency: CHANnel s: NUMBer 40

. FREQuency: CHANnel s: STATe ON

: POWer : LEVel : | Mvedi at e: AMPLI t ude - 10DBM
: OUTPut ON

/I1Select external data clock for GSM.

: RADI 0: GSM BBCLock EXT

- RADI 0: GSM SLOTO: NORMal : ENCRypt i on PN9
. RADI 0: GSM BURSt ON

: RADI 0: GSM SLOTO0: STATe ON

//Select triggering

. RADI 0: GSM TRI Gger : TYPE: SI NG
: RADi 0: GSM TRI Gger : EXT
: RADI 0: GSM TRI Gger : EXTer nal : SOURce EPT1

//Turn on GSM modulation.
: RADI 0: GSM ON

GPIB commandsto set up the 8960.

. CALL: OPER: MODE GBTT

1 CALL: BCH 120

:CALL: TCH 1

. CALL: POW - 10

:CALL: TCH: TSL 2

: CALL: TRI G FRAM NI DL: STAT ON

Real Time TDMA Formats
Enhanced Observed Time Difference (E-OTD)

The 8960 is now generation a broadcast channel (BCH) on absolute radio frequency channel number
(ARFCN) 120, atraffic channel (TCH) on ARFCN 1, and is sending out atrigger pulse for every frame not
idle. The ESG is being triggered to generate asingle dlot traffic channel on thistrigger. In thismode, it is
important that the symbol clock from the 8960 is used as the source for the external data clock on the ESG
Thisisimportant because the two instruments need to have their clocks aligned or the triggering can be
delayed up to 3.69 microseconds. Using the symbol clock from the 8960 as a data clock for the ESG ensures

synchronous operation.
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To make the trigger to TO measurement it is necessary to send the following command using the remote
interface:

: READ: PVT107?

The READ command performs an INIT followed by a FETCH so a new measurement is started each time.
With no averaging the standard deviation should be approximately 4ns for the ESG and 9ns for the 8960.

For this set up the ESG uses a continuous triggering mode, trigger and run. In this mode the ESG waits for a
trigger pulse, then runs and ignores any further trigger pul ses.

//Send the following commands to set the trigger mode:

. RADI 0: GSM TRI Gger : TYPE: CONTi nuous TRI G
: RADI 0: GSM TRI Gger EXT
: RADI 0: GSM TRI Gger : TYPE CONT

/IThe ESG is set up to have a non-combined BCH in slot 0 and anormal TCH on slot 2

: RADI 0: GSM SLOTO: NORMal ENCRypt i on BCHL
- RADI 0: GSM SLOT2: TYPE: NORMal
. RADI 0: GSM SLOT2: NORMal : ENCRypti on PN9

At this point the ESG iswaiting for atrigger. Sending a CALL statement to the 8960 resets the frame
counters and sets asingle trigger at the beginning of the multiframe. Now both the 8960 and the ESG are
running together but not perfectly aligned.

: CALL: TRI G QUTP: FRAM SYNC

Measure the trigger to TO for each. If the 8960 isthe first burst then it is necessary to restart the system with
asymbol offset applied to the trigger.

Send the following commands to make the ESG ready and align the ESG with the 8960:

- RADI 0: GSM TRI Gger : TYPE: CONT

: CALL: TRI G FRAM SYNC: OFFS xx (where xx is the nunber of synbols to advance the trigger)

. RADI 0: GSM TRI G EXT: DEL: FINE yy (where yy is the fraction of a synbol necessary for perfect
al i gnnent)

Thelast command is acall to the 8960 to start up again. Now both bursts should be in alignment and the
frame counters reset.

: CALL: TRI G QUTP: FRAM SYNC
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Sample SCPI Command Scripts

This section has two scenarios in which SCPI commands are used to setup the ESG to transmit a Broadcast
Channel (BCH).

Example 1, Setting Up a Non-Combined Broadcast Channel

This example will setup the ESG to generate a Non-Combined Broadcast Channel at 935.2 MHz with a
power level of —10 dBm. A public land mobile network (PLMN) value of 2 will be chosen and a base station
colour code (BCC) value of 3 will be set. The trigger will be setup in “trigger and run” mode which means
that the ESG will start generating a BCH on receipt of the first trigger and any further triggers will be
ignored. Thetrigger will be setup to use the external pattern trigger 1.

Reset the ESG to its power on state.
*RST

Select the frequency band, channel and power.

. FREQuency: CHANnel s: BAND BPGSm

. FREQuency: CHANnel s: NUMBer 1

: FREQuency: CHANnel s: STATe ON

. POWer : LEVel : | MVedi at e: AMPLI t ude -10dBm

. RADI 0: GSM BURSt : STATe ON

- RADI 0: GSM SLOTO: NORMal : ENCRypt i on BCHL
. RADI 0: GSM SLOT1: DUMW: TSEQuence #H1C5C5C5
. RADI 0: GSM SLOT2: NORMal : ENCRypti on PN9
- RADI 0: GSM SLOT3: NORMal : ENCRypt i on PN9
. RADI 0: GSM SLOT4: NORMal : ENCRypti on PN9
. RADI 0: GSM SLOT5: NORMal : ENCRypti on PN9
- RADI 0: GSM SLOT6: NORMal : ENCRypt i on PN9
. RADI 0: GSM SLOT7: NORMal : ENCRypti on PN9
. RADI 0: GSM SLOTO: TYPe NORMal

- RADI 0: GSM SLOT1: TYPe DUMW

. RADI 0: GSM SLOT2: TYPe NORMal

. RADI 0: GSM SLOT3: TYPe NORMal

- RADI 0: GSM SLOT4: TYPe NORMal

. RADI 0: GSM SLOT5: TYPe NORMal

. RADI 0: GSM SLOT6: TYPe NORMal

- RADI 0: GSM SLOT7: TYPe NORMal
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Setup the ESG to have a non-combined broadcast channel in dot 0, adummy burst in dot 1, and the other

time slots will have a normal burst with a PN9 sequence in the payload fields.
Turn each time slot on and select TSCO for the training bit sequence.

: RADi 0: GSM SLOTO:
: RADi 0: GSM SLOT1:
. RADI 0: GSM SLOT2:
: RADI 0: GSM SLOT3:
: RADI 0: GSM SLOT4:
. RADI 0: GSM SLOT5:
: RADI 0: GSM SLOT6:
: RADi 0: GSM SLOT7:
. RADI 0: GSM SLOTO:
: RADi 0: GSM SLOT1:
: RADI 0: GSM SLOT2:
. RADI 0: GSM SLOT3:
: RADi 0: GSM SLOT4:
: RADi 0: GSM SLOT5:
. RADi 0: GSM SLOT6:
: RADi 0: GSM SLOT7:

Setup the public land mobile network and base station color code values.

- ENCRypti on:
: ENCRypti on:
: ENCRypti on:
: ENCRypti on:
: ENCRypti on:
: ENCRypti on:

. RADI 0: GSM SLOTO:
: RADi 0: GSM SLOTO:
: RADi 0: GSM SLOTO:
. RADI 0: GSM SLOTO:
: RADi 0: GSM SLOTO:
: RADi 0: GSM SLOTO:

NORMal
NORMal
NORMal
NORMal
NORMal
NORMal
NORMal
NORMal
STATe
STATe
STATe
STATe
STATe
STATe
STATe
STATe

NORMal
NORMal
NORMal
NORMal
NORMal
NORMal

: TSEQuence
: TSEQuence
: TSEQuence
: TSEQuence
: TSEQuence
: TSEQuence
: TSEQuence
: TSEQuence

22222229

TSC3
TSC3
TSC3
TSC3
TSC3
TSC3
TSC3
TSC3

BCH: PLMN 2
BCH: BCC 3
BCH: CELLi d 4
BCH: MNC 2
BCH: MCC 2
BCH: LAC 4

Set the trigger mode to continuous, the trigger type to “trigger and run”, and setup the ESG to accept an
external trigger on EPT1.

: RADI 0: GSM TRI Gger :
: RADI 0: GSM TRI Gger

. RADI 0: GSM TRI Gger EXT

: RADI 0: GSM TRI Gger :

TYPE CONT
: TYPE: CONTi nuous: TYPE TRI Gger

EXTer nal : SOURce EPT1

Turn the GSM modulation format and RF to ON.

: OUTPut : STATe 1

: SOURce: RADI 0: GSM STATe ON
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Example 2, Setting Up a Combined Broadcast Channel

This example will setup the ESG to generate a Combined Broadcast Channel at 935.2 MHz with a power
level of =10 dBm. A public land mobile network (PLMN) value of 4 will be chosen and a base station colour
code (BCC) value of 1 will be set. The trigger will be setup in “trigger and run” mode which means that the
ESG will start generating a BCH on receipt of the first trigger and any further triggers will be ignored. The
trigger will be setup to use the external pattern trigger 1.

Reset the ESG to its power on state.
*RST
Select the frequency band, channel and power.

: FREQuency: CHANnel s: BAND BPGSm

. FREQuency: CHANnel s: NUMBer 1

. FREQuency: CHANnel s: STATe ON

: POWer : LEVel : | MVedi at e: AMPLI t ude - 10dBm

Setup the ESG to have a Combined Broadcast Channel in slot 0 and all other time slots will have a normal
burst with a PN9 sequence in the payload fields.

. RADI 0: GSM BURSt : STATe ON

. RADI 0: GSM SLOTO: NORMal : ENCRypti on BCH2
- RADI 0: GSM SLOT1: NORMal : ENCRypt i on PN9
. RADI 0: GSM SLOT2: NORMal : ENCRypti on PN9
. RADI 0: GSM SLOT3: NORMal : ENCRypti on PN9
- RADI 0: GSM SLOT4: NORMal : ENCRypt i on PN9
. RADI 0: GSM SLOT5: NORMal : ENCRypti on PN9
. RADI 0: GSM SLOT6: NORMal : ENCRypti on PN9
- RADI 0: GSM SLOT7: NORMal : ENCRypt i on PN9
. RADI 0: GSM SLOTO: TYPe NORMal

. RADI 0: GSM SLOT1: TYPe NORMal

: RADI 0: GSM SLOT2: TYPe NORMal

. RADI 0: GSM SLOT3: TYPe NORMal

. RADI 0: GSM SLOT4: TYPe NORMal

: RADi 0: GSM SLOT5: TYPe NORMal

. RADI 0: GSM SLOT6: TYPe NORMal

. RADI 0: GSM SLOT7: TYPe NORMal
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Turn each time slot on and select TSCO for the training bit sequence.

: RADI o:
: RADI o:
. RADI o:
: RADI o:
: RADiI o:
. RADI o:
: RADI o:
: RADiI o:
. RADI o:
: RADiI o:
: RADI o:
. RADI o:
: RADI o:
: RADiI o:
. RADI o:
: RADI o:

Setup the public land mobile network (PLMN) and base station color code (BCC) values.

- ENCRypti on:
: ENCRypti on:
: ENCRypti on:
: ENCRypti on:
: ENCRypti on:
: ENCRypti on:

. RADI o:
: RADI o:
: RADI o:
. RADI o:
: RADiI o:
: RADI o:

GSM SLOTO:
GSM SLOT1:
GSM SLOT2:
GSM SLOT3:
GSM SLOT4:
GSM SLOT5:
GSM SLOT6:
GSM SLOT7:
GSM SLOTO:
GSM SLOT1:
GSM SLOT2:
GSM SLOT3:
GSM SLOT4:
GSM SLOT5:
GSM SLOT6:
GSM SLOT7:

GSM SLOTO:
GSM SLOTO:
GSM SLOTO:
GSM SLOTO:
GSM SLOTO:
GSM SLOTO:

NORMal
NORMal
NORMal
NORMal
NORMal
NORMal
NORMal
NORMal
STATe
STATe
STATe
STATe
STATe
STATe
STATe
STATe

NORMal
NORMal
NORMal
NORMal
NORMal
NORMal

: TSEQuence
: TSEQuence
: TSEQuence
: TSEQuence
: TSEQuence
: TSEQuence
: TSEQuence
: TSEQuence

22222229

TSC1
TSC1
TSC1
TSC1
TSC1
TSC1
TSC1
TSC1

BCH: PLMN 4
BCH: BCC 1
BCH: CELLid 4
BCH: M\C 4
BCH: MCC 4
BCH: LAC 4

Set the trigger mode to continuous, the trigger type to “trigger and run”, and setup the ESG to accept an
external trigger on EPT 1.

: RADI 0: GSM TRI Gger :
: RADI 0: GSM TRI Gger :

. RADI 0: GSM TRI Gger EXT

: RADI 0: GSM TRI Gger :

TYPE CONT
TYPE: CONTi nuous: TYPE TRI Gger

EXTer nal : SOURce EPT1

Turn the GSM modulation format and RF to ON.

: OUTPut : STATe 1
: SOURce: RADIi 0: GSM STATe ON
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DECT Framed Modulation

This exampl e teaches you how to build framed real-time I/Q baseband generated DECT modulation for
testing receiver designs. The procedures in this section build on each other and are designed to be used
sequentially.

Activating Framed Data Format

1. PressPreset.

2. Press Mode > Real Time TDMA > DECT > Data Format Pattern Framed.

Configuring the First Timeslot

1. Press Configure Timeslots > Timeslot Type > Custom.

2. Press Configure Custom > Other Patterns > 8 1’s & 8 0’s.

Configuring the Second Timeslot

1. PressTimeslot # > 1 > Enter.

2. PressTimeslot Type > Traffic Bearer.

3. Press Configure Traffic Bearer > B field > Other Patterns >4 1’s & 4 0’s.
4

Press Return > Timeslot Off On to On > Return.

Generating the Baseband Signal

Press DECT Off On to On.

This generates a DECT signal with an active custom timeslot (#0) and an active traffic bearer timeslot (#1).
The signal generator may require several seconds to build the signal. During thistime, Baseband
Reconf i guri ng appears on the display. After the reconfiguration is complete, the display reads DECT On
and the DECT, ENVLP, and | / Qannunciators appear. The signal is now modulating the RF carrier.

The signal’s configuration dataresides in volatile memory and is not recoverable after an instrument preset,
power cycle, or reconfigured signal generation.
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Configuring the RF Output

1. Set the RF output frequency to 1.89 GHz.

2. Set the output amplitude to —10 dBm.

3. PressRF On/0ff to On.

The user-defined DECT signal is now available at the signal generator’s RF OUTPUT connector.

To store this real -time I/Q baseband digital modulation state to the instrument state register, see “ Saving an
Instrument State” on page 69.

To recall areal-time1/Q baseband digital modulation state, see “ Recalling an Instrument State” on page 70.
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PHS Framed Modulation

This example teaches you how to build framed real -time 1/Q baseband generated PHS modul ation for testing
receiver designs. The proceduresin this section build on each other and are designed to be used sequentially.

Activating Framed Data Format

1. PressPreset.

2. Press Mode > Real Time TDMA > PHS > Data Format Pattern Framed.

Configuring the First Timeslot

1. Press Configure Timeslots > Timeslot Type > Custom.
2. Press Configure Custom > FIX4.

3. Press 1010 > Enter > Return.

Configuring the Second Timeslot

1. Press Control Channel Dnlink Uplink.

2. PressTimeslot Type > Custom.

3. Press Configure Custom > Other Patterns > 4 1’s & 4 0’s.
4

. PressReturn.

Generating the Baseband Signal

Press PHS Off On to On

This generates a PHS signal with an active downlink custom timeslot (#1) and an active uplink custom
timeslot (#1). The signal generator may require several seconds to build the signal. During thistime,
Baseband Reconfi guri ng appears on the display. After the reconfiguration is complete, the display
reads PHS On and the PHS, ENVLP, and | / Qannunciators appear. The signal is now modulating the RF
carrier.

The signal’s configuration dataresides in volatile memory and is not recoverable after an instrument preset,
power cycle, or reconfigured signal generation.

Chapter 14 385



Real Time TDMA Formats
PHS Framed Modulation

Configuring the RF Output

1. Set the RF output frequency to 1.89515 GHz.

2. Set the output amplitude to 0 dBm.

3. PressRF On/0ff to On.

The user-defined PHS signal is now available at the signal generator’s RF OUTPUT connector.

To store this real-time I/Q baseband digital modulation state to the instrument state register, see “ Saving an
Instrument State” on page 69.

To recall areal-time1/Q baseband digital modulation state, see “ Recalling an Instrument State” on page 70.
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PDC Framed Modulation

This exampl e teaches you how to build framed real-time I/Q baseband generated PDC modulation for
testing receiver designs. The procedures in this section build on each other and are designed to be used
sequentially.

Activating Framed Data Format

1. PressPreset.

2. Press Mode > Real Time TDMA > PDC > Data Format Pattern Framed.

Configuring the First Timeslot

1. Press Configure Timeslots > Timeslot Type > Down TCH.
2. Press Configure Down TCH > TCH > FIX4.

3. Press 1010 > Enter > Return > Return.

Configuring the Second Timeslot

Press Rate Full Half.
Press Timeslot > 3 > Enter.
Press Timeslot Type > Down TCH.

Press Configure Down TCH > TCH > Other Patterns >4 1’s & 4 0’s.

o A WD

Press Return > Timeslot Off On to On > Return.

Generating the Baseband Signal

Press PDC Off On to On.

This generates a half rate PDC signal with an active downlink traffic channel timeslot (#0) and an active
downlink traffic channel timeslot (#3). The signal generator may require several secondsto build the signal.
During thistime, Baseband Reconfi guri ng appears on the display. After the reconfiguration is
complete, the display reads PDC On and the PDC, ENVLP, and | / Qannunciators appear. The signal is now
modul ating the RF carrier.

The signal’s configuration dataresides in volatile memory and is not recoverable after an instrument preset,
power cycle, or reconfigured signal generation.
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Configuring the RF Output

1. Set the RF output frequency to 832 MHz.

2. Set the output amplitude to 0 dBm.

3. PressRF On/0ff to On.

The user-defined PDC signal is now available at the signal generator’'s RF OUTPUT connector.

To store this real-time I/Q baseband digital modulation state to the instrument state register, see “ Saving an
Instrument State” on page 69.

To recall areal-time1/Q baseband digital modulation state, see “ Recalling an Instrument State” on page 70.
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NADC Framed Modulation

This exampl e teaches you how to build framed real-time I/Q baseband generated NADC modulation for
testing receiver designs. The procedures in this section build on each other and are designed to be used
sequentially.

Activating Framed Data Format

1. PressPreset.

2. Press Mode > Real Time TDMA > NADC > Data Format Pattern Framed.

Configuring the First Timeslot

1. Press Configure Timeslots > Timeslot Type > Down TCH.
2. Press Configure Down TCH > Data > FIX4.

3. Press 1010 > Enter > Return > Return.

Configuring the Second Timeslot

Press Rate Full Half.
Press Timeslot > 4 > Enter.
Press Timeslot Type > Down TCH.

Press Configure Down TCH > Data > Other Patterns >4 1’s & 4 0’s.

o A w DN

Press Return > Timeslot Off On to On > Return.

Generating the Baseband Signal

Press NADC Off On to On.

This generates a half rate NADC signal with an active downlink traffic channel timeslot (#1) and an active
downlink traffic channel timeslot (#4). The signal generator may require several secondsto build the signal.
During thistime, Baseband Reconfi guri ng appears on the display. After the reconfiguration is
complete, the display reads NADC (n and the NADC, ENVLP, and | / Qannunciators appear. The signal is
now modulating the RF carrier.

The signal’s configuration dataresides in volatile memory and is not recoverable after an instrument preset,
power cycle, or reconfigured signal generation.
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Configuring the RF Output

1. Set the RF output frequency to 835 MHz.

2. Set the output amplitude to 0 dBm.

3. PressRF On/0ff to On.

The user-defined NADC signal is now available at the signal generator’s RF OUTPUT connector.

To store this real-time I/Q baseband digital modulation state to the instrument state register, see “ Saving an
Instrument State” on page 69.

To recall areal-time1/Q baseband digital modulation state, see “ Recalling an Instrument State” on page 70.
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TETRA Framed Modulation

This exampl e teaches you how to build framed real-time I/Q baseband generated TETRA modulation for
testing receiver designs. The procedures in this section build on each other and are designed to be used
sequentially.

Activating Framed Data Format

1. PressPreset.

2. Press Mode > Real Time TDMA > TETRA > Data Format Pattern Framed.

Configuring the First Timeslot

1. Press Configure Timeslots > Timeslot Type > Up Control 1.
2. Press Configure Up Control 1 > Data > FIX4.

3. Press 1010 > Enter > Return > Return.

Configuring the Second Timeslot

1. PressTimeslot > 2 > Enter.

2. PressTimeslot Type > Up Custom.

3. Press Configure Up Custom > Other Patterns >4 1’s & 4 0’s.
4

Press Timeslot Off On to On > Return.

Generating the Baseband Signal

Press TETRA Off On to On.

This generates a TETRA signal with an active uplink control 1 timeslot (#1) and an active uplink custom
timeslot (#2). The signal generator may require several seconds to build the signal. During thistime,
Baseband Reconfi guri ng appears on the display. After the reconfiguration is complete, the display
reads TETRA On and the TETRA, ENVLP, and | / Qannunciators appear. The signal is now modulating the
RF carrier.

The signal’s configuration dataresides in volatile memory and is not recoverable after an instrument preset,
power cycle, or reconfigured signal generation.
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Configuring the RF Output

1. Set the RF output frequency to 1.894880 MHz.

2. Set the output amplitude to 0 dBm.

3. PressRF On/0ff to On.

The user-defined TETRA signal is now available at the signal generator’s RF OUTPUT connector.

To store this real -time I/Q baseband digital modulation state to the instrument state register, see “ Saving an
Instrument State” on page 69.

To recall areal-time1/Q baseband digital modulation state, see “ Recalling an Instrument State” on page 70.
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15 W-CDMA Digital Modulation for Component Test

Thisfeature is available only in E4438C ESG Vector Signal Generators with Option 001/601or 002/602.
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W-CDMA Downlink Modulation

This section teaches you how to build W-CDMA downlink waveforms for testing component designs. The
waveforms are generated by the signal generator’sinternal dual arbitrary waveform generator.

Activating a Predefined W-CDMA Downlink State
This procedure teaches you how to perform the following tasks:

» “Selecting a Predefined W-CDMA Setup” on page 394
* “Generating the Waveform” on page 394
e “Configuring the RF Output” on page 394

Selecting a Predefined W-CDMA Setup

1. PressPreset.
2. Press Mode > W-CDMA > Arb W-CDMA.
3. Press W-CDMA Select > 3 DPCH.

This selects three predefined dedicated physical channels (DPCH) for a downlink waveform. The display
changesto DL WCDVA Set up: 3 DPCH Downlink isthe signal generator’s default setting for link
direction and, therefore, does not need to be set.

Generating the Waveform

Press W-CDMA Off On until On is highlighted.

This generates the predefined 3 DPCH W-CDMA downlink waveform. During waveform generation, the
WCDWVA and | / Qannunciators appear and the waveform is stored in volatile ARB memory. The waveformis
now modulating the RF carrier.

Configuring the RF Output

1. Set the RF output frequency to 2.17 GHz.
2. Set the output amplitude to —10 dBm.
3. PressRF On/0ff until On is highlighted.

The predefined W-CDMA downlink signal is now available at the signal generator’'s RF OUTPUT
connector.
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Creating a User-Defined W-CDMA Downlink State
This procedure teaches you how to perform the following tasks:

e “Selecting aW-CDMA Downlink Setup” on page 395

e “Editing Downlink Channel Parameters’ on page 396

* “Inserting Additional Channels’ on page 398

» “Clipping the Waveform” on page 398

* “Generating the Waveform” on page 399

» “Applying Channel Modifications to an Active Waveform” on page 399
» “Configuring the RF Output” on page 399

CAUTION Unless previously saved to the signal generator’s non-volatile memory, modifications made
to predefined channel configurations are lost when changes are made to link direction.

To store a custom W-CDMA state, see “ Storing a W-CDMA Downlink/Uplink State” on
page 399.

Selecting a W-CDMA Downlink Setup

1. PressPreset.
2. Press Mode > W-CDMA > Arb W-CDMA.
3. Press W-CDMA Define > Edit Channel Setup.

The channel table editor is now displayed, as shown in the following figure. Notice that a dedicated physical
channel (DPCH) with predefined parameters is the default setup. The horizontal scroll bar at the bottom of
the screen indicates that there are more columns to the right of the Scr anbl e Code column. Use the front
panel knob or right arrow key to move the cursor to view the additional columns.
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Figure 15-1
FREQUENCY AMPLITUDE
U Edit Item
4.000 00000000 &= | -136.00 den
i Insert. RouM
| Oelete Row
Chip Rate: 3.8u0000NcPs Total Pouer: 0.00dB
Link: Doun Channel Code Domain: 0032-0035
T Adjust
Rate Spread Pouer Timing Scramble 5
Tupe  ksps  Code dB Offset TFCI  TPC  Code |-0d8 Domain Power
1 30.0 E 0.o0 0 0 555S 0
2 - T - T TT T Display
Code Domain Pover
Goto RoqM
[ ] More
(1 0f 27

Editing Downlink Channel Parameters

1. Usethe front panel knob or arrow keysto move the cursor to table row 1.
2. Highlight the TPC value (5555).
3. PresskEdit Item > 00FF > Enter.

The TPC value has now been modified and the cursor has moved to the next row in the TPC column.

NOTE TPC values are entered as hexadecimal digits. For information on what these values
represent, refer to “ Understanding TPC Values’ on page 413.

4. Highlight thevalue (0. 00) inthe TFQl Power dBfield, whichis currently hidden from view.

The horizontal scroll bar at the bottom of the screen indicates that there are columns to the right of the
Scranbl e Code column.

Press Edit Item > 2 > dB.

Highlight the value (0. 00) in the TPC Power dBfield.
Press Edit Item > 3 > dB.

Highlight the value (0. 00) inthe Pi | ot Power dBfield.
Press Edit Item > 1 > dB.

© © N o O
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NOTE For additional information on TFCI, TPC, and pilot power offsets, refer to “Understanding
TFCI, TPC, and Pilot Power Offsets’ on page 414.

10. Highlight the value (4) inthe Pi | ot Bi t s field.

11. PressEdit Item > 8.

12. Highlight the value (RANDQV) in the Dat a field.

13. Press Edit Item > PNO9.

14. Highlight the value (STD) in the Scr anbl e Type field.
15. Press Edit Item > Right Alternate.

16. Highlight the value (0) inthe Scr anbl e f f set field.
17. Press Edit Item > 1 > Enter.

NOTE For additional information on Scramble Type and Scramble Offset, refer to “Calculating
Downlink Scramble Codes’ on page 416.

The downlink DPCH channel parameters have now been modified, as shown. Other channel parameters can
be modified in the same manner.

Figure 15-2
FREQUENCY FLITUCE Edit. Ttem
4,000 000 000 00 st | ~136.00 oo
LLL Insert. Rou
| Delete Row
Chip Rate: 3.8u0000MNcps Total Pouer: 0.00dB
Link: Doun Channel Code Domain: 0000-0000
IEF[:I IJTIJ[: Bilut pilot Scramhle Ad.iust
ouer 'ouer ouer Pilo : H
dB dB dB Bils  Data  Tups Offset Code Domain Pouer
1 2.00 2.00 1.00 a PH3 RGT 1
2 - — = Display,)
Code Domain Power
Goto RowM
More
(1 of 23
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Inserting Additional Channels
Press Insert Row > More (1 of 2) > Multiple Channels > Channels > 20 > Enter > Done.

The channel table editor now contains 20 additional channels, as shown in the following figure. The page
only displays six channels. To view the additional channels, press the following keys:

Return > Goto Row > Page Up

Figure 15-3
FREQUENCY AMPLITLOE
PCCPCH
4.000 00000000 sz | -136.00 dn
L PSCH
| S5CH
Chip Rate: 3.8LD00OHCPs Total Pouer: 13.22dB
Link: Doun Channel Code Domain: 0000-0000
TFCI TPC Pilot
Pouer Pouer Pouer Pilot Scramble CPICH
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17 0.00 0.00 0.0 L RANDOM 510 0
18 0.00 0.0 0.00 L RAMOOM  STD u] OFCHM
19 0.00 0.oo0 0.00 L RANOOM  STD u]
20 0.00 0.0 0.00 L RAMOOM  STD u]
21 0.00 0.oo0 0.00 L RANOOM  STD u] ;
Hultipl
22 s — == Charne 15"
| More
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Clipping the Waveform
1. Press Mode Setup > More (1 of 2) > ARB Setup > Waveform Utilities > Clipping.
2. PressClip |1+jQ] To > 80 > %.
The waveform is now set to be clipped at 80 percent of its peak value.
NOTE If the waveform is active (W-CDMA Off On set to On), clipping settings are not applied until

you press the Apply To Waveform softkey.

398 Chapter 15



W-CDMA Digital Modulation for Component Test
W-CDMA Downlink Modulation

Generating the Waveform
Press Mode Setup > W-CDMA Off On until On is highlighted.

This generates a waveform with the custom W-CDMA downlink state created in the previous sections. The
display changesto DL WCDIVA Set up: 1 DPCH (Modi fi ed) . Notethat 1 DPCH refersto the predefined
configuration, not the number of channels in the user-modified waveform.

During waveform generation, the WCDIVA and | / Qannunciators appear and the waveform is stored in
volatile ARB memory. The waveform is now modulating the RF carrier.

For instructions on storing this user-defined W-CDMA state to the signal generator’s non-volatile memory,
see “ Storing a W-CDMA Downlink/Uplink State” on page 399.
Applying Channel Modifications to an Active Waveform

To apply channel modifications to an active waveform (W-CDMA Off On set to On), you must press the Apply
Channel Setup softkey to force the updated waveform to generate. For example, perform the following steps:

1. Press W-CDMA Define > Edit Channel Setup.
2. Movethe cursor to row 2.
3. Press Delete Row > Return > Apply Channel Setup.

Notice that the waveform isregenerated to include the modification of the deleted row. Any changes madein
the Edit Channel Setup table editor while awaveform is active will not be applied until the Apply Channel
Setup softkey is pressed.

Configuring the RF Output

1. Set the RF output frequency to 2.17 GHz.

2. Set the output amplitude to —10 dBm.

3. PressRF On/0ff until On is highlighted.

The custom W-CDMA downlink signal is now available at the signal generator’'s RF OUTPUT connector.

Storing a W-CDMA Downlink/Uplink State

This procedure teaches you how to store a user-defined W-CDMA state. If you have not created aW-CDMA
state, complete the steps in the previous section, “ Creating a User-Defined W-CDMA Downlink State” on
page 395.

1. Press Mode Setup to return to the top-level W-CDMA menu, where W-CDMA Off On is the first softkey.
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2. Press W-CDMA Define > Store Custom W-CDMA State > Store To File.
If thereis already a file name occupying the active entry area, press the following keys:
Editing Keys > Clear Text.

3. Enter afile name using the alpha softkeys and the numeric keypad with a maximum length of 23
characters.

4. PressEnter.

The user-defined W-CDMA downlink/uplink state is now stored in non-volatile memory and the file nameis
listed in the catalog of files. Note that the actual waveform is not stored; the parameters for generating the
signal are stored. The RF output amplitude, frequency, and operating state settings are not stored as part of a
user-defined W-CDMA statefile.

Recalling a W-CDMA Downlink/Uplink State

This procedure teaches you how to recall aW-CDMA state from the signal generator’s non-volatile memory.

If you have not created and stored aW-CDMA state, compl ete the stepsin the previous sections, “ Creating a
User-Defined W-CDMA Downlink State” on page 395 and “ Storing a W-CDMA Downlink/Uplink State”
on page 399, then preset the signal generator to clear the stored CDMA waveform from volatile ARB
memory.

1. Press Mode > W-CDMA > Arb W-CDMA.

2. Press W-CDMA Select > Custom W-CDMA State.
3. Highlight the desired file.

4. Press Select File.

5. Press W-CDMA Off On until On is highlighted.

The firmware generates the user-defined W-CDMA waveform in volatile ARB memory. The waveform is
now modulating the RF carrier.

For instruction on configuring the RF output, see “ Configuring the RF Output” on page 399.
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Creating a User-Defined Multicarrier W-CDMA State

This procedure teaches you how to perform the following tasks:

“Selecting aMulticarrier W-CDMA Setup” on page 401

“Adding aCarrier” on page 401

“Modifying Carrier Parameters’ on page 401

“Clipping the Multicarrier Waveform” on page 403

“Generating the Waveform” on page 403

“Applying Modifications to an Active Multicarrier Waveform” on page 404
“Configuring the RF Output” on page 404

Selecting a Multicarrier W-CDMA Setup

1
2.
3.

Press Preset.
Press Mode > W-CDMA > Arb W-CDMA.

Press Multicarrier Off On > Multicarrier Define.

TheMul ticarrier WCDVA 3GPP Set up table editor is now displayed, showing parameters for the
default two-carrier setup.

Adding a Carrier

1

Highlight the POCPCH + SCHcarrier in table row 2 and press, Insert Row > 3 DPCH.

This adds a predefined 3 DPCH carrier between the two original default carriers. You can also add a custom
W-CDMA carrier that has been previoudly created and stored.

Modifying Carrier Parameters

1
2.

Press Return.

Highlight the Freq O f set value (7. 500000 MHz) for the new 3 DPCH carrier in row 2 and press,
Edit Item > -2.5 > MHz. Refer to, “Multicarrier Setup Page 1" on page 402.

Highlight the Power value (0. 00 dB) for the new 3 DPCH carrier in row 2 and press, Edit Item > -10 >
dB. Refer to, “Multicarrier Setup Page 1" on page 402.

Highlight Pri mary Scranbl e Code value N A for the new 3 DPCH carrier in row 2 and press, Edit
Item > 5 > Enter. Refer to, “Multicarrier Setup Page 2" on page 403.
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5. Highlightthe Tim ng O f set value0 for the new 3 DPCH carrier in row 2 and press, Edit Item > 3 >
Enter. Refer to, “Multicarrier Setup Page 2" on page 403.

6. Highlightthel niti al

Phase valueO for the new 3 DPCH carrier inrow 2 and press,
Edit Item > 8 > Enter. Refer to, “Multicarrier Setup Page 2" on page 403.

7. HighlightthePre-FIR Cipping |1+ @ vaueforthenew 3 DPCH carrier in row 2 and press,
Edit Item > 50 > %. Refer to, “Multicarrier Setup Page 2" on page 403.

NOTE The E4438C allows you to clip each individual channel by setting the I+jQ pre-FIR and
post-FIR clipping percentage in the table editor and clip the composite waveform by setting
the 1+jQ percentage using the Composite Waveform Clip softkey.

Figure 15-4 Multicarrier Setup Page 1
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Rulticarrier UCDAA 3GPP Setup
Carrier Freq Offset Pouer
1 PCCPCH + SCH =7.500000 HHz 0.00 dB
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Figure 15-5 Multicarrier Setup Page 2
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You now have a user-defined 3-carrier W-CDMA waveform with a3 DPCH carrier at frequency offset of
—2.5 MHz, with a power of —10.00 dBm, a primary scramble code of 5, atiming offset of 3, aninitia phase
of 8, and pre-FIR clipping at 50%.

Clipping the Multicarrier Waveform

1. Press Mode Setup > More (1 of 2) > ARB Setup > Waveform Utilities > Composite Waveform Clip.
2. PressClip |1+jQ] To > 80 > %.

The composite multicarrier waveform is now set to be clipped at 80 percent of its original peak value. The
waveformis clipped after FIR filtering.

NOTE If the waveform is active (W-CDMA Off On set to On), clipping settings are not applied until
you press the Apply Multicarrier softkey.

Generating the Waveform
Press Mode Setup > W-CDMA Off On until On is highlighted.

This generates a waveform with the user-defined multicarrier W-CDMA state created in the previous
sections. Thedisplay changestoMul ti carrier Setup: 2 Carriers (Mdified).Notethat

2 Carriersrefersto the number of carriersin the predefined configuration, not the number of carriersin the
user-modified waveform.
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During waveform generation, the WCDIVA and | / Qannunciators appear and the waveform is stored in
volatile ARB memory. The waveform is now modulating the RF carrier.

For instructions on storing this user-defined multicarrier W-CDMA state to the signal generator’s
non-volatile memory, see “ Storing a Multicarrier W-CDMA State” on page 404.

Applying Modifications to an Active Multicarrier Waveform

1. Press Multicarrier Define.

2. Movethe cursor to row 2.

3. Press Delete Row > Apply Multicarrier.

Notice that the waveform isregenerated to include the modification of the deleted row. Any changes madeto
an active multicarrier waveform will not be applied until the Apply Multicarrier softkey is pressed.

Configuring the RF Output

1. Set the RF output frequency to 2.17 GHz.
2. Set the output amplitude to —10 dBm.
3. PressRF On/0ff until On is highlighted.

The user-defined multicarrier W-CDMA signal is now available at the signal generator’s
RF OUTPUT connector.

Storing a Multicarrier W-CDMA State

This procedure teaches you how to store a multicarrier W-CDMA state to the signal generator’s non-volatile
memory.

If you have not created a multicarrier W-CDMA state, compl ete the steps in the previous section, “Creating
a User-Defined Multicarrier W-CDMA State” on page 401.

1. Press Mode Setup to return to the top-level W-CDMA menu, where W-CDMA Off On is the first softkey.
2. Press Multicarrier Define > Store Custom Multicarrier > Store To File.

If thereisaready afile name from the Cat al og of MDWCDVA Fi | es occupying the active entry area,
press the following keys:

Editing Keys > Clear Text.

3. Enter afile name (for example, 3CARRI ER) using the alpha keys and the numeric keypad with a
maximum length of 23 characters.
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4. PressEnter.

The user-defined multicarrier W-CDMA state is now stored in non-volatile memory and the file name is
lissedinthe Cat al og of MDWIDWVA Fi | es. Note that the actual waveform is not stored; the parameters
for generating the signal are stored. The RF output amplitude, frequency, and operating state settings are not
stored as part of a user-defined W-CDMA statefile.

Recalling a Multicarrier W-CDMA State

This procedure teaches you how to recall a multicarrier W-CDMA state from the signal generator’s
non-volatile memory.

If you have not created and stored a multicarrier W-CDMA state, complete the stepsin the previous
sections, “ Creating a User-Defined Multicarrier W-CDMA State” on page 401 and “ Storing a Multicarrier
W-CDMA State” on page 404.

1. PressPreset to clear the stored W-CDMA waveform from volatile ARB memory.
Press Mode > W-CDMA > Arb W-CDMA.

Press Multicarrier Off On.

Press W-CDMA Select > Custom W-CDMA Multicarrier.

Highlight the desired file (for example, 3CARRI ER).

Press Select File.

N o g &~ W DN

Press W-CDMA Off On until On is highlighted.

The firmware generates the sel ected multicarrier W-CDMA waveform in volatile ARB memory. The
waveform is now modulating the RF carrier.
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W-CDMA Uplink Modulation

This section teaches you how to build uplink 3GPP 12-2004 W-CDMA waveforms for testing component
designs. The waveforms are generated by the signal generator’sinternal dual arbitrary waveform generator.

Creating a Predefined W-CDMA Uplink State
This procedure teaches you how to perform the following tasks:

» “Selecting a Predefined W-CDMA Setup” on page 406
* “Generating the Waveform” on page 406
» “Configuring the RF Output” on page 406

Selecting a Predefined W-CDMA Setup

1. PressPreset.
2. Press Mode > W-CDMA > Arb W-CDMA > Link Down Up.
3. Press W-CDMA Select > DPCCH + 3 DPDCH.

This selects a predefined setup, which consists of one dedicated physical control channel (DPCCH) and
three dedicated physical data channels (DPDCH) for an uplink waveform. The display changesto UL
WCDNVA Set up: DPCCH + 3 DPDCH.

Generating the Waveform

Press W-CDMA Off On until On is highlighted.

This generates a predefined W-CDMA uplink waveform with a DPCCH and 3 DPDCH channels. During
waveform generation, the WCDMA and | / Qannunciators appear and the waveform is stored in volatile ARB
memory. The waveform is now modulating the RF carrier.

Configuring the RF Output

1. Set the RF output frequency to 2.17 GHz.

2. Set the output amplitude to —10 dBm.

3. PressRF On/0ff until On is highlighted.

The predefined W-CDMA uplink signal is now available at the signal generator’s RF OUTPUT connector.
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Creating a User-Defined W-CDMA Uplink State
This procedure teaches you how to perform the following tasks:

» “Selecting aW-CDMA Uplink Setup” on page 407

e “Editing Uplink Channel Parameters’ on page 408

* “Inserting Additional Channels and Modifying 1/Q Settings’ on page 408
» “Clipping the Waveform” on page 409

* “Generating the Waveform” on page 409

» “Applying Channel Modifications to an Active Waveform” on page 410
e “Configuring the RF Output” on page 410

CAUTION Unless previously saved to the signal generator’s non-volatile memory, modifications made
to predefined channel configurations are lost when changes are made to link direction.

To store a custom W-CDMA state, see “ Storing a W-CDMA Downlink/Uplink State” on
page 399.

Selecting a W-CDMA Uplink Setup

1. PressPreset.
2. Press Mode > W-CDMA > Arb W-CDMA > Link Down Up.
3. Press W-CDMA Define > Edit Channel Setup.

The channel table editor is now displayed, as shown in the following figure. Notice that a dedicated physical
control channel (DPCCH) with predefined parameters is the default selection. The horizontal scroll bar at
the bottom of the screen indicates that there are more columnsto the right of the Dat a column. Use the front
panel knob or right arrow key to move the cursor to view the additional columns.
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Figure 15-6
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Editing Uplink Channel Parameters

1. Usethe front panel knob or arrow keysto move the cursor to table row 1.
2. Highlight the TPC value (5555).
3. PresskEdit Item > 00FF > Enter.

The TPC value has now been modified and the cursor has moved to the next row in the TPC column. Other
channel parameters can be modified in the same manner.

NOTE TPC values are entered as hexadecimal digits (0-9, A-F). For information on what these
values represent, refer to “Understanding TPC Values” on page 413.

Inserting Additional Channels and Modifying 1/Q Settings

1. PressInsert DPDCH > Channels > 6 > Enter > Done.
2. Press More (1 of 2) > Second DPDCH | Q until the letter | is highlighted.

The 1/Q setting for the second DPDCH channel (row 3) has changed from Q to |. Additionally, al
subsequent channels have also switched 1/Q settings, as shown in the following figure.
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Figure 15-7
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Clipping the Waveform

1. Press Mode Setup > More (1 of 2) > ARB Setup > Waveform Utilities > Clipping.
2. PressClip |1+jQ] To > 80 > %.

The waveform is now set to be clipped at 80 percent of its peak value.

NOTE If the waveform is active (W-CDMA Off On set to On), clipping settings are not applied until
you press the Apply To Waveform softkey.

Generating the Waveform
Press Mode Setup > W-CDMA Off On until On is highlighted.

This generates a waveform with the custom W-CDMA uplink state created in the previous sections. The
display changesto UL WCDVA Set up: DPCCH ( Modi fi ed) . During waveform generation, the WCDIVA
and | / Qannunciators appear and the waveform is stored in volatile ARB memory. The waveform is now
modul ating the RF carrier.

For instructions on storing this custom CDMA state to the signal generator’s non-volatile memory, see
“Storing a W-CDMA Downlink/Uplink State” on page 399.
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Applying Channel Modifications to an Active Waveform

To apply channel modifications to an active waveform (W-CDMA Off On set to On), you must first pressthe
Apply Channel Setup softkey before the updated waveform is generated. For example, perform the following

steps:

1. Press W-CDMA Define > Edit Channel Setup.

2. Movethe cursor to row 2.

3. Press Delete Row > Return > Apply Channel Setup.

Notice that the waveform isregenerated to include the modification of the deleted row. Any changes madein
the Edit Channel Setup table editor while awaveform is active will not be applied until the Apply Channel
Setup softkey is pressed.

Configuring the RF Output

1. Set the RF output frequency to 2.17 GHz.

2. Set the output amplitude to —10 dBm.

3. PressRF On/0ff until On is highlighted.

The custom W-CDMA uplink signal isnow available at the signal generator’'s RF OUTPUT connector.
To store a W-CDMA uplink state, refer to “ Storing a W-CDMA Downlink/Uplink State” on page 399.
To recall aW-CDMA uplink state, refer to “Recalling a W-CDMA Downlink/Uplink State” on page 400.
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Figure 15-8 Downlink Channel Structure
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Figure 15-9 Uplink Channel Structure
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channel table editor, TPC values are represented in hexadecimal format to simplify entries and
modifications. Figure 15-10 shows the channel table editor with the TPC value, 7F80, highlighted.

Figure 15-10 Highlighted TPC Value
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Hexadecimal TPC values are converted to their binary equivalent. In this example, the value 7F80 becomes
111 1111 1000 0000. Notice that there are 15 digitsin the binary TPC value. Because one frame contains

15 timeslots, one binary digit is assigned to each timesl ot (see Figure 15-11 on page 414). The assigned bit is
then repeated enough times to fill the TPC bit field (see the Ntpc column of Table 15-7). Since the example

in Figure 15-11 uses two TPC hits per timeslot, the values are either 11 or 00.

The TPC bitsthat are ones direct the receiving base or mobile station to increase its transmit power by an
amount specified by the W-CDMA standard. Likewise, TPC hits that are zeros cause the power to decrease

by the same amount. In this example, the transmit power isincreasing over timeslots O through 7 and

decreasing over timedots 8 through 14.
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Figure 15-11
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Binary Value = 111 1111 1000 0000

Hexidecimal Value = 7F80

Understanding TFCI, TPC, and Pilot Power Offsets

TFCI, TPC, and Pilot power offsets (PO), which are applied to downlink control channels (DPCCH), are
relative to the transmit power for data channels (DPDCH). Usually, these offsets are set to a positive value
(refer to Figure 15-12 on page 414). The intent isto transmit control symbols at a higher level than data
symbols to maintain the link between mobile and base. Because only the DPCCH transmit power is offset,

the total transmit power is minimized and less noise is generated in the system.

Figure 15-12 TFCI, TPC, and Pilot Power
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A PO2
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The display in Figure 15-13 shows that the channel in row 6 of the table editor has the data transmit power
(Power dB) set to —6.02 dB with the following offsets: TFCI Power set to 2.00 dB, TPC Power set to

3.00 dB, and Pilot Power set to 1.00 dB. Because of these offsets, the control symbols corresponding to
TFCI, TPC, and Pilot will transmit at —4.02 dB, —3.02 dB, and —5.02 dB respectively.

Figure 15-13 Table Editor Showing TFCI, TPC, and Pilot Power Offsets
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Calculating Downlink Scramble Codes

The Option 400 signal generator implements scrambling codes for downlink channelsin compliance with
3GPP specifications. Thisis done through the use of Scr anbl e Code, Scranbl e Type, and Scr anbl e
C f set fieldsin the downlink Edit Channel Setup table editor. These fields are linked so that an entry to
any field affects the actual scramble code. To better understand the relationship, please refer to the following
formula

= (16xi)+k+m
Table 15-1
Where n = scramble code Range: 0to 24575
i = scramble code field input Primary: Range O to 511
Secondary: Range O0to 511
k = scramble offset field input Range: 0to 15
m = scramble type field input Standard: adds 0
Right Alternate: adds 16384
Left Alternate: adds 8192
Figure 15-14
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The Scr anbl e Code field has two sets: primary and secondary, each with afield range of 0 through 511.
The primary and secondary sets are determined by the Scr anbl e O f set field. If the Scranbl e

C f set fieldiszero, then the scramble codeisin the primary set. Any non-zero entry enables the secondary
set. The Scranbl e O f set field hasarange of O through 15.

The Scranbl e Type field has three modes: Standard, Right Alternate, and L eft Alternate. The standard
scramble type has a value of zero and does not contribute to the scramble code. Selecting the right alternate
adds 16384 to the actual scramble code, whereas the left alternate adds 8192.

Scramble Codes with Standard Scramble Type

A primary scramble code is the product of the Scr anbl e Code field entry and 16. Therefore, the primary
scramble code set contains all multiples of 16 from 0 through 8176.

A secondary scramble code is the sum of the non-zero Scr anbl e O f set field entry and the primary
scramble code. The secondary scramble code set uses the numbers in between the multiples of 16.

Thus, all numbers from O through 8191 are available for scramble codes when using the standard scramble
type.
Refer to the following for examples of scramble codes generated with the primary and secondary sets:

n=(16xi)+k+m
Table 15-2
Where n = scramble code
i = scramble code field input
k = scramble offset field input

m = scramble type field input

Table 15-3
A: Primary set B: Secondary set
i=6 i=8
k=0 k=7
m=0 m=0
n=96 n=135
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Figure 15-15
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Scramble Codes with Right and Left Alternate Scramble Types

Recalling that right alternate adds 16384 to the scramble code and |eft alternate adds 8192, refer to the
following examples of scramble codes generated with the right alternate and | eft alternate scramble types:

n=(16xi)+k+m
Table 15-4
Where n = scramble code
i = scramble code field input
k = scramble offset field input

m = scramble type field input
Table 15-5

A: Primary set + Left Alternate B: Secondary set + Right Alternate

i=6 i=8
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Table 15-5
A: Primary set + Left Alternate B: Secondary set + Right Alternate
k=0 k=7
m = 8192 m = 16384
n=_8288 n=16519
Figure 15-16

Scramble Code Offset
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Set Set
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W-CDMA Frame Structures

This section contains graphical representations of W-CDMA frame structures, with associated tables, for
both downlink and uplink channels.

Downlink PICH Frame Structure

Figure 15-17 PICH Frame Structure
_ 300 bits =
288 bits { by, .., bos,} for paging indication using 1@ :;“ti ";';Lr'::)d
random (PN9 or PN15), 4-bit repeating pattern, not transmitted
or user file DTX
by | by | ba | ceeeereemi (ST [ J LU0 (799 EERREE
D One Frame (10 ms) g
Symbol rate = 15 ksps .
P
420
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Downlink PCCPCH + SCH Frame Structure

Figure 15-18 PCCPCH + SCH Frame Structure

Radio Frame (10 ms)

* L

Time Slot (0.667 ms)

+

W-CDMA Digital Modulation for Component Test

W-CDMA Frame Structures

Slot #0 Slot #1 Slot #1 4
PCCPCH
OFF Data
PSCH
Primary
Search Code OFF
SCH
SSCH
Secondary
Search Code OFF
pk760L
Table 15-6 Lengths of PCCPCH + SCH Fields
Parameter Symbols Per Slot
Nata 9
Nsch® 1

a. SCH comprises PSCH and SSCH
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Downlink DPCCH/DPDCH Frame Structure

Figure 15-19 DPCCH/DPDCH Frame Structure
Frame
Ts =10ms
Slot #0 Slot #1 Slot #2 Slot #14

4/,,»”””/”’

T, = 0_667_

< —
Data1 TPC TFCI Data? Pilot
N patat bits Nrpc bits Ntec bits Npata2 bits N pyot bits
DPDCH DPCCH DPCCH DPDCH DPCCH
pk781b
Table 15-7 DPDCH and DPCCH Fields
Bits/Frame DPDCH Bits/Slot DPCCH
g _ Bits/Slot
@4 &FE 3 -
32| B 5 T T 2
~ ~—~ -

Szl £ €1 818 < > Niatar | Ndata2 Nrci Nrec | Npilot

C © £ © o o o (@) =

O O wn [a) a — [a]

15 7.5 512 90 150 10 0 4 2 4

15 7.5 512 30 120 150 10 0 2 2 4

30 15 256 240 60 300 20 2 14 2 24

30 15 256 210 90 300 20 2 12 2 24

30 15 256 210 90 300 20 2 12 2 42

30 15 256 180 120 300 20 2 10 2 42

30 15 256 150 150 300 20 2 8 2 g2

30 15 256 120 180 300 20 2 6 2 g2
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Table 15-7 DPDCH and DPCCH Fields (Continued)
Bits/Frame DPDCH Bits/Slot DPCCH
E = Bits/Slot
=~ E ~ 2
o8 && 3 -
38| T 5 T - 2
~ ~ —
Ez|l £ 3 3 8 = > Ngatar | Ndata2 Nrecy Nrpc Nbpilot
£ © £ © o o o o =
O O x w [a) a — [a]
60 30 128 510 90 600 40 6 28 0 2 42
60 30 128 | 480 120 600 40 6 26 2 2 42
60 30 128 | 450 150 600 40 6 24 0 2 g2
60 30 128 | 420 180 600 40 6 22 2 2 g2
120 60 64 900 300 1200 80 12 48 gb 4 8
240 120 32 2100 | 300 2400 160 28 112 gb 4 8
480 240 16 4320 | 480 4800 320 56 232 gb 8 16
960 480 8 9120 | 480 9600 640 120 488 gb 8 16
192 960 4 1872 | 480 19200 1280 248 1000 8o 8 16
0 0

a. The number of pilot bits can vary with channel symbol rates of 15 and 30 ksps.
b. If TFCI bits are not used, then DTX (discontinuous transmission) is used in the TFCI field.

Chapter 15 423



W-CDMA Digital Modulation for Component Test
W-CDMA Frame Structures

Uplink DPCCH/DPDCH Frame Structure

Figure 15-20

DPCCH/DPDCH Frame Structure

Frame

/

=

I

]

3

]
L J

A

Slot #0 Slot #1 Slot #2 Slot #14
_ / T = 0667 ms -~
/ DPCCH
Pilot TFCI FBI TPC
N Bi OTB”S N TFCI Bits N FEI Bits N TPC Bits
DPDCH
Data
N [iata Bits
Table 15-8 DPDCH Fields o
Channel Bit Rate Channel Symbol Rate Spread . .
N
(kbps) (ksps) Factor Bits/Frame Bits/Slot data
15 15 256 150 10 10
30 30 128 300 20 20
60 60 64 600 40 40
120 120 32 1200 80 80
240 240 16 2400 160 160
480 480 8 4800 320 320
960 960 4 9600 640 640
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Table 15-9 DPCCH Fields
Channel
e o) wnne | s | N | N | e | e
(ksps)
15 15 256 150 10 6 2 0 2
15 15 256 150 10 8 0 0 2
15 15 256 150 10 5 2 1 2
15 15 256 150 10 7 0 1 2
15 15 256 150 10 6 0 2 2
15 15 256 150 10 5 2 2 1
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16 W-CDMA Uplink Digital Modulation for Receiver
Test

The following features are available only in E4438C ESG Vector Signal Generators with Option 001/601or
002/602.

This chapter teaches you how to build fully coded W-CDMA uplink modulated signals for testing base
station receiver designs and provides information on how the W-CDMA uplink format is implemented
withinthe ESG. The modulation is generated by the signal generator’sinternal baseband generator. There are
two channel modes for transmitting an uplink signal, PRACH and DPCH. This chapter covers both channel
modes and includes the following sections:

» “Equipment Setup” on page 429

* “Understanding the PRACH” on page 431

* “Generating a Single PRACH Signal” on page 444

e “Multiple PRACH Overview” on page 456

e “Setting Up aMultiple PRACH Signal” on page 461

*  “Overload Testing with Multiple PRACHs—Multiple ESGS’ on page 479

* “DPCH” on page 486

» “Compressed Mode Single Transmission Gap Pattern Sequence (TGPS) Overview” on page 499
e “Setting Up Compressed Mode for a Single TGPS Transmission” on page 501

*  “Compressed Mode Multiple Transmission Gap Pattern Sequence (TGPS) Overview” on page 510
e “Setting Up Compressed Mode for aMultiple TGPS Transmission” on page 513

» “Configuring the UE Setup” on page 524

» “Locating Rear Panel Input Signal Connectors’ on page 525

» “Configuring Rear Panel Output Signals’ on page 527

* “Adjusting Code Domain Power” on page 530

427
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e “W-CDMA Uplink Concepts’ on page 532
e “DPCCH/DPDCH Frame Structure” on page 557
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Equipment Setup
The following diagrams show the equipment setups that are used to measure the output signal generated

using the ESG. These setups are used for most of the procedures contained within this chapter and they apply
to both the PRACH and DPCH channel modes.

ESG and Agilent E4440A PSA Spectrum Analyzer Setup

Unless stated otherwise in a procedure, both the PRACH and DPCH procedures use the setup shown in
Figure 16-1 for viewing the ESG output.

Figure 16-1 PSA Setup

TRIGGER IN

I§

oo
oo
0 0 oooo
=) O OO

ooooonoo

ooooo
oooog

RF OUTPUT RF INPUT

53 _Ped

ESG and Base Transceiver Station (BTS) Setup

Unless stated otherwise in a procedure, both the PRACH and DPCH procedures in this chapter use the base
station setup shown in Figure 16-2. For more information on connecting the ESG to a base station, see
“Connecting the ESG to a W-CDMA Base Station” on page 534.
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Figure 16-2 Base Transceiver Station Setup
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Understanding the PRACH

Overview

The PRACH is used by the UE (user equipment/mobile) to signal and establish communications with a base
station. It consists of two components, a preamble and message part. However the PRACH, in an actual UE
to base station application, initially transmits only the preamble. The preambleis used to signal the base
station that a UE istrying to establish a connection, and is repeated until it receives an acknowledgment in
the form of an AICH (acquisition indication channel). Once the preamble has been identified by the base
station, the base station transmits the AICH. When the UE receives the AICH, it then sends the message part
of the PRACH transmission. The message part contains the synchronization and request data used in
establishing the base station connection.

There are two modes of PRACH operation within the ESG, single and multiple PRACH. The single PRACH
mode offers greater flexibility in configuring the PRACH signal, whereas the multiple PRACH mode gives
you the ability to transmit multiple PRACHs within an 80 ms time period. In this mode, you can configure
up to eight different UES each having its own signature. In addition, each UE can transmit multiple PRACHs
within an 80 mstime period.

The ESG gives you the option of transmitting only the preamble or the preamble and message part. This
gives you the ahility to simulate an actual PRACH transmission where multiple preambles may be
transmitted before the UE receives an acknowledgment (AICH) from a base station. In the single PRACH
mode, you can even configure the message part to transmit when an AICH trigger is received.

In addition to controlling many other parameters of the PRACH, you can adjust the preamble power, the
message part power, the distance between the preamble and the message part, the number of preambles prior
to the message part transmission (single PRACH mode only), and select aslot format according to the 3GPP
standards.

Access Slots

The access slots provide awell defined timeinterval for indicating the beginning of a PRACH transmission.
An access slot is 5120 chips long (1.33 ms) and there are 15 access slots per two 10 msradio frames (or 7.5
access slots per radio frame). A radio frame segments the transmission into blocks of time and assistsin
synchronizing the mobile transmission with the base station. So a 20 ms message part is transmitted over
two consecutive radio frames.

Access slots apply to both the uplink and downlink transmissions. In an actual UE to base station
transmission, the UE transmits its access slots before it receives the base station’s transmission of access
dots, thus creating an offset between the two. This offset is used to time the reception of the AICH by the
UE. Thistiming/offset of the AICH is called Tp-a (the distance from the beginning of the preamble to the
beginning of the AICH transmission) and is defined in the 3GPP standards. The PRACH also uses the access
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slots to set the timing/distance between preambl e transmissions (Tp-p) and the preamble and the message
part (Tp-m). Figure 16-3 shows these timing relationships. You will notice that all measurements are from
the beginning of one component to the next.

Figure 16-3 Access Slot Timing

AICH
One Access Slot

AICH Access
Slots RX at UE | |'_' [ [ - T [ [

I Preamble —P| \

Message Part
PRACH Access
Slots TX at UE | I |

|- |- |
Tp-m

The preamble is 4096 chipsin length (1.067 ms), so it does not occupy the entire length of an access slot.
When a 10 ms message part (7.5 access dots) is used, it only partially occupies the last access slot.

In multiple PRACH mode, the ESG provides you access slot resol ution. Because of this, you can select the
access slot for the beginning of your PRACH transmission. However when transmitting multiple PRACHs
for the same UE with the ESG, they cannot occupy any of the same access slotswithin an 80 mstime period.
If they do, the subsequent (second PRACH, etc.) PRACH transmission that uses any of the same access
dots, will not occur. See “Understanding the 80 ms Transmission/Time Period” on page 456 for more
information.

Preamble

The preambleis used to signal a base station that a UE istrying to establish communications. It is composed
of acomplex signature and scrambling code that is used by the base station to uniquely identify the UE. This
isa 1.067 msbursted signal, and isthe first part of the PRACH transmission.

Signatures

A signatureis a series of 16 bitsthat is repeated 256 times within a single preamble. These signatures are
shown in the 3GPP standards. The signatureisthe first of two parts used in the spreading of the preamble. It
points to a node within the channelization codes that corresponds to a spread factor (SF) of 16. This node,
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within the SF=16 group, has sub-trees (OV SF codes) that are used in the channelization/spreading of the
message part.

A base station can simultaneously receive 16 different UES, and all base stations use the same 16 signatures.
Using the BCH (broadcast channel), a base station tells each UE which signature to use and then uses the
signature to determine which UE it is communicating with.

Scrambling Codes

The scrambling code, in most cases, is unique to the base station and it identifies the base station that the UE
is communicating with. In an actual UE to base station transmission, the base station tells the UE which
scrambling code to use. This scrambling code is then used in connection with the signature to uniquely
identify the UE to the base station. The addition of the scrambling code is the second part of the spreading.

There are 8192 (0 to 8191) different scrambling codes. The value selected as the scrambling code is actually
the seed to generate the code sequence. The same scrambling code is used for both the preamble and
message part. However the preamble uses only the first 4096 chips of the selected scrambling code.

Message Part

The message part is transmitted as part of the PRACH after the UE receives the AICH from the base station.
It contains the information necessary for the UE to establish alink with the base station. Thisinformation is
transmitted in two parts, a control part and adata part. These two parts form the message part. Each part has
its own power level that influences the overall message part power. See “Power Control” on page 435 for
more information.

There are three groups of parameters that the ESG lets you set for controlling the message part: control part,
data part, and the message part as a whole. The message part can be set to transmit within either a 10 or
20 mstime period called a TTI (transmission time interval).

Structure

Each 10 ms message part is divided into 15 slots (two slots per access dot). Each of the 15 slots carry the
two parts that compose the message part, the control part and the data part. These two parts are transmitted
in parallel. Thisis similar to the DPCH (dedicated physical channel) that consists of a control channel
(DPCCH, dedicated physical control channel) and a data channel (DPDCH, dedicated physical data
channel). Figure 16-4 shows how the message part is formatted with the control part and data part.
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Figure 16-4 Message Part Structure
Data
Data M. bits
Filat TFCI
Contral N g bits Hogpr bits

T, = 2560 chips, 102 bits (k=0..3)

Slot #0 [ Slot #1 Slot# Slot #14
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The control part carries the pilot and TFCI (transport format combination indicator) bits. The pilot bits are
used by the base station to synchronize with the UE. The TFCI bits are used by the base station to determine
the data format being used by the transport channel. For example, this would let the base station know the
number of data blocks, the data block size, bit sequence, and number of CRC bits that are being used by the
transport channel. The TFCI pattern, relative to atransport channel configuration, is determined by the base
station network; it is not defined by the 3GPP standards. The 3GPP standards define only the number of
transmitted TFCI bit.

The data part contains only data bits and is the request information used for establishing a connection with
the base station.

Slot Formats

Slot formats are used to determine the transmitted frame structure such as the symbol rate, the number of
bits per frame, and the spread factor. Each dot format is defined in the 3GPP standards and implemented in
the ESG. The control part and data part each have their own slot formats and they are applied to the 15 slots
per 10 ms message part. The available slot formats are shown in Figure 16-5 and Figure 16-6.

If you are using the transport channel as the message part data type, you can inadvertently set values within
the transport channel that conflict with the current slot format. When this occurs, an error will be displayed
and you will need to either correct the transport channel values or select an appropriate data part slot format.

The control part only has one dot format, so its configuration is static, see Figure 16-5.
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Figure 16-5 Control Part Slot Format
Slot Format Channel Bit Channel SF Bits/ Bits! | Npnat | Mrro
# Rate (khps) Symhbol Rate Frame Slot
(ksps)
1] 15 14 256 140 10 ] 2

Unlikethe control part, the data part has multiple slot formats that enableit to transmit at different datarates.

Thisis shown in Figure 16-6.

Figure 16-6 Data Part Slot Format
Slot Format Channel Bit Channel Sk Bitss Bits/ Nasta
# Rate (khps) Symhbol Rate Frame Slot
{(ksps)
1] 15 15 266 150 10 10
1 a0 a0 128 300 20 20
2 B0 GO Bd GO0 40 40
3 120 120 32 1200 20 a0

Message Part Scrambling Codes

As stated in “ Scrambling Codes’ on page 433, the same code is used for both the message part and the
preamble. However the starting chip for the message part is shifted by 4096 chips from the preamble code.
The message part contains 38400 scrambling chips and they are repeated every 10 ms (every radio frame).
So a 20 ms message part would have two repetitions of the same code.

Power Control

The PRACH power is controlled by setting the preamble and the message part power. The PRACH power is
determined by the component (preamble or message part) of the PRACH that has the highest power level. If
both components have the same power level, then both components individually equal the PRACH power
level. The message part power is comprised of the absolute powers for the control part and data part. A
PRACH power value can be entered that exceeds the current displayed carrier power and vice versa. But in
reality, the PRACH power equals the carrier power; it cannot exceed it. When a PRACH over power
condition occurs, the ESG will automatically adjust the PRACH power or the carrier power to keep them
within limits. In the multiple PRACH mode, the ESG maintains an 18.06 dB offset between the carrier
power and the PRACH power level. Thisis so the ESG can accommodate the additional power required
when more UES (user equipment/mobiles) are utilized (see “ Understanding the Power Offset Between the
Carrier and the Multiple PRACH” on page 459 for more information).
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There are three areas that control the PRACH power level, the preamble power, the data part power, and the
control part power. Each of these areas are explained in the following sections. Figure 16-7 shows these
areas on the PRACH timing setup display while in the Pp-m power setup mode. Refer to “Power Control
Modes’ on page 441 for more information on the power setup modes. The power control display is accessed
using the PRACH Power Setup softkey.

Figure 16-7 PRACH Power Control Areas
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Controls the Preamble Power Controls the Data Part Power

Preamble Power

The preamble power is an absolute value (dBm) and is adjusted in the ESG by changing the value in the Max
Pw field. Itsvalueis used in determining the control part power level, which influences the total message
part power. See “Control Part Power” for more information.

The preamble power can be adjusted so that it exceeds the current carrier power. When this occurs, the ESG
will automatically adjust the carrier power. The reverseis also true when you enter anew carrier power.

Control Part Power

The control part power isan absolute value (dBm) that is set indirectly and with respect to the preamble. It is
derived from the sum of the highest preamble power and the Pp-m value.

The Pp-mis an offset value (dB) that determines the power difference between the control part and the
preamble powers (Pp-m = Cntlggm, - Pregem)- (See Figure 16-8.) So by adjusting your Pp-m value, you
change the control part power with respect to the preamble.
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To calculate the control part power, use the following formula:
Cntlggm = Preggm + Pp-m

Cntlyg, isthe control part power that is the sum of the preamble power (Pregg,,,) and the Pp-m value. The
preamble power is represented by the Max Pwr field on the ESG

Since the control part power is directly related to the Pp-m value, this means that when the Pp-m valueis
positive, the control part power is greater than the preamble power and the message part power will also be
greater than the preamble power by at least the Pp-m value. Conversely when the Pp-m value is negative, the
control part power isless than the preamble power and the message part can a so be less than the preamble
power depending on the data part power level. Figure 16-8 shows an example of the influence of the control
part power when the Pp-m value is positive and the data part power islow enough that it has minimal impact
on the overall message part power.

Figure 16-8 Control Part Power Determining Message Part Power

Pp-m ¢

Message Part / Data Part

-¢— Control Part

Preamble

Data Part Power

The data part power is not directly entered. It is adjusted and calcul ated using the difference between relative
power values. Theserelative powersareshownasCtrl Pw and Dat a Pw on the ESG. The power values
can be entered using random values, or in compliance with the 3GPP standards, they can be controlled using
gain factors called betas. The 3GPP standard refers to them as B, (control beta) and B (data beta). On the

ESG, they areshownas Ctrl Bet a and Dat a Bet a. Each beta (control and data) has 16 different values
numbered 0 to 15, and the values 1 through 15 are used to create an amplitude/voltage ratio for calculating
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therelative power levels. A beta of zero means the power has been turned off for that particular relative
power. Table 16-1 shows the beta values and their respective ratios.

Table 16-1 Control and Data Part Betas
Beta Values for Control | Amplitude/Voltage Ratios
and Data Beta
15 1
14 14/15
13 13/15
12 12/15
11 1115
10 10/15
9 9/15
8 8/15
7 7/15
6 6/15
5 5/15
4 4/15
3 3/15
2 2/15
1 115
0 offa

a. -40 dB for the ESG relative power levels

When betas are used, the control and data relative powers are cal culated using the following formula:
Relative power = 20 Log (beta/15)

According to the 3GPP standards, at any instant in time, one of the betas for either the control or data power
will result in aratio of one (0.00 dB). However the ESG gives you the flexibility to set your relative power
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values to meet your testing needs. Which ever method you use, the highest power value is used as your data
part power reference relative to the control part power.

NOTE When arandom power valueis used, the beta value is replaced by a hyphen, since it cannot
be defined by the beta values.

Using the relative power formula, a control beta of five would result in arelative control power value of
—9.54 dB. If the relative data power is 0.00 dB (beta of 15), thiswould mean that the data part power is
9.54 dB higher than the control part power. If the relative data power is —9.54 dB and the relative control
power is0.00 dB, this would mean that the data part power was 9.54 dB lower than the control part power.
When the betas are the same value, this means that the control part and data part powers are the same power
levels. Thisresultsin a3 dB (two times the control part power) increase in the message part power.

To calculate the data part absol ute power, perform the following steps where
Pwr ¢ = difference between relative power values ~ Cntly,,, = relative control power
Datay,,, = relative data power Cntl gy, = control part power

Dataygy, = data part power Preggm = preamble power

1. Calculate the absolute power for the control part.
Cntlggm = Preggm + Pp-m
The preamble power is represented by the Max Pwr field on the ESG.
2. Calculate the relative power difference between the two relative power values.
Pwries = Datagyr - cntipwr
3. Calculate the absolute power for the data part.
Dataggm = Cntlggm + PwWrifs

Do not confuse the control power as a means of adjusting the control part power. Remember the control part
power isthe sum of the preamble and the Pp-m values. The control power merely serves as a reference for
the data part power relative to the control part power. Figure 16-9 demonstrates the message part power
when the data part has a greater influence.
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Figure 16-9 Data Part Power Determining Message Part Power

Message Part Power = -25 dBm
(control part power (watts) + data part power (watts))

Data Part Power = —25.46 dBm

Pp'm 9.54 dB (DatadBm = CntldBm + PWrdiff)
* Difference
-5 dBm
Preamble * Control Part Power = =35 dBm
—30 dBm (Cntlggm, = Preggm + Pp-m)

The message part power calculation is explained in the following section, “ Message Part Power” .

Message Part Power

As stated earlier, the message part power (dBm) is comprised of the control part and data part power levels.
The message part power is calculated using the sum of the linear power valuesfor Datayg,,, (data part power)

and Cnitl 45y, (control part power). Use the following formulato cal cul ate the message part power:

10 Log[lO(Data dbm /10 +(-3)) 4 1(Cntl dBm/ 10+ (-3))]

By adjusting the two power levels, you can make the message power less than, equal to, or greater than the
preamble power. In some situations, the message part power can exceed the the carrier power. When this
occurs, the ESG will automatically adjust its carrier power, up to its limits, to accommodate the new
message part power. The following examples demonstrate some of the ways you can set the message part
power:

Example 1:
Preamble Power: -40 dBm Pp-m: 5dB Ctrl Beta: 15 DataBeta: 0

Thiswill result in acontrol part power level that isaways 5 dB higher than the preamble therefore making
the message part power 5 dB higher than the preamble.

440 Chapter 16



W-CDMA Uplink Digital Modulation for Receiver Test
Understanding the PRACH

Example 2:
Preamble Power: —40 dBm Pp-m: 0 dB Ctrl Beta: 0 Data Beta: 15

In this example the data part power will be 40 dB higher than the control part power. Since the Pp-m is set to
0 dB, this means that the control part power level is equivalent to the preamble power. This condition will
create a substantially higher message part power compared to the preamble power, and in most cases, this
would cause the carrier power to readjust itself to compensate for the high message part power.

Example 3:
Preamble Power: —40 dBm Pp-m: -10 dB Ctrl Beta: 15 DataBeta: 1

In this exampl e the control part power is 10 dB less than the preamble power and the data part power is
-23.52 dB (beta of 1) less than the control part power. These settings result in a message part power that is
less than the preamble power.

Power Control Modes

The ESG gives you the opportunity to control your PRACH power using one of two methods, a Pp-m mode
or a Total mode. The mode selection is accomplished using the PRACH Power Setup Mode Pp-m Total softkey.

Pp-m Power Mode

The Pp-m mode lets you control the message part power by making changes to your control part and data
part power levels. The control part power level is adjusted by entering values in the Pp- mfield. Thereisno
direct message part power adjustment in this mode sincethe Msg Pwr field is grayed-out (inactive).
However the message part power is shown in the grayed-out field. You can also calculate your message part
power by using the formulas given in the section, “Power Control” on page 435. Figure 16-10 shows the
Pp-m mode sel ection along with the two fiel ds that were mentioned earlier.
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Figure 16-10 Pp-m Mode
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Total Power Mode

The total mode lets you set the message part power directly, which in turn sets the control part power by
automatically adjusting the Pp-m value. In this mode, the Msg Pwr field is active and the Pp- mfield is
grayed-out (inactive). To calculate what control part power and Pp-m value will result from a message part

power value, perform the following steps where

Pwr¢¢ = difference between relative power values ~ Cntly,,, = relative control power

Datay,,, = relative data power

Preggm = preamble power Messygm, = message

Determine the difference between the relative power val

Pwrgies = Datagyr - cntipwr
Calculate the control part power.

CntldBm = MeSSdBm -10 LOg[l + 10(P\N|’ diff / 10)]

Calculate the expected Pp-m value.

Pp-m = Cntlggm —~ Pregsm

Cntl 4, = control part power

power

Ues.
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Figure 16-11 shows the selection of the total mode along with the two fields mentioned earlier.

Figure 16-11 Total Mode Selection
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Generating a Single PRACH Signal

Using the single PRACH mode may turn the ESG AL C feature off. For reliable results, you may need to
perform a power search. Refer to “ Special Power Control Considerations When Using DPCCH/DPDCH in
Compressed Mode or PRACH” on page 552 before completing this procedure.

The ESG is capable of transmitting a PRACH using the factory default channel parameters. This aspect of

the

ESG is demonstrated in the following procedures.

Configuring the RF Output

1
2
3.
4

Preset the ESG.

. Set the carrier frequency to 1.95 GHz.

Set the carrier power to —10 dBm.

. Turn on the RF output.

Selecting the PRACH and Single PRACH Modes

1. Press Mode > W-CDMA > Real Time W-CDMA > Link Down Up to Up.

Press Link Control > PhyCH Type > PRACH.
Press the PRACH Mode Single Multi softkey until Single is highlighted.
The factory default setting is the Single PRACH mode.

Selecting a Rear Panel Output Trigger

1

Press PRACH Rear Panel Setup > PRACH Output Signal Setup.

This sets up an output trigger signal at the EVENT 1 rear panel connector. Refer to “ Configuring Rear
Panel Output Signals’ on page 527 for more information.

Highlight the item under the Si gnal column that correspondsto Event 1 under the Rear Panel
Ports Column.

Press More (1 of 3) > More (2 of 3) > PRACH Pulse (RPS23).

Thiswill enable an output trigger that corresponds to the beginning of each PRACH.
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4. Press Mode Setup to return to the top-level real-time W-CDMA menu.

A default PRACH signal output has a single preamble and a message part with a 20 ms transmission time
interval (TTI). Setting the trigger output to occur on the PRACH pulse lets the spectrum analyzer or other
measuring equipment that is externally triggered, start its sweep at the beginning of the PRACH signal.

Generating the Baseband Signal

Press W-CDMA Off On to On.

Setting Up the E4440A PSA for the PRACH Signal

This procedure guides you through setting up the PSA for making a time domain measurement. Refer to
Figure 16-1 on page 429 for connecting the ESG to the E4440A PSA. Figure 16-12 on page 446 shows the
ESG output signal on the PSA display.

1. Preset the spectrum analyzer.
2. Select the W-CDMA mode.
Press Mode > W-CDMA.
3. Set the center frequency.
Press Frequency Channel > Center Freq > 1.95 > GHz.
4. Select the time domain measurement mode.
Press Measure > More 1 of 2 > Waveform (Time Domain).
5. Set asweep time that shows the components of the PRACH transmission.
Press Meas Setup > Sweep Time > 50 > ms.
This sets 5 ms as the vertical time divisor (10 divisions x 5 ms =50 ms)

6. Set the resolution bandwidth for a quick response time that captures the bursting nature of the PRACH
components.

Press Res BW > 500 > kHz.

7. Trigger the spectrum analyzer from the rear trigger input using the ESG’s PRACH pulse trigger signal.
Press Trig Source > Ext Rear.

8. Zoom in on the RF Envelope display.

Press zoom.
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Figure 16-12 Displayed ESG Signal
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Modifying the PRACH Physical and Transport Layers

The tasksin this procedure build upon the previous procedure, “ Generating the Baseband Signal” on
page 445.

The ESG lets you set many of the parameters that govern the PRACH transmission. This procedure guides
you through modifying some of these parameters for the physical and transport layers.
Modifying the Physical Layers
This task includes an example of setting up the preamble power ramp.
1. PressLink Control > PhyCH Setup > PRACH Power Setup.
2. Set the preamble power.
a. Movethe cursor to highlight the Max Pwr field.
b. Press-20>dBm.

Thisvalueislinked to the carrier signal power setting. When the W-CDMA format isfirst turned on,
the Max Pw Fi el d value changesto match the carrier signal power. It isagood practice to have
the W-CDMA format on prior to making adjustments to the PRACH power.
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3. Set the power ramp for multiple preambles.

a. Movethe cursor to highlight the Ranp St ep field.
b. Press7>dB.

This setting enables a power ramping when multiple preambles are used. Each successive preamble
transmission from the second to the last will increase in power by 7 dB.

4. Select the number of transmitted preambles.

a. Movethe cursor to highlight the Num of Pr e field.

b. Press4 > Enter.

The number of transmitted preamblesis now four, which means that the PRACH initial/starting power
level (first preamble) will be —41 dBm. The fourth preamble will be transmitted at the PRACH power
level set in step 2b or —20 dBm. This means the first three preambles will have power levels that arein
increments of 7 dB less than the fourth preamble. The initial power (first transmitted preamble power
level) is calculated asfollows:

3x7dB=21dB -20dBm - 21 dB = -41 dBm initial power

NOTE When setting the Max Pwr, Ranp St ep, and Num of Pre fi el ds, they need to be done
in the order shown. If you do not set them in the order shown, errors may occur and values
may automatically change to accommodate limits.

Figure 16-13 Display After the Power Parameter Changes
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5. PressReturn > PRACH Timing Setup.
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6. Configure the distance from the beginning of one preamble to the beginning of the next preamble. This
is expressed in access slots.

a. Movethe cursor to highlight the Tp- p (time period between preambles) field.
b. Press2 > Enter.

7. Set thetransmission timeinterval for the message part.

a. Movethe cursor to highlight the TTI (transmit time interval) field.
b. Press10 > msec.
8. Press Apply Channel Setup.

When the Appl y Needed annunciator appears, press the Apply Channel Setup softkey. You will not seea
change in the signal until you press this softkey.

Figure 16-14 Display After Time Parameter Changes
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Modifying the Transport Layer

The transport channel (RACH) is available when the PRACH physical channel datatypeis set to Tr Ch
(factory default datatype). This task teaches you how to make changes to the transport layer parameters.

1. PressReturn > Return > Transport Setup > TrCH Setup.
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2. Set the datablock size.

The block size and the number of blocks affect the bit rate into the transport layer. The datais punctured
or has bits added (rate matching) so that it fitsinto a frame for a given dot format. The Punct ur e field
currently displays anegative value. Thisindicates that bits will be added to the datain order to facilitate
rate matching. A positive valuein thisfield means that puncturing will occur according to the percentage
shown. Figure 16-15 shows the location of the Max Punct ur e and Punct ur e fields.

a. Movethe cursor to highlight the Bl k Si ze field.
b. Press 450 > Enter > Apply Channel Setup.

The puncture rate has changed, because an increase in the block size increases the RACH data rate.
Figure 16-15 shows what the ESG display 1ooks like once the transport channel parameters have been
Set.

Figure 16-15 Display after Transport Layer Setup
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Changing the PRACH Output Trigger

Press Return > Return > PRACH Rear Panel Setup > PRACH Output Signal Setup >
More (1 of 3) > More (2 of 3) > Message Pulse (RPS22) > Mode Setup.

This changes the triggering for the PSA so that the sweep starts at the beginning of the PRACH message
part.

You have now modified the PRACH physical and transport channel parameters. The PRACH will now
transmit four preambles with power stepping and the spacing/timing between each preamble (beginning of
one preamble to the beginning of the next preamble) was adjusted for two access slots. The message part
transmission has also been set to 10 ms. The RACH data rate was increased when the block size was
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adjusted. Thisresulted in the rate matching algorithm puncturing the datain order to fit it into aframe for the
given dot format.

Viewing the Modified PRACH Signal

This section uses the PSA settings from the procedure “ Setting Up the E4440A PSA for the PRACH Signal”
on page 445.

The PSA time domain measurement mode lets you view many of the PRACH parameters, since they are
time dependent. Figure 16-16 shows the PRACH signal after the modifications from the previous section
“Modifying the PRACH Physical and Transport Layers’ on page 446 have been completed. Notice the PSA
sweep starts at the beginning of the message part and the message part hasatimeinterval of 10 ms (there are
5 ms per vertical division). Thisisthe result of setting the ESG PRACH trigger to message pulse and the
preamble TTI field to 10 ms. You can also see the preamble power ramping.

Figure 16-16 Displayed ESG Signal
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Generating the AICH for the PRACH Message Transmission

The tasks in this procedure build upon the previous procedure, “Modifying the PRACH Physical and
Transport Layers’ on page 446. This procedure uses a different PSA connection diagram
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(Figure 16-17 on page 452) and base station connection diagram shown in the section, “Using the AICH
Feature with a Base Transceiver Station” on page 454.

Using the AICH feature may turn the ESG AL C feature off. For reliable results, you may need to perform a
power search. Refer to “ Special Power Control Considerations When Using DPCCH/DPDCH in
Compressed Mode or PRACH” on page 552 before compl eting this procedure.

This procedure will teach you how to set up the AICH (acquisition indication channel) feature so that it
triggers the message part transmission. This procedure uses the ESG's L F (low frequency) output to
simulate the AICH signal (TTL trigger), or if you prefer, an external source can be used. Connecting the
AICH trigger signal to the ESG requires the use of the rear panel AUX 1/0 connector. (See “Rear Panel
Overview” on page 15 or “Rear Panel Overview” on page 35 for more information on the AUX /O
connector.) An adapter will be needed to make the connection between the LF OUTPUT and pin 17 on the
AUX 1/O connector.

Finding the Rear Panel Input for the AICH Signal

1. PressLink Control > PRACH Rear Panel Setup > PRACH Input Signal Setup.
2. Find which rear panel connector accepts the AICH trigger.
The listed connector (Pattern trigger in 2onAUX pin 17)isapinonthe AUX I/O connector.

Changing the PRACH Output Trigger
Press Return > PRACH Output Signal Setup > More (1 of 3) > More (2 of 3) > PRACH Pulse(RPS23).

Thisis being done so you can view the message part transmission on the PSA asthe AICH isreceived. The
trigger output ison the EVENT 1 rear panel connector.
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Connecting the ESG
Refer to Figure 16-17 and make the connections as shown.

Figure 16-17 AICH Connection Diagram
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Configuring the PRACH Message for the AICH Trigger

1. Press Mode Setup > Link Control > PhyCH Setup > PRACH Timing Setup.
2. Select AICH astheentry for the Message Part field.

a. Highlight the Message Part field.

b. PressEdit Item > AICH.

This sets up the PRACH signal so that the message part is not transmitted until an AICH trigger is
received. Sincethe ESG is not areceiver, it cannot receive and demodulate atrue AICH signal, so
the input has to be atrigger signal.

3. Set the number of preamblesto 1.
a. Highlight the Nunber of Preanbl e field.
b. Press1 > Enter.

You can set the number of preamblesin either the PRACH Power or PRACH Timing Setup display.
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Setting Up the LF Output as the AICH Signal

Thistask sets up the LF output so the results of the AICH trigger signal can be viewed on the PSA display
(see " Viewing the PRACH Message Using an AICH Trigger”). By following the stepsin thistask, the
message part will appear intermittently after each displayed preamble as the AICH trigger is received.

Press LF Out > LF Out Source > Function Generator.
Press LF Out Waveform > More (1 of 2) > Pulse.
Press LF Out Period > 21 > msec.

Press LF Out Width > 1 > msec.

Press LF Out Amplitude > 5 > Vp.

© o A~ w D P

Press LF Out Off On to On.

Viewing the PRACH Message Using an AICH Trigger

This procedure guides you through configuring the PSA for making a spectrum analysis measurement. This
isbeing done to familiarize you with the different measurement modes that exist for the PSA. You could use
the W-CDMA maode, time domain measurement, to achieve the same results.

1. Preset the spectrum analyzer.

2. Select the spectrum analysis mode.
Press Mode > Spectrum Analysis.

3. Set the center frequency to 1.95 GHz.
Press Center Freq > 1.95 > GHz.

4. Set the span to zero hertz for close-in viewing of the PRACH signal.
Press Span > 0 > Hz.

5. Set the sweep timeto 50 ms.
Press Sweep > Sweep Time > 50 > ms.

6. Set the spectrum analyzer to trigger from the ESG’s PRACH pulse trigger signal.
Press Trig > Ext Rear.

You now see the message part moving across the display as the AICH trigger is received after each
preamble. Figure 16-18 shows the message part as it appears after the third preamble transmission.
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Figure 16-18 Displayed ESG Signal
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Using the AICH Feature with a Base Transceiver Station

Figure 16-19 shows the AICH feature connection with the AICH being provided by the base station. While
the ESG cannot demodulate an actual AICH signal, the base transceiver station can be configured to output
aTTL trigger signal that istimed with the AICH transmission. Thistrigger signal can then be used as the
AICH trigger for the ESG to transmit its message part. Or if you prefer, you can follow the instructions
shown in “ Setting Up the LF Output asthe AICH Signal” on page 453, and use the ESG’s LF output as the
AICH trigger source.

454 Chapter 16



Figure 16-19

W-CDMA Uplink Digital Modulation for Receiver Test
Generating a Single PRACH Signal

Base Transceiver Station AICH Connection Diagram
10 MHz Reference
~N
[ Frame Sync Trigger (Frame Clock or SFN)
( _ Simulated AICH (TTL Trigger) Tz
= lo
Chip Clock (Optional) QO |z [=
of |E | X AICH Optional)
= ': 'E = :’,..................'.'.
BTS i X< | |2 ! Aauxuo i
BASEBAND GEN REF INY T Y ¥ (PATTTRIGIN 2)

N ;

oa

LF OUTPUT

Q@
O0ooo oog

goooo
0o o oooo

-0 © O O

0000g oo

l

RF OUTPUT'I

proch_dch?

1. Connect the ESG to the base transceiver station as shown in Figure 16-19.

2. Configure the base transceiver station to output asimulated AICH (TTL trigger) signal.

3. If you need atrigger signal from the ESG to determine when it transmits the PRACH, follow the
instructions in the section, “ Changing the PRACH Output Trigger” on page 451.

4. Set up the ESG to expect the AICH trigger by following the instructionsin the section, “ Configuring the

PRACH Message for the AICH Trigger” on page 452.
5. Turn on the W-CDMA format.
6. Setup the ESG carrier signal.
7. Turn on the ESG RF output.
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Multiple PRACH Overview

The multiple PRACH feature of the ESG lets you simulate multiple UES (user equipment/mobile)
attempting to contact abase transceiver station (BTS). Thisfeatureis especially beneficial for BTS overload
testing when multiple ESGs are used (see “ Overload Testing with Multiple PRACHs—Multiple ESGS’ on
page 479). Thefollowing isalist of some of the characteristics you will find in the multiple PRACH feature:

80 ms transmission/time period with access slot resolution
60 access slots (80 ms/ 1.33 ms = 60) numbered 0 to 59

transmission simulation of eight UEs using independent signatures that automatically assigns the
channel codes in accordance with the 3GPP TS 25.213

transmission of an individual UE's PRACH multiple times (up to 8 times) within the 80 mstime period

The number of timesa UE's PRACH can be transmitted is dependent on the number of access dots each
PRACH occupies.

incorporate AWGN (additive white Gaussian noise) with the multiple PRACH transmission
transmit the preamble or the preamble plus the message part

synchronize multiple ESGs to increase the number of UES'PRACHSs

Understanding the 80 ms Transmission/Time Period

The multiple PRACH feature incorporates an 80 ms time period in which to transmit the multiple
PRACHS/UEs. This 80 ms period has access sot resolution, so it contains 60 selectable access dots (0-59).
The entire 80 ms period is transmitted each time, even if only one access dot is utilized. Within this 80 ms
period you have eight available UEs. All eight can be active at the same time, and each UE has the capability
of transmitting its PRACH up to eight times. Figure 16-20 shows the 80 ms period display.
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However asingle UE retransmission of its PRACH cannot overlap its previous PRACH transmission within
the same 80 ms period. For example, if UE1's PRACH is 11.5 access dots long and its first PRACH
transmission starts in access slot zero, then the second PRACH transmission for UE 1 must start, at a
minimum, in access slot 12. If it was configured to begin in access dot 11, the second transmission would
not occur because slot 11 is partially occupied by the first PRACH transmission. But different UES can
transmit in access sots occupied by other UES. Figure 16-21 illustrates an example of when a PRACH
retransmission for the same UE isignored. It also demonstrates how PRACHs can occupy the same access
slots when they are transmitted by different UEs.
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Figure 16-21 Transmitting PRACHs
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If athird PRACH transmission was configured that overlapped the second PRACH transmission for UEL,
the third transmission would occur because the second transmission is ignored/not transmitted.

The multiple PRACH feature is configured from the factory to have UE 1 on and set to start in access slot
zero. Thisis so you can have aPRACH signal just by turning on the W-CDMA format and the RF output,
assuming that the MOD Off On hardkey is set to on (MOD ONannunciator is showing in the display).

In accordance with the 3GPP standards, there are 16 different signaturesto choose from for each UE, and the
different signatures point to the appropriate channel codes for the control part and data part. These codes are
automatically selected when a signature is chosen and arelisted inthe ChCode | Dat column. The
control part is aways spread with the channelization code of spread factor 256. The spread factor for the
data part is determined by the slot format, but the node that the channelization code resides on is determined
by the signature.

Asseenin Figure 16-20, there are eight positions per UE for assigning access slot numbers. When a position
has not been assigned an access dlot, a dash is showing. If al eight positions have dashes, this has the same
affect as turning the UE off. Thisis because there are no PRACHs to transmit for the UE. You can transmit
eight PRACHs per UE by transmitting only the preamble. Since a preamble only occupies one access slot,
there would be no overlapping of the PRACH transmissions for an individual UE.
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There are multiple ways the ESG can trigger external measurement equipment for measuring the multiple
PRACH signal. Some examples of these are shown in the following list:

80 msframepulse This coincides with the frame boundaries for SFN mod 8=0.

10 msframe pulse This denotes the SFN frame boundaries.

Preamble pulse This indicates the beginning of the access dot for each preambl e transmission.
Message pulse This signifies the start of an access slot where the message part is being transmitted.
PRACH pulse This denotes the access slot boundaries between PRACH repetitions.

Refer to “PRACH Mode” on page 542 for more information on trigger signals.

Understanding the Power Offset Between the Carrier and the Multiple PRACH

The ESG has an 18.06 dB offset between the ESG carrier power and the multiple PRACH power level. This
offset is shown by the PRACH power level in the PRACH Power Setup display. Thisis demonstrated in
Figure 16-22 where the carrier power is 0.0 dBm and the PRACH power is —18.06 dBm

(0.0 dBm — (-18.06 dBm) = 18.06 dB offset). Since the data part power has been turned off, the PRACH
power is shown in both the Max Pwr field (preamble power) and the Msg Pwr field (message part power)
asindicated in the figure.

Figure 16-22 Offset Power
/ ESG Carrier Power
FRECILENCY AMPLITUOE
Edit Item
1.950 000 000 00 ez 0. 00 den
uconA Ll: OFF fon
| APply Channel
Setup
Mso Data
0.00 BT
-18.06 dEm .08
%E 0 uBT Pre fisg Girl RAGH Trg
-18. re----- PRACH
dBmI Power_Setup Mode
Uplink. Physical tupe: PRACH. Pouer(Multiple) = Total
( )Etr“l Prr: 0.00 d& —— SEE;}EE
& P -18.06 dBm = : Ctrl Beta: 15 :
Data Pur: -L0.00 B w7 ioser
\ Data Beta: N
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The offset is provided so the ESG can accommodate the additional power needed as more UES (user
equipment/mobiles) are utilized. This offset remains constant on the ESG display regardless of the number
of UEs activated or parameter changes. However with the AWGN feature on, the addition of noise to the
PRACH signal will increase the offset. When this condition occurs, the ESG carrier power will remain
constant and the PRACH power level will decrease. Thisis demonstrated in Figure 16-23 where the AWGN
feature is on with a C/N value of 0.0 dB.

Figure 16-23 Offset Power with Noise Added
ESG Carrier Power
FREQUENCY AMPLTTUCE i Edit Them
1.950 000 000 0Q sz 0 dBn
UCDHA L[: OFF J ﬂ

[k Applu Channel
Setup
Mso Data
0.00 dg T

-22.77 dEm ==
- odeT Pre fisa Ctrl RACH Trg
] [re]

FRACH
Power _Setup Mode

Uplink. Phusical tupe: PRACH. Pouer(Hultiple) Il Total
< )Etrl Pur: 0.00 dB —— SEEﬁEE
Max Pur: -22.77 dBm =TT T Ctrl Beta: 15 3
CtriBeta: 1 | ol T isser
‘ Oata Beta: I

PRACH Power—22.77 dB Offset from Carrier Power

This offset will not create any problems with the multiple PRACH transmission. Thetypical test that utilizes
amultiple PRACH featureis used to discern a single PRACH transmission from among a group of PRACH
signals. The PRACH power values shown on the ESG display are valid and will be reflected in your
measurements, even when all UEs are on. They are also used to calculate the various other parameters like
the control part and data part power levels.
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Setting Up a Multiple PRACH Signal

The ESG automatically turns off the ALC (automatic leveling control) when the multiple PRACH modeis
selected. Thisis due to the bursting characteristics of the PRACH signal that causes rapidly varying power
levels. This situation is compounded in the multiple PRACH mode where you have multiple PRACH bursts
occurring, so the ESG AL C cannot maintain a constant power level. A manual power search can be
performed by pressing the Apply Channel Setup softkey. Refer to “ Special Power Control Considerations
When Using DPCCH/DPDCH in Compressed Mode or PRACH” on page 552 for more information.

The procedure, “ Selecting the PRACH and Multiple PRACH Modes’ on page 462, shows you how to
access the W-CM A modulation format. However most of the other procedures start from the first-level
W-CDMA softkey menu, which is shown in Figure 16-24. In this way, each procedure can stand alone
without regard to steps performed in other sections.

Figure 16-24 First-Level W-CDMA Softkey Menu
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By following the proceduresin this section, you will learn how to setup abasic multiple PRACH signal. The
section, “Viewing a Multiple PRACH Signal” on page 477, shows the output of the ESG using the
parameters set in each of the following procedures.

Configuring the RF Output

1. Presetthe ESG

2. Set the carrier frequency to 1.95 GHz.
3. Set the carrier power to —10 dBm.

4. Turn on the RF output.
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Selecting the PRACH and Multiple PRACH Modes

1. Press Mode > W-CDMA > Real Time W-CDMA > Link Down Up to Up.
This selects the W-CDMA uplink mode which resides in the first-level W-CDMA softkey menu.

2. Press Link Control > PhyCH Type > PRACH.

3. Pressthe PRACH Mode Single Multi softkey until Multi is highlighted.

This softkey menu level provides you access to other menus that control the PRACH signal. You can
access a menu that enables you to choose the reference block size for the transport channel, access the
rear panel input/output signal selections, determine input trigger signal parameters, and access the
physical and transport channel set up tables/menus. Figure 16-25 shows this softkey menu level with the
multiple PRACH mode selected.

Figure 16-25 Multiple PRACH Mode Selection
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Selecting the Rear Panel Output Trigger

1. Press PRACH Rear Panel Setup > PRACH Output Signal Setup.

Multiple PRACH
Mode Selected

Access Rear Panel
I/0O Signal Setup

This sets up an output trigger signal at the EVENT1 rear panel connector. Refer to “Configuring Rear
Panel Output Signals’ on page 527 for more information.

2. Highlight the item under the Si gnal column that corresponds to Event 1 under the Rear Panel

Ports column.
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3. Press More (1 of 3) > More (2 of 3) > PRACH Pulse (RPS23).
Thiswill enable an output trigger that corresponds to the beginning of each PRACH.
4. Press Mode Setup to return to the top-level W-CDMA menu.

Generating the Baseband Signal

Return to the first-level W-CDMA menu and turn the W-CDMA format on.

This step can be performed at anytime during the setup. The advantage of turning the format on before
setting up the signal, if you have a spectrum analyzer or some other measuring equipment connected, is you
can see the changes as they are made.

Configuring the PRACH Code Setup

In this procedure you will learn how to set the parameters for controlling the transmission for the various
components that make up the PRACH. In addition, you will set the parameters that control the PRACH
transmission as awhole. It isdivided up into four tasks:

» “Accessing the Code Setup Table” on page 463

» “Controlling the PRACH Transmission” on page 464
e “Setting the Control Part Parameters’ on page 467

e “Setting the Data Part Parameters’ on page 468

Accessing the Code Setup Table
Press Link Control > PhyCH Setup > PRACH Code Setup.

Thistakes you into the table editor where you can set the parameters for the message part and preamble. You
can also set the number of transmissions for the PRACH configuration. The parameters set within thistable
apply to al eight UEs.
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Figure 16-26 PRACH Code Setup Display
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Controlling the PRACH Transmission

1

Set the PRACH scramble code.

a. Highlight the Scranbl i ng Code field.
b. Press506 > Enter.
Therange for thisfield is0 to 8191.

The scrambling code, in conjunction with the preamble signature, is used to uniquely identify the
mobile. The same scrambling code number is used for both the preamble and message part. The base
station informs the UE which code to use.

Set the number of transmitted 80 ms periods.

This feature is used in connection with atrigger for starting the PRACH transmission. Use this feature
when you want to measure the PRACH transmission for a set number of cycles or you just want to start
the transmission using atrigger.

a. Highlight the Nunber of 80ns field.
b. PressEdit Item.

Two softkeys are now showing, Enter and Infinity. The Enter key is used when you want to enter a
finite number of 80 ms period repetitions. You can actually enter the desired number without
pressing the Edit Item softkey. The Enter softkey will appear once you start entering avalue. The
Infinity selection lets the transmissions occur indefinitely once atrigger is received until itis
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terminated by some other means (RF is turned off, modulation of the carrier is turned off, or the
modulation format is turned off). To access the Infinity selection, you must pressthe Edit Item softkey.

C. Press100 > Enter.

Therangefor afinitetransmissionis 1 to 2147447836 repetitions. However the transmission will not
be limited unless Trigger has been selected as the PRACH trigger source.

d. Press Apply Channel Setup.

When the Appl y Needed annunciator appears, press the Apply Channel Setup softkey. The new
parameters will not be applied to the signal until this softkey is pressed.

e. Pressthe PRACH Trigger Source Immedi Trigger softkey until Trigger is highlighted.

In order to transmit alimited number of 80 ms periods, you must set the PRACH signal for a manual
trigger operation. If the W-CDMA format is on when you select Trigger, the signal will transmit until
thevalueinthe Nunber of 80ns field has been reached. Then the PRACH signal will terminate
and the RACH Tr g annunciator will gray-out. This means that the PRACH signal iswaiting for a
trigger to occur before another transmission can begin. Thisis shown in Figure 16-27. Notice that the
PRACH Trigger softkey has become active (no longer grayed out) when Trigger was highlighted.

Figure 16-27  PRACH (RACH) Trigger Annunciator
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f. Pressthe PRACH Trigger softkey.

The ESG is now transmitting 100 repetitions, entered in step 2c, of the current
80 ms period setup. The RACH Tr g annunciator will gray-out after 100 repetitions have been
completed. To repeat the transmission, just press the PRACH Trigger softkey again.
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You will notice the PRACH Trigger Source Immedi Trigger and the PRACH Trigger are located on several
softkey menus. Thiswas done so you could provide the trigger or make a different trigger choice without
having to return to any one particular menu. Pressing the PRACH Trigger softkey is amanual trigger
action. You can also provide an external trigger signal for the PRACH transmission.

3. Pressthe PRACH Trigger Source Immedi Trigger softkey until Immedi is highlighted.

The Immedi choice lets the W-CDMA signal transmission start as soon as the modulation format is
turned on. Since the format is already on, selecting Immedi will enable the immediate transmission of
the currently configured signal.

Configuring the Message Part Transmission
1. Choose whether or not to transmit the message part

a. Highlight the Message Part field.
b. PresstheEdit Item softkey.

Two softkeys are displayed, ON and OFF. When you select OFF, the message part is not transmitted
leaving only the preamble as the PRACH transmission.

c. Pressthe ON softkey since we will be transmitting the PRACH with both the preamble and message
part.

2. Select the transmission time for the message part.

a. Highlight the TTI (transmit timeinterval) field.
b. Press10 > msec.

There aretwo valid entries for thisfield, 10 or 20 ms. The values can be entered using decimal
notation (0.01 or 0.02 seconds) or millisecond units (10 or 20 ms).

The 10 ms setting equates to 7.5 access dots (one radio frame) and the 20 ms spans 15 access slots (two
radio frames).

If you need to have an individual PRACH (UE) repeat multiple times within the 80 ms time period, you
may want to use the 10 ms setting. Since you are limited to 60 access slots (80 ms), the 20 ms setting will
decrease the number of times a UE's PRACH can be retransmitted within the 80 ms time period.

3. Enter the number of access slots from the preamble to the message part (Tp-m).

The number of access slots starts from the beginning of the preamble and ends at the beginning of the
message part. Figure 16-28 shows a PRACH with a Tp-m of 3 access dots.
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Figure 16-28 Tp-m Setting
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a. Highlight the Tp- m(time from the preamble to the message part) field.
b. Press4 > Enter.
Therange for thisfield is 1 to 15.

You have now increased the distance from the for the Tp-m from three access slots (3.99 ms) to four
(5.32ms). An accessdot is 1.33 msin length.

If you need to have a UE repeat its PRACH multiple times within the 80 ms time period, you may want
to keep the Tp-m to aminimum value. Since you are limited to 60 access dots (80 ms), an increase in the
Tp-m value further limits the number of timesa UE's PRACH can be repeated.

4. Press Apply Channel Setup.
When the Appl y Needed annunciator appears, press the Apply Channel Setup softkey. You will not see a
change in the signal until you press this softkey.

Setting the Control Part Parameters
1. Select the message part control data.
a. Highlight theMsg- Ct r1  Dat a field.

b. PressEdit Item.

Notice that you have a selection of different control information types with the factory default being
3GPP STD (pilot bit pattern as stated in the 3G TS 25.211 V3.3.0 (2002-03). You can select a PN
seguence, FIX 4 pattern, or create your own control pilot information with the User File selection.

c. Ensurethat 3GPP STD is highlighted and press Return.
2. Setthe TFCI (transport format combination indicator) bits.

a. Highlightthe TFQ Patt ern field.
b. PressEdit Item.

Notice that you have a selection of different TFCI patterns that you can choose from, including the
ability to create your own pattern (User File softkey). The base station uses the TFCI to determine
what transport channel configuration is being used. The TFCI pattern, relative to a transport channel
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configuration, is determined by the base station network; it is not defined by the 3GPP standards. If
the message part TT1 is 20 ms, the TFCI is repeated in the second radio frame (each radio frameis
10 msin length).

Cc. PressPN Sequence > PN9.

3. Press Apply Channel Setup.
When the Appl y Needed annunciator appears, press the Apply Channel Setup softkey. The new
parameters will not be applied to the signal until this softkey is pressed.

Setting the Data Part Parameters
1. Set the datatype for the data part.

a. Highlight the Msg- Dat a Dat a field.
b. PressEdit Item.

Again you can see that you are provided different choices for the data type. The transport channel
selection (factory default) utilizes the RACH (random access channel) which gives you greater
flexibility in controlling the data parameters such as the data rate (setting block size), CRC size, and
puncture rate.

¢. Pressthe Transport CH softkey as the data selection type.

The softkey menu level, where PRACH was selected as the channel type, gives you access to the
transport channel table editor where you can set its parameters.

2. Select the message part slot format.

a. Highlight the Slot Format field.
Note the 60 ksps symbol rate (factory default) shown in the Synbol Rat e field.
b. Press1 > Enter.

You have a choice of dot formats: 0, 1, 2, and 3. Notice that the symbol rate changed to 30 ksps.
Remember that the symbol rate is controlled by the slot format.

Asseenin step b above, you can adjust your symbol rate by changing the valueinthe Sl ot  For mat
field. Conversely, you can adjust your slot format by using the Synbol Rat e field.

Each 10 ms message part period is subdivided into 15 slots and the slot format determines the attributes
for them. Each format is defined in the 3GPP standards.

3. Press Apply Channel Setup.

When the Appl y Needed annunciator appears, press the Apply Channel Setup softkey. The new
parameters will not be applied to the signal until this softkey is pressed.
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Figure 16-29 shows the PRACH code setup display after all tasks within this procedure have been
compl eted.

Figure 16-29 PRACH Code Settings
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Configuring the PRACH Power Setup

In this procedure you will learn how to set the various power levels used in a PRACH transmission. Within
the power setup menu there are two modes to choose from, Pp-m and Total. This procedure uses the Pp-m
mode. The PRACH power has two parts, the preamble and the message part. Further, the message part is
comprised of two other powers, control part and data part powers. For more information on PRACH power
control and modes, see “Power Control” on page 435 and “Power Control Modes” on page 441.

Notice as you make changes to the different power settings, the message part power
(grayed -out Msg Pwr field) also changes.

Accessing the PRACH Power Setup Display

Press Link Control >PhyCH Setup > PRACH Power Setup.

This takes you into the table editor where you can set the power parameters for the message part and
preamble. The parameters set within this table apply to all eight UEs.
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Figure 16-30 PRACH Power Setup Display
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Setting the Preamble Power

1. Highlight the Max Pwr field.
2. Press—30 > dBm.

Notice that the carrier power has changed. The carrier power will always be 18.06 dB above the PRACH
power. See “Understanding the Power Offset Between the Carrier and the Multiple PRACH” on page 459
for more information on the power offset.

Adjusting the Control Part Power

1. Highlight the Pp- mfield.
2. Press5>dB.

The control part power is set with respect to the preamble power level. The Pp-m value is used to adjust the
control part power level. Do not confuse this as setting the message part power

5 dB above the preamble. It is the combination of the control part and the data part power that determine the
message part power. However, since the control part isnow 5 dB higher than the preamble, the message part
power cannot drop below the level of —25 dBm (preamble power of =30 dBm + 5 dB Pp-m)
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Configuring the Data Part Power
1. Set the control power level to zero dB.

a. HighlighttheCtrl Bet afield.
b. Press15 > Enter.

You are now using the control part power as the 0 dB reference for the data part power. This means that
the —25 dBm control part power set in the “ Adjusting the Control Part Power” task, is now the zero dB
reference for the data part power that will be set in step 2. ChangestotheCtrl Pw ortheCtrl Beta
fields does not affect the control part power level; it only sets areference level for the data part power.

2. Set the data part power relative to the control part power.
a. Highlight the Dat a Bet a field.

b. Press5 > Enter.

You have now set the data part power to be 9.54 dB lower than the control part power. A beta of 5
equatesto —9.54 dB. Since the data part power isless than the control part power, you will notice that the
message part power is approximately 5 dB higher than the preamble power level. Thisindicates that the
message part power is dominated by the control part. If you set both data the part and control part
relative powersto 0.0 dB (equal data part and control part power levels or double the control part
power), you will see a

3 dB increase in the message part.

Figure 16-31 shows the PRACH power setup display after all tasks within this procedure have been
compl eted.

Figure 16-31 PRACH Power Settings
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Configuring the PRACH Timing Setup

In this procedure you will learn how to enable multiple UESYPRACHs and aign them within the access slots.
You have eight available UEs that can span an 80 mstime period (60 access slots numbered 0 to 59). The
UEs can be configured so their PRACHSs occupy the same or different access slot(s) relative to other UES.
Each UE can a so be configured to transmit its PRACH up to eight times using different access slots.

NOTE The number of times asingle UE can transmit its PRACH within the 80 mstime period is
constrained by the number of access slots a single PRACH occupies. If the UE retransmits
in atimeslot that is occupied by one of its previous PRACH transmissions, the
retransmission does not occur.

However you will have to turn the message part off to achieve the maximum number of individual UE
PRACH transmissions.

All eight UEs can be active at the same time and each can have adifferent or the same signature assignment.
For more information on understanding the PRACH Timing Setup display, see “ Understanding the 80 ms
Transmission/Time Period” on page 456.

Accessing the PRACH Timing Setup Display

Press Link Control > PhyCH Setup > PRACH Timing Setup.

Thistakes you into the table editor where you can set the number of UEs for transmitting multiple PRACHS.
For the factory default setting, UEL is on and the starting access slot in position one for all UEsis zero.

The parameters set in this table apply to the UE selected, unlike the other setup displays where the
parameters apply to al eight UEs.

For the following tasks, we will work with three UEs. Thiswill demonstrate how different UES can occupy
the same access slots, and how to repeat/retransmit a UE's PRACH.

Figure 16-32 on page 476 shows a graphical representation of the multiple PRACH transmission as
configured by this procedure, while Figure 16-33 on page 478 displays the same signal configuration on the
E4440A PSA.
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Activating the UES

Thistask assumesthe factory preset conditions for the timing setup table. The desired UEs can be turned off
or on at any time during your signal setup.

1. Turnon UE2 and UE4.
a. Highlight O f for UE2intheOn/ O f column.
b. PresstheEdit Item softkey.
Each press of the Edit Item softkey turns the UE on or off.
c. Repeat stepsaand b for UE4.

Setting the Preamble Signature

The signature is used by the base station to identify which UE it is communicating with. This task assumes
the factory preset conditions for the timing setup table.

1. Setthe UEL preamble signature to five.
a. Highlight the Si gnat ur e field that correspondsto UEL.
b. Press5 > Enter.
Therange for thisfield is0 to 16.
2. Set the UE2 preamble signature to seven.
a. Highlight the Si gnat ur e field that corresponds to UE2.
b. Press7 > Enter.
3. Set the UE4 preamble signature to zero.
a. Highlight the Si gnat ur e field that corresponds to UEA4.

b. Press0 > Enter.

Configuring Access Slots

When transmitting multiple PRACHs for the same UE, they cannot occupy any of the same access dots
within the 80 ms period. If they do, the subsequent (second PRACH, etc.) PRACH transmission that uses
any of the same access slots will not be occur.

There are two ways to enter the access slot number within the timing setup table:
» Enter the access slot number using the numeric keypad and press the Enter softkey.

» PresstheEdit Item softkey, enter the number using the numeric keypad, and press Enter.
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Access dot numbers can be entered into positions that either contain dashes or that already contain an access
slot number.

Conversely there are also two ways to eliminate access slot numbers:

Highlight the position for a UE that contains the unwanted access slot within the 80 ms time period.
Press the Edit Item softkey and then the Off softkey that appears.

You will see adash inserted in place of the access slot number. The dash means that the current position
within the 80 ms period has been turned off.

Highlight any position/item on a UE's row, and press the Clear All Pos of Selected UE softkey.

You will see adash inserted in place of all access slot numbers for the selected UE.

When all positions for a UE are occupied by dashes, the UE can no longer transmit any PRACHS. This has

the

same affect as turning off the UE.

In thistask you will learn how to use access slots for determining the placement of the PRACHs within the
80 mstime period.

This task assumes factory preset conditions for the timing setup display.

1. Setup UEL for two PRACH transmissions.
For this task, we will use the factory default access slot of zero for the first UEL PRACH transmission.
Using the parameters that can be set in the PRACH code setup display, you can cal culate the number of
access slots required for each UE1 PRACH transmission. This calculated value can then be used to
determine the placement for each repeated PRACH within the 80 ms period. This avoids overlapping the
retransmitted PRACHs. Remember a PRACH that is repeated and overlaps a previous transmission for
the same UE, isignored.
In the section, “ Configuring the PRACH Code Setup” on page 463, we set the Tp-m to 4 access dotsand
the message part TTI to 10 ms (7.5 access dots). These values are used in the following stepsto
determine the access dot for the second UEL PRACH transmission.
a. Highlight the second access slot position for UEL.
b. Calculate the number of access slots occupied by a single PRACH.
Message part TTI =10ms One accessslot = 1.33 ms
10 ms/ 1.33 ms = 7.5 access dots
Tp-m = 4 access lots
One PRACH transmission=7.5+4
= 11.5 access slots
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The second PRACH transmission will need to begin, at aminimum, in the 12th access slot (access
slot number 11 (0 + 11 = 11)). If you started the second transmission in access slot 10, it would be
ignored since the first transmission occupies part of that access slot.

In order to clearly show the second UEL PRACH transmission on the PSA, we will select an access
slot that will not be occupied by other UESs that are configured later in this task.

C. Pressi15 > Enter.

2. Configure UE2 for asingle PRACH transmission starting in access slot 2.

a. Highlight the first access dot position for UE2.
b. Press2 > Enter.

This PRACH will start its transmission between the first preamble for UEL and its message part. The
message part for UE2 will begin during the first message part for UEL. For the length of time that the
message part for UE1 and UE2 occupy the same access slots, they will be additive creating a stronger
signal during that time period.

3. Leave UE4 to transmit a single PRACH starting in access slot 0.

This PRACH will occupy the same access dots as the first PRACH transmission for UEL. UE1 and UE4
will be additive during this transmission time period creating a higher signal level for the same period of
time.

4. Press Apply Channel Setup.

When the Appl y Needed annunciator appears, press the Apply Channel Setup softkey. You will not see a
change in the signal until you press this softkey.
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Figure 16-32 shows both the completed timing setup display and a graphical representation of the setup by
access slot when this procedure was used to configure the multiple PRACH signal. Figure 16-33 on
page 478 shows the output of the ESG, with the same configuration, on the Agilent E4440A PSA Spectrum

Analyzer.
Figure 16-32 Multiple PRACH Timing Setup
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Viewing a Multiple PRACH Signal

This procedure uses the Agilent E4440A PSA Spectrum Analyzer for measuring the ESG output. Figure
16-1 on page 429 shows the connections between the ESG and the PSA. The signal shown in Figure 16-33
on page 478 was built using the procedures from the section “ Setting Up a Multiple PRACH Signal” on
page 461. If you have used other parameters, your signal output may show different characteristics.

1. Preset the spectrum analyzer.
2. Select the Spectrum Analysis mode.
Press Mode > Spectrum Analysis.
3. Set the center freguency.
Press Frequency Channel > Center Freq > 1.95 > GHz.
4. Select the zero Hertz span.
Press Span > Zero Span.
This sets the PSA to function like an oscilloscope measuring in time rather than frequency.
5. Set the sweep time to 80 ms.
Press Sweep > 40 > ms.

6. Set the resolution bandwidth for a quick response time that captures the bursting nature of the PRACH
components.

Press BW/Avg > 8 > MHz.

Whenever you make a measurement in the zero Hertz span, you need to set the resolution bandwidth to
its maximum value to ensure capturing all of the signal characteristics.

7. Trigger the spectrum analyzer from the rear trigger input using the ESG trigger signal selected in the
section, “ Selecting the Rear Panel Output Trigger” on page 462.

Press Trig > Ext Rear.

8. Set the PSA to average the signal measurement.
Press Det/Demod > Detector Auto Norm > Average.

9. Lower the reference level to —10 dBm.
Press Amplitude Y Scale > Ref Level > 10 > -dBm.

10. Resolve the display for a closer view of the signal.

Press Scale/Div > 5 > dB.
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11. Removethe Scal e/ D v 5. 00 dBtext from the display.
Press the ESC hardkey.

Figure 16-33 Transmitted Multiple PRACH Signal
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Connecting the ESG to a Base Station

1. Connect the ESG to the base station as shown in Figure 16-2 on page 430
2. Configure the base station to receive the multiple PRACH signal.
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Overload Testing with Multiple PRACHs—Multiple ESGs

With the advanced feature of transmitting multiple PRACHS, you can perform base transceiver station
overloading using two ESGs. This gives you the capability of transmitting up to 16 UEs. When the Frame
Sync Trigger signal isused for both ESGs, they will synchronize to within one chip of the base station frame
synchronization signal. When ESG 2 is synchronized using the ESG Sync Pulse signal, you may experience
an additional half chip delay from ESG 2. Figure 16-34 shows the multiple ESG setup and Table 16-2 list the
signals shown in the drawing and their respective ESG rear panel connections.

Figure 16-34 Multiple ESG Setup
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Table 16-2

Multiple ESG 170 Signals and Connections

Signal

Signal Type

Rear Panel
Connector

Input

10 MHz Reference

This ensures that both ESG’s timebase are phase
aligned with the BTS reference.

10 MHz IN

Frame Sync Trigger

Thisalignsthe ESG’s frametiming with the BTS. This
ensures that the BTS can detect the beginning of a
PRACH signal radio frame.

PATT TRIG IN

PRACH Start Trigger

Thisisthetrigger signal for ESG 1 to begin its
PRACH transmission.

BURST GATE IN

ESG Sync Pulse (only for ESG 2)

Thissignal lets ESG 2 synchronize with the BTS
through ESG 1. Thisisused if the Frame Sync Trigger
cannot be split between the two ESGs. This may cause
an additional one half chip delay in ESG 2.

PATT TRIG IN

PRACH Start Trigger Echo Back (only for
ESG 2)

Thissignal triggers ESG 2 to start its PRACH
transmission. The PRACH Start Trigger signal can be
used in place of thissignd, if it has the power
available to split between the two ESGs. If the
PRACH Start Trigger signal isused, ESG 2's
synchroni zation source must be set to the same source
asESG 1.

BURST GATE IN
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Table 16-2 Multiple ESG 170 Signals and Connections

Signal Signal Type Rear Panel
Connector

Output ESG Sync Pulse (only for ESG 1) EVENT 1

Thisisareplacement for the BTS Frame Sync signal
for ESG 2, if the BTS signal does not have the power
capability to split between two ESGs.

PRACH Start Trigger Echo Back (only for EVENT 2
ESG 1)

Thissignal is used to synchronize the beginning of the
PRACH transmission between the two ESGs. It
triggers ESG 2 to start its PRACH transmission.

All of the /O signal connectors can be identified using the softkeys accessed by the PRACH Rear Panel Setup
softkey. While the input signals are fixed to specific connectors, the output signals can be configured for
various rear panel connectors. In this procedure, the connectors listed in Table 16-2 are used.

If your BTS does not have the avail able power for splitting the frame synchronization signal between both
ESGs, ESG 1 can produce a synchronization signal for ESG 2. In this way, ESG 2 is synchronized with the
BTSthrough ESG 1. Thisis done by using the sync pulse signal from ESG 1. If your BTS does have the
power capability for splitting the frame synchronization signal between two ESGs, then the ESG sync pulse
signal is not required.

If more than 16 UEs are required, you can connect additional E4438Cs using the ESG’s PRACH start and
sync signal features to coordinate the synchronization and start triggers. For example, if athird ESG was
needed, you would follow the connections shown in Figure 16-34 on page 479 and the configuration
instructions in the following sections for ESG 2, and apply them to ESG 3.

The versatility of the ESG lets you configure the PRACH start trigger using a LF (low frequency) output
signal. The LF output can be configured for a pulse or square-wave, or you can use an external source. The
following multiple ESG procedure uses the ESG's LF output as the trigger source.

Connecting the ESG to the Base Transceiver Station

Connect the equipment as shown in Figure 16-34 on page 479 and listed in Table 16-2 on page 480.
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Configuring the ESGs

1. Set up the multiple PRACH signal for both ESG 1 and ESG 2 using the procedures from “ Setting Up a
Multiple PRACH Signa” on page 461. However, set each UE to a different signature, and turn on all
UEs.

You can vary the parameters between ESG 1 and ESG 2 for the multiple PRACH signals to obtain your
desired output.

2. Configure ESG 1 rear panel output trigger signals according to Table 16-2 on page 480.
3. Select the ESG input synchronization signal type.

a On ESG 1, press Link Control > PRACH Trigger Setup > Frame Trigger Setup >
Sync Source SFN FCIk ESG to FCIK.

b. On ESG 2 press Link Control > PRACH Trigger Setup > Frame Trigger Setup >
Sync Source SFN FCIk ESG to FCIk or to ESG if you are using the ESG sync pulse signal.

This lets the ESG synchronize using the BTS frame clock signal. The ESG selection for ESG 2 enables
ESG 2 to synchronize with ESG 1. Since ESG 1 is synchronized with the BTS, this means that ESG 2
will aso be synchronized with the BTS through ESG 1. The Frame Trigger Setup softkey can also be
accessed from the top level W-CDMA softkey menu.

4. Set the frame synchronization trigger mode.

a On ESG 1, press Frame Sync Trigger Mode Single Cont to Cont.
b. OnESG 2, press Frame Sync Trigger Mode Single Cont to Cont.

The single mode (Single) lets the ESG trigger off the first BTS frame pulse and ignores all subsequent
frame timing pulses. The continuous mode (Cont) enables the ESG to align its frame timing with each
BTS frame timing pulse.

5. Set the frametiming pulse interval.

a OnESG 1, press Frame Clock Interval > 10 msec, 20 msec, 40 msec, 80 msec, Or 2560 msec.
b. OnESG 2, press Frame Clock Interval > 10 msec, 20 msec, 40 msec, 80 msec, Or 2560 msec.

The actual frame timing interval value is dependent on the BTS frame clock pulse interval and whether
or not the ESG frame synchronization trigger mode is set to single or continuous. If the ESG trigger
mode is continuous, then it is critical that the selection is avalue that isless than or equal to the base
station frame pulseinterval, or else the ESG will incur an out of synchronization condition with the BTS.
When thisoccurs, an Qut  Sync annunciator appears on the ESG. For example, if the BTS frametiming
was 20 ms and the ESG sel ection was 40 msec, an out of synchronization condition will occur. The
results of the example are shown in Figure 16-35. An ESG frame clock interval of 10 or

20 mswill resolve the out of sync condition. This appliesto ESG 1 and ESG 2 if they are both directly
connected to the BTS frame timing interval signal. However, if ESG 2 is synchronized using the ESG
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Sync Pulse signal from ESG 1, then its frame interval selection, if incorrect, may cause only atemporary
out of synchronization condition that is self-corrected. Thisis because ESG 2 is synchronized with ESG
1 and not directly with the BTS. See “PRACH Synchronization” on page 548 and “Frame Sync Trigger
Status Indicator” on page 549 for more information.

Figure 16-35 Out of Synchronization Annunciator
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6. PressReturn > Return > PhyCH Setup > PRACH Trigger Source Immedi Trigger to Trigger.

Using the task, “Controlling the PRACH Transmission” on page 464, you can set the number of 80 ms
period repetitions for a finite number of PRACH transmissions, or using the infinity selection, you can
enable a continuous PRACH transmission once the PRACH start trigger isreceived by the ESG.

NOTE In order to have afinite number of transmitted 80 ms periods, you will need to ensure that
the PRACH trigger sourceis disabled once the PRACH transmission starts. If the trigger
sourceis not disabled, the PRACH signal will retrigger after the entered number of 80 ms
periods are transmitted.

Figure 16-36 shows the frame trigger menus after all selections have been completed. Your selection for the
Frame Clock Interval may be different than what is shown. If you have kept your PRACH trigger source
active, you will seethe RACH Trg annunciator gray-out intermittently as the transmission from the trigger
expires and a new trigger is acquired.
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Figure 16-36 ESG 1 and ESG 2 Frame Timing Setup
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Setting Up the LF Output as the PRACH Start Trigger Signal

While the equipment setup shows ESG 1 as providing the PRACH start trigger signal, the signal can be
provided by either ESG 1, ESG 2, or an external source. Perform the following steps for ESG 1:

1. PressLF Out > LF Out Source > Function Generator.
2. PressLF Out Waveform > More (1 of 2) > Pulse.
3. PressLF Out Period > 80 > msec.
This sets the trigger to occur every 80 msec.
4. PressLF Out Width > 8 > usec.
5. PressLF Out Amplitude > 3 > Vp.
Three volts was selected because the BURST GATE IN isa CMOS connection.
6. PressLF Out Off On to On.

Figure 16-37 shows how the LF output display looks after all the steps from this procedure have been
compl eted.

Figure 16-37 LF Output Setup
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You now have two ESG output signals that are transmitting a combined total of 16 UEs. The BTS can be
configured to try and identify each individual PRACH or configured to identify an individual UE from
among the 16 transmitted PRACHSs.
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Generating a DPCCH/DPDCH with a Reference Measurement Channel

The tasksin this procedure teach you how to set up a pre-defined DPDCH reference measurement channel.

Configuring the RF Output

1. Presetthe ESG

2. Set the carrier frequency to 1.95 GHz.
3. Set the carrier power to —10 dBm.

4. Turn on the RF output.

Selecting a Reference Measurement Channel

The ESG provides a single-softkey solution for configuring the transport layer coding according to the
reference measurement channel’s (RM C) 3GPP specifications.

1. Press Mode > W-CDMA > Real Time W-CDMA > Link Down Up to Up.
2. PressLink Control > Ref Measure Setup > RMC 384 kbps (25.141).

3. PressPhyCH Setup > DPCH Power Setup.

4. Press Adjust Code Domain Power > Scale to 0dB.

This adjustment changes only the displayed power values, the I/Q channels are automatically adjusted to
achieve zero dB power. For more information on channel power, see “ Adjusting Code Domain Power”
on page 530.

5. Press Mode Setup to return to the top level W-CDMA menul.

In this task you have selected a predefined 384 kbps reference measurement channel setup that conformsto
the 3GPP standards. For more information on reference measurement channels, see “ Reference
Measurement Channels (RMC)” on page 532.

Generating the Baseband Signal

Press W-CDMA Off On to On.
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Configuring the E4440A PSA for Viewing the DPCCH/DPDCH Output

One of the features of the PSA isits ability to measure the occupied bandwidth of the input signal. Since this
feature requires minimal setup, it provides a quick way of viewing the input and making a measurement.
This procedure guides you through setting up an occupied bandwidth measurement.

1. Preset the spectrum analyzer.
2. Select the W-CDMA mode.

Press Mode > W-CDMA.
3. Select the mobile setup.

Press Mode Setup > Radio > Device BTS MS to M S.
4. Set the center frequency.

Press Frequency Channel > Center Freq > 1.95 > GHz.
5. Display the signal’s bandwidth.

Press Measure > Occupied BW.

Figure 16-38 Displayed ESG Signal
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Modifying the DPCCH/DPDCH Physical and Transport Layers

Modifying the Physical Layer

The tasksin this procedure build upon the procedure, “Using the Transmit Power Control” on page 495.

1. PressLink Control > PhyCH Setup > DPCH Power Setup.

2. Maodify the power level for the reference measurement channel.

a. Highlight the DPDCH Power field.
b. Press-5>dB.

3. Press Adjust Code Domain Power > Scale to 0dB > Apply Channel Setup.

When the Appl y Needed annunciator appears, press the Apply Channel Setup softkey. The new settings
are not be applied to the signal until this softkey is pressed.

You have now modified the DPDCH to have a—5 dB power level. Figure 16-39 shows the power setup

display with the new power value.

Figure 16-39 DPCH Power Setup Display
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4. Changethe symbol rate.

a  PressReturn > DPCH Code Setup > DPCH DPCCH DPDCH to DPDCH.

b. Highlight Synbol Rate.

C. Press480 > ksps > Enter.

The Synbol Rat e and Sl ot For mat fieldsare coupled. If you select asymbol rate that istoo high for
the current dot format, this could cause over puncturing of the transport channel data. But since the
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symbol rate and slot formats are linked together, a change to one value will automatically adjust the
other when required.

5. Set the bit error rate ratio.

a. Highlight the Tr CH BER Cycl e field.
b. Press125 > Enter.

The value entered composes a group of data bits that can contain a specified number of error bits,
which are entered in the following steps. If you enter zero for the Tr CH BER Cycl e field, this
effectively terminates the error bit insertion feature.

c. Highlight the Tr CH BER Err Len field.
d. Press10 > Enter.

This sets the number of error bits contained in the group of data bits shown in the

Tr CH BER Cycl e field. The value ten means that ten of the 125-bits are error bits. The error bit
positions are randomly changed to prevent them from appearing in fixed positions and to ensure,
when multiple transport channels are used, that errors can appear across all data blocks. You can aso
enter zero for no error bit insertion.

The value for the Tr CH BER Er r Len cannot be greater than the value for the
Tr CH BER Cycl e. If you enter agreater value, the ESG will disregard the entered parameter and set the
field equal to the Tr CH BER Cycl e field setting.

The error ratio is calcul ated using the following formula:
BER=TrCH BER ErrLen/TrCH BER Cycl e
Using the values entered above: BER=10/125

BER = .08 or 8%

The BER is shown in the grayed-out Tr CH BERfield. See Figure 16-40 for the location of the
BER fields.
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6.

Press Apply Channel Setup.

When the Appl y Needed annunciator appears, press the Apply Channel Setup softkey. The new settings
are not be applied to the signal until this softkey is pressed.

You have now changed the DPDCH symbol rate and modified the transport channel bit error rate to
8 percent. Figure 16-40 shows the code setup display after making the changes.

Figure 16-40 DPCH Code Setup Display
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Modifying the Transport Layer

Up to six transport data channels are available to the DPDCH when the DPDCH data typeis set to TrCh
(factory default datatype). This task teaches you how to make changes to the transport layer parameters
while maintaining an acceptable data puncture rate.

1

2
3.
4

Press Return > Return > Transport Setup.
Press 3 > Enter to highlight/select channel 3.
Press TrCH State Off On to On.

Press TrCH Setup.

Refer to Figure 16-41. Notice the greyed out fields Max Punct ur e and Punct ur e. The Max

Punct ur e field shows the maximum amount of puncturing allowed for this transport channel and the
Punct ur e field shows the current puncture rate. A positive puncture value indicates the datais being
punctured while a negative value means that bits are added. The current puncture value exceeds the
allowable puncture rate of 60%. The excessive puncturing will be reduced when the rate matching
attribute is adjusted in one of the following steps.
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Figure 16-41 Excessive Puncturing
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Select the encoder type.

a. Movethe cursor to highlight the Codi ng field.
b. PressEdit Item > 1/3 Conv.

Thiswill actually increase the puncturing slightly. Thisis because the encoding is changed from
1/2 convolutional encoding (one bit in, two bits out) to 1/3 convolutional encoding (one bit in, three
bits out).

Set the rate matching.
a. Movethe cursor to highlight the Rat e Mat ch At tr field.
b. Press 256 > Enter.
Notice that the puncture rate is now reduced to an acceptable level.
PressReturn > 2 > Enter > TrCH Setup.

Notice that the puncture rate for DCH 2 matches the maximum puncture rate. The puncture rate
increased when the parameters for channel three were modified. This can be adjusted by reducing the
block size.

Set the block size.
a. Movethe cursor to highlight the Bl k Si ze field.
b. Press 95 > Enter > Apply Channel Setup.

When the Appl y Needed annunciator appears, press the Apply Channel Setup softkey. The new
settings are not be applied to the signal until this softkey is pressed.
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9. PressReturn.

A third transport channel has been turned on and configured to use 1/3 convolutional encoding with arate
match attribute of 256. Changing channel parameters can affect your puncture rate, and they may also affect
the parameters for other active channels. Whenever parameters are changed in one channel, check the other
channels to ensure their parameters are still within acceptable limits. Notice that decreasing the block size
for transport channel two lowered the data rate which in turn decreased the amount of data that would be
punctured. Puncturing can also be reduced by increasing the DPDCH symbol rate.

Configuring the E4440A PSA for Viewing Additive Noise

1. Select the spectrum analysis mode.
Press Mode > Spectrum Analysis.
2. Set the center frequency to 1.95 GHz.
Press Frequency > 1.95 > GHz.
3. Set the spanto 10 MHz.
Press Span > 10 > MHz.
4. Averagethe signal for better viewing.
Press BW/Avg > Average On Off to On.
5. Remove text showing average value from the display.

PressESC.

Adding Noise

Thetasksin this procedure build upon the procedure “ Viewing and Adjusting the Compressed Mode Signal”
on page 507. There are two ways that you can set your carrier to noise ratio (C/N). Oneis by directly
entering your C/N value and the other is by setting the energy per bit to noiseratio (E/N,) value. Setting

your Ep/N,, will change your C/N and the opposite is also true.

The following ESG tasks teach you how to set the overall C/N ratio for the uplink W-CDMA signal and the
Ep/N, value referenced to individual physical or transport channels.

Setting the Carrier to Noise Ratio

1. PressMode Setup to return to the top-level real-time W-CDMA menu.
2. PressLink Control > PhyCH Setup > DPCH AWGN Setup > Channel State Off On to On.
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3. Press Apply Channel Setup.
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When the Appl y Needed annunciator appears, press the Apply Channel Setup softkey. The new settings
are not be applied to the signal until this softkey is pressed. This softkey needs to be pressed whenever

you make parameter changes with the AWGN editor table.

4. Set the channel to noise ratio (C/N).

a. Movethe cursor to highlight the & N val ue field.

b. Press25 > dB.

NOTE C/N valuesless than 10 dB may not be visible on a spectrum analyzer.

You have now set the overall carrier to noiseratio to 25 dB and turned on noise. Thisis done to apply a
discernible level of noise across the entire channel spectrum. Figure 16-42 shows the signal on the PSA

display.

Figure 16-42 C/N Setting
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Setting EbNo
1. Configurethe noise for aparticular channel.

a. Movethe cursor to highlight the Eb Ref field.
b. PressEdit Item > DPDCH > Apply Channel Setup.
2. Set the channel E/N, value

a. Movethe cursor to highlight the Eb/ No val ue field.
b. Press10> dB.

NOTE C/N values less than 10 dB may not be visible on a spectrum analyzer.

You have now set the Ei/N, value for the DPDCH channel to 10 dB. Notice that modifying the E/N, value
for achannel will change the overall carrier to noise ratio and the E,/N, value for all other active channels.

The 10 dB setting for Ep/N,, has decreased the C/N value to where the W-CDMA signal is almost hidden by
the noise. For reliable results when making hand calculations to determine or verify E/N, values, it is

recommended that you first scal e the code domain power to 0 dB to display the normalized relative channel
power levels (see “ Scaling to 0 dB” on page 530).
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Figure 16-43 Ep/N, Setting
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Using the Transmit Power Control

The tasksin this procedure teach you how to set up dynamic DPCH power control using an external signal.
In this closed loop example, the ESG is used to communicate a UE response to TPC commands.

Connecting the ESG to a Base Transceiver Station

1. Connect the ESG to the base station as shown in Figure 16-44.
2. Configure the base station to send a TPC signal, and receive the RF signal.
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Figure 16-44 ESG to Base Station Connection Diagram
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Configuring the RF Output

1. Presetthe ESG

2. Set the carrier frequency to 1.95 GHz.
3. Set the carrier power to —10 dBm.

4. Turn on the RF output.

Selecting a DPCH Channel
1. Press Mode > W-CDMA > Real Time W-CDMA > Link Down Up to Up.

2. PressLink Control > PhyCH Type > DPCH > Return.

Generating the Baseband Signal

Press W-CDMA Off On to On.
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Configuring an External Signal for DPCH Power Control

1. PressLink Control > Power Mode Norm TPC to TPC.

2. PressPhCH Setup > Transmit Power Control Setup.

This accesses a softkey menu and a table editor that enables you to set the power parameters.

W-CDMA Uplink Digital Modulation for Receiver Test

Figure 16-45 on page 497 displays the transmit power control menu and data fields.

Figure 16-45
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3. Highlight the M n Power field and press Edit Item > —35 > dB.

NOTE

TheM n Power andI nit Power fieldsarelinked to the Power St ep field. The values
will automatically round to alower value if the selected Power Step value requires such an

adjustment.

4. Highlightthel nit Power field and pressEdit Item > —20 > dB.

Notice that the absolute power values changed.
5. Highlight the Power St ep field and press Edit Item > 2.0 dB.
Noticethat the M n Power field valueis rounded to alower value (-35 dB to —34 dB).

6. Press Apply Channel Setup.

When the Appl y Needed annunciator appears, press the Apply Channel Setup softkey. The new
parameters will not be applied to the signal until this softkey is pressed.
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7. Start the power control.

Press Power Hold Off On to Off.

NOTE The default for Power Hold automatically setsthe power hold mode to On. In this mode the
transmission power remains constant. In addition, the ALC function is turned off and the
ALC CFF annunciator appears on the status bar.

Figure 16-46 on page 498 shows how the power control feature isimplemented.

Figure 16-46 DPCH External Power Control
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Power Control
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8. Stop the power control.
Press Power Hold Off On to On.
9. Returntoinitia power level.

Press Reset to Initial Power.
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Compressed Mode Single Transmission Gap Pattern Sequence (TGPS)
Overview

The compressed mode is very flexible with many adjustable parameters. You can have one or two
transmission gaps. When two gaps are used, each gap can have a different length and operate using the
single or double frame method. Table 16-3 describes some of the parameters that are available for the
compressed mode. The compressed mode frames are fully coded which enables you to perform BER and
BLER testing of the receiver.

The ESG also supports multiple transmission gap pattern sequences (one to six). This enables you to set up
multiple pattern sequences. For more information, see “ Compressed Mode Multiple Transmission Gap
Pattern Sequence (TGPS) Overview” on page 510.

Table 16-3 Uplink Compressed Mode Parameters

Name Definition

Transmission gap pattern repetition count (TGPRC) Number of transmission gap patterns within the
transmission gap pattern sequence.

Transmission gap connection frame number (TGCFN) | CFN of the first compressed frame of the first

pattern within the transmission gap pattern
sequence.

Transmission gap slot number Slot number of the first transmission gap within

(TGSN) the first radio frame of the transmission gap
pattern.

Transmission gap length 1 Duration of the first transmission gap within the

(TGL1) transmission gap pattern.

Transmission gap length 2 Duration of the second transmission gap.

(TGL2)

Transmission gap duration Thisisthe distance, measured in slots, from the

(TGD) beginning of the first transmission gap to the
beginning of the second transmission gap.

Transmission gap pattern length 1 Duration of first transmission gap pattern that

(TGPL1) includes TGL1/2.

Transmission gap pattern length 2 Duration of the second transmission gap pattern

(TGPL2) that includes TGL1/2.
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Table 16-3 Uplink Compressed Mode Parameters (Continued)
Name Definition
Stop connection frame number CFN of thelast radio frame.
(Stop CFN)
Transmission gap pattern sequence identifier (TGPSI) | Thisidentifies the currently selected transmission
gap pattern sequence.
Transmission gap pattern sequence Thislets you select whether or not to transmit the
(TGPS) current TGPSI. Activeit will be transmitted,
inactive it will not be transmitted.
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Setting Up Compressed Mode for a Single TGPS Transmission

Using the compressed mode can turn off the AL C feature. For reliable results, you may need to perform a
power search. Before completing this procedure, refer to “ Special Power Control Considerations When
Using DPCCH/DPDCH in Compressed Mode or PRACH” on page 552.

Equipment Setup

Connect the ESG to the Agilent E4440A PSA Spectrum Analyzer or an equivalent instrument as shown in

Figure 16-47.

Figure 16-47 PSA Setup
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Configuring the RF Output

1. Pressthe Preset hardkey.
2. Set the frequency and amplitude values.
3. Pressthe RF On/0ff hardkey to On.

Steps two and three can be performed either before or after setting the W-CDMA signal parameters.
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Accessing the W-CDMA Modulation Format and Selecting Uplink

Unless stated otherwise, all procedures or tasks begin from the first-level W-CDMA softkey menu accessed
in this procedure.

1. Press Mode > W-CDMA > Real Time W-CDMA.

This accesses the first-level W-CDMA softkey menu. From this display you can elect to set up the base
station parameters (downlink) or the user equipment (UE—uplink).

2. Using the Link Down Up softkey, ensure that Up is highlighted as shown in Figure 16-48.

Figure 16-48 First-Level W-CDMA Softkey Menu
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LE Setuph
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Setting UP the W-CDMA Signal Parameters

This procedure uses a reference measurement channel as the DPCH setup. All other DPCH parameters use
the factory preset values.

1. PresstheLink Control softkey.

2. Ensure that DPCH is showing as the selected channel type for the PhyCH Type softkey. If not, press
PhyCH Type > DPCH.
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Figure 16-49 DPCH is Selected
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3. PressRef Measure Setup > 64 kbps.

Setting Up Compressed Mode for a Single TGPS Transmission

\—— Ensure that DPCH

is Showing

This configures the DPCH with a 64 kbps reference measurement channel according to the 3GPP
specifications. This reference measurement channel sets up two transport channels (DCH) and the

required DPCH parameters.

4. Pressthe Mode Setup hardkey to return to the first-level W-CDMA softkey menu.

Generating the Baseband Signal

Press the W-CDMA Off On softkey to On.

This step can be performed at anytime during the setup. The advantage of turning the format on before

setting up the signal, if you have a spectrum analyzer or some other measuring equipment connected, is you
can see the changes asthey are made. However you may experience aslight delay in signal processing while
the ESG updates the W-CDMA signal with any changes that are made.

Configuring Compressed Mode

This task teaches you how to set up compressed frames.

1. PressLink Control > DPCH Rear Panel Setup > DPCH Output Signal Setup > More (1 of 2) > Compressed Frame

(RPSS).

This enables an output trigger signal at the rear panel EVENT 1 connector when the compressed frameis

transmitted.
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2. PressReturn > Return > PhyCH Setup > Compressed Mode Setup.

This accesses the compressed mode TGPSI display and is shown in Figure 16-50. From this display, you
can select a TGPS using the TGPSI softkey, view its parameters, enter the table editor to make parameter
changes, and enable or disable the compressed mode feature. In this procedure, TGPSI 1 is used, which
isthe factory preset cursor location. The factory preset selection for the Compressed Mode Off On softkey is

On.

Figure 16-50 TGPSI Display
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3. Pressthe Comp Parameter Setup softkey shown in Figure 16-50.

This accesses the table editor for the selected TGPS. The table editor, shown in Figure 16-51, isfor
setting the parameters for the selected TGPSI number, which is TGPSI 1 for this procedure. To access

the previous display, press the Return hardkey.
Notice that the Comp Parameter Setup softkey is replaced with the Ref Param Setup softkey.
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Figure 16-51 Compressed Frame Parameters
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4. Set dot eight of the frame as the starting slot for the first transmission gap.

a. Movethe cursor to highlight the TGSN field.
b. Press8 > Enter.

This sets the first compressed frame so it has eight slots (0-7) of data prior to the transmission gap that
starts with slot eight.

5. Set thefirst transmission gap length, which is expressed as a number of dots.
a. Movethe cursor to highlight the TG_1 field.
b. Press14 > Enter.

Out of the 15 slots per frame, the standard specifies that seven of them can be used as discontinuous
transmission (DTX) slots. However the total gap length can be spread over two frames. The value 14
denotes 14 DTX dslots, which spans 2 frames. Thisis called the double-frame method. If the value was
seven or less, this would mean that the DTX dlots are contained in one frame.

6. Set the second transmission gap length, which is expressed as a number of slots.
a. Movethe cursor to highlight the TA.2 field.
b. Press3 > Enter.
For the second transmission gap, the single frame method is used.
7. Set the spacing between the first and second transmission gaps, which is expressed as anumber of dots.
a. Movethe cursor to highlight the TGDfield.
b. Press37 > Enter.
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10.

11.

12.

13.

Set the duration of the first transmission gap pattern, which is expressed as a number of frames.
a. Movethe cursor to highlight the TGPL1 field.
b. Press6 > Enter.

Set the duration of the second transmission gap pattern, which is expressed as a number of frames.

a. Movethe cursor to highlight the TGPL2 field.

b. Press4 > Enter.

Set the compressed frame power relative to the non-compressed (normal) frames.
a. Movethe cursor to highlight the P O f s field.

b. Press6>dB.

This enables you to compensate for reduced spreading gain. The higher power level makes the
compressed frames easier to view.

Enable the compressed frames.
Press the TGPS Inactive Active softkey until Active is highlighted.
Press the Apply Channel Setup softkey.

When the Appl y Needed annunciator appears, press the Apply Channel Setup softkey. The new settings
are not applied to the signal until this softkey is pressed.

Pressing this key disables the compressed mode trigger. Therefore whenever thiskey is pressed while
transmitting in compressed mode, the following step will have to be repeated.

Press the Compressed Mode Start Trigger softkey.
The Conp t r g annunciator appears and the ESG is now transmitting compressed frames.

The ESG does not transmit compressed frames until an external start trigger is received or the Compressed
Mode Start Trigger softkey is pressed. Compressed frame transmission is terminated when an external stop
trigger is received, the Compressed Mode Stop Trigger softkey is pressed, or a parameter is changed and the
Apply Channel Setup softkey is pressed. You can also stop the transmitted compressed mode frames after a set
number of transmissions by changing the TGPRCfield from | nf i ni t y to the desired number of repetitions.

Figure 16-52 shows what the ESG display |ooks like when this procedure is compl eted.
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Figure 16-52 Compressed Mode Setup
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Viewing and Adjusting the Compressed Mode Signal

This procedure will show the ESG compressed signal output on the PSA display (Figure 16-53 on page 509)
using the parameters set in the previous procedures. In addition, you will learn how to set the compressed
mode transmission for afinite number of repetitions.

Configuring the E4440A PSA

1. Select the W-CDMA mode.
Press Mode > W-CDMA.

2. Select the mobile setup.
Press Mode Setup > Radio > Device BTS MS to M S.

3. Set the center frequency to the ESG carrier frequency. This procedure uses 1.95 GHz.
Press Frequency > 1.95 > GHz.

4. Select the time domain measurement.
Press Measure > More 1 of 2 > Waveform (Time Domain).

5. Set a Sweep time that lets you view the signal parameters.
Press Meas Setup > Sweep Time > 100 > ms.

6. Set the resolution bandwidth for afaster response time that captures the signal components.
PressRes BW > 1 > MHz.
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7. Trigger the spectrum analyzer from the rear panel input using the supplied ESG trigger signal.
Press Trig Source > Ext Rear.

8. Zoom in on the RF Envelope display
Press Zoom.

You can now see the compressed signal moving across the PSA display.

To remove any text showing on the display, press the ESC hardkey.

Adjusting the Number of Gap Patterns
This task builds upon the procedure “ Configuring Compressed Mode” on page 503.

Thistask will set up the ESG so that the transmitted gap patterns have a finite repetition. Thiswill enable
you to have a clearer view of how the compressed signal parameters affect the transmission.

1. Enter the number of transmitted gap patterns.
a. Highlight the TGPRCfield.

b. Press5 > Enter.
2. Press Apply Channel Setup > Compressed Mode Start Trigger.

The Conp Tr g annunciator comes on and then goes off after 5 gap pattern transmissions. Thisindicates
that the compressed mode trigger is no longer active and the ESG has quit transmitting compressed
frames.

Notice that the frame pattern is now easily viewed on the PSA display and is shown in Figure 16-53. This
figure also points out some of the compressed mode parameters as they appear on the signal.
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Figure 16-53 Displayed Compressed Signal and Signal Parameters
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Compressed Mode Multiple Transmission Gap Pattern Sequence (TGPS)
Overview

Multiple TGPSs (pattern sequences) are used to sample frequencies from the various transmission formats
such as frequency division duplex (FDD), time division duplex (TDD), and GSM in preparation for a
handoff. The number of pattern sequencesis dependent on the type(s) of transmission format you need to
sample. Thefollowing list shows the number of TGPSsthat are required to receive each type of transmission
format:

FDD one TGPS per FDD frequency
TDD one TGPS per TDD signal
GSM three TGPSs per GSM signal

For example, if you wanted to sample the frequencies for aFDD and GSM signal, you would need four
TGPSs, one for the FDD signal and three for the GSM signal. If you wanted to sample three FDD
frequencies, you would need three TGPSs.

The ESG supports up to six different pattern sequences. Setting up the compressed frame signal with
multiple TGPSsis very similar to setting up a compressed frame signal using asingle TGPS that is
demonstrated in the section “ Configuring Compressed Mode” on page 503.

Each TGPS has the same parameters that are described in Table 16-3 on page 499, and the parameters are
local to each pattern sequence, with the exception of the Powdf f s field. Thisfield is common (global) for
all TGSPs and sets the amount of power offset for the compressed frames relative to the normal frames.
Whenitissetin one TGPS, it isapplied to all the active pattern sequences and is shown in the PowC f s
field.

Understanding Multiple TGPS Compressed Frame Alignment

When multiple TGPSs are used, it is very important to ensure that there are no overlapping compressed
frames configured for the same frame position. If compressed frame overlapping occurs, the ESG
discontinues the compressed frame transmission (compressed frame start trigger is terminated) and normal
frames are transmitted. When the compressed frames from a multiple TGPS signal are properly aigned, the
output is a composite signal that contains the compressed frames from all the pattern sequences. Both
conditions are demonstrated in Figure 16-54.
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Figure 16-54 Multiple TGPS Compressed Frame Alignment
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You can see in Figure 16-54 that an offset is required between the pattern sequences so the compressed
frames do not overlap. This is done using connection frame numbers (CFN), which are a subset of the
system frame numbers (SFN). Each value of the CFN indicates a frame number with the first frame
numbered zero. In Figure 16-54, TGPS 1 has atwo frame offset since the first compressed frame starts at
frame two. Thiswould require that TGPSI 1 hasa CFN of two. TGPS 2 has no offset, soits CFN is zero. For
the compressed mode feature, the CFN is set using the TGCFN (transmission gap connection frame number)
field within the compressed mode display.

If you plan on a continuous signal output with multiple pattern sequences, you have to ensure that the
compressed frame alignment remains consistent. It is easy to set up a compressed frame sequence that
initially transmits the intended pattern, but as the signal progresses, the positioning for the compressed
frames among the multiple sequence patterns start overlapping. This problem is especially predominant
when multiple transmission gap lengths (TGL 1/2) and transmission gap pattern lengths (TGPL 1/2) are used.
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Setting Up Compressed Mode for a Multiple TGPS Transmission

Using the compressed mode can turn the ESG AL C feature off. For reliable results, you may need to
perform a power search. Before completing this procedure, refer to “ Special Power Control Considerations
When Using DPCCH/DPDCH in Compressed Mode or PRACH” on page 552.

Prior to setting your multiple TGPS parameters, it is a good practice to diagram the compressed frame
output and transfer the diagram settings to the ESG. This can eliminate the trial and error method for
properly aligning the compressed frames among the pattern sequences.

Equipment Setup

Connect the ESG to the Agilent E4440A PSA Spectrum Analyzer or equivalent instrument as shown in
Figure 16-55.

Figure 16-55 PSA Setup
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Configuring the RF Output

1. Pressthe Preset hardkey.

2. Set the frequency and amplitude values.

3. Pressthe RF On/0ff hardkey to On.

Steps two and three can be performed either before or after setting the W-CDMA signal parameters.
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Accessing the W-CDMA Modulation Format and Selecting Uplink

Unless stated otherwise, all procedures and tasks begin from the first-level W-CDMA softkey menu
accessed in this procedure.

1. Press Mode > W-CDMA > Real Time W-CDMA.

This accesses the first-level W-CDMA softkey menu. From this display you can elect to set up the base
station parameters (downlink) or the user equipment (UE—uplink).

2. Using the Link Down Up softkey, ensure that Up is highlighted as shown in Figure 16-56.

Figure 16-56 First-Level W-CDMA Softkey Menu
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Setting UP the W-CDMA Signal Parameters

This procedure uses a reference measurement channel as the DPCH setup. All other DPCH parameters are
left at factory preset values.

1. PresstheLink Control softkey.

2. Ensure that DPCH is showing as the selected channel type for the PhyCH Type softkey. If not, press
PhyCH Type > DPCH.
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Figure 16-57 DPCH is Selected
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3. PressRef Measure Setup > 64 kbps.

This configures the DPCH with a 64 kbps reference measurement channel according to the 3GPP
specifications. This reference measurement channel sets up two transport channels (DCH) and the
required DPCH parameters.

Selecting the Rear Panel Output Trigger

This procedure builds upon the previous procedure “ Setting UP the W-CDMA Signal Parameters’ on
page 514.

1. Press DPCH Rear Panel Setup > DPCH Output Signal Setup > More (1 of 2) >
Compressed Frame (RPS8).

This enables an output trigger signal at the rear panel EVENT 1 connector when a compressed frame is
transmitted.

2. Pressthe Mode Setup softkey to return to the first-level W-CDMA softkey menu.

Generating the Baseband Signal

Press the W-CDMA Off On softkey to On.

This step can be performed at anytime during the setup. The advantage of turning the format on before
setting up the compressed frame signal, if you have a spectrum analyzer or some other measuring egquipment
connected, isyou can see the changes as they are applied to the signal. However you may experience aslight
delay in signal processing while the ESG updates the W-CDMA signal with any changes that are made. If
you want to configure a spectrum analyzer to view the ESG signal during the setup, see “Viewing the
Multiple TGPSI Signal” on page 522.
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Configuring TGPSI 1

1. PressLink Control > PhyCH Setup > Compressed Mode Setup.

This accesses the compressed mode TGPSI display and is shown in Figure 16-58. From this display, you
can select a TGPS using the TGPSI softkey, view its parameters, enter the table editor to make parameter
changes, and enable or disable the compressed mode feature. TGPSI 1 is the factory preset cursor
location and On is the factory preset selection for the Compressed Mode Off On softkey.

Figure 16-58
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2. Pressthe Comp Parameter Setup softkey shown in Figure 16-58.

This accesses the table editor for the selected TGPS. The table editor, shown in Figure 16-59, isfor
setting the parameters for the selected TGPSI number, which is TGPSI 1 for this procedure. To access
the previous display, press the Return hardkey.

Access selected TGPS
Table Editor

Enable/Disable
Compressed Mode
Ensure On is Highlighted

Notice that the Comp Parameter Setup softkey is replaced with the Ref Param Setup softkey.
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Figure 16-59 Compressed Frame Parameters
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3. Set dot five of the frame as the starting slot for the first transmission gap.

a. Movethe cursor to highlight the TGSN field.
b. Press5 > Enter.

This sets the first compressed frame so it has five slots (0-4) of data prior to the transmission gap that
starts with slot five.

4. Setthefirst transmission gap length which is expressed as a number of slots.
a. Movethe cursor to highlight the TG_1 field.

b. Presss5 > Enter.

Out of the 15 slots per frame, the standard specifies that seven of them can be used as discontinuous
transmission (DTX) slots. However the total gap length can be spread over two frames. The value 5
denotes 5 DTX dots. Since the TGSN value previously entered is also five, this would mean that the
single frame method is being used.

5. Set the second transmission gap length which is expressed as a number of slots.
a. Movethe cursor to highlight the TA.2 field.
b. Press7 > Enter.
For the second transmission gap, the single frame method is also used.
6. Set the spacing between the first and second transmission gaps expressed as a number of slots.
a. Movethe cursor to highlight the TGDfield.
b. Press30 > Enter.
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a. Movethe cursor to highlight the TGPL1 field.

b. Presss5 > Enter.

7. Set the duration of the first transmission gap pattern which is expressed as a number of frames.

If desired, you can also establish a second gap pattern using the TGPL2 field, however this does create a
more complex signal that can make it harder to keep compressed frames in proper alignment among the

multiple pattern sequences.

Set the compressed frame power relative to the non-compressed frames.

a. Movethe cursor to highlight the Piwr O f s field.
b. Pressé6 >dB.

Thisisaglobal setting for all TGPSIs. It enables you to compensate for reduced spreading gain. The
higher power level makes the compressed frames easier to view.

Press the TGPS Inactive Active softkey until Active is highlighted.
This enables TGPSI 1 and can be pressed either in the current display or in the previous TGPSI display.
You have now completed configuring TGPSI 1. Figure 16-60 shows what the ESG display looks like

after completing this step.

Figure 16-60 Compressed Mode Setup for TGPSI 1
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10. Press the Return hardkey to return to the TGPSI display.
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Configuring TGPSI 2

This procedure builds upon the previous procedure, “ Configuring TGPSI 1” on page 516 and configures the
second TGPS so that the compressed frames from TGPSI 1 and 2 are properly positioned.

1
2.

Press 2 > Enter > Comp Parameter Setup.

Set slot three of the frame as the starting dot for the first transmission gap.

a. Movethe cursor to highlight the TGSN field.
b. Press3 > Enter.

This sets the compressed frame so it has three slots (0-2) of data prior to the transmission gap that starts
with slot three.

Set the first transmission gap length which is expressed as a number of slots.
a. Movethe cursor to highlight the TA.1 field.

b. Press7 > Enter.

Out of the 15 slots per frame, the standard specifies that seven of them can be used as discontinuous
transmission (DTX) slots. However the total gap length can be spread over two frames. The value 7
denotes 7 DTX dots, which are contained in one frame since the TGSN valueisthree. So the single
frame method is being used.

Set the second transmission gap length which is expressed as a number of slots.
a. Movethe cursor to highlight the TGQ_2 field.

b. Press3 > Enter.

The single frame method is also used for the second transmission gap.

Set the spacing between the first and second transmission gaps expressed as a number of slots.

a. Movethe cursor to highlight the TGDfield.
b. Press29 > Enter.

This positions the second transmission gap (TA_2 field) for TGPS| 2 so it occurs in the second
normal frame transmitted by TGPSI 1. If compressed frames from the different TGPSs occupy the
same frame position (overlap), the ESG will transmit only normal frames. Thisis shown in Figure
16-54 on page 511.
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Set the frame offset for the first compressed frame so it does not overlap a compressed frame from
TGPSI 1.

a

b.

Move the cursor to highlight the TGCFN field.
Press 1 > Enter.

The connection frame numbers (CFN) are a subset of the system frame numbers (SFN). Each value
denotes the start of anew frame with zero being the first frame position. To avoid compressed frame
overlapping, you must position the compressed frames for TGPSI 2 so they occur during normal
frame transmissions for TGPSI 1. Since TGPSI 1 startsat TGCFN 0 (frame position one) and has a
normal frame in the second frame position, TGPSI 2 will start its first compressed frame in the
second frame position (CFN one).

7. Set the duration for the transmission gap pattern, which is expressed as a number of frames.

Move the cursor to highlight the TGPL1 field.
Press5 > Enter.

Thisvalueisthe same asfor TGPSI 1. This ensures that my frame alignment is consistent over time
and keeps frame overl apping from occurring between the two pattern sequences for the current setup.
This setting alone does not keep the proper alignment consistent, it is the combination of this setting
and the other spacing values that ensure proper compressed frame alignment.

8. Pressthe TGPS Inactive Active softkey until Activeis highlighted.

9. Pressthe Apply Channel Setup softkey.

When the Appl y Needed annunciator appears, press the Apply Channel Setup softkey. The new settings
are not applied to the signal until this softkey is pressed.

Pressing this key disables the compressed mode trigger. Therefore, whenever this key is pressed while
transmitting in compressed mode, the compressed mode start trigger will have to be reapplied.

Figure 16-62 shows what the ESG display |ooks like when this step is completed.
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Figure 16-61 TGPSI 2 Setup
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10. Press the Return hardkey to return to the TGPSI display.

11. Press the Compressed Mode Start Trigger softkey.

The Conp t r g annunciator appears and the ESG is now transmitting compressed frames.

The ESG does not transmit compressed frames until

an external start trigger is received or the Compressed

Mode Start Trigger softkey is pressed. Compressed frame transmission is terminated when an external stop
trigger is received, the Compressed Mode Stop Trigger softkey is pressed, or a parameter is changed and the
Apply Channel Setup softkey is pressed. You can also stop the transmitted compressed frames after a set
number of transmissions by changing the TGPRCfield from | nf i ni t y to the desired number of repetitions.

Figure 16-62 shows what the ESG display looks like when this procedure is compl eted.

Figure 16-62 Completed TGPSI Display
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Viewing the Multiple TGPSI Signal

1. Select the Spectrum Analysis mode.
Press Mode > Spectrum Analysis.

The W-CDMA mode can also be used, and is demonstrated in the task “ Configuring the E4440A PSA”
on page 507.

2. Set the center frequency to match the ESG carrier signal. This procedure uses 1.95 GHz.
Press Frequency > 1.95 > GHz.

3. Set the spectrum analyzer for a zero span (time domain measurement).
Press Span > Zero Span.

4. Set the resolution bandwidth for afaster response time that captures the signal components.
Press BW/Avg > Res BW > 8 > MHz.

5. Set a Sweep time that lets you view the signal parameters.
Press Sweep > Sweep Time > 100 > ms.

This setting makes it easier to view the frames since each vertical graticleis 10 ms, which is the same
time period for one frame.

6. Trigger the spectrum analyzer from the rear panel input using the supplied ESG trigger signal.
Press Trig > Ext Rear.

Figure 16-63 shows the ESG output signal configured in the previous section, “ Setting Up Compressed
Mode for a Multiple TGPS Transmission” on page 513. In the figure, you can see two transmissions for
TGPSI 1 and one full and a partial transmission for TGPSI 2. Notice the one frame offset for the start of
TGPSI 2 that was created by setting its TGCFNfield to one.
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Figure 16-63 Multiple TGPSIs on the Spectrum Analyzer Display
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Configuring the UE Setup

1. Press Mode > W-CDMA > Real Time W-CDMA > Link Down Up to Up.
2. PressUE Setup.
This opens a menu where you can select the filtering type and adjust the chip rate for the simulated user

equipment (see Figure 16-64). Use the arrow keys or the knab to highlight the data fields for editing.
Press Edit Item to change the value for the desired user equipment parameter.

Figure 16-64 User Equipment Setup
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Locating Rear Panel Input Signal Connectors

One feature of the W-CDMA uplink format is the ease in which you can locate a rear panel input connector
for aparticular signal application. This feature applies to both the DPCH and the PRACH. This procedure
guides you through the softkey menus to where you can view the information.

1
2.

Press Mode > W-CDMA > Real Time W-CDMA > Link Down Up to Up.
Press Link Control > PhyCH Type.

The PhyCH Type softkey opens another menu where you can select either the PRACH or DPCH mode.
The factory default is DPCH. You need to select the mode for which the input signal is intended. If the
input signal isthe AICH for the PRACH, you would need to be in the PRACH mode to see which
connector acceptsthe AICH signal.

Select the channel mode, DPCH or PRACH.

Once amode is selected, you will be returned to the previous softkey menu.

Press DPCH Rear Panel Setup or PRACH Rear Panel Setup depending on the selected mode.
Press DPCH Input Signal Setup or PRACH Input Signal Setup depending on the selected mode.

The information shown in the text area, displaysthe connector and the type of input signal it accepts. For
example, the BBG Ref er ence i nlisting (BASEBAND GEN REF IN connector) inthe Rear Panel
Por t s column accepts a baseband generator (BBG) chip clock signal. Figure 16-65 shows the position
of thisinformation on the DPCH signal input display.

Figure 16-65 Rear Panel Connector Information
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6. To exit this display, press either Mode Setup to return to the top-level W-CDMA softkey menu or press
Return until you come to the desired softkey menu/display.
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Configuring Rear Panel Output Signals

The W-CDMA uplink format provides you the ability to configure output signals for the various rear panel
output connectors. Thislets you select trigger signals based on your needs and applies to both the DPCH and
the PRACH. This procedure guides you through the softkey menus to where you can configure your signals.

Accessing the Output Trigger Signal Menu

1
2.

4.
5.

Press Mode > W-CDMA > Real Time W-CDMA > Link Down Up to Up.
Press Link Control > PhyCH Type.

The PhyCH Type softkey opens another menu where you can select either the PRACH or DPCH mode.
The factory default is DPCH. You need to select the mode for which the input signal is intended. If the
desired output signal isthe PRACH pulse, you would need to bein the PRACH modeto select the signal
and an output connector.

Select the channel mode, DPCH or PRACH.

Once amode is selected, you will be returned to the previous softkey menu.

Press DPCH Rear Panel Setup or PRACH Rear Panel Setup depending on the selected mode.
Press DPCH Output Signal Setup or PRACH Output Signal Setup depending on the selected mode.

Selecting an Output Signal

This procedure will use a PRACH output signal selection as an example. While the signal selection may
change between the PRACH and DPCH modes, the process remains the same.

1

Using the arrow keys, highlight theitem in the Si gnal column that corresponds to the Event 2
connector listed under the Rear Panel Ports column.
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Figure 16-66
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2. Press More (1 of 3) > More (2 of 3) > Preamble Pulse (RPS21).

Notice that under the Si gnal

column in row two of the text display, NONE( RPSO) changed to

Preanbl e pul se( RPS21) . This correspondsto the Event 2 connector listed under the Rear Panel
por t s column. Figure 16-67 shows what the ESG display looks like after the preamble pulse selection

is made.

Figure 16-67
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Deselecting an Output Signal
This procedure builds upon the previous procedure “ Selecting an Output Signal”.
1. Press More (3 of 3).
This returns you to the top-level output signal selection display shown in Figure 16-66.
2. Highlight the Event 2 connector listing.
3. Press NONE(RPSO).
Notice that the output signal selection listed in the Si gnal column has changed to None( RPSO) . The

none indicates that there is no signal output selected for the corresponding connector.

Figure 16-68 Deselected Signal
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Adjusting Code Domain Power

This procedure teaches you about scaling the uplink channels (DPDCH and DPCCH) to 0 dB on the ESG for
meeting the code domain power requirements.

Scaling to 0 dB

After changing the relative power level for a channel, the ESG automatically scales the total power to 0 dB,
while preserving the relative channel power levels. Although the displayed total power changesin value as
channel powers are adjusted, the actual total power is maintained at 0 dB. The displayed channel power
levels remain unchanged, reflecting only user-assigned values, so the user can complete the relative power
adjustments. Thistask teaches you how to update the display to show the normalized relative channel power
for each channel after completing your setup.

1. Press Mode > W-CDMA > Real Time W-CDMA > Link Down Up to Up.

2. PressLink Control > PhyCH Type > DPCH > PhyCH Setup > DPCH Power Setup >
Adjust Code Domain Power > Scale to 0 dB.

DPCH isthe factory default channel mode.

The displayed power level for each channel is now changed to show the normalized relative channel power
and the displayed total power shows 0 dBm. Figure 16-69 is an example showing power levels before and
after the scale to 0 dB function.

Figure 16-69 Scaling to Zero dB (Uplink DPCCH/DPDCH)
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Setting Equal Channel Powers

This task teaches you how to set equal relative power levels for al active channels while maintaining the
code domain power of 0 dB. The normalized relative power level of each channel depends on the number of
active channels. Thistask isan alternative to scaling to

0 dB.

Press Adjust Code Domain Power > Equal Powers.

Both channels have now been set to equal powers. Figure 16-70 shows the displayed normalized relative
power levels after the Equal Powers softkey is pressed with two active channels. Depending on the entered
channel powers, the displayed total power may show alow residua value (such as0. 02 dB) dueto decimal
rounding.

Figure 16-70 Equal Powers (Uplink DPCCH/DPDCH)

1 2 3 After Equal Powers

DPCCH | DPDCH
0 1
-3.01 | -3.01 —— Displayed Power Levels

Uplink. Phusical tupe: DPCH. Pouer Total Pouer: 0.00dB
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W-CDMA Uplink Concepts

Data Channel Air Interface Block Diagram
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Daolgcé;'s > qu'il':I:BRfs > Cg:vﬁg&;eder Bi Inte1:|:aver ™ gel\?'lan;sll:l B MHIR(::;Q —‘

40 ms Frames

60 kbps | Scramble Code
DPDCH " | 3.840 Mcps
Data Bits > |
3.840 Mcps & SF=64
c Data OVSF Gain OVSF2 | @
84| Generator Generator
27 Scramble X Complex
Code Generator b Scrambling
c Control OVSF | Decimate
DPCCH h28  Generator Tl by2
Data Bits 3.840 Mcps ¥_ gF=256
15 kbps i Q
Pilot, Power Control, and TFCI Q 3840 Mcps
Gain = -6dB

| Scramble Code

NOTE: Shaded areas of the graphic indicate pre-calculated values based on the user's collection

of data and coding parameters. Multiplexing and spreading are done real time. e o

Reference Measurement Channels (RMC)

The W-CDMA real-time signal generation modulation format provides reference measurement channels
(RMC) at 12.2, 64, 144, and 384 kbps. This option also provides transport layer coding for AMR 12.2
(adaptive multi-rate) and UDI 64 (unrestricted digital information) protocols. Along with user defined
parameters for the DPCH, the ESG also supports the predefined 12.2 kbps RMC, 64 kbps RMC, 144 kbps
RMC, AMR 12.2 kbps, and UDI 64 kbps with compressed mode.

The signal generator provides one-button setup capabilities for transport channel configuration. The
dedicated physical channel DPDCH is predefined by pressing the Ref Measure Setup softkey (or sending the
appropriate SCPlI commands) and selecting the desired RMC. RMC 12.2 kbps is the factory default
selection.
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Table 16-4 describes the uplink reference measurement channel (RMC) configurations.

Table 16-4 The Uplink RMC Predefined DPDCH Configuration
Parameter DPCH Values at Specified Reference Measurement Channel
Channel Rate 12.2 kbps 64 kbps 144 kbps 384 kbps UDI 64 kbps AMR 12.2 kbps
Power 0.00dB 0.00dB 0.00dB 0.00dB 0.00dB 0.00dB
Beta 15 15 15 15 15 15
Data TrCH TrCH TrCH TrCH TrCH TrCH
Symbol Rate? 60 ksps 240 ksps 480 ksps 960 ksps 240 ksps 60 ksps
Slot Format? 2 4 5 6 4 2
Channel Code 16 4 2 1 4 16

a. The user-selectable symbol rate and slot format parameters are coupled together.

Transition between Normal Frame and Compressed Frame

In a dedicated physical channel (DPCH), an RF notch exists at the transition between a normal frame and a
compressed frame (see Figure 16-71). In aCW signal, the notch measures approximately five microseconds
in length and approximately seven decibels in depth (peak compressed mode to peak nhormal mode).

Figure 16-71

o

DPCH Cha

QUIDUT examoie

RF Notch with Compressed Mode Transitions

normal frames » compressed frames

- —RCOCOCOEP

normmal frames
b

| |

Naotch exists here
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Settling Time during User Event for DPCH Compressed Mode

Some user events, such as changing the amplitude or frequency, will cause the signal to jump to an
unexpected amplitude for a short period of time before it settles to expected parameters. This transition
period is approximately 200 milliseconds (see Figure 16-72). It is, therefore, important to allow for thistime
when you make changesto signal characteristics. If you make changes using remote SCPI commands, insert
wait instructions into the program. The following events can cause this unstable transition time:

» amplitude and frequency changes
* RF switched on and off

» modulation switched on and off

* ALC switched on and off

» saving or recalling states

Figure 16-72 DPCH Compressed Mode Signal after a Change in Amplitude

Transition period: around 200m sec
-~ - & Setting Completion: amplitude settled here

Amplitude before key presm;\

User Event: For example, amplitude changed here
Unexpected amplitude (same with indicated amplitude)

amplitude_cmpr

Connecting the ESG to a W-CDMA Base Station

Figure 16-73 shows the connections and signal s necessary for the ESG to simulate user equipment whenitis
connected to a base station.
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Figure 16-73 Cable Connections

Frame Clock (CMOS)
u — 10, 20, 40, 80, 2560 msec

— SFN Reset (CMOS)

Pattern Trigger In
(Rear—Panel BN

Chip Clock (Optional) >
|| BBG REF In (Rear-Pan¢l BNC) % :
10MHz REF -

10 MHz REF IN (Rear-Patal BNC) ’

<

: BE4438C

RF

Trigger Signals (CMOS)
PRACH Trigger: “Burst Gate In” (BNC)
AICH Trigger: “Pattern Trigger IN 2” (AUX Pin 17)
Compressed mode Start Trigger: “Burst Gate In (BNC)
Compressed mode Stop Trigger: “Pattern Trigger IN 2 (AUX Pin 17)

System Triggering and Synchronization

Either the system frame number reset signal or the frame clock which is applied to the PATT TRIG IN
connector can be set as a system trigger signal. After a delay time defined by the sum of 1024 chips (TO =
the standard timing offset between downlink and uplink), timing offset, and timesl ot offset (plus 10 mswhen
the SFN reset signal isused), async signal is generated to time align all other signals. The RF output signal
is generated after the fixed delay of the processing time by the hardware. This delay applies to DPCH mode
only. Refer to “ Synchronization Diagrams’ on page 544 for more information.

For increased measurement accuracy, the signal generator’srear panel 10 MHz OUT frequency reference
can be utilized by other instruments in the test system.

Connector Assignments for W-CDMA Uplink

This section describes connector assignments for the W-CDMA uplink personality. The block diagram in
Figure 16-74 shows these connector assignments. Notice the front panel connectors are not used in the
uplink real-time signal generation personality.
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Figure 16-74 ESG 170 Connectors for W-CDMA Uplink
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Refer to Table 16-5 for descriptions on connector assignments when using W-CDMA uplink in DPCH

mode. For PRACH mode, refer to Table 16-6 on page 538.

Table 16-5 Connector Descriptions for DPCH Mode
Connector Label Connector Type Input/Ou | Assigned Signal
tput
PATTERN BNC Input Frame sync trigger. This signal determines the
TRIGGER IN SFN frametiming of the ESG so it is
synchronous with the base station.
536
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Table 16-5 Connector Descriptions for DPCH Mode (Continued)
Connector Label Connector Type Input/Ou | Assigned Signal
tput
PATTERN AUX I/O Pin 17 Input Compressed mode stop trigger. Compressed
TRIGGER IN 2 mode must be active. The trigger instructs the

signal generator to stop the compressed mode
pattern at the frame number specified in the
St op CFN# datafield.

ALT POWERIN | AUX I/OPin 16 Input Trigger for user-defined TPC hits.

BURST GATEIN | BNC Input Compressed mode start trigger or the TPC
control signal.

The compressed mode or TPC mode must be
active. The compressed mode start trigger
instructs the signal generator to begin the
compressed mode pattern. The TPC control
signal instructs the ESG to increase or decrease
the DPCH signal power relative to the carrier

power.
BASEBAND BNC Input External system clock in. This connector isused
GEN REF IN for chip clock input when using external data

clock sources. To use an externa signal source as
the data clock input, press BBG Chip Clock Ext Int
to Ext or send the appropriate SCPI command.
This clock rate can be multiplied by setting the
Ext Clock Rate X1 X2 X4 softkey to either x2 or x4.

10 MHz IN BNC Input 10 MHz referencein.

10 MHz OUT BNC Output 10 MHz reference out.

EVENT 1 BNC Output Signal assigned by user. Default is DPDCH raw
data.

EVENT 2 BNC Output Signal assigned by user. Default is DPDCH raw
data clock.

EVENT 3 AUX I/O Pin 19 Output Signal assigned by user. Default is none.

EVENT 4 AUX I/O Pin 18 Output Signal assigned by user. Default is none.
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Table 16-5 Connector Descriptions for DPCH Mode (Continued)
Connector Label Connector Type Input/Ou | Assigned Signal
tput
DATA OUT AUX I/OPIn7 Output Signal assigned by user. Default is DPCCH raw
data
DATA CLOCK AUX /O Pin 6 Output Signal assigned by user. Default is chip clock.
ouT
SYMBOL SYNC | AUXI/OPIn5 Output Signal assigned by user. Default is sync trigger

ouT

reply.

Table 16-6 Connector Descriptions for PRACH Mode

Connector Label Connector Type Input/Ou | Assigned Signal

tput

PATTERN BNC Input Frame sync trigger. This signal determines the

TRIGGER IN SFN frametiming of the ESG so it is
synchronous with the base station.

PATTERN AUX /O Pin 17 Input AICH trigger input. This connector pinis used

TRIGGER IN 2 for the AICH trigger when operating in PRACH
mode. The AICH trigger instructs the signal
generator to generate the message part. The
Message Part datafield must be set to AICH.

ALT POWERIN | AUX I/OPin 16 Input Unused.

BURST GATEIN | BNC Input PRACH start trigger. The connector is used for
the PRACH start trigger when PRACH is
selected in the physical channel setup. The
PRACH start trigger instructs the signal
generator to begin the PRACH pattern.

BASEBAND BNC Input External system clock in. This connector is used

GEN REF IN for chip clock input when using external data
clock sources. To use an externa signal source as
the data clock input, press BBG Chip Clock Ext Int
to Ext or send the appropriate SCPI command.
This clock rate can be multiplied by setting the
Ext Clock Rate X1 X2 X4 softkey to either x2 or x4.
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Table 16-6 Connector Descriptions for PRACH Mode (Continued)

Connector Label Connector Type Input/Ou | Assigned Signal
tput

10 MHz IN BNC I nput 10 MHz referencein.
10 MHz OUT BNC Output 10 MHz reference out.
EVENT 1 BNC Output Signal assigned by user. Default is none.
EVENT 2 BNC Output Signal assigned by user. Default is none.
EVENT 3 AUX I/O Pin 19 Output Signal assigned by user. Default is none.
EVENT 4 AUX I/O Pin 18 Output Signal assigned by user. Default is none.
DATA OUT AUX I/OPRIn7 Output Signal assigned by user. Default is none.
DATA CLOCK AUX /O Pin 6 Output Signal assigned by user. Default is none.
ouT
SYMBOL SYNC | AUXI/OPIn5 Output Signal assigned by user. Default is none.
ouT

Signal Descriptions for W-CDMA Uplink

Figure 16-75 shows how W-CDMA uplink input and output signals align with respect to time. Notice that all
signals are aligned with the leading edge of the chip clock pulse.
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Figure 16-75 Input/Output Signal Alignment
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DPCH Mode

Table 16-7 provides descriptions for fixed and user-selectable signals available in DPCH mode. Figure
16-76 on page 541 shows an example of DPCH output timing alignment.

Table 16-7 Signal Descriptions for DPCH Mode
Signal Label Input/ Signal Description SCPI
Output Syntax
Frame Sync Trigger Input Theinput signal can be set to either the frameclock | FSYN

or the system frame number SFN) reset signal by
toggling the Sync Source FClk SFN softkey. The frame
clock can be set to 10, 20, 40, 80, or 2560 ms.

TPC User File Trigger Input Trigger for user-defined TPC bits. USER
CompressedModeStart | Input Trigger to start compressed mode. CSTT
Trigger
Compressed Mode Stop | Input Trigger to stop compressed mode. CsPT
Trigger
None Output No signal. RPSO
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Table 16-7 Signal Descriptions for DPCH Mode (Continued)
Signal Label Input/ Signal Description SCPI
Output Syntax
Chip Clock Output Chip clock. 3.84 MHz is the default setting. RPS1
Trigger Sync Reply Output Response pulse of the frame sync trigger. Theframe | RPS7
(system sync output) sync trigger reply reports that the frame sync trigger
was received, and is used to adjust frame timing.
When the system trigger is not received, the system
sync output pulseis not generated.
DPDCH Raw Data Output DPDCH data after 2nd interleaver (before spreading | RPS2
and scrambling).
DPCCH Raw Data Output DPCCH data after 2nd interleaver (before spreading | RPS4
and scrambling).
DPDCH Raw Data Output The clock for DPDCH raw data. Theratedependson | RPS3
Clock the slot format (data rate) of DPDCH.
DPCCH Raw Data Output The clock for DPCCH raw data. The rate of this RPS5
Clock clock isfixed at 15 kHz.
10 ms Frame Pulse Output Indicates the frame boundaries for data generation. RPS6
TTI Frame Pulse Output Indicates the frame boundaries for TTI. RPS9
CFN #0 Frame Pulse Output Indicates the frame boundaries for CFN frame #0. RPS10
Compressed Frame Output Thissignal indicates the status of the compressed RPS8
frame. A Oindicatesanormal frame. A 1 indicates a
compressed frame.
Figure 16-76 DPCH Signal Alignment
cnmprgsed fr ame compressed frame
DRCH Channel outpld exarrplie 4'—| |'—| I_

10ms frame pulse
Campressed frame

1

I I I I I I I

Chapter 16

541



W-CDMA Uplink Digital Modulation for Receiver Test

W-CDMA Uplink Concepts

PRACH Mode

Table 16-8 provides descriptions for fixed and user-sel ectable signals available in PRACH mode. Figure
16-77 on page 543 shows an example of PRACH output timing alignment.

Table 16-8 Signal Descriptions for PRACH Mode
Signal Label Input/ Signal Description SCPI
Output Syntax
Frame Sync Trigger Input Theinput signal can be set to either the frameclock | FSYN
or the system frame number SFN) reset signal by
toggling the Sync Source FClk SFN softkey. The frame
clock can be set to 10, 20, 40, 80, or 2560 ms.
PRACH Start Trigger Input Trigger to start PRACH. PSTR
AICH Trigger Input Trigger to start AICH. AITR
None Output No signal. RPSO
Chip Clock Output Chip clock. 3.84 MHz is the default setting. RPS1
Trigger Sync Reply Output Response pulse of the frame sync trigger. Theframe | RPS7
(system sync output) sync trigger reply indicates how much frame
alignment was necessary.
Preamble Raw Data Output Preamble data after 2nd interleaver (before RPS15
spreading and scrambling).
Preamble Raw Data Output The clock for preamble raw data. RPS16
Clock
Message Data Raw Output The data for the message data part after 2nd RPS11
Data interleaver (before spreading and scrambling).
Message Ctrl Raw Data | Output The data for the message control part after 2nd RPS13
interleaver (before spreading and scrambling).
Message Data Raw Output The clock for the message data part raw data. RPS12
Data Clock
Message Ctrl Raw Data | Output The clock for the message control part raw data. RPS14

Clock
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Table 16-8 Signal Descriptions for PRACH Mode (Continued)
Signal Label Input/ Signal Description SCPI
Output Syntax
PRACH Processing Output Thissignal indicates the status of PRACH signaling. | RPS19
The signal is high until the configured number of
PRACH repetitionsis complete. A 0 indicates the
PRACH signal is off. A 1 indicates the PRACH
signal is generating. The signal’s state changes in
accordance with access dot resolution.
Sub-Channel Timing Output Indicates sub-channel timing, which is specified RPS17
through the user interface. A PRACH data stream
must begin on the leading edge of one of these
pulses.
10 ms Frame Pulse Output Indicates the frame boundaries for SFN. RPS6
80 ms Frame Pulse Output Indicates the frame boundaries for SFN RPS20
mod 8 = 0.
Preamble Pulse Output Indicates the start for each preamble access dlot. RPS21
Message Pulse Output Indicatesthe start of an access slot whenthe message | RPS22
part is going to be transmitted.
PRACH Pulse Output Indicates the beginning access slot boundary of a RPS23
PRACH repetition (preamble only or
preamble+message).
Figure 16-77 PRACH Signal Alignment
PRACH Channal PRACH repetition = 2
ot exarmple E El |E| mﬁsaﬁe Eart El El El messaée Eart
Sub-channel _ N | I 1
Preamble pulse o nn 01
Message pulse I I
PEACH processing signal | M ate| Access slot res olution |_
PRACH pulse _ I 1
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Synchronization Diagrams

Signal Alignment for Default DPCH Mode

Figure 16-78 illustrates the timing rel ationships between the signals from the rear panel BNC input and
output connectors relative to the RF Output connector for default signal assignmentsin DPCH mode. Signal
states are referenced to the chip clock provided at the DATA CLK OUT connector.

Figure 16-78 Signal Alignment for Default DPCH Mode

] «hu: $
"« H $

DATACLK OUT % I | ;é |

SYMBOL
SYNC OUT

EVENT1

5 X [ ]

7/

I‘ L'

:Depend on DPDCH slot format:

ﬂﬁjﬂﬁﬂ

i
1 /L { 1
DATAOUT | % X Qg
! 1
I I< /
E i 256 chips
] 1
T — MMV AN VI
A .
% ‘ RF OUTPUT delay 'i
e V4 Total delay i

ul_timing_diag

DPCH Synchronization

Figure 16-79 illustrates the timing alignment for the DPCH channel. Delay timeis defined by the sum of TO
(1024 chips = the standard timing offset between downlink and uplink), timing offset, and timeslot offset.
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Figure 16-79 DPCH Synchronization - Frame Timing Alignment
Frame fiming 15 determined by the Frame gync trigger. ‘/ESG Parameters
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Timing Offset + Timgeslot Offset

ESC UL DPCH Frame timing 0 | 1 |

Figure 16-80 illustrates the frame number alignment for the DPCH channel. The frame number is aligned by
the frame sync trigger signal from the BTS. When using the frame clock, set the frame clock period to be
equal or greater than the longest transport channel TTI period (select 10, 20, 40, or 80 ms). In Figure 16-80,
Reference Measurement Channel 12.2k requires aframe clock of 20 ms or longer to achieve the correct
frame number alignment. Using aframe clock of 10 mswould cause an unpredictable frame timing
alignment with the transport channel TTI period. Best results are achieved when the frame clock is set to 80
or 2560 ms, or a system frame number reset signal is used. (The signal generator’s TTI period can be
measured on the TTI frame pulse from the rear panel.)

Figure 16-80 DPCH Synchronization - Frame Number Alignment
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Figure 16-81 illustrates the frame number alignment for compressed mode when the TGPRC data field is set
to Infinity. In this case, the frame clock period must be equal to or be a multiple of the compressed mode
(TG pattern length) definition.

Figure 16-81 DPCH Synchronization - Frame Number Alignment for Continuous (Infinity)
Compressed Mode
Frame Clock period must match with or multiple of Compressed mode (TG Pattern length) definition
when TGPRC is set as Infinity.

I SFN RST
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ESG System Frame number
SFN 40851 1 2] 31 a] s 6] 7 8 [ 9] I =
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TG Pattem 1 TG Pattern 2 TG Pattern 1 | TG Pattern 2 |
TGPL1 =Zframes, TGPL2 = 5fratnes, TGPRC =mfanity, TGCFI =10

Example 1, TG pattern can be aligned with Frame Clock 80msec, but not with 40msec
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Figure 16-82 illustrates the frame number alignment for compressed mode when it isrequired to align with
CFN number counting. This mode of operation requires aframe clock of 2560 ms or a system frame number
reset signal as the frame sync trigger.

Figure 16-82 DPCH Synchronization - Frame Number Alignment for Compressed Mode with CFN
Number Count

Compressed mode Trigger operation requires Frame Clock 2560msec or SFN_RST
to align CFN number count.
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« TG Pattem 1 I TG Pattern 2 TG Pattern | TG Fattern 2
[ TGPL1=3frames, TGPL2 = 3frames, TGPRC =4i TGCFN =0

Compress mode Start Trigger

Example 2, Transmission Gap (compress) pattern can be aligned with SFN_RST or Frame Clack 2560msec,
However, NOT with 80msec
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PRACH Synchronization

Figure 16-83 illustrates the frame timing alignment for the PRACH channel. Delay time is defined by the
sum of the timing offset and timeslot offset minus the Tp-a value.

Figure 16-83
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Figure 16-84 illustrates the frame number alignment for the PRACH channel. The frame number is aligned
by the frame sync trigger signal from the BTS. Best results are achieved when the frame clock is set to 80 or
2560 ms, or a system frame number reset signal is used. When the sync trigger isaframe clock of 10, 20, or
40 ms, the signal generator can align frame timing. However, an 80 ms period must equal the cycle of
sub-channel 0 and frame boundary to achieve frame number alignment. (The signal generator’s frame
number alignment can be observed on the 80 ms frame pulse from the rear panel.)
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Figure 16-84 PRACH Synchronization - Frame Number Alignment
Frame number is also detervined by the Frame sync trigger.
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Frame Sync Trigger Status Indicator

The signal generator uses a synchronization annunciator to indicate the state of the signal generator’s frame
synchronization and whether or not a synchronization trigger was received. Figure 16-85 shows the uplink
user interface (Ul) and the synchronization annunciator. When Sync Tr g replacesQut  Sync asthe current
annunciator, the frame sync trigger has either been received (dark text) or has not been received (gray text).
The conditions are described as follows:

Sync Trg (grayed out):
The frame sync trigger was not received after atrigger status reset.

Sync Trg (active):
The frame sync trigger was received after the trigger statusis reset.

Out Sync: When the synchronization annunciator indicates Qut  Sync, the signal generator is not
synchronizing with the external frame sync trigger. It is only displayed when an
out-of-sync condition occurs. Thisindicator remains active until the next frame sync
trigger is received.
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Figure 16-85 Front Panel Display
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DPOCH Slot Format: 2 C/N walue: -18.00 dB

OPCH, |
Rear Panel Setup

NOTE Thetrigger statusreset is automatically performed whenever the frame sync trigger modeis
changed or the Apply Channel Setup softkey activated.

Out Sync Annunciator

When the timing of the external frame synchronization signal does not match the signal generator’s frame
generation, the Qut  Sync annunciator isdisplayed. Qut  Sync replacesSync Tr g under these
conditions.

The signal generator’s frame synchronization method depends on the trigger mode selected:

Single Trigger The frametiming is adjusted at the first trigger. All triggers, except the first one are
ignored and not used for signal generator frame timing.

Continuous
Trigger All external triggers are used to adjust the signal generator’s frame timing.

Figure 16-86 describes trigger mode and synchronization patterns.
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Figure 16-86 Trigger Mode and Synchronization

Single Frame Mode
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ESG frame adjustment ‘
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Frame timing is adjusted. Check_trigé;ertiming and frame timing. If both timings are not
"Sync Trg" is Displayed. synchronized, "Out Sync" is displayed. Then, adjust frame timing.

frm_trig-cont

The signal generator checks the timing difference between the external trigger and the internal frame timing
whenever an external trigger isreceived. If the single trigger mode is selected, the signal generator checks
the timing difference between the external trigger and the internal frame timing when the first trigger is
received. If continuous trigger mode is selected, timing is checked at each trigger signal. If thereisatiming
differencein either mode, then the Qut  Sync annunciator is displayed.
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The signal generator’s behavior, when Qut  Sync isdisplayed, depends on the trigger mode used. Table
16-9 describes the signal generator’s behavior for different trigger modes.

Table 16-9

Trigger Mode | ESG output signa statuson Qut  Sync.

Single The ESG outputs frameseven if Qut  Sync isdisplayed.

Continuous The ESG output is discontinued. The synchronization is corrupt and no output is
availablewhen Qut Sync isdisplayed. The ESG timing is retriggered by the
externa trigger when this occurs.

Special Power Control Considerations When Using DPCCH/DPDCH in Compressed Mode
or PRACH

When using either DPCCH/DPDCH in compressed mode or PRACH, more than a single power level is
required. In addition to the rapidly varying power levels for these two channels, there are also periods of
discontinuous transmission (gaps where no RF is transmitted). Under these conditions, the automatic level
control (ALC) will try to counteract the rapid power variations. To prevent this, the signal generator employs
AL C hold mode. However, even with ALC hold active, if the RF gap islonger than five seconds, the output
level may drift significantly. Under certain conditions, such as waiting for an input trigger, the length of the
RF gap is unpredictable. Under these conditions, the signal generator turns the AL C off. Table 16-10 on
page 552 shows the specific settings of the DPCCH/DPDCH in compressed mode or PRACH that will turn
the ALC off. Notice that the settings may differ for the mechanical attenuator.

Table 16-10 Conditions that Turn the ALC Off
Channel Type Electronic Attenuator Mechanical Attenuator
(Option UNB)
PRACH Settings PRACH Trigger Source Immedi PRACH Trigger Source Immedi

Trigger softkey set to Trigger Trigger softkey set to Trigger
Message Part datafieldset | or

to AICH Message Part datafield set
or to AICH
PRACH Mode Single Multi or

softkey is set to Mult PRACH Mode Single Multi

softkey is set to Multi

DPCCH/DPDCH Settings not applicable all compressed frames
(no normal frames)
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When one of the conditions listed in Table 16-10 turns the AL C off, amanual power search must be
performed in order to ensure the correct output power level. Pressing the Apply Channel Setup softkey
executes the manual power search function. Temperature changes or changes to certain signal generator
settings may cause the output power level to change over time. Even though the Appl y Needed
annunciator may be off, it is recommended that you press Apply Channel Setup to perform a manual power
search at least every hour to maintain the correct output power level.

W-CDMA AWGN Measurements and Bandwidths

The AWGN (additive white Gaussian noise) feature produces a noise signal across a

7.68 MHz bandwidth (2x the W-CDMA 3.84 M Hz bandwidth) and |ets you enter valuesthat adjust the noise
level across this spectrum. To resolve the noise signal’s effect on the W-CDMA signal, the ESG also
displays noise values across the W-CDMA 3.84 MHz bandwidth. In addition, the DPCH AWGN feature
shows the bandwidth of the noise signal during the period when it has aflat frequency response. Thisis
called the flat-noise bandwidth. Figure 16-87 shows the different noise settings/values as they appear on the
W-CDMA AWGN display along with a graphical representation of the noise signal showing the different
bandwidth features.
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Figure 16-87 Noise Measurement Bandwidths
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Asshown in Figure 16-87, the noise signal is added to the W-CDMA signal across the entire W-CDMA
signal spectrum. The ESG gives you two ways to control the noise level. You can adjust the noise using
either E,/N, (energy per bit to noise power density ratio) or C/N (carrier power to noise power ratio). Any
adjustment to either noise parameter, E,/N, or C/N, will affect the other; they are not mutually exclusive.
Ep/N, letsyou set the noise ratio relative to the power of the data stream for the selected reference channel,
versus setting the noise relative to the carrier power (C/N). For example, if you have the RACH transport
channel selected as the data source (Eb Ref field, see Figure 16-88) with a 12.2 kbps datarate, the
bandwidth for the datais 12.2 kHz. The data within this bandwidth has a certain power level. This power
level iswhat is used in the ratio for Ep/N,,.

When you use Ei/N,, you can select the reference to use as the data power source. For example, you can use
any of the transport channels for the DPDCH, the PRACH transport channel, the PRACH preamble, or the
DPCCH. Your choice does depend on whether you are using the PRACH or the DPCH mode. Figure 16-88
shows the PRACH data sources that can be used for E,/N,,.
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Figure 16-88 PRACH E,/N, Reference Selection
FREQLENCY AMPLITUDE
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Uplink. Phusical tupe: PRACH. AUGH(Multiple)
Eb/Mo value: L.10 dB C/N wvalue: —22.50 dB
m

Data Source Field

You can calculate the noise values using the following formulas:
Tp=10Log[(Cy + N,y) / .001]

T, = total noise power (dBm)
Cy = linear carrier power (watts) across the 3.84 MHz bandwidth
Ny = linear noise power (watts) across the 3.84 MHz bandwidth
CIN = Ei/N, + 10Log(Ref Data Rate/3.84 MHz)
These formulas clearly show the relationship between Ep/N, and C/N and their effect on the total noise
power across the 3.84 MHz bandwidth.
DPCH Transmit Power Control by an External Signal

Figure 16-89 illustrates the DPCH power control using an external signal. When the Power Hold is turned
off, the ESG output responds to the power control trigger signal. The transmit power control signal is sent
from the base station and indicates whether to increase or decrease the power level. Increases and decreases
are done in increments of the specified Power Step. Once the power level has reached the specified Max
Power, signals requesting an increase in the power level will be ignored (the power is clipped to Max
Power). Thereisa50 chip delay between the base station signal and the RF power response.
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Figure 16-89 DPCH External Power Control
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DPCCH/DPDCH Frame Structure

This section contains graphical representations of W-CDMA frame structures, with associated tables, for

uplink channels.

Figure 16-90 DPCCH/DPDCH Frame Structure
Frame
) / T[ =_ R
Slot #0 Slot #1 Slot #2 Slot #14
_ / T = 0667 ms -~
/ DPCCH
Pilot TFCI FBI TPC
N Bi OTB”S N TFCI Bits N FEI Bits N TPC Bits
DPDCH
Data
NIIQTH Bits
Table 16-11 DPDCH Fields o
Channel Bit Rate Channel Symbol Rate Spread . .
N
(Kbps) (ksps) Factor Bits/Frame Bits/Slot data
15 15 256 150 10 10
30 30 128 300 20 20
60 60 64 600 40 40
120 120 32 1200 80 80
240 240 16 2400 160 160
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Table 16-11 DPDCH Fields (Continued)

Chanfe it Rate | Crannel SymbolRate. | Spread gits/Frame | Bits/Slot | Noaa
480 480 8 4800 320 320
960 960 4 9600 640 640

Table 16-12 DPCCH Fields
Channel
s o | T | awane | mwsor | M | M | e | e
(ksps)

15 15 256 150 10 6 2 0 2
15 15 256 150 10 8 0 0 2
15 15 256 150 10 5 2 1 2
15 15 256 150 10 7 0 1 2
15 15 256 150 10 6 0 2 2
15 15 256 150 10 5 2 2 1
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17 W-CDMA Downlink Digital Modulation for

Receiver Test

In the following sections, this chapter provides the following information. These features are available only
in E4438C ESG Vector Signal Generators with Option 001/601or 002/602.

This chapter teaches you how to build fully coded W-CDMA downlink modulated signals for testing
mobile/user equipment (UE) designs and provides information on how the W-CDMA downlink format is
implemented within the ESG. The modulation is generated by the signal generator’s internal baseband
generator. This chapter includes the following sections:

“Using W-CDMA Downlink” on page 560

“Transmit Diversity Overview” on page 568

“Configuring for Transmit Diversity and BERT” on page 571
“Out-of -Synchronization Testing Overview” on page 582
“Configuring for Out-of-Synchronization Testing” on page 583
“Compressed Mode Overview” on page 589

“Setting Up for a Compressed Mode Signal” on page 592
“Making Compressed Mode Signal Measurements” on page 601
“Locating Rear Panel Input Signal Connectors’ on page 607
“Configuring Rear Panel Output Signals’ on page 609
“W-CDMA Downlink Concepts’ on page 614

“W-CDMA Frame Structures’ on page 621
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Using W-CDMA Downlink

This section teaches you how to build real-time W-CDMA downlink modulation for testing mobile receiver
designs. The modulation is generated by the signal generator’sinternal baseband generator. The procedures
in this section build on each other and are designed to be used sequentially.

Configuring the Base Station Setup

1. PressPreset.

2. Press Mode > W-CDMA > Real Time W-CDMA > BS Setup.

This opens a menu where you can adjust the filtering type, chip rate, scrambling code, and
synchronization delay for the simulated base station (see Figure 17-1).

Figure 17-1 Base Station Setup

FREQUENCY

4.000 000 000 00 &+

AMPLITUDE

-136.00 den
®

IWJCDMA DOWN LINK 3GPP LCDMA Setup.

(3GPP

09-2002)
Filter: B Coi=0, 220 0ENT
Chip Rate: 3.8L0000 HMops
Scrambling Code: a
Sunc Delau: 0.0 chips
T= Diversitu: Mone

Edit Item

Use the arrow keys or the knob to highlight the data fields to be edited. Once afield has been

highlighted, pressing the Edit Item softkey enables you to change the value.
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Configuring the Physical Layer

The stepsin this procedure build upon the previous procedure.

1

Press Return > Link Control > 5 > Enter.

2. PressPhyCH Setup.
3.
4

Move the cursor to highlight the O f value for DPCH data channel 2.

. PressEdit Item to toggle the channel on.

The data channel state changes each time you press Edit Item. You can now move the cursor to edit other
data channel fields as well.

5. PressReturn.

Press Channel State Off On to Off.

Notice that toggling the channel state not only turns off or on the selected physical channel (in this case
DPCH), but also turns off or on all of its data channels, which are shown in the table editor. To turn
individual data channels off or on, repeat steps 2 through 4.

Press Channel State Off On to On.
Press 6 > Enter. (Or, press the right arrow key.)
Press Channel State On Off to On > PhyCH Setup.

This activates the OCNS physical channel, turning on all 16 of its data channels, and accesses the table
editor. Refer to Figure 17-2.
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Figure 17-2

Physical Layer Table Editor

FREQUEMNCY

4.000 000 000 00 &=

AMPLITUDE

-136.00 den

i

Tx Diversitu: HOHE

Dounlink Total Pouer:3.03dB
1 2 3 L a9 [ 6 | 7
SCH CPICH |P-CCPCH| PICH DPCH OCHS

FTHL FrN3

-3.30 | -5.30 | -8.30
Chan 0On/ Data Data 2nd Scr  tOCHS
Code Off Pouer Rate  Tupe Offset  Offset
1 On -12.00 15000 PRI ] 1
2 26 0On -1zZ.00 15000 PRI ] 2
3 28 On -1z2.00 15000 PRI ] 3
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Edit Item

Each data channel can be edited to have different settings, such as time offsets, as required by 3GPP

TS25.101 for performing some of the functional tests.

Use the arrow keys or the knob to highlight the data fiel ds to be edited. Once afield has been highlighted,

pressing the Edit Item softkey enables you to change the value.

Configuring the Transport Layer

The stepsin this procedure build upon the previous procedure.

1. PressReturn > 5 > Enter. (Or, pressthe |eft arrow key.)

2. PressTransport Setup > TrCH Setup.
This accesses the Downlink Transport type table editor. Refer to Figure 17-3.
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Figure 17-3 Transport Layer Table Editor
FREQUENCY

4.000 000 000 00 &=

AMPLITUDE

—136.00 dBn Edit Item
)

Tx Diversitu:- HOHE
Dounlink Transport tupe: DCH Fixed Position |

2 3 Iy 5 6
OCH
1
Blk Set Size:EIN Ozta: PNA  TTI: 10.0 msec
Blk Size: 20 Rate Match Attr: 1
# of Blocks: 1 CRC Size: a
Coding: 1/2 Conv

Use the arrow keys or the knob to highlight the data fields to be edited. Once afield has been highlighted,
pressing the Edit Item softkey enables you to change the value.

Adjusting Code Domain Power

The tasksin this procedure build upon the previous procedure. This procedure teaches you how to perform
the following tasks:

e “Scalingto 0 dB” on page 563
* “Setting Equal Channel Powers’ on page 564

Scaling to 0 dB

After changing the relative power level for a channel, the ESG automatically scal es the total power to O dB,
while preserving the relative channel power levels. Although the displayed total power changesin value as
channel powers are adjusted, the actual total power is maintained at 0 dB. The displayed channel power
levels remain unchanged, reflecting only user-assigned values, so the user can complete the relative power
adjustments. Thistask teaches you how to update the display to show the normalized relative channel power
for each channel after completing the setup.

1. Press Mode Setup to return to the first-level real-time W-CDMA menu.
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2. PressLink Control > Adjust Code Domain Power > Scale to 0 dB.

The power level displayed for each channel is now changed to show the normalized relative channel power.
The values shown in Figure 17-4 result from activating the OCNS channel, as described earlier in this
section. Notice the displayed power levels before and after the Scale to 0 dB softkey is pressed.

Figure 17-4 Scaling to Zero dB
Dounlink Total Pouer:3.23dB
1 2 3 L

SCH CPICH |P-CCPCH| PICH
FTskL FH3
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Dounlink Total Pouer:0.00dB
1 2 3 y
SCH CPICH |P-CCPCH| PICH
FIHL Fra )
—=.52 | -8.52 | -11.52 Displayed Power Levels

After Scaling to 0 dB

Setting Equal Channel Powers

Thistask teaches you how to set the relative power level for al active channelsto be equal, for atotal power
level of 0 dB. The normalized relative power level of each channel depends on the number of active
channels. Thistask isan alternative to scaling to 0 dB.

Press Adjust Code Domain Power > Equal Powers.

All active channels have now been set to equal powers. Figure 17-5 shows the displayed normalized relative
power levels after the Equal Powers softkey is pressed with seven active channels. Notice also that the
displayed total power shows aresidual value of 0. 02 dB due to decimal rounding.

Figure 17-5 Equal Powers
Dounlink Total Pouer:0.02dB
1 2 3 L
SCH CPICH |P-CCPCH| PICH
F THL Fr3
—13.22 |-12.22 | -12.2=2 Displayed Power Levels
After Equal Powers
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Managing Noise
The tasksin this procedure build upon the previous procedure.

The following tasks teach you how to set the overall carrier-to-noise (C/N) ratio for the downlink W-CDMA
setup and to set the E/N,, value for individual physical channels.

e “Setting the Carrier to Noise Ratio” on page 565
e “Setting EC/NQ” on page 565

Setting the Carrier to Noise Ratio

Press Mode Setup to return to the first-level real-time W-CDMA menu.
Press Link Control > 8 > Enter > Channel State Off On to On.

Press PhyCH Setup.

Move the cursor to highlight the & N val ue field.

o >~ w DN P

Press 10 > dB.

NOTE Noise values less than 10 dB may not be visible on a spectrum analyzer.

You have now set the overall carrier to noiseratio to 10 dB and turned on noise. Thisis done to apply a
discernible level of noise across the entire channel space.

Setting E./N,

1. Movethe cursor to highlight the Ec Ref field.

2. PressEdit Item > DPCH 2.

3. Movethe cursor to highlight the Ec/ No val ue field.
4. Press15>dB.

You have now set the E/N,, value for the DPCH 2 channel to 15 dB. Note that modifying the E/N, value for
achannel will change the overall carrier to noise ratio and the E./N, value for all other active channels. For
reliable results when making hand calculations to determine or verify EJ/N, values, it is recommended that

you first scale the code domain power to 0 dB to display the normalized relative channel power levels (see
“Scaling to 0 dB” on page 563).

Chapter 17 565



W-CDMA Downlink Digital Modulation for Receiver Test
Using W-CDMA Downlink

Generating the Baseband Signal

This procedure builds upon the previous procedure.
Press Mode Setup > W-CDMA Off On to On.

This generates the real-time downlink W-CDMA signal. The signal generator experiences a dight delay
while the signal is being built. During thistime, Baseband Busy appears on the display. After the signal
generation is completed, the display reads WCDVA On and the WCDMVA and |/ Qannunciators appear. The
signal is now modulating the RF carrier.

The signal’s configuration dataresides in volatile memory and is not recoverable after an instrument preset,
power cycle, or another signal generation.

Applying New Settings
The stepsin this procedure build upon the previous procedure.

Signal parameters changes are not always automatically applied to the current signal being transmitted.
When this condition occurs, an annunciator appears informing you that the new changes must be applied to
the signal. This procedure demonstrates how these types of changes are applied to the current signal outpuit.

1. PressLink Control >5 > Enter.

2. PressPhyCH Setup.

3. Movethe cursor to highlight the On value for DPCH data channel 1.
4. PressEdit Item to toggle the channel off.

Notice that with the personality already turned on, as soon as a data channel parameter is changed, the
Appl y Needed annunciator appears (see Figure 17-6). This indicates that the new setting has not yet
taken effect in the active baseband signal.
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Figure 17-6 Display Indicates that Apply is Needed
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2 11 0On -13.25 PN o 0 Up/Doun

5. Press Apply Channel Setup.

The new setting to the DPCH data channel is now applied to the baseband signal. Notice also that the
Appl y Needed annunciator is replaced with Appl y Conpl et ed.

The Apply Channel Setup softkey is grayed-out until a change occurs that is not automatically applied to the
signal. When such a change occurs, the Appl y Needed annunciator appears and the Apply Channel Setup
softkey shows as being active (no longer grayed-out). The new settings are not be applied to the signal until
this softkey is pressed.

Configuring the RF Output
The stepsin this procedure build upon the previous procedure.

1. Set the RF output frequency to 2.11 GHz.
2. Set the output amplitude to —10 dBm.
3. PressRF On/0ff to On.

The user-defined, real-time downlink W-CDMA signal is now available at the RF OUTPUT connector of
the signal generator.

To store this real-time I/Q baseband digital modulation state to the instrument state register, see “ Saving an
Instrument State” on page 69.

To recall area-time 1/Q baseband digital modulation state, see “Recalling an Instrument State” on page 70.
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Transmit Diversity Overview

Transmit diversity is used to diminish the effects of fading by transmitting the same information from two
different antennas. However the data from the second antenna (antenna two) is encoded differently to
distinguish it from the primary antenna (antenna one). The user equipment (UE) must be able to recognize
that the information is coming from two different locations and properly decode the data.

The ESG gives you the ability to perform open-loop transmit diversity testing on UEs. This involves using
two ESGs, one setup as antenna one (non-diversity antenna) and the other configured as antenna two
(diversity antenna).

The implementation of transmit diversity in the ESG follows the 3GPP specifications and empl oys space
time transmit diversity (STTD) encoding on the primary common control physical channel (P-CCPCH),
page indicator channel (PICH), and the dedicated physical channel (DPCH). The synchronization channel
(SCH) uses time switched transmit diversity (TSTD). The ESG gives you the option of disabling the TSTD
mode for the SCH. The transmit diversity display for the ESG is shown in Figure 17-7.

Figure 17-7 ESG Transmit Diversity Selection Display
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Transmit Diversity Mode Selection

While the common pilot channel (CPICH) isnot STTD encoded, it is affected when transmit diversity is
utilized. The CPICH istransmitted from both antennas (ESGs), but the pre-defined bit sequence for the
CPICH will differ between antenna one and antenna two per the 3GPP specifications.

While STTD encoding transmits the same information through both antennas, the data on antennatwo is
transmitted in a different order and some bits are inverted. Thisis shown in Figure 17-8.

568 Chapter 17



W-CDMA Downlink Digital Modulation for Receiver Test
Transmit Diversity Overview

Figure 17-8 Generic STTD Encoder
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Antenna 2

In order to simulate two antennas for atransmit diversity application, both ESGs are configured the same
with the exception of one being designated as antenna one and the other as antenna two. The ESG selected
as antenna two will also modify the pilot bits for the dedicated primary common control channel (DPCCH).

TSTD isused only for the SCH and alternately transmits the SCH between the two antennas. Normally the
SCH istransmitted ten percent of the time for each slot of aradio frame. A radio frameis10 mslong and is
comprised of 15 slots (0-14). During the TSTD transmission, the SCH is broadcasted on antenna one during
even numbered slots and on antenna two during odd numbered slots. Thisis demonstrated in Figure 17-9.

Figure 17-9 SCH TSTD Operation
Slot 0 L Slot 1 L Slot 2 R ) Slot 14
SCH SCH SCH SCH
Anftenna 1 |1y on Tx Off Tx On Tx On
SCH SCH SCH SCH
Antenna 2 |1x off Tx On Tx Off Tx Off

The phase for the SCH is also inverted when the P-CCPCH is STTD encoded. When TSTD isturned off, the

SCH is broadcasted in every dot for the selected antenna. Thisis beneficial for synchronization purposes
when only asingle ESG is used.
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Since two antennas are transmitting the same information for asingle UE, the W-CDMA signal timing
(frame timing, system frame numbering, etc.) and transmission from both antennas must occur at the same
time. There are two methods you can use to synchronize the transmission between the two ESGs. One
manner of synchronization involves using either an external trigger source or the LF Output on the ESG.
However using either of these two sources does involve several stepsin configuring the trigger signal.

The second method of synchronizing is designed into the ESG providing an easier method for setup. This
method utilizes a multiple ESG synchronization trigger whereby the first ESG outputs a synchronization
trigger signal to itself and ESG two. All that isinvolved in configuring this trigger signal isjust selecting it
from the rear output signal menu. Thisisthe method demonstrated in the task “ Selecting the Rear Panel
Output Synchronization Signal” on page 575 and “ Generating the Baseband Signals and Synchronizing the
ESG Transmissions’ on page 579.
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Configuring for Transmit Diversity and BERT

Both ESGs are configured with the same settings. The only difference will be setting one as antenna one and
the other as antenna two. Refer to Figure 17-10 on page 572 for the equipment setup diagram.

In this section, factory preset parameters are used for all channels except for the DPCH. If your needs
require specific settings for the different channels, changing the parameters should not modify the
measurement setup demonstrated here, provided the channels for both ESGs are configured the same.

NOTE Ensure that both the Out-of-sync Test Off On softkey and the Compressed Mode Off On softkeys
are set to Off. If either of the two features are active, a conflict of settings error message
(error -221) is generated when the antenna selection is made. Thiswill prevent you from
performing the test. Refer to “ Generating the Baseband Signal and Activating the
Out-Of-Synchronization Test Feature” on page 587 for instructions on accessing the
Out-of-sync Test Off On softkey and “ Setting the Compressed M ode Parameters’ on page 597
for the locating the Compressed Mode Off On softkey.

Equipment Set Up

Required Equipment
The following equipment is required to make transmit diversity BER measurements.
» one E4438C ESG Vector Signal Generator with Options 001/601or 002/602, 400, and UN7
Both ESGs can have Option UN7 (BERT) installed, however it isonly required on one of the ESGs.
» one E4438C ESG Vector Signal Generator with Options 001/601or 002/602 and 400
» oneAgilent 87302C Isolator or an equivalent isolator or combiner
» anexterna controller to control the UE being tested

» aninterfacelevel matching circuit for interfacing between the UE being tested and the signal generator
when the UE signal specifications are different from those of the signal generator
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Connection Diagram

Refer to Figure 17-10 and connect the cables for the ESGs and the UE.

Figure 17-10 Transmit Diversity Setup with BERT
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Configuring the RF Output for both ESGs

1. Pressthe Preset hardkey.

2. Set the frequency and amplitude values.

3. Pressthe RF On/0ff hardkey to On.

Steps two and three can be performed either before or after setting the W-CDMA signal parameters.
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Accessing the W-CDMA Modulation Format and Selecting Downlink

Unless stated otherwise, all procedures or tasks begin from the first-level W-CDMA softkey menu accessed
in this procedure.

1. Press Mode > W-CDMA > Real Time W-CDMA.

This accesses the first-level W-CDMA softkey menu. From this display you can elect to set up the base
station parameters (downlink) or the user equipment (UE—uplink).

2. Using the Link Down Up softkey, ensure that Down is highlighted as shown in Figure 17-11.

Figure 17-11 First-Level W-CDMA Softkey Menu
FREQUENCY AMPLITUDE -core
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Chip Rate: 3.8L0000 Mops
Scrambling Code: ]

Sunc Delay: 0.0 chips BS Setupk

| T Diversitu: None\
More
N\ (1 of 2)

Current Transmit Diversity Mode
Setting UP Antenna One (ESG One)

Selecting Antenna One Mode

1. PresstheBS Setup softkey.
2. Highlightthe Tx Di versity field.
3. PresstheEdit Item softkey.
This displays the different transmit diversity selections shown in Figure 17-12.
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Figure 17-12 Transmit Diversity Mode Selection Display
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4. Pressthe OpenLoop Antl softkey.

ESG oneis now selected as antenna one. Notice that the display summary for the
Tx Di versity field now shows QoenLoop Ant 1. Thisisshown in Figure 17-13.

Figure 17-13 Antenna One Selection
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5. PresstheReturn hardkey to return to the first-level W-CDMA softkey menu.
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Selecting the Rear Panel Output Synchronization Signal

Thistask will guide you in selecting the synchronization signal that is used to synchronize the transmission
between the two ESGs. Either ESG can be configured as the trigger source, but to follow the setup diagram,
ESG oneis being used as the trigger source.

The signal selected in this task goes from the EVENT 1 connector on ESG oneto the PATT TRIG IN

connector on both ESGs.

1. Press More (1 of 2) > Rear Panel Output Setup.

2. Highlight the signal typeinthe Si gnal column that corresponds to the Event 1 rear panel connector
Panel ports column. Thisisdemonstrated in Figure 17-14.

listed in the Rear

Figure 17-14
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3. Press More (1 of 5) > More (2 of 5) > More (3 of 5) > More (4 of 5) >
MIt-ESG-Sync-Trigger-Out (DRPS42).

This changes the current highlighted signal type to the multiple ESG synchronization trigger signal. This
isshown in Figure 17-15.
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Figure 17-15
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4. PressReturn > More (2 of 2) or just press Mode Setup to return to the first-level W-CDMA softkey menu.

Configuring the Signal Parameters

1. PressLink Control > 5 > Enter.

This positions the cursor on the DPCH.

2. PressPhyCH Setup > Ref Measure Setup > 64 kbps.

This selects the 64 kbps reference measurement channel (RMC) as described in the stated 3GPP TS
standard and configures two dedicated channels (DCH, transport channels). If desired, you can adjust the
TFCI bits for the DPCH and the secondary scramble code. Notice that Ref 64 is showing as the data

type for DPCH one.

Thisis demonstrated in Figure 17-16.
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Figure 17-16 64 kbps RMC Selected
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3. Pressthe Mode Setup hardkey to return to the first-level W-CDMA softkey menu.

Setting UP Antenna Two (ESG Two)

All tasks within this section begin at the first-level W-CDMA softkey menu. See “ Accessing the W-CDMA
Modulation Format and Selecting Downlink” on page 573 for locating the first-level W-CDMA softkey
menul.

Selecting Antenna Two Mode

1. Pressthe BS Setup softkey.
2. Highlightthe Tx Di versity field.
3. PresstheEdit Item softkey.
This displays the different transmit diversity selections, which are shown in Figure 17-17.
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Figure 17-17 Transmit Diversity Mode Selection Display
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4. Pressthe OpenLoop Ant2 softkey.

ESG two is now selected as antenna two. Notice that the display summary for the
Tx D versity field now shows QpenLoop Ant 2. Thisisshown in Figure 17-18.

Figure 17-18 Antenna Two Selection
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5. PresstheReturn hardkey to return to the first-level W-CDMA softkey menu.
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Configuring Signal Parameters

1

3.

Press Link Control > 5 > Enter.
This positions the cursor on the DPCH.
Press PhyCH Setup > Ref Measure Setup > 64 kbps.

This selects the 64 kbps reference measurement channel (RMC) as shown in the stated 3GPP TS
standard and configures two dedicated channels (DCH, transport channels). If desired, you can adjust the
TFCI bits for the DPCH and set a secondary scramble code. Notice that Ref 64 is showing as the data
type for DPCH one.

Press the Mode Setup hardkey to return to the first-level W-CDMA softkey menu.

Generating the Baseband Signals and Synchronizing the ESG Transmissions

1

Press the W-CDMA 0ff On softkey to On for both ESG one and two.

This step can be performed at anytime during the setup. The advantage of turning the format on before
setting up the signal, if you have a spectrum analyzer or some other measuring equipment connected, is
you can see the changes as they are made. However you may experience aslight delay in signal
processing while the ESG updates the W-CDMA signal with any changes that are made.

On ESG one, press More (1 of 2) > MIt ESG Sync Trigger.

The output signal for both ESGs are now synchronized and ready to be received by the user equipment
(UE).

NOTE If any signal parameters are changed after the W-CDMA format isturned on and the MIt ESG

Sync Trigger softkey is pressed, it may cause aloss of synchronization. You will need to press
the MIt ESG Sync Trigger softkey after any parameter change is applied to the signal to ensure
proper synchronization between ESG one and two.

Configuring the UE

Using the UE controller, configure the maobile for the call setup procedure to receive the combined ESG
signals, ensuring that the receiver frequency is set to the same as the ESGs.

The UE must be able to demodulate and decode the data from the ESG, and then send this data back to the
ESG for the BERT measurement. The return signal to the ESG must bea TTL or CMOS level signal.
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Making the BERT Measurement

This procedure demonstrates how to make W-CDMA transmit diversity BER measurements. Either ESG

can

be configured to perform the BERT measurement as long as it has Option UN7 installed. For this

procedure, we are using ESG one as shown in the setup diagram. For more information on BERT
measurements see Chapter 9, “BERT,” on page 251.

Selecting the BERT Data Pattern and Total Bits

1

Access the BERT function.

For an ESG with Option UN7 Installed
Press Aux Fctn > BERT > Configure BERT.

For an ESG with Options UN7 and 300 Installed
Press Aux Fctn > BERT > Baseband BERT > Configure BERT.

If the Data softkey does not show that PN9 is the selected data pattern, press
Data > PN9.

The selected PN sequence must match the data PN sequence used on the channel being measured. For
exampleif the DCH (DTCH) is using PN9 data, then the data selection in the BERT function must also
be PN9.

Press Total Bits > 5110 > Bits.

5110 bits (ten times the PN9 data length) at 64 kbps (current data rate for the DCH) takes 0.080 seconds
to test. The value used in this step is merely an example of the number of bits being tested, you can set
the total bitsto meet your test needs.

Selecting the BERT Trigger

1

Press Return > Configure Trigger.

If the BERT Trigger softkey does not show Trigger Key as the selected trigger, press
BERT Trigger > Trigger Key.

Press Return > BERT Off On to On.
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Starting BERT Measurement

Press the front panel Trigger hardkey to start the BERT measurement. You will see the measurement result
valuesfor Total Bits, Error Bits, and BER on the signal generator display.

NOTE If you encounter problems making a BER measurement, check the following:

» Make sure that the cable connections are properly configured.

» Make surethat the data pattern for the BER measurement, specified by the Data softkey,
matches the transmitted data pattern.

» Make sure that the RF isturned on.
e Make sure that the amplitude is set to the correct level.

» Make sure that the UE under test is controlled to receive the signal of the specified
carrier frequency.
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Out-of-Synchronization Testing Overview

The signal level transmitted by the UE is based on transmit power control (TPC) control information
received from the base station. This control information is contained in the DPCCH. When the DPCCH
power level is significantly reduced, the UE may not be able to decode the TPC bits. When the UE can no
longer decode the TPC bits, it has no way of controlling its power output and should terminate transmission.
When the DPCCH power level is restored, the UE should be able to decode the TPC information and begin
transmitting.

Out-of-synchronization testing is used to determine whether or not a UE can detect that the base station’s
dedicated physical control channel (DPCCH) power has decreased to an undesired level and to also detect
when the DPCCH power returns to a sufficient amplitude. When the UE determines that the DPCCH power
istoo low, it isrequired to discontinue its transmission. When the proper DPCCH power level isreceived,
the UE is required to begin transmitting. This test is described in the 3GPP specifications.

The ESG provides a method of out-of-synchronization testing by implementing an adjustable discontinuous
transmission (DTX) period for the dedicated physical channel (DPCH). Since the DPCCH is multiplexed
with the dedicated physical data channel (DPDCH) onto the DPCH, injecting a DPCH DTX period
simulates a DPCCH low power condition. The length of the DTX period is determined by an input DTX
gating signal. You are given the option of either having the DTX period occurring on the positive
transition/duty period of the trigger signal or occurring on the negative transition/period. The DTX gating
can be provided by an external source or you can simply use the ESG’s LF Output function as demonstrated
in the procedure “ Configuring the DPCH DTX Gating Trigger Signal” on page 588.

582 Chapter 17



W-CDMA Downlink Digital Modulation for Receiver Test
Configuring for Out-of-Synchronization Testing

Configuring for Out-of-Synchronization Testing

This section will teach you how to configure the ESG and perform an out-of-synchronization test. While the
test described in this section does not follow the 3GPP conformance test, it will demonstrate the capability
of the UE to determine whether or not it can detect the received DPCCH TPC bits. One of the differences
between this and the conformance test, isthat the ESG discontinues the DPCH transmission where the 3GPP
conformance test adjusts the DPCCH power level. The out-of-synchronization test will work only with
DPCH one.

NOTE Ensure that transmit diversity has been set to None and compressed mode is off. If either of
the two features are active, a conflict of settings error message (error -221) is generated
when the out-of-synchronization mode is turned on. Thiswill prevent you from performing
the test. Refer to “ Selecting Antenna One Mode” on page 573 for instructions on accessing
the transmit diversity mode softkey selection menu and “ Setting the Compressed M ode
Parameters’ on page 597 for the locating the Compressed Made Off On softkey.

Equipment Set up

Required Equipment

» one E4438C ESG Vector Signal Generator with Options 001/601or 002/602 and 400
» anexternal controller to control the UE under test

» anAgilent E4440A PSA Spectrum Analyzer or an equivalent instrument

An oscilloscope can be used in place of the spectrum analyzer.
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Connection Diagram

Refer to Figure 17-19 and connect the cables.

Figure 17-19 Out-of-Synchronization Setup
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Setting the RF Output

1. Pressthe Preset hardkey.

2. Set the frequency and amplitude values.

3. Pressthe RF On/0ff hardkey to On.

Steps two and three can be performed either before or after setting the W-CDMA signal parameters.
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Accessing the W-CDMA Modulation Format and Selecting Downlink

Unless stated otherwise, all procedures and tasks begin from the first-level W-CDMA softkey menu
accessed in this procedure.

1. Press Mode > W-CDMA > Real Time W-CDMA.

This accesses the first-level W-CDMA softkey menu. From this display you can elect to set up the base
station parameters (downlink) or the user equipment (UE—uplink).

2. Using the Link Down Up softkey, ensure that Down is highlighted as shown in Figure 17-20.

Figure 17-20 First-Level W-CDMA Softkey Menu
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Setting UP the W-CDMA Signal Parameters
This procedure uses the factory preset parameters for al channels except for the DPCH.

1. PressLink Control > 5 > Enter > PhyCH Setup.
2. Ensurethat anitem on line one (DPCH one) is highlighted.
3. PressRef Measure Setup > 12.2 kbps.

This configures DPCH one as a 12.2 kbps reference measurement channel according to the 3GPP
specifications. This reference measurement channel sets up two transport channels (DCH) and the
required DPCH parameters. Ref 12 shows asthe data type for DPCH one and is demonstrated in Figure
17-21.
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Figure 17-21 12.2 kbps RMC Selected
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If desired, you can adjust the TFCI bits, control the TPC pattern, and set the secondary scrambling code.
4. Pressthe Mode Setup hardkey to return to the first-level W-CDMA softkey menu.
Selecting the Input DTX Gating Signal Trigger Polarity

1. Press More (1 of 2) > Rear Panel Input Setup > Trigger Polarity Setup.

Notice that there are three different trigger polarity softkeys, two for the compressed mode feature and
one for the DPCH DTX gate signal (out-of-synchronization feature). Thisis shown in Figure 17-22.

Figure 17-22 Trigger Gating Signal Trigger Polarity Selection
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When the trigger polarity selection is positive, the DPCH DTX occurs while the gating signal is high.
The reverseistrue when the trigger polarity selection is negative. When the trigger polarity selectionis
negative, the DPCH DTX starts when the out-of-synchroni zation mode is turned on since the absence of
atrigger isinterpreted asif the gating signal was low.

Press the Mode Setup hardkey to return to the first-level W-CDMA softkey menu.

Generating the Baseband Signal and Activating the Out-Of-Synchronization Test Feature

1

Press the W-CDMA Off On softkey to On.

This step can be performed at anytime during the setup. The advantage of turning the format on before
setting up the signal, if you have a spectrum analyzer or some other measuring equipment connected, is
you can see the changes as they are made. However you may experience aslight delay in signal
processing while the ESG updates the W-CDMA signal with any changes that are made.

Press More (1 of 2) > Out-of-sync Test Off On to On.

This prepares the ESG to receive the DPCH DTX trigger gating signal.

Configuring the UE

Using the UE controller, configure the mobile for the call setup procedure to receive the ESG signal
ensuring that the receiver frequency is set to the same as the ESG.

Setting Up the Spectrum Analyzer for Detecting the UE DTX

For this procedure we are using the Agilent E4440A PSA Spectrum Analyzer.

1
2.

Preset the spectrum analyzer.

Configure the spectrum analyzer to accept an external 10 MHz frequency reference.
a.  Press System > Reference > Freq Ref nn.nnnnn MHz Int Ext until Ext is underscored.
b. Press10> MHz.

Select the spectrum analysis mode.

Press Mode > Spectrum Analysis.

Set the frequency to match the transmission frequency of the UE.

a. Pressthe Frequency hardkey.
b. Using the numeric keypad, enter the frequency of the UE signal.
Set a zero frequency span.

Press Span > Zero Span.
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Set the sweep time for 500 ms.
Press Sweep > 500 > ms.
Select external triggering so the measurement begins when the DPCH DTX period starts.

Press Trig > Ext Rear.

Configuring the DPCH DTX Gating Trigger Signal

One of the fundamental features within the ESG is the ability to generate trigger signals using the LF Output
function. In this procedure, we will use the LF Output function to create the DPCH DTX gating signal.

1
2.
3.

Press LF Out > LF Out Source > Function Generator.
Press LF Out Waveform > More (1 of 2) > Pulse.
Press LF Out Period > 500 > msec.

In accordance with the 3GPP specifications, the UE will cease transmission within a certain amount of
time when the base station's DPCCH power level decreases by a certain amount. Conversely, the UE
will again begin transmission within a certain amount of time once the DPCCH power level attains the
correct power level. With the ESG, thisis simulated by creating aDTX period for the DPCH. The pulse
period time entered allows for a complete cycle where the UE should discontinue and then begin
transmission.

Press LF Out Width > 200 > msec.

Thisis the approximate period of time in which the UE should detect that the ESG’s DPCH has
discontinued transmission, and then turn off its own transmission.

Press LF Out Amplitude > 2.5 > Vp.
Press LF Out Off On to On.
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Compressed Mode Overview

Compressed mode is used when you need to create a discontinuous transmission period (DTX), also called a
transmission gap, so the user equipment (UE) can sample other frequencies. During the DTX period, the UE
can receive control information from either another W-CDMA base station or a GSM base station for a
handoff.

The UE must be able to receive the compressed frames and properly demodul ate and decode the data along
with the normal frames. BER and BL ER measurements are made on the data to ensure proper UE operation.
The ESG facilitates this type of testing by transmitting fully coded transport channels (DCH) for
compressed, normal, or a combination of compressed and normal frames. These fully coded channels can
automatically be configured using the provided reference measurement channels (RMC) or you can set your
own custom configurations. The ESG supports the following 3GPP defined DPCH channel configurations
for compressed mode:

e 12.2 kbps
* 64 kbps

e 144 kbps
e 384 kbps

« AMR12.2Kbps
- UDI IDSN 64 kbps

With both the fully coded transport channels and the wide choice of RMCs, you are able to fully test the UE
for proper demodulation and decoding using BER testing. For more information on the supported RMCs,
see “Reference Measurement Channels” on page 614.

The compressed mode in the ESG complies with the 3GPP specifications and is very flexible with many
adjustable parameters. You can have one or two transmission gaps. When two gaps are used, each gap can
have a different length and operate using the single or double frame method. The double frame method uses
dots from two compressed frames to create one transmission gap. Table 17-1 describes some of the
parameters that are available for the compressed mode.
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Table 17-1

Downlink Compressed Mode Parameters

Name

Definition

Transmission gap pattern repetition count (TGPRC)

Number of transmission gap patterns within the
transmission gap pattern sequence.

Transmission gap connection frame number (TGCFN)

CFN of the first compressed frame of the first
pattern within the transmission gap pattern
sequence.

Transmission gap slot number
(TGSN)

Slot number of the first transmission gap within
the first radio frame of the transmission gap
pattern.

Transmission gap length 1

Duration of the first transmission gap within the

(TGLYI) transmission gap pattern.

Transmission gap length 2 Duration of the second transmission gap.
(TGL2)

Transmission gap duration Thisisthe distance, measured in dots, from the
(TGD) beginning of the first transmission gap to the

beginning of the second transmission gap.

Transmission gap pattern length 1

Duration of first transmission gap pattern that

(TGPLY1) includes TGL /2.

Transmission gap pattern length 2 Duration of the second transmission gap pattern
(TGPL2) that includes TGL 1/2.

Stop connection frame number CFN of the last radio frame.

(Stop CFN)

Transmission gap pattern sequence identifier (TGPSI)

Thisidentifies the currently selected transmission
gap pattern sequence. Only one TGPSI is
supported at thistime.

Transmission gap pattern sequence
(TGPS)

Thislets you select whether or not to transmit the
current TGPSI. Activeit will be transmitted,
inactive it will not be transmitted.

CM Method: SF/2 (spread factor divided by two) or
Puncturing

This determines the data processing mode used to
create the gaps.

Frame Struct: A or B

A: Optimizes the gap length.
B: Optimizes the power control.
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The ESG offers two different compressed mode methods for transmitting compressed frames. Thisis shown
as CM Method: SF/2 (spread factor divided by two) or Puncturing in Table 17-1. SF/2 reduces the spread
factor of the compressed frame by half; puncturing reduces the amount of transmitted data by eliminating
bits.

The ESG also supports the DPCH dot sub-formats, denoted in the specifications by the slot format number
withan ‘A’ or ‘B’, that are used during compressed frame transmission. The sub-format used is dependent
on the selected compressed mode method. The ESG automatically selects the correct sub-format for the
current slot format when you select the compressed mode method. For example if you were using slot
format 3, which includes the sub-formats 3A and 3B, and selected the SF/2 compressed mode method, the
ESG would use sub-format 3B. If you were to select puncturing as the compressed mode method, then the
ESG would automatically select sub-format 3A.

Another feature of the ESG compressed mode gives you the ability to select the different frame structures
utilized during compressed frame transmission. Frame structure ‘A’ optimizes the DTX periods by not
transmitting any power control information (TPC field) during this time. Frame structure ‘B’ optimizes for
power control by inserting power control information during the first DTX dot for each transmission gap.
Both frame structures transmit the pilot bits during the last dlot for each transmission gap.
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Setting Up for a Compressed Mode Signal

Using the compressed mode turns the ESG AL C feature off. To maintain amplitude accuracy, it is
recommended that you perform a power search. Thisis demonstrated in the task, “Performing a Manual
Power Search” on page 599.

The signal parameters set in this section are used for both setups shown in the Equipment Setup section.

NOTE Ensure that transmit diversity has been set to None and the Out-of-sync Test Off On softkey is
set to Off. If either of the two features are active, a conflict of settings error message
(error -221) is generated when compressed mode is turned on. Thiswill prevent you from
using the feature. Refer to “ Selecting Antenna One Mode” on page 573 for instructions on
accessing the transmit diversity mode softkey selection menu and “ Generating the
Baseband Signal and Activating the Out-Of-Synchronization Test Feature” on page 587 for
instructions on accessing the Out-of-sync Test Off On softkey.

Equipment Setup

Required Equipment for Measuring the DPCH Symbol Power

» one E4438C ESG Vector Signal Generator with Options 001/601or 002/602 and 400
» oneAgilent E4440A PSA Spectrum Analyzer with Options B7J and BAF or an equivalent instrument

Required Equipment for BERT Measurements

e one E4438C ESG Vector Signal Generator with Options 001/601or 002/602, 400, and UN7
» anexterna controller to control the UE being tested

« aninterfacelevel matching circuit for interfacing between the UE being tested and the signal generator
when the UE signal specifications are different from those of the signal generator
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Connection Diagram for Measuring the DPCH Symbol Power

Refer to Figure 17-23 and connect the cables for the ESG and PSA (spectrum analyzer).

Figure 17-23 Compressed Mode Setup for a Symbol Power Measurement

TRIGGER IN

EVENT 1

RF OUTPUT RF INPUT

53 _Ped

Connection Diagram for BERT Measurements

Refer to Figure 17-24 and connect the cables for the ESG and the UE.
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Figure 17-24 Compressed Mode Setup for BERT
Optional
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Setting the RF Output

1. Pressthe Preset hardkey.
2. Set the frequency and amplitude values.
3. Pressthe RF On/0ff hardkey to On.

Steps two and three can be performed either before or after setting the W-CDMA signal parameters.
However they must be done before the power search is performed in the task, “ Performing a Manual Power
Search” on page 599.
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Accessing the W-CDMA Modulation Format and Selecting Downlink

Unless stated otherwise, all procedures and tasks begin from the first-level W-CDMA softkey menu
accessed in this procedure.

1. Press Mode > W-CDMA > Real Time W-CDMA.

This accesses the first-level W-CDMA softkey menu. From this display you can elect to set up the base
station parameters (downlink) or the user equipment (UE—uplink). See Figure 17-25 for the first-level
W-CDMA softkey menu display.

Using the Link Down Up softkey, ensure that Down is highlighted as shown in Figure 17-25.
Figure 17-25 First-Level W-CDMA Softkey Menu
FRECUENCY AMPLITUOE Lo
2.10000000000 &= | -10.00 cen .
@@ e Ensure that Down
> is Highlighted (Default)
| Link ControlM
[CDMA DOuN LINK 3GPP WCOMA Setup.
(3GPP
Off
BEG Chip Clock
Filter: RNYD (0=0. 220 EWH Ext
Chip Rate: 3.8L0000 Mops
Sane Oslog: 0.0 chips BS Setup
| T Diversitu: None\
Mare
AN (1 af 2)

Current Transmit Diversity Mode is Set to None (off)

Setting Up the W-CDMA Signal Parameters

This procedure uses the factory preset parameters for all channels except for the DPCH.

1
2.

Press Link Control > 5 > Enter > PhyCH Setup.
Ensure that an item on line one (DPCH one) is highlighted.

The compressed mode feature operates with only DPCH one. If you were to try use DPCH two by itself
or in unison with DPCH one, an error message i s generated.

Press Ref Measure Setup > 12.2 kbps.

This configures DPCH one as a 12.2 kbps reference measurement channel according to the 3GPP
specifications. This reference measurement channel sets up two transport channels (DCH) and the
required DPCH parameters. Ref 12 now shows as the data type for DPCH one and is demonstrated in
Figure 17-26.
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Figure 17-26 12.2 kbps RMC Selected
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2 11 0ff -10.20 PRIS 0 0 Up/Down

[ y ]

/

12.2 kbps RMC Selection Showing
If desired, you can change the TFCI bits, control the TPC pattern, and select the secondary scrambling
code.
4. Pressthe Mode Setup hardkey to return to the first-level W-CDMA softkey menu.

Generating the Baseband Signal

Press the W-CDMA Off On softkey to On.

This step can be performed at anytime during the setup. The advantage of turning the format on before
setting up the signal, if you have a spectrum analyzer or some other measuring equipment connected, is you
can see the changes asthey are made. However you may experience aslight delay in signal processing while
the ESG updates the W-CDMA signal with any changes that are made.

Configuring Compressed Mode

Selecting the Rear Panel Output Trigger Signal

Performing thistask isnot required if you are performing BERT measurements. A rear panel output signal is
used to trigger an instrument, so it begins measuring the RF output signal at a certain point.

1. Press More (1 of 2) > Rear Panel Output Setup > More (1 of 5) > More (2 of 5) >
DPCH Compressed Frame Indicator (DRPS32).

This enables an output trigger signal at the rear panel EVENT 1 connector when the compressed frameis
transmitted.

2. Pressthe Mode Setup hardkey to return to the first-level W-CDMA softkey menu.
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Setting the Compressed Mode Parameters

1

Press Link Control > 5 > Enter > Compressed Mode Setup.

Notice that the cursor is already showing in the compressed mode table editor. This means you can
immediately start editing parameters upon entering the compressed mode display. Thisis unlike the
uplink where another softkey needsto be pressed before the cursor is displayed in the table editor.

The compressed mode feature is accessible only when the DPCH (5) is highlighted. The Compressed
Mode Setup softkey is grayed-out when any other channel is selected.

Set slot eight of the frame as the starting slot for the first transmission gap.
a. Movethe cursor to highlight the TGSN field.

b. Presss8 > Enter.

This sets the first compressed frame to have eight slots (0-7) of data with slot eight marking the
beginning of the first transmission gap.

Set the first transmission gap length which is expressed as a number of slots.
a. Movethe cursor to highlight the TG_1 field.
b. Press 14 > Enter.

Out of the 15 slots per frame, the standard specifies that seven of them can be used as discontinuous
transmission (DTX) slots. However the total gap length can be spread over two frames. The value 14
denotes 14 DTX dlots, which spans 2 frames. Thisis called the double-frame method. When TGSN is <
8and TGL is< 7, then the DTX dlots are contained in one frame forming the single-frame method.

Set the second transmission gap length which is expressed as a number of slots.

a. Movethe cursor to highlight the TA.2 field.

b. Press3 > Enter.

For the second transmission gap, the single frame method is used.

Set the spacing between the first and second transmission gaps expressed as a number of slots.
a. Movethe cursor to highlight the TGDfield.

b. Press37 > Enter.

Set the duration of the first transmission gap pattern which is expressed as a number of frames.
a. Movethe cursor to highlight the TGPL1 field.

b. Press6 > Enter.
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7. Set the duration of the second transmission gap pattern which is expressed as a number of frames.
a. Movethe cursor to highlight the TGPL2 field.
b. Press4 > Enter.

8. Enable the compressed frames.
a. Movethe cursor to highlight the TGPS field.
b. PressEdit Item > Active.

9. Pressthe Compressed Mode Off On softkey to On.
This softkey turns the compressed mode feature on, but it does not cause the compressed frame
transmission to begin. Compressed frames are not transmitted until the ESG receives atrigger signal.
Thisisdemonstrated in the task, “ Setting the Frame Power Offset and Triggering the Compressed Frame
Function” on page 600.
Notice that when compressed mode is turned on, the AL C feature of the ESG is turned off. Thisis
indicated by the ALC COFF annunciator showing in the display and shown in Figure 17-27.
The Compressed Mode Off On softkey can be set to On at any time, however doing it at the end appliesthe
changes to the baseband signal, so you do not have to pressthe
Apply Channel Setup softkey. This just decreases the number of required key presses during the signal
setup. But if changes are made to the compressed mode after the feature is turned on, the Appl y
Needed annunciator may appear. When the annunciator appears, this means that you must press the
Apply Channel Setup softkey to apply the changesto the signal.
Figure 17-27 shows the compressed mode display once all parameters from this procedure are
completed.
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Figure 17-27 Completed Compressed Mode Display
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Page 2

Performing a Manual Power Search
Thistask builds upon the previous task, “ Setting the Compressed M ode Parameters’ on page 597.

The ALC feature is disabled when compressed mode is used (Compressed Mode Off On softkey set to On), and
it isrecommended that amanual power search is performed to ensure the correct output power level. See the
section “ Special Power Control Considerations When Using Compressed Mode” on page 620 for more
information.

Thistask will guide you in configuring and performing amanual power search. If desired, you can adjust the
power search settings to meet your individual test needs.

1. Press Amplitude > Power Search > Power Search Reference Fixed Mod to Mod.

Mod references the power search on the rms value of the 1/Q modulation, whereas fixed uses a 0.5 volt
reference during the power search operation.

From this current softkey menu, you can make adjustments to the other power search parameters to meet
your test needs.

2. PressReturn > Do Power Search.

The ESG has now performed a power adjustment for the current carrier frequency. If you change
frequencies or the RF output power level, the power adjustment will have to be done again.

3. PresstheReturn hardkey to access the previous compressed mode menu.
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Setting the Frame Power Offset and Triggering the Compressed Frame Function

NOTE If you are using the spectrum analyzer setup shown in the section “Connection Diagram for
Measuring the DPCH Symbol Power” on page 593, it is best to perform Step 3 once you
have completed the spectrum analyzer setup in the section, “Measuring the DPCH Symbol
Power” on page 601. Because this is a demodulation measurement, the spectrum analyzer
needs to capture the DPCH before DTX periods are incorporated. If the spectrum analyzer
encountersa DTX period while making a demodulation measurement, it will not recognize
the DPCH transmission.

1. Set the compressed frame power relative to the non-compressed (normal) frames.

a. Movethe cursor to highlight the Piwr O f s field.
b. Press6 > dB.

This enables you to compensate for reduced spreading gain. The higher power level makes the
compressed frames easier to view.

2. Pressthe Apply Channel Setup softkey.
3. Pressthe Compressed Mode Start Trigger softkey.

The compressed mode function terminates when the Compressed Mode Stop Trigger softkey is pressed, an
external stop trigger signal is received, or when the Apply Channel Setup softkey is pressed. You can also stop
the transmitted compressed mode signal after a set number of transmissions by changing the TGPRCfield
from | nfi ni ty to the desired number of repetitions. To restart the compressed mode function, just press
the Compressed Mode Start Trigger softkey or send an external start trigger signal.
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Making Compressed Mode Signal Measurements

Measuring the DPCH Symbol Power

This procedure will guide you through setting up a spectrum analyzer for demodulating the compressed
DPCH that was configured in the previous procedures. While the main steps are generically written, the
substeps are written specifically for the E4440A PSA. The setup diagram for this procedureis shownin
Figure 17-23 on page 593.

Configuring the Spectrum Analyzer

1. Preset the spectrum analyzer.
2. Select the W-CDMA measurement mode.
Press Mode > W-CDMA.
3. Set the spectrum analyzer to receive a base station signal.
Press Mode Setup > Radio > Device BTS MS until BTS is underscored.
4. Set the spectrum analyzer frequency to match the transmission frequency of the ESG.

a. Pressthe Frequency hardkey.

b. Using the numeric keypad, enter the carrier frequency of the ESG signal.
5. Select the code domain measurement.

Press Measure > More 1 of 3 > Code Domain.
6. Set aspan that lets you view the channels.

Press Span > Scale/Div > 64 > Enter.

Figure 17-28 shows the current spectrum analyzer display. If the display does not show the channels,
press the Restart hardkey to perform another measurement.
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Figure 17-28 DPCH Selected on PSA
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7. Set the spectrum analyzer so it measures the DPCH symbol power.

a. Press Meas Setup > Symbol Rate > 30 > ksps.
This sets the DPCH symbol rate for the 12.2 kbps RMC data rate and matches the ESG DPCH

symbol rate shown in Figure 17-29

b. Press Code Number > 10 > Enter.

This sets the channel code branch that the DPCH is using and is associated with the with the SF for
the symbol rate of 30 ksps (3.84 Mcps/ 30 ksps = SF 128).

The code number is found on the ESG DPCH setup display and is shown in Figure 17-29.

DPCH
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8. Select aframe captureinterval that will display the DPCH compressed pattern.

Press More 1 of 3 > Capture Intvl > 8 Frame (Long Mode).

Notice that the display changes from code domain to symbol power.

9. Zoom in on the symbol power display

Press the Zoom hardkey.

10. Trigger the spectrum analyzer from the rear panel input using the supplied ESG DPCH compressed

frame trigger signal.

Press More 2 of 3 > Trig Source > Ext Rear.

NOTE If you have not started the triggering for the ESG compressed mode signal, press the
Compressed Mode Start Trigger softkey on the ESG.

11. Start the measurement for the symbol power.

Press the Restart hardkey.

The spectrum analyzer may take a few moments to display the DPCH symbol power. Depending on

which compressed frame triggers the spectrum analyzer measurement, your display may differ from the
one showing in Figure 17-30. However the characteristics of the signal as depicted in Figure 17-30 till

apply.
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Figure 17-30 Compressed DPCH Signal
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12. Use amarker to measure the different displayed symbol power levels.

a  Press Marker > Trace > Symbol Power.

b. Usethe RPG knaob to position the cursor at the desired location.

You can make further signal measurements on the PSA such as measuring the number of slots for a section

on the display. Thisis accomplished with Meas Interval x Slots and the

Meas Offset x Slots softkeys located in the Meas Setup hardkey menu. This can help you verify the signal
parameters that were set on the ESG
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Making the BERT Measurement

This procedure demonstrates how to make W-CDMA compressed signal BER measurements. Option UN7
must be installed on the ESG. The setup diagram for this procedure is shown in Figure 17-24 on page 594.
For more information on BERT measurements see Chapter 9, “BERT,” on page 251.

Configuring the UE

Using the UE controller, configure the mobile for the call setup procedure to receive the ESG signal,
ensuring that the receiver frequency is set to the same asthe ESG.

The UE must be able to demodul ate and decode the data from the ESG, and then send this data back to the
ESG for the BERT measurement. The return signal to the ESG must bea TTL or CMOS level signal.

Selecting the ESG BERT Data Pattern and Total Bits

1. Accessthe BERT function.

For an ESG with Option UN7 Installed
Press Aux Fctn > BERT > Configure BERT.

For an ESG with Options UN7 and 300 Installed
Press Aux Fctn > BERT > Baseband BERT > Configure BERT.

If the Data softkey does not show that PN9 is the selected data pattern, press
Data > PN9.

The selected PN sequence must match the data PN sequence used on the channel being measured. For
exampleif the DCH (DTCH) is using PN9 data, then the data selection in the BERT function must also
be PN9.

2. PressTotal Bits > 5110 > Bits.

5110 hits (ten times the PN9 data length) at 12.2 kbps (current data rate for the DCH) takes
0.419 secondsto test. The value used in this step is merely an example of the number of bits being tested,
you can set the total bits to meet your test needs.

Selecting the ESG BERT Trigger

1. PressReturn > Configure Trigger.

If the BERT Trigger softkey does not show Trigger Key as the selected trigger, press
BERT Trigger > Trigger Key.

2. PressReturn > BERT Off On to On.
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Starting the ESG BERT Measurement

Press the front panel Trigger hardkey to start the BERT measurement. You will see the measurement values
for the Total Bits, Error Bits, and BER on the signal generator display.

NOTE If you encounter problems making a BER measurement, check the following:

» Make sure that the cable connections are properly configured.

e Make surethat the data pattern for the BER measurement, specified by the Data softkey,
matches the transmitted data pattern.

» Make sure that the RF isturned on.
e Make sure that the amplitude is set to the correct level.

» Make sure that the UE under test is controlled to receive the signal of the specified
carrier frequency.
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Locating Rear Panel Input Signal Connectors

One feature of the W-CDMA downlink format is the ease in which you can determine the correct rear panel
input connector for a particular signal application. The input signal type changes depending on whether you
are in the compressed mode, performing the out-of-synchronization test, or doing transmit diversity, which

is the same as the standard (default) downlink mode. This section guides you through the softkey menusto

where you can view the information.

1. Press Mode > W-CDMA > Real Time W-CDMA > Link Down Up to Down (default).
2. Press More (1 of 2) > Rear Panel Input Setup.

The information shown in the text area, displaysthe connector and the type of input signal it accepts. For
example, the BBG Ref er ence i nlisting (BASEBAND GEN REF IN connector) inthe Rear Panel
Por t s column accepts a baseband generator (BBG) chip clock signal. Figure 17-31 shows the different
input signal to connector displays.
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Figure 17-31 Rear Panel Input Signal Connector Information
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3. Toexit this display, press either Mode Setup to return to the first-level W-CDMA softkey menu or press
Return until you come to the desired softkey menu/display.
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Configuring Rear Panel Output Signals

The W-CDMA downlink format provides you the ability to configure output signals for the various rear
panel output connectors. This lets you control trigger signals based on your needs. Unlike the rear panel
input signals, the ESG does not have to be in aparticular mode to select any of the rear panel output signals.
However the correct feature (transmit diversity, compressed mode, out-of-synchronization testing, etc.) must
be active before some signals are available at the rear panel. For example, if you select the DPCH Compressed
Frame Indicator(DRPS32) as an output trigger signal, the ESG must be transmitting a compressed mode signal
before thisrear panel trigger is realized. This section guides you through the softkey menus to where you
can configure your signals.

Accessing the Rear Panel Output Signal Menu

1. Press Mode > W-CDMA > Real Time W-CDMA > Link Down Up to Down (default).
Thisisthefirst-level W-CDMA softkey menu.
2. Press More (1 of 2) > Rear Panel Output Setup.

Selecting an Output Signal

1. Using the arrow keys, highlight theitem in the Si gnal column that corresponds to the Event 2
connector listedinthe Rear Panel Ports column. ThisisshowninFigure 17-32.

Figure 17-32 Output Connector Selection
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2. Press More (1 of 5) > More (2 of 5) > DPCH data-clk(DRPS28).

Notice that in row two of the table editor under the column Si gnal , the text
SFN reset - si gnal ( DRPS5) changed to DPCH dat a- ¢l k( DRPS28) . This corresponds to the
Event 2 connector listed inthe Rear Panel ports column. Figure 17-33 shows what the ESG
display looks like after the DPCH data-clock selection is made.
Figure 17-33 Output Trigger Signal Selection
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SFM sunc-pulse (ORPSE)

o s
B

OPCH
Y datarll | Softkey
(ORPS28)
OPOCH data-clk
WithoutOTH
(DRPS30)
Rear Panel ports Connector Signal

DPCH data-clock

. OPCH
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(ORPS33

Data out Al Pin 7 OPCH TPC-Bits-0OutcORPSLLY )
Data clock out AUX Fin B 3.84MHz Chip-clock (DRPSY)
Sumbol Sunc out AUX Pin 5 80ms Frame-FPulse (DRFS13)

PICH data-clk
(ORFPS3L )

Selected

More

(3 o0f 57

To exit this display, press either Mode Setup to return to the first-level W-CDMA softkey menu or press
Return until you come to the desired softkey menu/display.

Deselecting an Output Signal

This procedure builds upon the previous procedure Selecting an Output Signal.

1. Press More (3 of 5) > More (4 of 5).

2. Highlight the Event 2 connector listing.

3. Press NONE(DRPS0).
Notice that the output signal selection listed in the Si gnal column has changed to None( RPSO and is
shown in Figure 17-34. The none indicates that there is no signal output selected for the corresponding
connector.
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Figure 17-34 Deselected Signal
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Rear Panel Output Signal Descriptions

Table 17-2 describes the different downlink rear panel output signals available on the ESG. The DRPSxx
designator, shown in parenthesis, refers to the remote SCPI command parameter that corresponds to the
particular softkey selection. For example, the designator DRP4 refers to the SCPI command parameter for

a3.84 MHz chip-clock signal.

Table 17-2 Downlink Rear Panel Output Signals

Signal Name

Description

3.84 MHz chip-clk (DRPS4)

Assigns a 3.84 MHz chip clock signal to the selected
rear panel output port.

SFN reset-signal (DRPS5)

Assigns a system frame number (SFN) reset-signal to
the selected rear panel output port.

SFN sync pulse (DRPS6)

Assigns a system frame number (SFN) synchronization
pulse to the selected rear panel output port.

SCH dlot pulse (DRPS10)

Assigns the synchronization channel pulse to the
selected rear panel output port.

10ms Frame pulse (DRPS11) Assigns the 10 millisecond frame pulse to the selected
rear panel output port.
80ms Frame pulse (DRPS13) Assigns the 80 millisecond frame pulse to the selected

rear panel output port.
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Table 17-2

Downlink Rear Panel Output Signals

Signal Name

Description

DPDCH data-clk withDTX (DRPS20)

Assigns the dedicated physical data channel (DPDCH)
data clock to the selected rear panel output port. Thisis
a continuous pulsed signal that is not affected by the
transmission gaps incurred during compressed frame
operation.

DPCCH TPC data-clk (DRPS21)

Assigns the dedicated physical control channel
(DPCCH) transmit power control (TPC) data clock to
the selected rear panel output port.

DPCCH TFCI data-clk (DRPS22)

Assigns the dedicated physical control channel
(DPCCH) transmit format combination indicator
(TFCI) dataclock to the selected rear panel output port.

DPCCH Pilot data-clk (DRPS23)

Assigns the dedicated physical control channel pilot
data clock to the selected rear panel output port.

DPCH data-stream (DRPS24)

Assigns the DPCH data stream to the selected rear
panel output port (prior to spreading and scrambling).

DPCH TimeSlot pulse (DRPS25)

Assigns the DPCH timeslot pulse to the selected rear
panel output port.

DPCH 10ms Frame Pulse (DRPS26)

Assigns the DPCH 10 millisecond frame pulse to the
selected rear panel output port.

DPCH data-clk (DRPS28)

Assigns the DPCH data clock to the selected rear panel
output port.

DPDCH data-clk withOutDTX (DRPS30)

Assigns the dedicated physical data channel (DPDCH)
data clock to the selected rear panel output port. This
signal provides DTX periods that reflects the absence
of DPDCH data during the transmission gaps that are
incurred during compressed frame operation. When
compressed mode is disabled, this signal performs the
same function as the DRPS20 signal.

DPCH Compressed Frame Indicator (DRPS32)

Assigns the DPCH compressed frame indicator signal
to the selected rear panel output port.

DPCH Gap Indicator (DRPS33)

Assigns the DPCH gap indicator signal to the rear
panel output port for compressed mode.
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Table 17-2 Downlink Rear Panel Output Signals

Signal Name

Description

PICH data (DRPS35)

Assigns paging indicator channel (PICH) data to the
selected rear panel output port.

PICH TimeSlot pulse (DRPS36)

Assigns the paging indicator channel (PICH) timeslot
pulse to the selected rear panel output port.

PICH 10ms FramePulse (DRPS37)

Assigns the paging indicator (PICH) 10 millisecond
frame pulse to the selected rear panel output port.

P-CCPCH data-clk (DRPS38)

Assigns the primary common control physical channel
(P-CCPCH) dataclock to the selected rear panel output
port.

P-CCPCH data (DRPS39)

Assigns the primary common control physical channel
(P-CCPCH) data to the selected rear panel output port.

DPCH ChipARB frame pulse (DRPS40)

Assigns the DPCH chip ARB frame pulse data to the
selected rear panel output port.

DPCH TPC bits out (DRPS41)

Assigns the DPCH transmit power control (TPC) bits
to the selected rear panel output port.

MIt-ESG-Sync Trigger-Out (DRPS42)

Used to instantly synchronize the output signals of
multiple ESGs while performing open-loop transmit
diversity testing.
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W-CDMA Downlink Concepts

DPCH Coding Block Diagram
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NOTE: Shaded areas of the graphic indicate pre-calculated values based on the user's collection
of data and coding parameters. Multiplexing, scrambling and spreading are done real-time.
pkTdc

Reference Measurement Channels

Real-time W-CDMA provides fully coded reference measurement channels (RMC) at 12.2, 64, 144, and
384 kbps, the AMR at 12.2 kbps, and the UDI ISDN at 64 kbps. Along with user defined parameters, all four
RMCs, the AMR 12.2, and the UDI ISDN are supported for use with the compressed mode feature.

The signal generator provides one-button setup capabilities for transport channel configuration. The
dedicated physical channel DCH (downlink) is automatically setup by pressing the Ref Measure Setup softkey
(or sending the appropriate SCPI commands) and then selecting the desired data type. To activate the Config
Transport softkey, one of the reference measurement rates must be selected or the DPCH Dat a field value
must be set to Transport CH
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Table 17-3 describes the downlink RMC configurations generated by pressing the Ref Measure Setup softkey
after the signal generator has been preset. Transport channel parameters can be modified in atable editor by
pressing the Config Transport softkey, then moving the cursor to the desired data field and pressing Edit Item.
DPCH parameters can be individually modified in atable editor by pressing PhyCH Setup, then moving the
cursor to the desired data field and pressing Edit Item.

Table 17-3 The Downlink RMC Predefined DPCH Configuration
Parameter DPCH Values at Specified Reference Measurement Channel
Channel Rate 12.2 kbps 64 kbps 144 kbps 384 kbps AMR 12.2 kbps UDI ISDN 64 kbps
Power 0.00dB 0.00 dB 0.00dB 0.00 dB 0.00 dB 0.00 dB
Channel Code? 6 6 6 6 6 6
SecSrc Code OS 0 0 0 0 0 0
TPC Pat Steps 1 1 1 1 1 1
Data?® Ref 12 Ref 64 Ref 144 Ref 384 AMR 12 ISDN
Symbol Rate® 30.00 ksps 120.0 ksps 240.0 ksps 480.0 ksps 30.0 ksps 120.0 ksps
TFCI Pattern 00000000 00000000 00000000 00000000 00000000 00000000
TPC Pattern Up/Down Up/Down Up/Down Up/Down Up/Down Up/Down
Slot Format 11 13 14 15 8 13
Time Offset 0 0 0 0 0 0

a. ESG Channel # 1 default shown. Default channel code for Channels 2 through 4 are based on the equation: Default
Channel Code = (Channel #) + 5.

b. If a transport configuration parameter is changed using the Config Transport
softkey and the table editor, the Dat a field reverts to Transport CH showing that it no longer contains a specified
reference measurement channel.

¢. Symbol rate is not user-selectable. It is coupled to slot format. To change the symbol rate, use the appropriate slot format.
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Scramble Codes

The real-time 1/Q baseband 3GPP W-CDMA personality implements scrambling codes for downlink OCNS
and DPCH channels in compliance with the 3GPP specifications. Thisis done through the use of the
Scranbl i ng Code (primary scramble code) field, located in the BS setup menu, and the SecScr  Code
G5 (secondary scrambl e code offset) fields located in the OCNS and DPCH Physical Channel Setup menus.
Thesefields are linked so that an entry to any field affects the actual scramble code. To better understand the
relationship, refer to the following formula:

n= (16 xi) +k
Table 17-4
Where n = scramble code Range: 0to 8191
i = Primary Scrambling Code field input Range 0 to 511
k = SecScr Code OS field input Range: 0to 15

The primary and secondary setsare determined by the SecScr Code OSfield values. If theSecScr Code
Cs fidd valueis zero, then the scramble code is in the primary set. Any non-zero entry enables the
secondary set. The SecScr Code OSfield value has arange of

0 through 15.

A primary scramble code is the product of the Scr anbl i ng Code field value and 16. Therefore, the
primary scramble code set contains all the multiples of 16, from 0 through 8176.

A secondary scramble code is the sum of the non-zero SecScr Code G5 field value and the primary
scramble code. The secondary scramble code set uses the numbers in between the multiples of 16.

Thus, all numbers from 0 through 8191 are available for scramble codes.
Refer to the following for examples of scramble codes generated with the primary and secondary sets:
n= (16 xi) +k
Table 17-5
Where n = scramble code
i = Scrambling Code field input
k = SecScr Code OS field input
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Table 17-6
A: Primary set B: Secondary set
i=6 i=8
k=0 k=7
n=96 n=135

Scramble Code Offset
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W-CDMA AWGN Measurements and Bandwidths

The AWGN (additive white Gaussian noise) feature produces a noise signal across a 7.68 MHz bandwidth
(2x the W-CDMA 3.84 MHz bandwidth) and lets you enter values that adjust the noise level acrossthis
spectrum. To resolve the noise signal’s effect on the W-CDMA signal, the ESG also displays noise values
across the W-CDMA 3.84 MHz bandwidth. In addition, the AWGN feature shows the bandwidth of the
noise signal during the period when it has aflat frequency response. Thisis called the flat-noise bandwidth.
Figure 17-35 shows the different noise settings/values as they appear on the W-CDMA AWGN display
along with a graphical representation of the noise signal showing the different bandwidth features.
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Figure 17-35 Noise Measurement Bandwidths
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Asshown in Figure 17-35, the noise signal is added to the W-CDMA signal across the entire W-CDMA
signal spectrum. The ESG gives you two ways to control the noise level. You can set the noise using either
EJ/N, (energy per chip to noise power density ratio) or C/N (carrier power to noise power ratio). Any
adjustment to either noise parameter, E//N, or C/N, will affect the other; they are not mutually exclusive.
EJ/N, lets you set the noise power relative to the power of achannel, versus setting the noise relative to the
carrier power (C/N). For example, if you select the P-CCPCH (called areference channel), the power level
of this channel isused in theratio for E//N,. Figure 17-36 shows the downlink channel selections for E./Ng

and the channel reference fields.
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Figure 17-36 E./N, Reference Selection
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\ Channel Reference and Channel Noise Power Reference Fields

When E/N, is 0.0 dB, C/N is equal to the reference channel power. Thisis demonstrated in the following
CIN formula:

CIN = (Ec Ref Pow - EJ/N,)
The total noise power in a3.84 MHz bandwidth is calculated using the following formula:
T,=10Log[(Cy +Ny)/.001]

T, = total noise power (dBm)

C,, = linear carrier power (watts) across the 3.84 MHz bandwidth

Ny, = linear noise power (watts) across the 3.84 MHz bandwidth

These formulas clearly show the relationship between E./N, and C/N and their effect on the total noise
power across the 3.84 MHz bandwidth.
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Special Power Control Considerations When Using Compressed Mode

When using the compressed mode, more than a single power level is required. In addition to the rapidly
varying power levels for the DPCH, there are also periods of discontinuous transmission (gaps where no RF
is transmitted). Thisiswhy the signal generator turns off the ALC when the compressed mode is turned on.
Because the ALC isturned off, the output power level may not be consistent with the power level entered on
the ESG, so amanual power search must be performed in order to ensure the correct output power level.
Pressing the Do Power Search softkey executes the manual power search function. Thisis demonstrated in the
task “Performing a Manual Power Search” on page 599.

Temperature changes or changes to certain signal generator settings may cause the output power level to
change over time. It is recommended that you perform amanual power search at least every hour to maintain
the correct output power level.
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W-CDMA Frame Structures

This section contains graphical representations of W-CDMA frame structures, with associated tables, for
downlink channels.

Downlink PICH Frame Structure

Figure 17-37 PICH Frame Structure
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Downlink PCCPCH + SCH Frame Structure

Figure 17-38 PCCPCH + SCH Frame Structure

Radio Frame (10 ms)

* L

Time Slot (0.667 ms)

+

Slot #0 Slot #1

PCCPCH

Slot#14

OFF Data
PSCH
Primary
Search Code OFF
SCH
SSCH
Secondary
Search Code OFF
pk760b
Table 17-7 Lengths of PCCPCH + SCH Fields
Parameter Symbols Per Slot
Ndata 9
Nsch? 1

a. SCH comprises PSCH and SSCH
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Figure 17-39 DPCCH/DPDCH Frame Structure
Frame
Ts =10ms
Slot #0 Slot #1 Slot #2 Slot #14

4/,,»”””/”’

T, = 0_667_

< —
Data1 TPC TFCI Data? Pilot
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pk781b
Table 17-8 DPDCH and DPCCH Fields
Bits/Frame DPDCH Bits/Slot DPCCH
g _ Bits/Slot
@4 &FE 3 -
32| B 5 T T 2
~ ~—~ -
Szl £ § 1 818 < > Neatar | Naata2 Nrci Nrec | Npilot
C © £ © o o o (@) =
O O wn [a) a — [a]
15 7.5 512 20 150 10 0 4 0 2 4
15 75 512 30 120 150 10 0 2 2 2 4
30 15 256 240 60 300 20 2 14 0 2 24
30 15 256 210 20 300 20 2 12 2 2 24
30 15 256 210 20 300 20 2 12 0 2 42
30 15 256 180 120 300 20 2 10 2 2 42
30 15 256 150 150 300 20 2 8 0 2 g2
30 15 256 120 180 300 20 2 6 2 2 g2
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Table 17-8 DPDCH and DPCCH Fields (Continued)
Bits/Frame DPDCH Bits/Slot DPCCH
E = Bits/Slot
=~ E ~ 2
o8 && 3 -
38| T 5 T - 2
~ ~ —
Ez|l £ 3 3 8 = > Ngatar | Ndata2 Nrecy Nrpc Nopilot
£ © £ © o o o o =
O O x w [a) a — [a]
60 30 128 510 90 600 40 6 28 0 2 42
60 30 128 | 480 120 600 40 6 26 2 2 42
60 30 128 | 450 150 600 40 6 24 0 2 g2
60 30 128 | 420 180 600 40 6 22 2 2 g2
120 60 64 900 300 1200 80 12 48 gb 4 8
240 120 32 2100 | 300 2400 160 28 112 gb 4 8
480 240 16 4320 | 480 4800 320 56 232 gb 8 16
960 480 8 9120 | 480 9600 640 120 488 gb 8 16
192 960 4 1872 | 480 19200 1280 248 1000 8o 8 16
0 0

a. The number of pilot bits can vary with channel symbol rates of 15 and 30 ksps.
b. If TFCI bits are not used, then DTX (discontinuous transmission) is used in the TFCI field.
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If You Encounter a Problem

If You Encounter a Problem

If the signal generator is not operating properly, refer to the proper section in this chapter for a possible
solution. If you do not find a solution, refer to the E4428C/38C ESG Sgnal Generators Service Guide.

NOTE If the signal generator displays errors, always read the error message text by pressing
Utility > Error Info.
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Basic Signal Generator Operations

Cannot Turn Off Help Mode

1. Press Utility > Instrument Info/Help Mode
2. Pressthe Help Mode Single Cont softkey until Single is highlighted.
The signal generator has two help modes; single and continuous.

When you press Help in single mode (the factory preset condition), help text is provided for the next key you
press. Pressing another key will exit the help mode and activate the key’s function.

When you press Help in continuous mode, help text is provided for the next key you press and that key's
function isalso activated (except for Preset). You will stay in help mode until you press Help again or change
to single mode.

No RF Output

Check the RF QN CFF annunciator on the display. If it reads R CFF, press RF On/0ff to toggle the RF
output on.

The Power Supply has Shut Down

If the power supply is not working, it requires repair or replacement. There is no user-replaceable power
supply fuse. Refer to the E4428C/38C ESG Sgnal Generators Service Guide for instructions.
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Signal Loss While Working with Mixers

If you experience signal loss at the signal generator’s RF output during low-amplitude coupled operation
with amixer, you can solve the problem by adding attenuation and increasing the RF output amplitude of the
signal generator.

Figure 18-1 on page 628 shows a hypothetical configuration in which the signal generator provides alow
amplitude signal to a mixer.

Figure 18-1 Effects of Reverse Power on ALC

SIGNAL GENERATOR
OUTPUT CONTROL

ALC LEVEL RE OUTPUT MIXER
=-8dBm =-8dBm
—_—> -
RF LEVEL
CONTROL > j j Lo
DETECTOR DETECTOR LO FEEDTHRU LO LEVEL
MEASURES MEASURES =-5dBm - +10 dBm
-8dBm -5dBm
ALC LEVEL REVERSE
POWER IF

Theinternally leveled signal generator RF output (and ALC level) is—8 dBm. The mixer is driven with an
LO of +10 dBm and has an L O-to-RF isolation of 15 dB. The resulting L O feedthrough of -5 dBm enters
the signal generator’s RF output connector and arrives at the internal detector.

Depending on frequency, it is possible for most of this LO feedthrough energy to enter the detector. Since
the detector responds to its total input power regardless of frequency, this excess energy causesthe ALC to
reduce the RF output of the signal generator. In this example, the reverse power across the detector is
actually greater than the ALC level, which may result in loss of signal at the RF output.

Figure 18-2 on page 629 shows a similar configuration with the addition of a 10 dB attenuator connected
between the RF output of the signal generator and the input of the mixer. The signal generator’'sALC level is
increased to +2 dBm and transmitted through a 10 dB attenuator to achieve the required -8 dBm amplitude
at the mixer input.
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Figure 18-2 Reverse Power Solution
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Compared to the original configuration, the ALC level is 10 dB higher while the attenuator reduces the LO
feedthrough (and the RF output of the signal generator) by 10 dB. Using the attenuated configuration, the
detector is exposed to a+2 dBm desired signal versus the —15 dBm undesired L O feedthrough. This 17 dB
difference between desired and undesired energy resultsin a maximum 0.1 dB shift in the signal generator’s
RF output level.

Signal Loss While Working with Spectrum Analyzers

The effects of reverse power can cause problems with the signal generator’s RF output when the signal
generator is used with a spectrum analyzer that does not have presel ection capability.

Some spectrum analyzers have as much as +5 dBm L O feedthrough at their RF input port at some
frequencies. If the frequency difference between the L O feedthrough and the RF carrier islessthan the ALC
bandwidth, the LO’sreverse power can cause amplitude modulation of the signal generator’s RF output. The
rate of the undesired AM equals the difference in frequency between the spectrum analyzer’'sLO
feedthrough and the RF carrier of the signal generator.

Reverse power problems can be solved by using one of two unleveled operating modes: AL C off or power
search.
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ALC Off Mode

AL C off mode deactivates the automatic leveling circuitry prior to the signal generator’s RF output. In this
mode, a power meter is required to measure the output of the signal generator and assist in achieving the
required output power at the point of detection.

To set the signal generator to the AL C off mode, follow these steps:

1. PressPreset.

2. PressFrequency, enter the required frequency, and terminate the entry with the appropriate terminator
softkey.

3. Press Amplitude, enter the required amplitude, and terminate the entry with the appropriate terminator
softkey.

4. Set RF On/0ff to Off.

5. Press Amplitude > ALC Off On to Off.
This deactivates the signal generator’s automatic leveling control.

6. Monitor the RF output amplitude as measured by the power meter.

7. Press Amplitude and adjust the signal generator’s RF output amplitude until the desired power is
measured by the power meter.

Power Search Mode

Power search mode executes a power search routine that temporarily activatesthe ALC, calibratesthe power

of the current RF output, and then disconnects the AL C circuitry.
To set the signal generator to manual fixed power search mode, follow these steps:
1. PressPreset.

2. PressFrequency, enter the required frequency, and terminate the entry with the appropriate terminator
softkey.

3. Press Amplitude, enter the required amplitude, and terminate the entry with the appropriate terminator
softkey.

4, Set ALC Off On to Off

This deactivates the ALC circuitry.
5. Set RF On/0ff to On.
6. Press Do Power Search.

This executes the manual fixed power search routine, which is the default mode.
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There are three power search modes: manual, automatic, and span.

When Power Search is set to Manual, pressing Do Power Search executes the power search calibration routine
for the current RF frequency and amplitude. In this mode, if there is achange in RF frequency or amplitude,
you will need to press Do Power Search again.

When Power Search is set to Auto, the calibration routine is executed whenever the frequency or amplitude of
the RF output is changed.

When Power Search is set to Span, pressing Do Power Search executes the power search calibration routine
over aselected range of frequencies at one time. The power search corrections are then stored and used
whenever the signal generator istuned within the selected range of frequencies.

RF Output Power too Low

1. Look for an GFFS or REF indicator in the AMPLI TUDE area of the display.

CFFS tellsyou that an amplitude offset has been set. An amplitude offset changes the value shown in the
AVPLI TUDE area of the display but does not affect the output power. The amplitude displayed is equal to
the current power output by the signal generator hardware plus the value for the offset.

To eliminate the offset, press the following keys:
Amplitude > More (1 of 2) > Ampl Offset > 0 > dB.

REF tells you that the amplitude reference mode is activated. When this mode is on, the displayed
amplitude value is not the output power level. It isthe current power output by the signal generator
hardware minus the reference value set by the Ampl Ref Set softkey.

To exit the reference mode, follow these steps:

a.  Press Amplitude > More (1 of 2).
b. Press Ampl Ref Off On until Off is highlighted.
You can then reset the output power to the desired level.

2. If you are using the signal generator with an external mixer, see “ Signal Loss While Working with
Mixers’ on page 628.

3. If you are using the signal generator with a spectrum analyzer, see “ Signal Loss While Working with
Spectrum Analyzers’ on page 629.
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No Modulation at the RF Output

Check the MDD QV CFF annunciator on the display. If it reads MCD OFF, press Mod On/0ff to toggle the
modulation on.

Although you can set up and enable various modulations, the RF carrier is modulated only when you have
also set Mod On/0ff to On.

On the E4438C for digital modulation, make sure that 1/Q Off On is set to On.

Sweep Appears to be Stalled

The current status of the sweep is indicated as a shaded rectangle in the progress bar. You can observe the
progress bar to determineif the sweep is progressing. If the sweep appears to have stalled, check the
following:

0 Haveyou turned on the sweep by pressing any of the following key sequences?
Sweep/List > Sweep > Freq
Sweep/List > Sweep > Ampl
Sweep/List > Sweep > Freq & Ampl

O Isthe sweep in continuous mode? If the sweep isin single mode, be sure that you have pressed the
Single Sweep softkey at least once since completion of the prior sweep. Try setting the mode to
continuous to determine if the missing single sweep is blocking the sweep.

O Isthesignal generator receiving the appropriate sweep trigger? Try setting the Sweep Trigger softkey to
Free Run to determine if a missing sweep trigger is blocking the sweep.

O Isthesignal generator receiving the appropriate point trigger? Try setting the Point Trigger softey to Free
Run to determine if amissing point trigger is blocking the sweep.

O Isthedwell time appropriate? Try setting the dwell time to one second to determineif the dwell timewas
set to avalue which was too slow or too fast for you to see.

0 Doyou have at least two pointsin your step sweep or list sweep?
Cannot Turn Off Sweep Mode

Press Sweep/List > Sweep > Off.

In the sweep mode menu you can choose to set the sweep to various sweep types or to turn sweep off.

632 Chapter 18



Troubleshooting
Basic Signal Generator Operations

Incorrect List Sweep Dwell Time

If the signal generator does not dwell for the correct period of time at each sweep list point, follow these
steps:
1. Press Sweep/List > Configure List Sweep.
This displays the sweep list values.
2. Check the sweep list dwell values for accuracy.
3. Edit the dwell values if they are incorrect.

NOTE The effective dwell time at the RF OUTPUT connector is the sum of the value set for the
dwell plus processing time, switching time, and settling time. This additional time
added to the dwell is generally afew milliseconds. The TTL/CMOS output avail able at
the TRIG OUT connector, however, is asserted high only during the actual dwell time.

If the list dwell values are correct, continue to the next step.
4. Observeif the Dwell Type List Step softkey is set to Step.

When Step is selected, the signal generator will sweep the list points using the dwell time set for step
sweep rather than the sweep list dwell values.

To view the step sweep dwell time, follow these steps:

a. Press Configure Step Sweep.

b. Observe the value set for the Step Dwell softkey.

List Sweep Information is Missing from a Recalled Register

List sweep information is not stored as part of the instrument state in an instrument state register. Only the
current list sweep isavailableto the signal generator. List sweep data can be stored in the instrument catal og.
For instructions, see “ Storing Files’ on page 67.
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Data Storage

Registers With Previously Stored Instrument States are Empty

The save/recall registers are backed-up by a battery when line power to the signal generator is not
connected. The battery may need to be replaced.

To verify that the battery has failed, follow these steps:

1. Turn off line power to the signal generator.

2. Unplug the signal generator from line power.
3. Plug inthe signal generator.

4. Turn onthe signal generator.

5. Observe the display for error messages.

If either error message —311 or =700 is stored in the error message queue, the signal generator’s battery
has failed.

6. Refer to the E4428C/38C ESG Sgnal Generators Service Guide for battery replacement instructions.

Saved an Instrument State in a Register but the Register is Empty or Contains the Wrong State

If you have selected aregister number that is greater than 99, the signal generator will automatically select
register 99 to save your instrument state.

If the register number you intended to use is empty or contains the wrong instrument state, press the
following keys:

Recall > 99 > Enter.

Thisrecalls register 99. The lost instrument state may be saved there.
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Signal Generator Lock-Up

If the signal generator islocked up, check the following:

» Make sure that the signal generator is not in remote mode. (In remote mode, the R annunciator will
appear on the display.) Press Local to exit remote mode and unlock the front panel keypad.

» Make sure that the signal generator is not in local lockout condition. Local lockout will prevent front
panel operation of the signal generator. For more information on local lockout, refer to the E4428C/38C
ESG Sgnal Generators Programming Guide.

» Check for a progress bar on the signal generator display which indicates that an operation isin progress.
*  PressPreset.

» Cycle power on the signal generator.

Fail-Safe Recovery Sequence

The fail-safe recovery sequence should only be used if the previous suggestions do not resolve the problem.

NOTE This process will reset the signal generator, but it will destroy data.

The fail-safe recovery sequence will destroy the following types of data:

o all user files (instrument state and datafiles)

 DCFM/DC®M cdlibration data

e persistent states

Do not attempt to perform any other front panel or remote operations during the fail-safe sequence.

To run the fail-safe sequence, follow these steps:

1. Hold down the Preset key while cycling power.
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2. Continue to hold down the Preset key until the following message is displayed:

WARNING You are entering the diagnostics menu which can cause unpredictable instrument
behavior. Areyou sure you want to continue?

CAUTION Carefully read the entire message! It may list additional risks with this procedure.

3. Releasethe Preset key.
4. Press Continue to continue with the sequence (or Abort to abort with no lost files).

At the conclusion of the sequence, follow these steps:

1. Cycle power.

Cycling power restores all previously installed options. You should expect to see several error messages
resulting from calibration files being restored from EEPROM.

2. Perform the DCFM/DC®M calibration.

Refer to the DCFM/DC®M Cal softkey description in the E4428C/38C ESG Signal Generators Key and
Data Field Reference Volume 1.

3. Agilent Technologiesisinterested in the circumstances that made it necessary for you to initiate this
procedure, please contact us using the website on page 641. We would like to help you eliminate any
repeat occurrences.
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Error Messages

If an error condition occursin the signal generator, it isreported to both the front panel display error queue
and the SCPI (remote interface) error queue. These two queues are viewed and managed separately; for
information on the SCPI error queue, refer to the E4428C/38C ESG Sgnal Generators Programming Guide.

NOTE When there is an unviewed message in the front panel error queue, the ERR annunciator
appears on the signal generator’s display.

Characteristic Front Panel Display Error Queue

Capacity (#errors) 30

Circular (rotating).

Overflow Handling Drops oldest error as new error comesin.

Viewing Entries Press: Utility > Error Info > View Next (or Previous) Error Page

Clearing the Queue | Press: Utility > Error Info > Clear Error Queue(s)

Unresolved Errors® | Re-reported after queue is cleared.

When the queue is empty (every error in the queue has been read, or the queueiis cleared), the
No Errors following message appearsin the queue:
0 No Error Message(s) in Queue

a. Errors that must be resolved. For example, unlock.

Error Message File

A complete list of error messages is provided in the file errormessages.pdf, on the CDROM supplied with
your instrument.

In the error message list, an explanation is generally included with each error to further clarify its meaning.
The error messages are listed numerically. In cases where there are multiple listings for the same error
number, the messages are in alphabetical order.
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Error Message Format

When accessing error messages through the front panel display error queue, the error numbers, messages
and descriptions are displayed on an enumerated (“1 of N”) basis.

Error messages appear in the lower-left corner of the display asthey occur.

Error Description

Error Number Error Message (May be truncated on the display)
A A

r NS A\

=222 Data out of range; wvalue clipped to lower limit.

Indicates that the user has entered a deviation, depth or internal
source frequency that is beyond the specified limits. y
\

'

Explanation provided in the Error Message List
(This is not displayed on the instrument)

638 Chapter 18



Troubleshooting
Error Messages

Error Message Types

Events do not generate more than one type of error. For example, an event that generates a query error will
not generate a device-specific, execution, or command error.

Query Errors (—499 to —400) indicate that the instrument’s output queue control has detected a problem
with the message exchange protocol described in IEEE 488.2, Chapter 6. Errorsin this class set the query
error bit (bit 2) in the event status register (IEEE 488.2, section 11.5.1). These errors correspond to message
exchange protocol errors described in IEEE 488.2, 6.5. In this case:

» Either an attempt is being made to read data from the output queue when no output is either present or
pending, or

» datain the output queue has been lost.

Device Specific Errors (—399 to —300, 201 to 703, and 800 to 810) indicate that a device operation did not
properly complete, possibly due to an abnormal hardware or firmware condition. These codes are also used
for self-test response errors. Errorsin this class set the device-specific error bit (bit 3) in the event status
register (IEEE 488.2, section 11.5.1).

The <error_message> string for a positive error is not defined by SCPI. A positive error indicates that the
instrument detected an error within the GPIB system, within the instrument’s firmware or hardware, during
the transfer of block data, or during calibration.

Execution Errors (—299 to —200) indicate that an error has been detected by the instrument’s execution
control block. Errorsin this class set the execution error bit (bit 4) in the event status register (IEEE 488.2,
section 11.5.1). In this case:

» Either a<PROGRAM DATA> element following a header was evaluated by the device as outside of its
legal input range or is otherwise inconsistent with the device's capabilities, or

» avalid program message could not be properly executed due to some device condition.

Execution errors are reported after rounding and expression eval uation operations are completed. Rounding
anumeric data element, for example, is not reported as an execution error.

Command Errors(—199 to —100) indicate that the instrument’s parser detected an |EEE 488.2 syntax error.
Errorsin this class set the command error bit (bit 5) in the event status register (IEEE 488.2, section 11.5.1).
In this case:

» Either an IEEE 488.2 syntax error has been detected by the parser (a control-to-device message was
received that isin violation of the | EEE 488.2 standard. Possible violations include a data element that
violates device listening formats or whose type is unacceptabl e to the device.), or

» an unrecognized header was received. These include incorrect device-specific headers and incorrect or
unimplemented |EEE 488.2 common commands.
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Upgrading Firmware
The firmware in your signal generator may be upgraded when new firmware is released. New firmware
releases may contain signal generator features and functionality not availablein previous firmware releases.

To inquire about the availability of new signal generator firmware, contact Agilent at
http://ww agi | ent. cond fi nd/ upgr adeassi st ant, or call 1 800 452 4844.
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Returning a Signal Generator to Agilent Technologies
To return your signal generator to Agilent Technologies for servicing, follow these steps:

1. Gather as much information as possible regarding the signal generator’s problem.

2. Call the phone number listed on the Internet (http://www.agilent.com/find/assist) that is specific to your
geographic location. If you do not have access to the Internet, contact your Agilent field engineer.

After sharing information regarding the signal generator and its condition, you will receive information
regarding where to ship your signal generator for repair.

3. Ship the signa generator in the original factory packaging materials, if available, or use similar
packaging to properly protect the signal generator.
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Contacting Agilent Sales and Service Offices

Assistance with test and measurements needs and information on finding alocal Agilent office are available
on the Internet at:
http: //mwww.agilent.com/find/assi st

You can also purchase E4428C/38C ESG accessories or documentation items on the Internet at:
http: //mww.agilent.com/find/esg

If you do not have access to the Internet, please contact your field engineer.

NOTE In any correspondence or telephone conversation, refer to the signal generator by its model
number and full serial number. With this information, the Agilent representative can
determine whether your unit is still within its warranty period.
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oM
annunciator, 12, 32
configuring, 198
deviation, 198
rate, 198

Numerics
007, option, 4, 22
10 MHz IN connector, 17, 43
10 MHz OUT connector, 17, 44
2's complement description, 225, 238
321.4 IN connector, 36
601/602, option
description, 22

A
A, 104
AC power receptacle, 16, 41
ACP, 88
activating asignal, 56
active entry area, 14, 34
adding & editing (instrument state), 69
alc hold, 115-118
description, 121
saving settings, 120
ALC OFF annunciator, 12, 32
AM
annunciator, 12, 32
depth, 195
modulation, 195
rate, 195, 196
amplitude
display area, 14, 34
hardkey, 6, 25
LF output, 201, 202
modulation. See AM
amplitude offset, 50
amplitude reference, 50
amplitude sensitivity search, 268
analog modulation, 4, 22, 193-202
configuring, 194
annunciators, display area, 12-13, 32-33
ARB

triggers, 135
waveform clipping, 144-151
waveform scaling, 152-154

arb, 88

ARMED annunciator, 12, 32

arrow keys, 9, 28

ATTEN HOLD annunciator, 12, 32

AUTOGEN_WAVEFORM file, 88, 90, 104

AUX 1/O connector, 39
AWGN
dual ARB player, 109

B

baseband
clipping, 144-151
scaling, 152-154
BASEBAND GEN REF IN connector, 44
baseband generator, 88
custom arb mode, 22
custom real-time I/Q mode, 22
dual arb mode, 23
multitone mode, 23
options, 21
basic operation, 45-85
BCH synchronization, 263
BER connectors
BER CLK IN, 36
BER DATA IN, 36
BER GATE IN, 36
BER, DPCH transport channel, 439
BERT annunciator, 32
BERT, option UN7, 252
GPsS, 337
GPS testing, 342
loopback test equipment setup, 257
bit file editor, using, 184
bits per symbol, equation, 169
block diagrams
frame structure
DPCCH/DPDCH downlink, 422, 623
DPCCH/DPDCH uplink, 424, 557
PCCPCH+SCH, 421, 622
PICH, 420, 621
GPS signal generation, 333
GPS subframe structures, 334
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Bluetooth marker behavior, 118
Bluetooth signal, setting up, 242
BURST GATE IN connector, 43

C

carrier bandwidth, 109
carrier signal modulation, 58
carrier to noise ratio, 109
catalog, FIR files, 322
CCDF curve, 149-151
CDMA template, customizing, 325
cdma2000
component test, storing, 304, 305
cdma2000 forward link modulation, 296, 310
cdma2000 reverse link modulation, 300, 316
cdma2000, receiver test
forward link
adjusting code domain power, 312
base station setup, 310
changing channd states, 310, 311
configuring the RF output, 315
generating the baseband signal, 314
modifying channel parameters, 311
scaling to 0 dB, 312
setting EbNo, 314
setting equal channel powers, 313
setting noise parameters, 313
setting the carrier to noiseratio, 314
reverse link
adjusting code domain power, 318
changing channdl states, 317
changing the operating mode, 316
configuring the RF output, 321
editing channel setups, 316
generating the baseband signal, 320
mobile setup, 316
modifying channel parameters, 317
scaling to 0 dB, 318
setting EbNo, 320
setting equal channel powers, 319
setting noise parameters, 319
setting the carrier to noiseratio, 320
ceiling function, bits per symbol, 169
certificate, license key, 81
channels

forward link, editing, 297, 301
PCCPCH+SCH, 421, 622
circular clipping, 150
clipping
CCDF curve, 149-151
circular, 147, 150
concepts, 144-149
procedure, 150, 151
rectangular, 147, 151
clock adjustment
phase and skew, 216
clock gate, 276
clock rate limits, logic type output, 204
clock source
setting, 228, 235
clock timing
paralel data, 211
paraldl interleaved data, 214
phase and skew, 216
serial data, 216
clocking, frequency reference, 208
clocking, frequency reference diagrams, 210
Clocks Per Sample
paralel data, 211
paralel interleaved data, 214
coefficient values, entering, 163
COH CARRIER connector, 37
comments, adding & editing (instrument state), 69
common frequency reference diagrams, 210
component test, 88
components, testing, 295, 394, 406
compressed mode, W-CDMA
downlink, 589
frame structure, 591
manual power search, 599, 620
uplink
manual power search, 552
multiple TGPS, 510
single TGPS, 499
concepts
waveform clipping, 144-149
waveform markers, 120
waveform scaling, 152-154
confidential data, 73
connection diagram
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user flatness correction, 61 contrast hardkeys, 9, 28
connections control part power, message part, 436
common frequency reference, 210 control timeslot ramping, GSM, 369
connectors control timeslot ramping, GSM & EDGE, 366
10 MHzIN, 17, 43 correction array (user flatness)
10 MHz OUT, 17, 44 configuration, 61
321.41N, 36 load from step array, 62
AUX 1/O, 39 viewing, 62
BASEBAND GEN REF IN, 44 See also user flatness correction
BER CLK IN, 36 creating waveform segments, 105
BER DATA IN, 36 creating waveform sequences, 106
BER GATE IN, 36 custom
BURST GATE IN, 43 CDMA template, editing, 325
COH CARRIER, 37 cdma2000 waveforms
DATA, 30 creating, 306
DATA CLOCK, 29 storing, 304, 305
digital bus, 41 using, 308
EVENT 1, 38 multicarrier COMA waveforms
EVENT 2, 38 creating, 327
EXT 1INPUT, 7, 26 editing, 329
EXT 2INPUT, 7, 26 multicarrier TDMA waveforms
externa triggering, 138 creating, 357
externa triggering source, 140 RF output, configuring, 362
GPIB, 16, 42 TDMA digital modulation, 354
I, 30 custom arb, 89
| OUT, 37 custom arb waveform generator, 22
I-bar OUT, 36 custom mode, 88
LAN, 17,42 custom real-time |/Q baseband, 22
LF OUTPUT, 7, 27 CW mode
PATT TRIGIN, 39 description, 4, 22
Q, 30
QOuUT, 37 D
Q-bar OUT, 38 DAC over-range errors, 152—154
RF OUTPUT, 8, 27 data
RS 232, 16, 42 framed, 136
SWEEP OUT, 17, 43 input methods, 73
SYMBOL SYNC, 29 patterns
TRIGIN, 17, 43 triggering, 135
TRIG OUT, 17, 43 removal, 77
continuous sensitive, 73, 77
triggering, 137 storage, 73
continuous step sweep example, 53 unframed, 136
continuous wave DATA CLOCK connector, 29
description, 4, 22 DATA connector, 30
continuous wave output, 48 datafields
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editing, 47
datafiles
creating, 184
modifying, 187
storing, 186
datafiltering, pre or post fir, 225, 238
data part power, message part, 437
data processing, 283
data storage
file types, 66
troubleshooting, 634
data types, 220
declassification, 73
DECT framed modulation, 383
default navigation data, GPS, 334
default waveform file, 90
delay, external trigger signal, 137
Delete Item softkey, 47
Delete Row softkey, 47
description, adding & editing (instrument state), 69
device clock source selection, 228, 235
DHCP, 83
diagram
data types, 220
diagrams
clock timing, parallel data, 211
clock timing, parallel interleaved data, 214
clock timing, phase and skew, 216
clock timing, serial data, 216
common frequency reference, 210
differential encoding, bits per symbol, 169
differential state map, bits per symbol, 169
digital bus, 41
digital modulation
annunciators, 33
component testing, 295, 394, 406
formats, 22
IQ map, QAM, 170
receiver testing, 363
TDMA, 34
W-CDMA, 393424, 559-623
digital signal interface module

active entry area, 14, 34
amplitude area, 14, 34
annunciators, 12, 13, 32, 33
blanking, 79
contrast hardkeys, 9, 28
description, 11, 31
error message area, 14, 34
secure, 79
softkey area, 14, 34
text area, 14, 34
downlink
DPCCH frame structure, 422, 623
DPCH slot formats A and B, 591
DPDCH frame structure, 422, 623
PCCPCH+SCH frame structure, 421, 622
PICH frame structure, 420, 621
scramble codes, 416
downlink errors, 288
DPCCH
downlink frame structure, 422, 623
uplink frame structure, 424, 557
DPCH dot formats A and B, 591
DPCH, transport channel BER, 439
DPCH, uplink, TPC equipment setup, 495
DPDCH
downlink frame structure, 422, 623
uplink frame structure, 424, 557
dual ARB, 98
dual arb, 88
dual ARB player, 23, 104-111
dual ARB real-time noise, 109
dual arbitrary waveform generator, 23, 104-111

E

EDGE frame structure, 289

EDGE framed modulation, 364

EDGE framed modulation with GMSK, 364
EDGE timeslot ramping control, 366

Edit Item softkey, 47

editing file headers, 92, 98

editor, bit file, 184

equipment setup

N5102A, 203 DPCH and PRACH, 429, 534
discrete steps, skew range, 216 DPCH, uplink, TPC, 495
display multiple PRACH overload test, 479
646 Index



PRACH AICH, 452, 454
user flatness correction, 61
equipment, user flatness correction, 59
Erase All, 77, 78, 79
erase and overwrite, 77
erase and sanitize, 78
erased frame detection, 288
erasing memory, 73, 77, 78, 79
ERR annunciator, 12, 32, 637
error messages
DAC over-range, 152-154
display area, 14, 34
message format, 638
overview, 637
queue, 637
types, 639
ESG
configuring GSM mode, 260
modes of operation, 4, 22
EVENT 1 connector, 38
EVENT 2 connector, 38
examples
®M, configuring, 198
AM, configuring, 195
continuous wave output, 48

custom cdma2000 state, storing, 304, 305

files
storing, 67
viewing, 66
FIR filters
creating, 162
modifying, 167
using, 322
FM, configuring, 197
LF output, configuring, 200
options, enabling, 81
pulse modulation, configuring, 199
RF output, configuring, 48-55
swept output, 51
table editor, list mode values, 46
table editors, editing, 47
traffic channels, inserting, 299, 302
user flatness correction, 59-65
EXT 1 INPUT connector, 7, 26
EXT 2 INPUT connector, 7, 26

EXT REF annunciator, 12, 32
EXT1 annunciators, 12, 32
EXT2 annunciators, 12, 32
external clock source selection, 228, 235
external modulation, 196
external trigger
connection, 138
gated, setting, 138
source connector, 140
extracting waveform files, 82

F

fail-safe recovery sequence, 635
failures. See troubleshooting
features, signal generator, 2, 20
file header description, 93
file headers
dual ARB, 98, 99
editing, 92, 98
generating, 98
overview, 90
playing waveforms, 102
sequences, 98
settings, 90
viewing, 98
viewing a different file, 100
files, 68
FIR filter, using, 322
FSK, storing, 182
using, 66
waveform segments, 105, 110
waveform segquences, 106-109
See also instrument state register
See also memory catalog
filtered & unfiltered samples, 225, 238
filters
gaussian, loading default, 167
interpolation, 152-153
nyquist, selecting, 355
FIR filters
creating, 162
custom filter, using, 322
modifying, 167
storing, 166
FIR table editor
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accessing, 162
coefficients, duplicating, 163
coefficients, entering values, 163
coefficients, modifying, 168
files, loading, 167
filters
creating, 162
modifying, 167
storing, 166, 168
oversampleratio, setting, 164
firmware, upgrading, 640
flatness correction. See user flatness correction
FM
annunciator, 12, 32
configuration example, 197
deviation, 197
rate, 197
format, generating, 56
formula, skew discrete steps, 216
forward link modulation
cdma2000, 296
forward link modulation, cdma2000, 310
forward link traffic channels, inserting, 299, 302
frame structure, 288, 420
downlink
compressed mode, 591
DPCCH, 422, 623
DPDCH, 422, 623
PCCPCH+SCH, 421, 622
PICH, 420, 621
uplink
DPCCH, 424, 557
DPDCH, 424, 557
framed data, 136
framed modulation
DECT, 383
EDGE, 364
GSM, 368
NADC, 389
PDC, 387
PHS, 385
TETRA, 391
free run trigger response, 137
frequency
display area, 11, 31

hardkey, 6, 24
LF output, 201
start and stop, swept-sine, 202
modulation. See FM
offset, 49
reference, 49
RF output, setting, 48
frequency output limits, clock rates & logic levels,
204
frequency reference
common, 208
hookup diagrams, 210
front panel
disabling keys, 79
display description, 11, 31
features, 5, 15, 24, 35
knob, 6, 25
FSK files, storing, 182
fundamental operation See basic operation

G
gated triggering, 136, 138
gaussian filter, loading default, 167
GMSK modulation, 364
Goto Row softkey, 47
GPIB
connector, 16, 42
listener mode, 64
GPS
basic operation, 338
BER testing, 337, 342
chip clock reference, 335
configuring external reference clock, 339
data modes, 334
default navigation data, 334
handover word, 334
handover word structure, 335
overview, 332
satellite ID range, 332
sensitivity testing, 341
signal generation diagram, 333
subframe indicator, 335
subframe structures, 334
TLM word, 334
TLM word structure, 335
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user files, 336 input connectors, 36
green LED, 9, 29 10 MHzIN, 17, 43
GSM frame structure, 288 321.41N, 36
GSM framed modulation, 368 AUX 1/0, 39
GSM mode BASEBAND GEN REF IN, 44
configuring the ESG, 260 BER CLK IN, 36
configuring the VSA, 259 BER GATE IN, 36
GSM timeslot ramping control, 366, 369 BURST GATEIN, 43
DATA, 30
H DATA CLOCK, 29
handover word, GPS, 334, 335 EXT 2 INPUT, 7, 26
hardkeys GPIB, 16, 42
Amplitude, 6, 25 I, 30
arrow, 9, 28 LAN, 17, 42
contrast, 9, 28 line power, 16, 41
Frequency, 6, 24 PATT TRIGIN, 39
Help, 7, 26 Q, 30
Hold, 9, 28 RS 232, 16, 42
Incr Set, 8, 28 SYMBOL SYNC, 29
Local, 9, 28 TRIGIN, 17, 43
MENUS group, 6, 25 Insert Item softkey, 47
Mod On/Off, 8, 27 Insert Row softkey, 47
numeric, 8, 27 instrument state register
Preset, 9, 28 comments, adding and editing, 69
Recall, 6, 25 troubleshooting, 634
Return, 9, 28 using, 68
RF On/Off, 8, 27 See also memory catal og
Save, 6, 25 interface, remote
Trigger, 7, 26 GPIB, returning to listener mode, 64
header files, 90 intermodulation distortion
Help hardkey, 7, 26 how to minimize, 146
Hold hardkey, 9, 28 internal clock source selection, 228, 235

interpolation filter, 152-153
| interslot ramping control, GSM, 369

| connector, 30 interslot ramping control, GSM & EDGE, 366

| input, 196 IQ

| OUT connector, 37 clock rates, 206 _

1/Q waveform 1Q map, QAM modulatlon, 170
clipping, 144-151 1S-95A modulation, 324
scaling, 152-154

I-bar OUT connector, 36 K

Incr Set hardkey, 8, 28 key, license, 81

information keypad, numeric, 8, 27
protecting sensitive, 73 keys

disabling, 79
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knab, front panel, 6, 25

L

L (listener mode) annunciator, 12, 32
lan configuration, 83
LAN connector, 17, 42
LEDs, 9, 29
left alternate scramble code, 418
LF output
amplitude, 201, 202
configuration example, 201, 202
description, 200
frequency, 201
source
function generator, 202
internal modul ation monitor, 201
swept-sine
start frequency, 202
stop frequency, 202
waveform, 194, 200, 202
LF OUTPUT connector, 7, 27
LFO. See LF output
license key, 81
limits, clock & sample rates, logic outputs, 204
line power (green) LED, 9, 29
list
error messages, 637
list mode values table editor example, 46
list sweep examples, 53-55
listener mode annunciator, 12, 32
listener mode, returning to, 64
L oad/Store softkey, 47
loading segments, 110
Local hardkey, 9, 28
logic type
output levels, 204
selecting, 223
loopback BER
measuring, 266
low frequency output. See LF output

M

manual power search, W-CDMA DL, 599
manual power search, W-CDMA UL, 552

marker, Bluetooth behavior, 118
markers

waveform, 115-118, 119-134
measuring RF loopback BER, 257
media storage, 73
memory, 104

base instrument, 73

baseband generator, 73

erasing, 73, 77

hard disk, 73

overwriting, 77

persistence, 73

physical location, 73

sanitizing, 78

secure mode, 78

size, 73

types, 73

waveform, 73

writing to, 73
memory catalog

troubleshooting, 634

using, 66

See also instrument state register
menu, hardkeys, 6, 25
menus

marker, 124

marker polarity, 134

trigger, 137
message part

control part power, 436

data part power, 437

scrambling code, 435

slot formats, 434

structure, 433
message part power examples, 440
message part power, PRACH, 440
mirror table, duplicating coefficients, 163
MOD ON/OFF annunciator, 13, 33
Mod On/Off hardkey, 8, 27, 58
modes of operation, 4, 22
modes, triggering, 136
modify file header, 92
modulation

amplitude. See AM

analog, 4, 22
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analog, configuring, 194
annunciators, 13, 33
carrier signal, 58
component testing, 295, 394, 406
digital, 22
format generation, 56
forward link, cdma2000, 296
framed
DECT, 383
EDGE, 364
GMSK, 364
GSM, 368
NADC, 389
PDC, 387
PHS, 385
TETRA, 391
frequency. See FM
IS-95A, 324
phase. See ®M
pulse, 4, 22,199
receiver testing, 363
reverse link, cdma2000, 300
module user interface location, 222, 231
multicarrier CDMA waveforms
creating, 327
editing, 329
multicarrier cdma2000 waveforms
creating, 306
using, 308
multicarrier TDMA waveforms
creating, 357
multitone, 88
multitone mode, 23
multitone waveform, setup, 348

N

N5102A
baseband data, 222
clock rates, 204
clock settings, 226, 233
clock source
description, 207
clock timing, 204, 211
common frequency reference, 208
connectionsto clock and device, 218

data parameters, setting, 224, 237
data types, 220
digital data, 239
digital signal interface module, 203
frequency reference connector, 209
generating data, 230
input direction, 232
input mode, 220, 231
interleaving clock timing, 214
logic type, port configuration, 232
logic types, 223
output direction, 224
output mode, 220, 222
phase and skew clock timing, 216
serial clock timing, 216
user interface, 222
user interface module, 231
NADC framed modulation, 389
negation description, 226, 239
noise, 109
noise bandwidth factor, 109
non-volatile memory, 104
numeric format selection, 225, 238
numeric keypad, 8, 27
NVWFM, 90, 104
nyquist filter, selecting, 355

0

off/on key usage, modulation format, 56
offset

amplitude, 50

frequency, 49
offset binary use, 225, 238
on/off switch, 10, 29
operation

modes of, 4, 22
operation, basic, 45-85
options, 3, 21

007, 4, 22

409, GPS, 338

601/602

description, 22

baseband generator, 21

enabling, 81

UN7, BERT, 252, 342

Index
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UNT, 4, 22

UNU, 4, 22

UNW, 4, 22
out of synchronization testing, W-CDMA DL, 582
output connectors

10 MHz OUT, 17, 44

AUX 1/0, 39

COH CARRIER, 37

EVENT 1, 38

EVENT 2, 38

GPIB, 16, 42

| OUT, 37

|-bar OUT, 36

LF OUTPUT, 7, 27

QOuUT, 37

Q-bar OUT, 38

RF OUTPUT, 8, 27

RS 232, 16, 42

SWEEP OUT, 17, 43

TRIG OUT, 17, 43
output levels, logic types, 204
output. See LF output and RF output
OVEN COLD annunciator, 13, 33
over-range errors, 152-154
overview, file headers, 90
overview, GPS, 332
overview, signal generator, 1-17, 19-44
overwriting memory, 77

P

Page Down softkey, 47
Page Up softkey, 47
parallel
clock rates, 206
data clock timing, 211
interleaved data clock timing, 214
sample rates, 206
PATT TRIG IN connector, 39
PCCPCH+SCH
frame structure, 421, 622
PDC framed modulation, 387
peak to average power
CCDF curve, 149
high ratios, 146
reducing, 147

phase clock timing, 216
phase modulation. See ®M
PHS framed modulation, 385
PICH frame structure, 420, 621
pilot power offset, 414
player, dual ARB, 104-111
polarity
markers, 134
trigger, external, 138
port configuration, selecting, 223
power
offsets, 414
peaks, 144-149
sensor, models, 59
switch, 10, 29
power adjustment, timeslots, 366, 369
power control modes, 441
Pp-m, 441
total, 442
power meter
configuration, 60
user flatness correction, 59
power receptacle, 16, 41
power supply, troubleshooting, 627
Pp-m power control mode, 441
PRACH
AICH equipment setup, 452, 454
equipment setup, 429
overload test equipment setup, 479
PRACH power control
message part, 440
control part power, 436
data part power, 437
data part power formulas, 438, 439
power formula, 440
preamble power, 436
PRAM, 88
preamble
power control, 436
scrambling codes, 433
signature, 432
pre-fir samples selection, 225, 238
Preset hardkey, 9, 28
primary scramble code, 417
private data, 73
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problems with security function, 79
problems. See troubleshooting
proprietary data, 73
protecting data, 73
PUL SE annunciator, 13, 33
pulse modulation, 4, 22

period, 199

width, 199
pulse, marker, viewing, 131
pulse/rf blank, 115-118

Q

Q connector, 30

Q OUT connector, 37

QAM modulation IQ map, 170
Q-bar OUT connector, 38
queue, error, 637

R

R (remote) annunciator, 13, 33

ramping timeslots, GSM, 369

ramping timeslots, GSM & EDGE, 366

rea time, 88

real-time mode, 22, 89

real-time noise, 109

real-timetriggers, 135

rear panel input signals
description, W-CDMA UL, 536
locating, W-CDMA DL, 607
locating, W-CDMA UL, 525

rear panel output signals
configuring, W-CDMA DL, 609
configuring, W-CDMA UL, 527
description, W-CDMA DL, 611
description, W-CDMA UL, 536

recal, 68

Recall hardkey, 6, 25

recall states, 68

receiver test, 88

receiver testing, real time TDMA, 363

recovery sequence, fail-safe, 635

rectangular clipping, 151

reference
amplitude, 50

Index

frequency, 49

GPS chip clock, 335
registers, 68, 72
remote control

GPIB, returning to listener mode, 64
remote operation annunciator, 13, 33
removing sensitive data, 77
repeat measurements, 284
required equipment, GPS, 342
required equipment, W-CDMA transmit diversity,

571, 583, 592

reset & run trigger response, 137
response, triggering mode, 136
restricted data, 73
Return hardkey, 9, 28
returning asignal generator, 641
reverse link modulation

¢cdma2000, 300
reverse link modulation, cdma2000, 316
RF blanking, 115-118

marker function, 132

settings, saving, 120
RF loopback BER measurement, 257
RF ON/OFF annunciator, 13, 33
RF On/Off hardkey, 8, 27
RF output

configuring, 48-55

connector, 8, 27

troubleshooting, 627

user flatness correction, 59-65
right alternate scramble code, 418
routing, marker, 121

RF blanking, 132

saving settings, 120
RS-232

connector, 16, 42
runtime scaling, 154

S
S (service request) annunciator, 13, 33
sample
rates, 204
rates, parallel/parallel intrlvd port configuration,
206
rates, serial port configuration, 205

Index
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type selection, 225, 238
samples
baseband, 152153
interpolated, 152—-153
sanitizing memory, 78
satellite ID range, GPS, 332
save, 68
save and recall states, 68
Save hardkey, 6, 25
scaling
concepts, 152-154
procedure, 154
runtime, 154
waveform data, 154
SCH, TSTD, 569
SCPI, 83
scramble codes
calculating, 616
downlink, calculating, 416
primary and secondary, 417
scrambling code, message part, 435
secondary scramble code, 417
secure display, 79
secure mode, 78
security function
problems with, 79
security functions, 73, 78
security level, 78
segment advance triggering, 137, 140
segments, waveforms, 105, 110
sensitive data, 73
sensitivity testing, GPS, 341
seguence file headers, 98
sequences, 110
creating and storing, 106-109
deleting, 72
editing, 108
instrument state register, 68
marker control, 129
playing, 107
triggering, 135
serial
clock and sample rates, 205
clock timing, 216
service reguest annunciator, 13, 33

service, Agilent sales and service offices, 642
settings, file headers, 90
signal generation, 56
signal generator
analog modulation, 193-202
firmware, upgrading, 640
GPIB listener mode, returning to, 64
modes, 4, 22
operation, basic, 45-85
overview, 1-17, 19-44
standard features, 2, 20
signal generator lock up, 635
single step sweep example, 52
single trigger mode, 136
skew
clock timing, 216
range, 216
dot formats A and B, DPCH, 591
dlot formats, message part, 434
softkeys
location, key, 5, 24
location, labels, 14, 34
table editor, 47
source, external trigger, 138
special pattern ignore function, 284
spectral regrowth, 146
standard features, signal generator, 2, 20
standby (yellow) LED, 9, 29
step array (user flatness)
number of points configuration, 62
start and stop frequency configuration, 62
See also user flathess correction
step sweep, 51-53
storing segments, 110, 111
structure, PRACH message part, 433
STTD encoding, W-CDMA transmit diversity, 568
subframe indicator, GPS, 335
Sweep
annunciator, 13, 33
mode, 4, 22
trigger, 55
troubleshooting, 632
SWEEP OUT connector, 17, 43
swept output examples, 51-55
switch, power, 10, 29
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SYMBOL SYNC connector, 29
synchronization, 283, 284, 287
synchronizing

BCH, 263

TCH, 265

T

T (talker mode) annunciator, 13, 33
table editors
modifying, 47
softkeys, 47
using, 46
talker mode annunciator, 13, 33
TCH synchronization, 265
TCP/IP, 83
TDMA digital modulation, 354
TETRA framed modulation, 391
text area (on display), 14, 34
TFCI
power offset, 414
timeslot power level adjustment, 366, 369
timeslot ramping control, GSM, 369
timeslot ramping control, GSM & EDGE, 366
TLM word, GPS, 334, 335
total power control mode, 442
TPC
DPCH uplink, 495, 555
equipment setup, DPCH uplink, 495
power offset, 414
values, 413
traffic channels, inserting, 299, 302
transmit diversity, W-CDMA
overview, 568
STTD encoding, 568
TSTD, 569
transmit power control, 413
transport channel DPCH BER setting, 489
TRIG IN connector, 17, 43
TRIG OUT connector, 17, 43
trigger
connectors, 17, 43
hardkey, 7, 26
setting, 55
trigger & run, 137
triggers, 135-141

Index

troubleshooting
data storage, 634
fail-safe recovery sequence, 635
help mode, 627
RF output, 627-632
signal generator lock up, 635
sweep, 632—633

TSTD for SCH, 569

two tone, 88

v

unfiltered & filtered samples, 225, 238
unframed data, 136
UNLEVEL annunciator, 13, 33
UNLOCK annunciator, 13, 33
UNT, option, 4, 22
UNU, option, 4, 22
UNW, option, 4, 22
uplink
DPCCH frame structure, 424, 557
DPDCH frame structure, 424, 557
uploading waveform files, 82
user files
data, creating, 184
data, modifying, 187
data, storing, 186
FIR files catalog, 322
GPS usage, 336
modifying, 187
renaming, 186
saving user files, 186
user flatness correction, 59-65
user interface location, module, 222, 231

\Y

volatile memory, 104
VSA

configuring GSM mode, 259
V SA required options, 257

w

Walsh Code, editing CDMA template, 325
warranted logic output clock rates, 204
waveform license, 82

Index
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waveform memory, 73 configuring PRACH, 446
waveforms configuring user equipment, 524

CCDF curve, 149-151

clipping, 144-151

DAC over-range errors, 152154

interpolation, 152-153

markers, 115-118, 119

player, dual ARB, 104-111

samples, 152-153

scaling, 152-154

segments, 105, 110

sequences, 106109, 129

statistics, 150-151

triggering, 135

utilities, 150-151

W-CDMA digital modulation, 393-424, 559-623

W-CDMA, receiver test

downlink
adjusting code domain power, 563
applying settings to an active signal, 566
base station setup, 560
compressed mode, 589
configuring the physical layer, 561
configuring the RF output, 567
configuring the transport layer, 562
DPCH slot formats A and B, 591
frame structure, 420, 621
frame structure, compressed mode, 591
generating the baseband signal, 566
manual power search, 599
out-of -synchronization testing, 582
rear panel output signal descriptions, 611
rear panel output signals, configuring, 609
scaling to 0 dB, 563
setting EcNo, 565
setting equal channel powers, 564
setting noise parameters, 565
setting the carrier to noise ratio, 565
STTD encoding, 568
transmit diversity, 568
TSTD for SCH, 569

uplink
adjusting code domain power, 530
compressed mode, 499
configuring DPCCH/DPDCH, 486

manual power search, 552
modifying the physical layer, 446, 488
modifying the transport layer, 490
rear panel output signals, configuring, 527
rear panel signal descriptions, 536
scaling to 0 dB, 530
selecting a reference measurement channel, 486
setting DPCH transport channel BER, 489
setting EbNo, 494
setting equal channel powers, 531
setting noise parameters, 492
setting the carrier to noiseratio, 492
setting up the compressed mode, 513, 592
web server, 83
WFM1, 90, 104
wideband AM, 196

Y
yellow LED, 9, 29
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